先日、Win2kが起動しなくなってしまったので
再インストがてらパーティションを一から全て区切りなおし、
WinMe、2kをインストールしました。

ところが、バックアップしたデータを移動していて気づいたのですが、
サイズの大きい、または数量の多いフォルダを移動(コピー)する際に
転送速度が目に見えて落ちてしまっています。
具体的には 転送→少し止まる→転送→少し止まる→・・・・
といったぐあいに飛び飛びになてしまっているのです。

購入してまだ半年なので、故障とは思われにくいし、
最適化する必要もないです。何か解決策はないでしょうか・・・。

問題のHDDは 30GB/5400rpm(IDE)です

A 回答 (7件)

LEVIN3DOOR様こんばんわ


かなりてこずっているようですが、私の経験から一言
Service Pack 2は導入済みでしょうか?
最新の VIA 4in1 導入済みでしょうか?
CPUがDuronとゆうことなので チップセットはVIAだと推測します、
転送モードはDMAに設定できないとの事ですが Win2000は
Service Pack 2を導入しなければ Ultra DMA非対応です
そのためPIO転送になりCPUの使用率があがるのではないでしょうか、もしService Pack 2がまだのようでしたら
試してみるかちは あるようです

この回答への補足

>tosihiroさん
有難うございます!
SP2を導入したところ見事にUltra DMAが有効になり、
飛躍的に速度が向上しました!
解決です!

>wa_jiroさん
SP2のことをほのめかしていたにもかかわらず、私が
それに言及しなかったためいらぬお手間と貴重な時間を
わずらわせてしまいました。
しかし、詳細かつ克明な説明を親身になり与えてくださった
wa_jiroさんには感謝の気持ちが絶えません。
(本題でない問題に言及してくださったのもうれしかったです)
月並みな言葉でしか言えませんが、本当にありがとうございました。
感謝します!

補足日時:2001/09/17 02:12
    • good
    • 0

LEVIN3DOORさん、こんばんわ。


もうすっかり、回復したものと思っていました。
ご回答を拝見させて頂いて、愕然としております。
イベントビュアー等にまたエラー表示が出ていないのですか?。
貴方の記載された順序にて、再セットアップされて、その後の
確認では、どうでしたか?
エラー表示や、ファイル転送遅延を起こしましたか?。
>転送中に動作が重くなる(CPUの使用率が極端に上がる)
との事ですが、具体的に何のアプリケーションが動いているのか
分かりますか?

この回答への補足

wa_jiroさんこんばんは。お付き合いいただき有難うございます。
手順どおりにセットアップ後、PCI機器を取り付ける前に
(素の状態で)SCSI HDDだけを繋ぎ(情報の更新をしてから)
転送実験を行いましたが、駄目でした。
イベントビューアでエラーは確認できませんでした。
また、タスクマネージャでもどのアプリが影響を及ぼしているのかは
わかりません。(タスクマネージャの動きは以前に書いたとおりです)

しかし、Meのほうで調べていて気付きました。Meでは
例の遅延現象は起こらないのです。(ベンチマークソフトで確認した
ので確かです)ということは、Win2000のほうに問題があるようです。
また、Win2000のほうではDMAがオンにできません。
HDDドライバの問題か・・・はたまたNTFSでないからか・・・(以前Win2000
のドライブはNTFSでした)。

そっちのほうで少し調べてみることにします。
駄目元でWin2000をフォーマットを変えてインストール、というのも
考えています(あまり効果は期待できないですが)。

補足日時:2001/09/16 23:35
    • good
    • 0

LEVIN3DOORさん、こんにちは。


ご回答の内容で宜しいのでは、ないかと思います。
まるで、私が教わっているかのようです。(笑)
頑張って下さい。

この回答への補足

どうも、今すべて終わったところですが、結果は・・・
駄目でした・・・。転送速度は向上しませんでした。
ご丁寧な解説をいただいたのに、上手くいかず結構
落ち込み気味です。

やはり、「転送中に動作が重くなる(CPUの使用率が極端に上がる)」
というのが気になりまして、ソフト面の問題かも・・・と思っています。

自分なりに調べてみますが、またご回答頂けたら
参考になります。では。

あ、お礼を忘れるところでした。これまでの親切かつ詳細な説明に感謝します。

補足日時:2001/09/16 15:39
    • good
    • 0

LEVIN3DOORさん、再度、こんばんわ。


安心して下さい。 再度のご回答補足で全て理解できました。

ひとつずつ解決していきましょう。
まず、NBTディバイスエラーの件ですが、これは放置しない方が賢明です。
恐らく、設定間違いだけの内容だろうと思います。
しかし、これが表示されると通常接続しないのが普通なのですが‥。
しかしながら、問題なく接続できているとの事、ある意味不思議です。
多分、色々なICMPソケットをかなり出しており、偶然に接続できている
ような気がします。(DHCPサーバ機能の設定か何かされている)
このままでご使用になりたいとの事ですが、このまま使用していくと
再度不具合が出て、接続も困難になると思います。
あまり脅かすつもりはありませんが、時間の問題であろうと思います。
レジストリーが苦手との事なので、一旦それらをアンインストールして
再度インストールされた方が無難だと思います。
(その際には、必ずreadmeや設定の方法等をよく確認して下さい)
このエラーは、TCP/IPの設定エラーから引き起こされます。

さてつぎに、
工場出荷時点の(ん、自作PCでしたネ)
再セットアップを何らかの理由で行う場合(その理由は、不具合がある
ということによるセットアップが殆どです)には、それら不具合を局所化
する為にも基本状態に戻し、その時点で機器装置を確認し、それから
外部拡張を付け足していく事が基本です。
それを行う事によって、不具合原因がだんだんと局所化していき、その
原因がはっきり解明します。
この場合もそうですが、何故かという理屈を書くとまた長くなってしまい
そうなので、ここでは割愛させて頂きますが、これはどんな機器であろうと
同じ事です。
よく、セットアップを行っていったら、何となく直ったヨと聞きますが、それは
ありえないと思っています。
また、同一の症状がきっと発生します。

長くなりそうなので、結論より
レジストリー等の操作に自信がないとの事なので、ゆっくり、落ち着いて
再度、再セットアップを行って下さい。その際に、注意する事は、
まず、基本状態に戻し、その時点で再度イベントビュアー等にて
エラーがないかどうか確認を行って下さい。
確認終了後、外部拡張関連をひとつずつ装着していき、再度確認。
確認は、必ず、再起動後の確認をとるようにして下さい。
それとSCSI系のディバイス系は、それ自体でROMをもっているものや
内部ファイルを保持しているものがあります。
よって、これも外部装置として認識して下さい。 これらファイルに以前の
情報が書き出されている場合があります。
更に、外部ディスクにも、そのディスクヘッダーに、その情報を保持して
います。
接続相手先である情報が書き込んであります。 それが再度セットアップの
際、以前の異なる情報が送付されてくるので、戸惑ってしまいます。
(詳しい情報は、割愛します。) これを解消する為に更新を行うのです。
更に、LEVIN3DOORさんは、パーティションを再度きりなおしをされて
いますので余計そうなります。
更新を行う事によって、ディスクヘッダーに情報が更新されますので、
この内容の解消につながります。
恐らく内蔵ディスクもきちんとした更新がされていない可能性があります。
順番をよく考慮して、再セットアップをおやりになれば、すべて解消すると
思いますヨ。  (出来れば、紙に順番を書き込まれた上でおやりになった
方がよいと思います。 恐らく、弘法も筆のあやまりでしょうか‥)

最後に、ディスクの更新方法は、下記のとおりです。
マイコンピュタで右クリックを行うと補助メニューが表示されます。
その補助メニューの中の管理を開くとその中にディスクの管理が存在
する筈です。(これは、イベントビュアーを開いた時と同様です)
ディスクの管理を開くと、その上部メニュー上に操作が存在するはずです。
その中に更新は存在します。
但し、ちょっとでも不安があったら、その中のヘルプに目を通して下さい。

これで恐らく、もとのように快適な機械になると思います。 更に、今度は
ネットワークのエラーも解消できている筈ですから、接続も今までより
簡単に繋がると思います。(おまけつきでよかったですネ)

この回答への補足

再々々のご回答有難うございます。
とても詳細に書いていただき、助かります。
手順を確認させてもらいます。(教えて君みたいですが・・・)

0.PCI・SCSI機器を全て外す。
1.起動ディスクで起動。
2.fdiskコマンドで基本・拡張領域を全て削除。
3.パーティションを区切る。
4.Meをインストール。
5.Meから2000をインストール
6.PCI機器をインストール。イベントビューアにて逐一確認。
7.SCSIボードをインストール。
8.外部HDDを接続。
9.外部HDDの情報を更新。
10.外部HDDのデータを移す。

wa_jiroさんのおっしゃるHDDの更新はコンパネ→管理ツール→
コンピュータの管理→ディスクの管理 の「最新の情報に更新」
でよろしいのでしょうか?

・以下ヘルプから引用

[最新の情報に更新] をクリックすると、ディスクの管理に示されている
ドライブ文字、ファイル システム、ボリューム、およびリムーバブル
メディアの情報が最新の状態に更新され、さらに、読み込み不能ボリュームが
読み込み可能になったかどうかがチェックされます。ただし、ハードウェアの
スキャンは行われません。ハードウェア情報を更新するには、[ディスクの再スキャン] をクリックしてください。


wa_jiroさんのおっしゃっていることに、これが一番近いと思うのですが・・。

以上、間違いが無ければ、今日にでも実行したいと思います。

補足日時:2001/09/16 01:56
    • good
    • 0

LEVIN3DOORさん、こんばんわ。


詳細な内容の補足ありがとうございました。
資料を拝見させて頂き、Win2000はSP2が当たっているようですネ。

さて、補足の内容をみた限りでの、私の不審に思った事をここに記載しておきます。
1.>NBTデバイスからI/O制御情報を読み取れません。
    この表示が出る場合の殆どが、TCP/IP或いはサービスのバンイド
    エラーが殆どです。
    LEVIN3DOORさんは、現在の環境で、DHCPサーバや
WINS解決等のLAN環境にされていますか?。
    或いはLMHOSTを使用するアプリケーションを使用しているでも‥。
    もし、そのような状況でなければ、ネットワーク設定をもう一度ご確認
    してみて下さい。
    更に、イベントビュアー自体の表示は、このエラー表示(恐らく警告)が
    かなりの回数、時間が表示されているのですよネ。
    そうすると、これらのサービスを開始しようとして、かなりリソースを
    使用しているのではないかと思われます。
    (まず、めったにないのですが‥)
    Me側と2000側の設定をよくチェックして下さい。
    もし、レジストリーを操作できるのであれば、該当個所をチェックして
    みて下さい。
2.>外付けSCSIHDD・30GB、>PCI:SB Live! DigitalAudio2、
>SCSIボード一枚
  これは、ME及びWin2000再セットアップ時に外されておりましたか。
  補足のご記入のなされ方を参照させて頂くとかなりのパワーユーザで
  あろうと思われましたが、一応、念の為にです。
3.これも非常に気になるのですが、初回ご質問の内容の中と今回の情報とで
  >バックアップしたデータを移動していて気づいたのですが、
  この多量のサイズの大きいデータは、もしかして、SCSIディスクに退避
  (以前繋がっていた再セットアップ前)されており、再セットアップ後
  そのまま繋げているという事ではないですよネ。
  必ずディスクの情報の更新はおやりになっていますよネ。

もし、上記の内容に心あたりがあれば、それらを解消されてください。
恐らく、補足の内容や現象からでは、ハードディスク自体の障害では
ないと思われます。
もう一度、再セットアップを順序よくおやりになった方がよいと思います。

この回答への補足

wa_jiroさん、再度詳細な回答いただき有難うございます。
私はパワーユーザと呼ぶには余りにおこがましい自作素人のなので、
無知な面や筋が通っていない部分もありますが、ご容赦ください。

・1の件に関して
仰るとおり、エラーログに頻繁にこれが頻繁に出没しています。
心当たりとしてはBlackICEというネットワーク監視ツールを
導入しているので、おそらくそれではないか・・と。これまで特に
問題になったことは無い(というか気付かなかった)ので
放置していましたが、これはOSに対し何らかの害をもたらすエラー
なのでしょうか?レジストリに関してはちょっと手が出ないので、
問題なければこのまま使い続けようと思います。
ちなみに接続環境はISDNです。

・2の件
ご指摘のとおりボード関連は全てつけっぱなしでHDDの整理を
行いました。(^^;) 外付けHDDは電源を切っていたものの、やはり
つけっぱなしです。幼稚な質問ですみませんが、こういった
類のハードウェアを接続したままセットアップすると、HDDに何か
支障が出るのでしょうか?

・3の件
これもご指摘の通りです。(;´`)外付けHDDに退避させていた
データを内臓HDDの抹消後に再び繋げ直し、元(内臓の)HDDにコピーしました。
(CD-Rなんかに焼くとえらい手間がかかってしまうので・・・)
申し訳ないですが、ここの「ディスクの情報の更新」というのについて
教えてもらえると有難いです。

補足ですが、問題のHDD転送の遅延減少は 外付け→内臓 と移動(コピー)
した場合、 内臓→内臓 とした場合に起こります。
外付け→外付け の場合には起こりません。
(当然とは思いますが、一応明記しておきます)



長い質問にお付き合いいただき有難うございます。

補足日時:2001/09/15 23:34
    • good
    • 0

LEVIN3DOOORさん、こんにちは。


ご投稿のご質問拝読させて頂きました。
現在の症状の原因は、複数の起因する要素がある為、お書きになった
内容だけでは、それらを特定する事が出来ませんが、それらを少しでも
局所化する為に、以下の事を実行されてみて下さい。
その中で一番可能性があると思われる点を記載しますので、チェック
される事をお勧めします。

(一番の可能性が高いと私が思っている点;その機器のリソースが
 何らかの起因される要因で、奪われている状態。)
1.機器をWin2000にて起動後、(ログインは、ADMINで行って
  下さい)先にご投稿になった内容の処置を実行(ファイル転送)
2.タスクマネージャーを起動し、どのタスクがCPU及びメモリーを
  多く占有しているのかを確認して下さい。
3.上記1の時点で、何らかの転送障害が発生している場合には
  イベントビュアーでその内容を確認して下さい。
4.上記2まで、その実行速度に疑問が生じていた場合に、
  タスクマネージャーでそれらのプログラムを追跡して下さい。
  また、実行終了しても、CPU及びメモリを異常に
  多く、実行しているプログラムがないかを注意して見て下さい。
  CPUやメモリ状態の全体の負荷率と一緒に比較すると
  よく分かると思います。
  もし、何ら実行していない場合であれば、CPUの負荷率は
  恐らく1%前後の筈です。
  それらが前述の容量を超えているとすれば、何らかの処理が
  自動的に稼動している事が考えられます。
  何らかのソフトウエアを登録した際、自動的にスタートアップ
  あるいは、自動サービスの登録を行っている場合があります。
  (常駐プログラムを疑ってみるという事です。)
5.上記4まで、何の異常がないと思われたら、ファイル検索にて
  Drwtsn32.log を参照し、何らかのエラー発生がないかを
  確認して下さい。

上記の内容をご確認されて、そして、もし、内容の改善がなされなかったら
各OSのバージョンとSPのパージョン、そしてハードウエアの状況
(メモリ・周辺機器の有無(USB・SCSI接続の有無)を再度、ご提示
下さい。 また、特に、ハードディスクをどのようなイニシャライズを
なされたかをご提示下さい。(FAT16、FAT32、まずNTFSではないとは
思いますが)

この回答への補足

>>wa_jiroさん
丁寧な御解説有難うございます。さて、ご指摘の手順を踏んでなんとか
原因を究明しようと試みたのですが、結果は思わしいものではありません
でした。(常駐ソフトはできるものは全て解除しました)

・タスクマネージャ
転送中のCPU使用率が70~100%と激増。物凄く重いです。
「プロセス」タブの「CPU」が何を指しているのかはわかりませんが
「system idle process」「system」がそれぞれ0~70程度まで増減、
その他「explore」「taskmgr」が多少の動きを見せました。
ほかに特に動きの目立ったものはないです。

・イベントビューア
使ったことの無いツールなのでよくわかりませんが、それらしい
エラーログは発見できませんでした。強いてあげるなら
「アプリケーションログ」で「NBTデバイスからI/O制御情報を
読み取れません。」というのが目に付きました。
(これが何を指しているかはわからないのですが・・・)

・Drwtsn32.log
これについては、それらしい記述は見当たりませんでした。

・ハードウェア環境
OS:Windows2000 professional 5.00.2195(Meとデュアルブート)
CPU:Duron800MHz(クロックアップ無し)
メモリー:384MB(128*3)

プライマリ・マスター:IBM-DTLA-305030(問題のドライブ)
プライマリ・スレーブ:無し
セカンダリ・マスター:TEAC CD-W58E
セカンダリ・スレーブ:Aopen 12× DVD-ROM/ASH
外付けSCSIHDD・30GB
仮想CD-ROMドライブ一台

AGP:GeForce2MX400チップビデオボード
PCI:SB Live! DigitalAudio2、SCSIボード一枚

USBポート:ゲームパッド一個のみ

HDD構成
C:WindowsMe(5GB)
D:データ(10GB)
E:Windows2000(5GB)
F:データ(10GB)
I:データ(30GB、SCSI外付け)
フォーマットは全てFAT32

>>:tosihiroさん
デバイスマネージャでプライマリのIDEチャネルからDMAの有無を
確認しましたが、転送モードは「DMA(利用可能な場合)」
現在のモードは「PIO」でした。DMAに設定できないようです。
また、ドライバは問題なく動いています。
以前にWin2000が起動できなくなった原因は不明です。
思い当たる節がないのです。(それまでHDDは正常でした)。



ちなみに「HDBENCH」で以前と結果を比較すると
Read:6590→1744
Write:6760→1908
FileCopy:2353→978

・・・・ヽ(;´Д`)ノ

長文になりましたが、引き続きご回答を募集しています。
よろしくお願いします。m(_ _)m

補足日時:2001/09/15 20:25
    • good
    • 0

ハードウェア及びトラブルのOSが不明のため何とも言えないのですがWin2000ならばIDEコントローラがDMAモードになっているか確認したほうがよいでしょう。


どうも ソフトを入れてなければ HDD自体もしくは ドライバーが原因のような気がします。
なぜ 前回はWin2000が起動しなくなったのでしょうか。
何か思い当たるふしを考えてください
    • good
    • 0

お探しのQ&Aが見つからない時は、教えて!gooで質問しましょう!

今、見られている記事はコレ!

おしトピ編集部からのゆる~い質問を出題中

お題をもっとみる

このQ&Aを見た人が検索しているワード


このカテゴリの人気Q&Aランキング

おすすめ情報

カテゴリ