はじめまして。
今、WinNT4.0+SP6aにIIS4.0をのせる作業を行っているのですが、LANでつながるほかの端末からURLを http://IPアドレス/ と指定しても「検索中のページには問題があるので表示できません。」となって見ることができません。IISがのっているNTから http://localhost/ とすれば見ることができます。あまりサーバの設定をやったことがなくて困っています(TT)。どなたかIISの設定について教えていただけませんか?よろしくお願いします。

A 回答 (4件)

「HTTP 500 - 内部サーバー エラー」だけではなんともいえないですね。

いろいろな原因がありえます。
NTFSのアクセス権はわかりますよね?
一度、InetPub内のNTFSセキュリティを全てEveryoneFullControlに変えてみてください。

それでも無理ならIISのアクセス権ですかね。
サービスマネージャで規定のWEBサイトのプロパティ-ホームディレクトリタグにアクセス権の設定個所があります。
最低でも読取権限にチェックがついていないと見ることが出来ません。
ディレクトリセキュリティのタグには匿名アクセスの許可/不許可の設定個所があります。
念のため確認してください。

余談ですが、スタイルシートをNTのデスクトップ上で作成し、同PC上で動作するウェブサーバに公開したところ、自分のアカウントでログインしたその端末からしか見ることの出来ないサイトが完成してしまったことがあります。NTFSのアクセス権が引き継がれたようです。「見えてないで!」と指摘されるまでわかりませんでした。
    • good
    • 0

すでにご回答にあるものの他に、


・NTFSアクセス権
・IISのアクセス権
・スクリプトのエラー(DBサーバと連動してるならSQLとか)
なども考えられます。
確認方法などわからなければ補足してください。

このエラーメッセージはIEのですね。
ブラウザによって吐き出すメッセージが違いますよ。
Netscapeの方が詳しくエラーの原因を表示してくれると思います。
試してみてください。

この回答への補足

ご回答ありがとうございます。特にアクセス権などを変更していません。変更する必要があるのでしょうか?
Netscapeがすぐに手に入らないので確認できないのですが、IEで「HTTP 500 - 内部サーバー エラー 」というメッセージも表示されています。この HTTP500 などエラーコードに対する処置方法みたいなのを、どこかに公開されていないのでしょうか?

補足日時:2000/12/07 11:08
    • good
    • 0

他の端末からpingを実行してみて正常に返ってきますか?


#pingはDOS窓から行ってください

pingが正常に返ってこない場合は、ネットワークの設定が
おかしいはずです。

#もしかして別セグメントのサーバにIISを導入しているっ
#てことはないですよね?
#もしそうなら、DNS等の設定は正しいですか?

ま、どちらにしろlocalhostでは、見ることができるので
ネットワークの設定がおかしいと思いますよ!

この回答への補足

ご回答ありがとうございます。ping は問題ないようです。別セグメントとは?他社の環境で作業しているので他にサーバがあるか分かりません。DNSの設定で何かする必要があるのですか?IPを直接指定する場合は特に必要ないとどこかで見たような気がするのですが・・(自信なし)

補足日時:2000/12/07 11:18
    • good
    • 0

特に設定らしい設定はしなかったと思うんですが、LAN内のIPはプライベートアドレスで設定されていますか?


フォルダの共有などは正常にできているんでしょうか?

この回答への補足

ご回答ありがとうございます。ご指摘通り特に設定らしいことはしていません(^^;。アドレスは問題ないです。別に回答を頂いた horus さんに指摘された ping を行ったのですが正常でした。フォルダの共有も問題ないようです。

補足日時:2000/12/07 10:52
    • good
    • 0

お探しのQ&Aが見つからない時は、教えて!gooで質問しましょう!

今、見られている記事はコレ!

おしトピ編集部からのゆる~い質問を出題中

お題をもっとみる

このQ&Aを見た人が検索しているワード


このカテゴリの人気Q&Aランキング

おすすめ情報

カテゴリ