「javaによる図形処理入門」と云う本で勉強しています。だいぶ前に買った本で、当時はちゃんとコンパイルできていたのですが、ひさしぶりに新しいノートPCにインストールした最新のjava(1.5.0_07)でコンパイルするとエラーが出ます。ソースは以下の内容です。(エラーが出るところだけ掲載しています。)
==============================
import java.applet.Applet;
import java.awt.*;
import java.awt.event.*;

public class Gr3dim extends Applet
implements MouseListener,MouseMotionListener {
int doX, doY;
int angX=30,angY=30;
Cube data = new Cube();
Color [] Col={Color.gray, Color.cyan, Color.green,
Color.red,Color.white,Color.orange,
Color.magenta,Color.pink };

}
=========================

上記のCube data = new Cube();でエラーが出ます。
バージョンアップが何か関係あるのでしょうか?
お分かりの方いらっしゃいましたら、ご指導ください。よろしくおねがいします。

A 回答 (1件)

1)


Applet → java.applet.Applet
MouseListener,MouseMotionListener → java.awt.event.*
Color → java.awt.*
であることはわかりますが、Cubeクラスは以下のHPで存在しませんでした。本に載ってあった自作クラスですか?

2)
エラーとは具体的にどんなエラーですか?

参考URL:http://java.sun.com/j2se/1.5.0/ja/docs/ja/api/in …
    • good
    • 0
この回答へのお礼

ご指導ありがとうございます。

質問の意味をうまく、表現できていませんでしたが、Cubeクラスのjavaファイルがそのフォルダに無い事がエラーの原因だとわかりました。と言う事で、無事にエラーがなくなりました。ありがとうございました。

なにぶんjavaのプログラミングが6年ぶりなもので、本当に基礎的な事まで忘れてしまっていました。ご迷惑をおかけいたしました。

最後に本当にありがとうございました。

お礼日時:2006/06/04 11:14

お探しのQ&Aが見つからない時は、教えて!gooで質問しましょう!

今、見られている記事はコレ!

おしトピ編集部からのゆる~い質問を出題中

お題をもっとみる

このQ&Aを見た人が検索しているワード


このカテゴリの人気Q&Aランキング

おすすめ情報

カテゴリ