Q質問

 題記の件なのですが、NT4.0で解像度を不用意に上げてしまい、画面が表示されなくなってしまいました。
他のPCのディスプレイでも試してみたのですが、シグナルが反ってこないようでした。
過去の質問を見て、VGAで起動すれば良いとのことでしたが、PC起動時にVGA選択が出て来ていないため選択できません。
他にVGAモードでの起動方法を知っている方御教授の方宜しくお願いします。

質問者からの補足コメント

  • 回答ありがとう御座います。
    PC起動後ローダーが走りますが、 待ち時間が0秒になっていた場合というのは、画面に一瞬でも見えると、思うのですが、目で確認した限りでは、その画面自体が出てこないといった状況です。TT

    No.1の回答に寄せられた補足コメントです。 補足日時:2003/09/10 12:48 通報する
  • 他の人の全く同じPCを立ち上げて確認したところ、通常モードかVGAモードのどちらでの起動かを設定出来るようでした。
    ↓キーを押したままも試してみましたが、音が鳴るばかりで、前と同じようになってしまいました。

    No.3の回答に寄せられた補足コメントです。 補足日時:2003/09/10 13:41 通報する
  • 回答どうもありがとう御座います。
    やはり、最終的にはそのような方法しかないのでしょうか。。

    No.2の回答に寄せられた補足コメントです。 補足日時:2003/09/10 14:57 通報する
  • ドライブを共有していなかったため、他から変更も出来ませんでした。
    何度も回答頂き有り難う御座いました。

    No.4の回答に寄せられた補足コメントです。 補足日時:2003/09/10 14:59 通報する

A 回答 (6件)

他のPCにHDDを接続して作業した方がGUI環境での操作で簡単なんですが、
HDDの取り外しをせずにおこなうなら、
DOSフロッピー起動してコマンドラインでの作業になります、
BOOT.INIを用意し(テキストエディタで書いて保存)、
CドライブがFAT16なら起動フロッピーにコピーし、
これで起動して、
attrib -r -h -s x:\boot.ini (XはBOOT.INIのあるドライブ、大抵はCのはず)
として属性解除、
次に
copy a:\boot.ini c:\
としてフロッピーからBOOT.INIをCドライブにコピー、
これで起動時にVGAモードが使えるかどうか確認を、
NTFSの場合は以下のURLを参考にDOSからNTFSが認識できるようにして行って下さい。

http://win2000.nikkeibp.co.jp/tips/filedrive/ind …

http://www.netjapan.co.jp/FAQ/PQ_hint/boot_ini.h …

この回答へのお礼

何度も回答して頂いてありがとう御座いました。
今回は違う方法で解決しましたが、とても参考になりました、本当に何度も有り難う御座いました。

お礼日時:2003/09/10 16:43
    • good
    • 0

何度も申し訳ありません。
かっこいいやり方ではないのですが、過去に何回かやった事があるのでその方法だけ。
私はまだVGAモードが何たるかを知らなかった頃に解像度をいじって同じような現象になった時、イメージだけで直した事があります(笑)。というのは解像度をいじっただけなら画面が見えないだけで実際には動いていますよね。見えないなりにカーソルがデスクトップにあると仮定してマウスを右クリック、↓を5回押してエンターキーを押すと画面のプロパが開く、その後TABキーを3回押して・・・・・みたいな感じで実際に使える違う端末の操作を参考にしながらマウスを使わずに解像度を直した経験があります。

一応の参考までに・・・(笑)。

この回答へのお礼

なんとか解決できました。
解決方法はbobbleさんの言う通り他のNT機でプロパティでどのキーを何回押せば戻せるというのを調べて、やってみたところなんとか、元に戻すことが出来ました。
結局のところ表示できるようになった画面で、起動/シャットダウンを見てみたところ、『待ち時間』のところが0秒になっていました。
起動時に選択画面が出て来なかった原因は分かっていませんが、直ぐに待ち時間を設定し直しました^^;

本当に何度も、回答頂いて有り難う御座いました。

お礼日時:2003/09/10 16:49
    • good
    • 0

こんにちわ。申し訳ありませんが私の実力ではここまでですね(:_;)。
後、保証はできないのですが、#2で仰っているようにboot.iniを書き換える手段もあります。

通常?私が使用しているNTのboot.iniは

[boot loader]
timeout=20
default=multi(0)disk(0)rdisk(0)partition(1)\WINNT
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINNT="Windows NT Workstation Version 4.00"
multi(0)disk(0)rdisk(0)partition(1)\WINNT="Windows NT Workstation Version 4.00 [VGA mode]" /basevideo /sos
てな感じです。
もしも他の端末から、設定ミスした端末のcドライブを割り当てできるのであれば、boot.iniの内容を確認してtimeoutの設定を大きい数字(max999)に変更して起動がどのようになるか(設定画面がでてくるか)?
後は[operating systems]の下に上記のように2行の定義があるようであれば、上下を入れ替えて保存してやるとデフォルト起動がvgaモードになるので、それで起動してみてどうなるかって所ですか?

後、boot.iniを修正する場合読み取り専用になっているのでboot.iniのプロパから読取専用のチェックを外してから修正する必要があります。

    • good
    • 0

こんにちわ。
そうですか・・・。
他の同じスペックの端末があれば確認してほしいのですが、マイコンピュータのプロパに[起動・シャットダウン]というタグがあると思うのですが、そのプロパ画面の[起動]というところで通常モードかVGAモードのどちらで立ち上げるのかという設定ができるようになっています。もし他の端末で2種類から選択できるようになっているのであれば、その解像度が間違ってあげてしまった端末も同様に選択ができるはずだと思うのです。
一度やってみてほしいのですが、その端末の電源投入後(ローダーが走る前から)にずっと↓のカーソルキーを押したままにして起動したらどうなるかやってみてもらえないでしょうか?
もし↓のカーソルキーを押したまま起動してもログオン画面まで進むのであれば、起動中に通常とVGAの選択画面がでていない事になります。もし選択画面が表示されていたのであれば、その選択画面で一旦ストップするはずです。

    • good
    • 0

Win2000やXPなら別に編集したBOOT.INIを回復コンソールから上書きしちゃえるんだけど、
NTには回復コンソール無いから、
HDDを取り出して別のPCにHDDを接続してBOOT.INIのtimeoutを書き換えるしかないんじゃないかな?

    • good
    • 0

こんにちわ。
VGA選択ができないとの事ですが、PCを立ち上げてローダーが走った頃に通常モードかVGAモードかを選択できる画面がでてくると思うのですが、その画面がでてこないのでしょうか?
本当は選択画面は出てるけども、起動の待ち時間を0にしている為に一瞬で選択画面が消えているだけって事はないのでしょうか?

    • good
    • 0

お探しのQ&Aが見つからない時は、教えて!gooで質問しましょう!

新しく質問する

注目の記事

鬼は外!福は内〜!節分特集

春が来る季節の変わり目に豆を撒いて邪気を追い払い、無病息災を願う風習“節分”。落花生を撒いたり、掛け声も地方さまざま。節分をより楽しめる特集です。

このQ&Aを見た人が検索しているワード


このカテゴリの人気Q&Aランキング

おすすめ情報