ホームぺージをサーバーに転送したんですが写真の部分だけ×になって移りません
全部の写真だけでなく違うページの写真は写ってるのですが。。それとホームに戻るためのクリックするアイコン最後につけますよね。それも×になって写らないやつがあるんですけど(ホームには一応帰ります)何が原因でしょうか?初めて転送したので分かりません。よろしくお願いします。

このQ&Aに関連する最新のQ&A

A 回答 (10件)

ええっと、メモ帳でそのホームページ(.html とか .htm ってついているファイルです)を開いて見て下さい。



これに似た記述がありませんか?
<a href="http://www.geocities.co.jp/WINDOWS/​デスクトップ/写真/4oya11.JPG">
写真名
</a>

もしくは
<a href="http://www.geocities.co.jp/WINDOWS/​デスクトップ/写真/4oya11.JPG">
<img src="http://www.geocities.co.jp/WINDOWS/​デスクトップ/写真/4oya11.JPG" heigt=200 width=200>
</a>

<a>はアンカーといいます。
<a href="">文字</a>
のようにして宣言します。

ホームページ上では、「文字」のところだけ青くなって表示されていて、クリックするとhrefに代入したファイルやフォルダ(""の間に記述されているファイル名やフォルダ名)を開きます。

さてhref=""の部分を見て下さい。
href = "http://www.geocities.co.jp/WINDOWS/​デスクトップ/写真/4oya11.JPG"

これはウィンドウズでは
href = "C:\WINDOWS\​デスクトップ\写真\4oya11.JPG"
と書いているのと大体同じです。
パソコン名、ファイル名、フォルダ名です。
厳密には違いますが、簡単に言うとそういうものです。

サーバーというのはWindowsではなくUnixやリナックスという名前のOSが入ったパソコンのことです。

Windowsではフォルダ名やファイル名にふんだんに日本語が使えますが、サーバーではファイル名、フォルダ名に日本語を使わせないように設定している場合が多いです。

では、サーバー上に作ったフォルダ名に日本語は含まれていませんか?
フォルダやファイルを適切にアンカーで指定してあげていますか?

ご確認ください。
    • good
    • 0

#4 でファイル名って書いてますが,


#7の方の回答の通り,フォルダ名も該当します。

サーバーとブラウザの組み合わせによっては見えることも
あるようですが、
基本的に使ってはいけない文字です。

とりあえず、写真のファイルの置き場所を
htmlがあるフォルダに移動すれば見えるように
思えます。
    • good
    • 0

#2のBlack_Tigerです。



#7の方の回答でいいと思います。
サーバーではファイル名に2バイト文字は使えないという事と覚えてもらってても結構です。
あと、拡張子やファイル名も1バイト小文字に統一した方がいいですよ。
    • good
    • 0

http://www.geocities.co.jp/WINDOWS/デスクトップ/写真/4oya11.JPG
ていうのは見た瞬間違うかなって感じですね。2バイト文字はやめましょう。『写真』フォルダやめて『images』とか何でもいいんで半角英数字にして下さい。
で、ディレクトリが『/WINDOWS/デスクトップ/』てところが絶対違うと思うんですが。ローカルのディレクトリ構造がそのまま反映されてるんですね。
写真を配置しているHTMLファイルから見た相対パスを入れないと。トップページのアドレスを教えてもらえれば見えてくるんですが、わかりますか?
    • good
    • 0

オフラインではちゃんと見えているんですよね?転送時のエラーとかで表示されない場合って結構ありますよ。

一度サーバのデータを全部消してもう一度転送してみては?何回もやってるとうまく行くと思います。(大量にあるなら見えない画像だけ送り直すとか)
ちゃんと転送できてても通信時のエラーで見えないこともあるし。(再読み込みで見えるようになる)

あと、いろいろ考えられることあるんですが、keiko336さんの環境が全然書いてないので、それを詳しく教えてもらえるといいのですが。
(他にも見られるのですが結構質問する人、環境を全然書いてないってこと多いですよね。環境わかんないと解決その分遅くなりますよ)

この回答への補足

ご回答ありがとうございます
補足説明ですが他のパソコンでみてみると画像もボタン類もすべてしろくなっていたのでやはり基本的なミスをしているんだと思います
ソフトはフロントページエクスプレスとFFFTを使ってます
写真のタグはhttp://www.geocities.co.jp/WINDOWS/デスクトップ/写真/4oya11.JPG
となっていて種類が使用不可になっているんですがこれが原因なんでしょうか?

補足日時:2001/07/29 12:00
    • good
    • 0
この回答へのお礼

自分の作り方を補足させていただきます。
フロントページエクスプレスを開いて新規作成でトップページをつくる。 画像は写真をスキャナーで取り込んでデスクトップ上に写真のホルダーを作って保存しました。 それから表のますに画像を挿入する感じで挿入しました。それからあとはそれを保存してFFFTで転送しました。
FFFTに画像ファイルがないのが原因かと思ってデスクトップから画像をコピーして転送しました。画像のアドレスがデスクトップとかなってるから利用不可と表示されるんでしょうか?画像のプロパティをみると作成日も利用不可になっています
プロトルコ HyperText 転送プロトコル (HTTP  
種類 利用不可 
アドレス http://www.geocities.co.jp/WINDOWS/デスクトップ/写真/4oya11.JPG
作成日更新日 利用不可

といった感じです

お礼日時:2001/07/29 12:38

HPはどうやって製作していますか?


ソフト使用ですか?
サーバーへのアップが初めてと言うことで、おそらく
何かしらのソフトを使ってるのでは?と思ったのですが。

もしWinのフロントページエクスプレスを使っている場合、よくこのような現象がおこります。
原因はまさに「画像をローカルから読み込むようになっている」からです。
しかも困ったことに、「全部がそうなる」と言うわけでなく、「いくつかがごくまれにそうなる」ので、いちいち自分でソースをチェックするか、第3者に見てもらうかして、チェックしないと分かりません。

もしソフト使用ならば要注意ですよ。

この回答への補足

ご回答ありがとうございます
補足説明ですが他のパソコンでみてみると画像もボタン類もすべてしろくなっていたのでやはり基本的なミスをしているんだと思います
ソフトはフロントページエクスプレスとFFFTを使ってます
写真のタグはhttp://www.geocities.co.jp/WINDOWS/デスクトップ/写真/4oya11.JPG
となっていて種類が使用不可になっているんですがこれが原因なんでしょうか?

補足日時:2001/07/29 12:01
    • good
    • 0
この回答へのお礼

自分の作り方を補足させていただきます。
フロントページエクスプレスを開いて新規作成でトップページをつくる。 画像は写真をスキャナーで取り込んでデスクトップ上に写真のホルダーを作って保存しました。 それから表のますに画像を挿入する感じで挿入しました。それからあとはそれを保存してFFFTで転送しました。
FFFTに画像ファイルがないのが原因かと思ってデスクトップから画像をコピーして転送しました。画像のアドレスがデスクトップとかなってるから利用不可と表示されるんでしょうか?画像のプロパティをみると作成日も利用不可になっています
プロトルコ HyperText 転送プロトコル (HTTP  
種類 利用不可 
アドレス http://www.geocities.co.jp/WINDOWS/デスクトップ/写真/4oya11.JPG
作成日更新日 利用不可

といった感じです

お礼日時:2001/07/29 12:38

ファイル名に漢字(2byte文字,全角文字)を使っていると


うまくいかないことがあります。

厳密な規則は覚えてませんが,
英数字と_だけにしておけば間違いないと思います。

ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz0123456789_

この回答への補足

ご回答ありがとうございます
補足説明ですが他のパソコンでみてみると画像もボタン類もすべてしろくなっていたのでやはり基本的なミスをしているんだと思います
ソフトはフロントページエクスプレスとFFFTを使ってます
写真のタグはhttp://www.geocities.co.jp/WINDOWS/デスクトップ/写真/4oya11.JPG
となっていて種類が使用不可になっているんですがこれが原因なんでしょうか?

補足日時:2001/07/29 12:01
    • good
    • 0
この回答へのお礼

自分の作り方を補足させていただきます。
フロントページエクスプレスを開いて新規作成でトップページをつくる。 画像は写真をスキャナーで取り込んでデスクトップ上に写真のホルダーを作って保存しました。 それから表のますに画像を挿入する感じで挿入しました。それからあとはそれを保存してFFFTで転送しました。
FFFTに画像ファイルがないのが原因かと思ってデスクトップから画像をコピーして転送しました。画像のアドレスがデスクトップとかなってるから利用不可と表示されるんでしょうか?画像のプロパティをみると作成日も利用不可になっています
プロトルコ HyperText 転送プロトコル (HTTP  
種類 利用不可 
アドレス http://www.geocities.co.jp/WINDOWS/デスクトップ/写真/4oya11.JPG
作成日更新日 利用不可

といった感じです

お礼日時:2001/07/29 12:39

>写真の部分だけ×になって


この上で右クリックして、プロパティからURLを確認し、画像を転送したフォルダーにその画像があるかを確かめてください。
名前が違っているか(全角、半角も)、URLの指定先が違っているかと思います。

この回答への補足

ご回答ありがとうございます
補足説明ですが他のパソコンでみてみると画像もボタン類もすべてしろくなっていたのでやはり基本的なミスをしているんだと思います
ソフトはフロントページエクスプレスとFFFTを使ってます
写真のタグはhttp://www.geocities.co.jp/WINDOWS/デスクトップ/写真/4oya11.JPG
となっていて種類が使用不可になっているんですがこれが原因なんでしょうか?

補足日時:2001/07/29 11:59
    • good
    • 0
この回答へのお礼

自分の作り方を補足させていただきます。
フロントページエクスプレスを開いて新規作成でトップページをつくる。 画像は写真をスキャナーで取り込んでデスクトップ上に写真のホルダーを作って保存しました。 それから表のますに画像を挿入する感じで挿入しました。それからあとはそれを保存してFFFTで転送しました。
FFFTに画像ファイルがないのが原因かと思ってデスクトップから画像をコピーして転送しました。画像のアドレスがデスクトップとかなってるから利用不可と表示されるんでしょうか?画像のプロパティをみると作成日も利用不可になっています
プロトルコ HyperText 転送プロトコル (HTTP  
種類 利用不可 
アドレス http://www.geocities.co.jp/WINDOWS/デスクトップ/写真/4oya11.JPG
作成日更新日 利用不可

といった感じです

お礼日時:2001/07/29 12:39

#1の方の補足です。



(3)画像ファイルの拡張子が大文字でアップされ、ソースでは小文字である。

補足要求です。
アップする前のローカルでの表示は完璧ですか?

この回答への補足

ご回答ありがとうございます
補足説明ですが他のパソコンでみてみると画像もボタン類もすべてしろくなっていたのでやはり基本的なミスをしているんだと思います
ソフトはフロントページエクスプレスとFFFTを使ってます
写真のタグはhttp://www.geocities.co.jp/WINDOWS/デスクトップ/写真/4oya11.JPG
となっていて種類が使用不可になっているんですがこれが原因なんでしょうか?

補足日時:2001/07/29 12:03
    • good
    • 0
この回答へのお礼

自分の作り方を補足させていただきます。
フロントページエクスプレスを開いて新規作成でトップページをつくる。 画像は写真をスキャナーで取り込んでデスクトップ上に写真のホルダーを作って保存しました。 それから表のますに画像を挿入する感じで挿入しました。それからあとはそれを保存してFFFTで転送しました。
FFFTに画像ファイルがないのが原因かと思ってデスクトップから画像をコピーして転送しました。画像のアドレスがデスクトップとかなってるから利用不可と表示されるんでしょうか?画像のプロパティをみると作成日も利用不可になっています
プロトルコ HyperText 転送プロトコル (HTTP  
種類 利用不可 
アドレス http://www.geocities.co.jp/WINDOWS/デスクトップ/写真/4oya11.JPG
作成日更新日 利用不可

といった感じです

お礼日時:2001/07/29 12:40

考えられる原因は二つ。


(1)写真だけ転送し忘れた。
(2)HTMLで写真のURLをローカルで記述してしまっている。

(2)の場合は、HTMLのソースを開いて、写真を表示する部分のタグが間違っていないかチェックしてみてください。
file:///C:/My Documents/MyHome/xxx.jpg
などとなっていたら正しく表示されませんので、ホームページの相対パスにしたがって正しく記述し直してやる必要があります。

この回答への補足

ご回答ありがとうございます
補足説明ですが他のパソコンでみてみると画像もボタン類もすべてしろくなっていたのでやはり基本的なミスをしているんだと思います
ソフトはフロントページエクスプレスとFFFTを使ってます
写真のタグはhttp://www.geocities.co.jp/WINDOWS/デスクトップ/写真/4oya11.JPG
となっていて種類が使用不可になっているんですがこれが原因なんでしょうか?

補足日時:2001/07/29 11:53
    • good
    • 0
この回答へのお礼

自分の作り方を補足させていただきます。
フロントページエクスプレスを開いて新規作成でトップページをつくる。 画像は写真をスキャナーで取り込んでデスクトップ上に写真のホルダーを作って保存しました。 それから表のますに画像を挿入する感じで挿入しました。それからあとはそれを保存してFFFTで転送しました。
FFFTに画像ファイルがないのが原因かと思ってデスクトップから画像をコピーして転送しました。画像のアドレスがデスクトップとかなってるから利用不可と表示されるんでしょうか?画像のプロパティをみると作成日も利用不可になっています
プロトルコ HyperText 転送プロトコル (HTTP  
種類 利用不可 
アドレス http://www.geocities.co.jp/WINDOWS/デスクトップ/写真/4oya11.JPG
作成日更新日 利用不可

といった感じです

お礼日時:2001/07/29 12:40

お探しのQ&Aが見つからない時は、教えて!gooで質問しましょう!


このカテゴリの人気Q&Aランキング

おすすめ情報