痔になりやすい生活習慣とは?

RedHat9でKDEを使用しています。

# rpm -qa | grep kde
lockdev-devel-1.0.0-23
kdeaddons-3.1-4
kdenetwork-devel-3.1-5
kde-i18n-Afrikaans-3.1-2
kde-i18n-Dutch-3.1-2
kde-i18n-Icelandic-3.1-2
kde-i18n-Romanian-3.1-2
kde-i18n-Ukrainian-3.1-2
kdetoys-3.1-3
kdebase-devel-3.1-15

とバージョンはなっています。
Redhat9のインストールCDに入っていたKDEです。

最近、
「KDEのインターネットプロトコルコミュニケーションのセットアップにエラーが起
こりました。システムのメッセージは以下の通りです。
Could not open network socket
'dcopserver'プログラムが実行中か確認して下さい。」

となり、[OK]をクリックするとパスワードを聞かれます。

暫らくするとこれが出てうっとうしいのですがこれはどうすれば改善されるのでしょ
うか?

このQ&Aに関連する最新のQ&A

A 回答 (2件)

> スンマセン。

削除しちゃいました。
・・(o ̄∀ ̄)ノ” 私のコメントの書き方も悪かったですね。
 傷害復旧やテストなどでは、元の状態の保存は気を遣うとよいです。(^^;

> Kouquorer上で適すとテキストエディタでテキストファイルを開こうとすると、相変わらず、
> 「KlauncherはDCOP経由で到達できませんでした」
> あと、相変わらず、
> ファイルマネージャー・スーパーユーザモードが立ち上がりません。

 調べておりませんので、なんともいえませんが、DCOPについても傷害報告(だったかセキュリティアラートだったか)があったと思います。
 そのせいなのかなぁ~

> > KDEをバージョンアップされるというのはいかがでしょうか?
> これは大変な作業になるんですかね?

 インストールは RPM で行われているようですね。
 インターネットへ繋がる環境であるのならば、Red Hat 9 ですから up2date や apt-get などが利用できると思います。
 簡単なのは、apt-get だと思います。(up2date は殆ど触ったこと無いのですが、どうも操作しづらかった記憶がありますけど・・apt-get は簡単でよいです)

 kde から始まるパッケージをアップデートするだけですので、バージョンをそろえて rpm ファイルをインストールするだけになります。

 apt-get だとかのコマンドについてはインターネット上にはたくさんでていますが、はまってしまいそうなら、また質問してください。

 ところで、kde パッケージに i18n系でいろんな言語対応されていますが、必要なんですかね。すごいなぁ~って思いました。(^^;

この回答への補足

>> スンマセン。削除しちゃいました。
> ・・(o ̄∀ ̄)ノ” 私のコメントの書き方も悪かったですね。
>  傷害復旧やテストなどでは、元の状態の保存は気を遣うとよいです。(^^;
了解致しました。

>> あと、相変わらず、
>> ファイルマネージャー・スーパーユーザモードが立ち上がりません。
>  調べておりませんので、なんともいえませんが、DCOPについても傷害報告(だった
> かセキュリティアラートだったか)があったと思います。
>  そのせいなのかなぁ~
そうなんですか。

>>> KDEをバージョンアップされるというのはいかがでしょうか?
>> これは大変な作業になるんですかね?
>  インストールは RPM で行われているようですね。
>  インターネットへ繋がる環境であるのならば、Red Hat 9 ですから up2date や
> apt-get などが利用できると思います。
>  簡単なのは、apt-get だと思います。(up2date は殆ど触ったこと無いのですが、
> どうも操作しづらかった記憶がありますけど・・apt-get は簡単でよいです)
>
>  kde から始まるパッケージをアップデートするだけですので、バージョンをそろえ
> て rpm ファイルをインストールするだけになります。
>
>  apt-get だとかのコマンドについてはインターネット上にはたくさんでています
> が、はまってしまいそうなら、また質問してください。
apt-getですね。分かりました。試してみたいと思います。

補足日時:2005/01/17 16:24
    • good
    • 0
この回答へのお礼

有難うございます。

.kde/socket-<マシン名>/ 以下のファイルの
ownerとパーミッションを確認してみて
そのディレクトリをリネームしてからXwindowを再度起動して上手くいきました。

お礼日時:2005/01/20 12:31

KDEのバグに掲載されていたような記憶が・・うっす~らあります。

(うっす~らです)

/tmp/.ICE-unix/*
$HOME/.DCOPserver*

上記のファイルたちについて、削除しちゃうとよいらしいです。

 KDEをバージョンアップされるというのはいかがでしょうか?

 試してみてください。(削除じゃなくて、移動して試されることをお勧めします)

この回答への補足

ご回答大変有難うございます。

スンマセン。削除しちゃいました。
# ls /tmp/.ICE-unix/
2313= 2505= dcop2217-1105437367= dcop2475-1105437498=

# rm /tmp/.ICE-unix/*
rm: remove ソケット `/tmp/.ICE-unix/2313'? yes
rm: remove ソケット `/tmp/.ICE-unix/2505'? yes
rm: remove ソケット `/tmp/.ICE-unix/dcop2217-1105437367'? yes
rm: remove ソケット `/tmp/.ICE-unix/dcop2475-1105437498'? yes

# ls -a /home/user01/ | grep DCOP
.DCOPserver_rh9.dyndns.net_:0@
.DCOPserver_rh9.dyndns.net_:2@
.DCOPserver_rh9.dyndns.net__0
.DCOPserver_rh9.dyndns.net__2
# rm /home/user01/.DCOPserver*
rm: remove シンボリックリンク `/home/user01/.DCOPserver_rh9.dyndns.net_:0'? yes
rm: remove シンボリックリンク `/home/user01/.DCOPserver_rh9.dyndns.net_:2'? yes
rm: remove 通常ファイル `/home/user01/.DCOPserver_rh9.dyndns.net__0'? yes
rm: remove 通常ファイル `/home/user01/.DCOPserver_rh9.dyndns.net__2'? yes

として、改善されました。
でも、
Kouquorer上で適すとテキストエディタでテキストファイルを開こうとすると、相変わらず、
「KlauncherはDCOP経由で到達できませんでした」
あと、相変わらず、
ファイルマネージャー・スーパーユーザモードが立ち上がりません。

> KDEをバージョンアップされるというのはいかがでしょうか?
これは大変な作業になるんですかね?

補足日時:2005/01/15 13:11
    • good
    • 0

このQ&Aに関連する人気のQ&A

お探しのQ&Aが見つからない時は、教えて!gooで質問しましょう!


人気Q&Aランキング