gooドクター有料プランが1ヶ月間無料!

仕事で使用しているPCにLinuxのCentOS7をインストールしました。
そしたらLANケーブルを挿し直しても、アドレスの設定をしても『ネットワークへの接続を失敗しました』と出ます。
それで「ifconfigコマンド」を使って現在の設定状況を確認してみました。
すると「inet」「netmask」等がすでに設定したはずなのに何にも表示されません。
これはNICの不具合なのでしょうか?
すみませんが、どなたか回答お願いします。

gooドクター

A 回答 (4件)

どうやってIPアドレスの設定をしましたか?


/etc/sysconfig/network-script/ifcfg-eth* なファイルを直接編集してますか?
もしそうだとして、NetworkMagerが有効になっている場合、こいつが設定を上書きしてるかもしれません。
# systemctl disable NetworkManager
ってやって無効化するか、あるいはNetworkManagerで設定してみたらどうでしょうか。Network Managerで設定するなら↓が便利かも。
# nmtui

個人的にはNetworkManagerを使うメリットが見いだせないので、いつも無効化しちゃってます。
    • good
    • 0
この回答へのお礼

設定はOSのインストールの際にネットワークの設定でIPアドレス等を設定しました。
別の方へのお礼にも書きましたが一度PCにインストールした時に設定したときには繋がったんですが、もう一度同じPCにOSをインストールし直した(インストール初心者のためパーティションをやり直したくて)場合、繋がらなくなってしまいました。
NetworkManagerの設定に関しては次回行ったときに確認してみようと思います。
回答ありがとうございました。

お礼日時:2021/06/16 15:41

>一度インストールした時に設定したときには繋がったんですが、もう一度同じPCにOSをインストールし直した(インストール初心者のためパーティションをやり直したくて)場合、繋がらなくなってしまいました。


よく聞く話だね。
まあ、そんな時言うことは、「同じことをやった」との思いを疑えです。
大抵どっかでミスってますね。

何をどう設定したかの情報がないので
それ以上の言及は避けます。
    • good
    • 0
この回答へのお礼

回答ありがとうございました。

お礼日時:2021/06/17 10:29

>すると「inet」「netmask」等がすでに設定したはずなのに何にも表示されません。


設定が間違ってんじゃないの?
    • good
    • 0
この回答へのお礼

一度インストールした時に設定したときには繋がったんですが、もう一度同じPCにOSをインストールし直した(インストール初心者のためパーティションをやり直したくて)場合、繋がらなくなってしまいました。
とりあえず回答ありがとうございました。

お礼日時:2021/06/16 15:38

PC以外の接続機器、ルーターやONU、ハブなどには問題ないのでしょうか。

まずそちらから調べられた方が宜しいように思います。
    • good
    • 0
この回答へのお礼

スイッチングハブで何台か使用していますが、とりあえず他のPCは問題なく動いています。
とりあえず色々試してみたいと思います。
回答ありがとうございました。

お礼日時:2021/06/15 14:42

お探しのQ&Aが見つからない時は、教えて!gooで質問しましょう!

このQ&Aを見た人はこんなQ&Aも見ています

gooドクター

このQ&Aを見た人がよく見るQ&A

人気Q&Aランキング