【先着1,000名様!】1,000円分をプレゼント!

ホームページを作るために、メモ帳を使かおうとしています。だが、HTMLタグを打って画像と同じフォルダーに入れて保存をするのですが、どうしても×印が出てしまい、画像を表示させることが出来ません。HTMLタグは合っているはずだし、同じフォルダー内に入れているのになぜか×印が表示されてしまいます。
もしよろしかったら解決方法を教えて頂きたいのですが…同じ方法で以前に1度だけ表示させることが出来ましたが、それ以降はまったく出来なくなりました。

このQ&Aに関連する最新のQ&A

A 回答 (5件)

画像の色がRGBではなくて、CMYKになってませんか?


普通の写真は初期では殆どRGBですが、フォトショップなんかのプロ用ソフトで作成した写真なら確認して見て下さい。

よく分からない場合は、その写真だけブラウザで開いて見て下さい。
見れるのであれば、タグ等の間違え、見れないなら写真そのものの問題です。

この回答への補足

ありごとうございます。保存の方法に誤りがあったみたいです。無事解決が出来ました。申し訳ございませんでした。

補足日時:2005/05/18 00:40
    • good
    • 0
この回答へのお礼

ありがとうございます。もう一度色々とやってみます。ちなみに普通の写真です。

お礼日時:2005/05/18 00:11

画像の形式は何でしょうか。

特殊な形式で保存してませんか? epsとかpsdとか。とりあえずjpgやgifなら問題なく表示されるはずです。
表示されないという画像ファイルを、ブラウザへドラッグしてみて表示されれば画像自体は問題はなく、htmlファイルに原因があることになります。

画像のリンクのタグは、
<IMG SRC="画像フアィル名">
ですが、画像がhtmlと違うフォルダにある場合は、画像ファイルの前に/で区切ってフォルダ名を付け足さなければなりません。ですが、同じフォルダの中に画像もhtmlファイルもあるんですよね。
もしかしたら画像ファイル名の前に、余計なフォルダの名前がくっついていてウソの場所を指定してる状態になってるのかもしれません。
上のタグで示す例の、" "の間が画像ファイルのみになるように画像ファイルのファイル名をコピぺし直してみてください。

この回答への補足

ありごとうございます。保存の方法に誤りがあったみたいです。無事解決が出来ました。申し訳ございませんでした。

補足日時:2005/05/18 00:37
    • good
    • 0
この回答へのお礼

ありがとうございます。もう一度色々と試してみます。
画像の形式はjpgです。

お礼日時:2005/05/18 00:09

こんばんは。



<img src='~~~.jpg'>や<img src="~~~.jpg">
ですよね。

(1)拡張子をちゃんと入れていますか?
(2)タグやファイル名は全角/半角, 大文字/小文字で誤りは無いですか?
(3)ブラウザで画像を表示させるようになっていますか?
※ツール→インターネットオプション→詳細設定
(4)imgとsrcの間のスペースは半角になっていますか?

以上を確認し、もしダメならそこのIMGタグだけでもここに貼り付けてもらえないでしょうか?

この回答への補足

ありごとうございます。保存の方法に誤りがあったみたいです。無事解決が出来ました。申し訳ございませんでした。

補足日時:2005/05/18 00:37
    • good
    • 0
この回答へのお礼

ありごとうございます。もう一度色々と試してみます。
ちなみに画像は表示されるようにしています。家にある2台のパソコン両方で出来ないので、もしかしたらタグやファイル名がおかしいのかもしれません。

お礼日時:2005/05/17 23:57

まず、画像のファイル名をすべて小文字にして保存し直してください。

そしてIMGタグの中のファイル名も同じようにすべて小文字にしてみて下さい。

結構大文字小文字の問題で悩まされたことがあります。

この回答への補足

ありごとうございます。保存の方法に誤りがあったみたいです。無事解決が出来ました。申し訳ございませんでした。

補足日時:2005/05/18 00:36
    • good
    • 0
この回答へのお礼

ありがとうございます。もう一度色々と試してみます。確かに大文字と小文字はややこしいですね。

お礼日時:2005/05/18 00:02

ためしに絶対パスで入力してください(IMGタグのとこ)。

この回答への補足

ありごとうございます。保存の方法に誤りがあったみたいです。無事解決が出来ました。申し訳ございませんでした。

補足日時:2005/05/18 00:33
    • good
    • 0
この回答へのお礼

ありがとうございました。もう一度色々と試してみます。もしかしたらHTMLに問題があるのかもしれません。

お礼日時:2005/05/17 23:59

お探しのQ&Aが見つからない時は、教えて!gooで質問しましょう!


人気Q&Aランキング