Delphi初心者です。
現行VBVersion5で構築したシステムが動作するPC上にDelphi
(バージョンは未だ決まってません)
でシステムを構築しようと考えていますが、この2つのシステムの
共存は可能なのでしょうか?
(VB同士でバージョンが異なるとDLLとかの問題がありますが、Delphiでは
 それと似たような制限とか問題はあるのでしょうか?)
なに分初心者なので、おかしな質問かも知れませんが、よろしくお願い
します。

このQ&Aに関連する最新のQ&A

A 回答 (2件)

問題はないと思いますよ


以前、VisualStudio6.0とDelphi4の共存した環境を使用したことがありますが
DLLが書き換えられたとか言う問題は起こりませんでした
どちらの言語も、正常に使用できましたよ
Delphiのバージョン違いを複数共存させる時には問題が起きるでしょうが
VBとDelphiでは問題は起きないと思います
    • good
    • 0
この回答へのお礼

即時の回答ありがとうございます。<(_ _)>
とりあえず、”問題はないと思いますよ”の
回答に安心しました。

お礼日時:2001/10/18 17:36

こんにちは、honiyonです。



 Delphi5を愛用しています。
 私もVisualStdioとDelphiを何の問題もなく両方インストールしています。
 VB5で構築したシステムが...とは、VB5とDelphiを一緒にインストールして問題ないか?という意味ですよね?

 Delphiで開発したソフトは、ランタイムライブラリ(外部DLL)を必要としません。 そのため、実行する際にはソフト単体で大丈夫です。 同様の理由で実行する際にバージョン云々の問題は発生しません。

 私はやった事ないので難しいか簡単か分かりませんが、Delphi1から全部バージョンを残し、新旧バージョン混在でインストールしている人がいるので、これも可能です。

 余談ですが、Delphi6の低グレード(Standardだったかな?)は Borlandのサイトで無償で配布されています。[参考URL]

 参考になれば幸いです(..

参考URL:http://www.borland.co.jp/
    • good
    • 0
この回答へのお礼

回答ありがとうございます。
二人の方に意見をいただけると心強いです。
参考URLからのダウンロード早速してみました。
これから色々試してみたいとおもいます。
回答していただいたお二方
あわせてありがとうございました。(^^)

お礼日時:2001/10/19 10:14

このQ&Aに関連する人気のQ&A

お探しのQ&Aが見つからない時は、教えて!gooで質問しましょう!


人気Q&Aランキング

おすすめ情報