redhatLinux7.1にphp4.0.6をインストール(--with-pgsqlはなし)でインストールしました。プログラムから外部のpostgresデータベースを操作したいのですが、Undefined functionとなってpg_connectなどの関数が使えません。--with-pgsqlをつけてconfigureするとエラーが出たっぽいので外したんですが・・・。pgsql関数を使うにはpostgres本体もインストールしないとダメなんでしょうか??関数だけ使う方法はないでしょうか??教えてください。

このQ&Aに関連する最新のQ&A

A 回答 (1件)

先ずpostgresqlをインストールしておいて、。

--with-pgsqlでpostgresqlのパスを指定して./configureするのでposugresqlのインストールは必須だと思います。どちらが先かはあんまり関係ないような気もしますが(?)
関数だけは無理じゃないかと思います。
    • good
    • 0
この回答へのお礼

どうもありがとうございます。
postgresいれます。

お礼日時:2001/12/03 14:59

お探しのQ&Aが見つからない時は、教えて!gooで質問しましょう!


人気Q&Aランキング

おすすめ情報