どうか教えて下さい!
症状としてはあるサイトのURLに対して、PCのブラウザから見た場合はきちんとhttps通信が可能なのに、
i-MODEの503iからだと「SSL通信が切断されました」となってしまうのです。当然httpでは問題ありません。
あとどの503端末で試してみてもダメでした。
こういった症状を経験された方はいらっしゃらないでしょうか!?または考えられる原因がありましたら
教えて下さい。
日本ベリサインのセキュウア・サーバID申請をもらって、mod_sslを使っております。OSはFreeBSD4.3でApacheです。

[エラーログの内容]
[error] OpenSSL: error:14094412:SSL routines:SSL3_READ_BYTES:sslv3 alert bad certificate [Hin
t: Subject CN in certificate not server name or identical to CA!?]

このQ&Aに関連する最新のQ&A

A 回答 (1件)

残念ながら、今の携帯電話では、HTTPS(SSL) は、Cokkie 情報をもてません。

(なぜなら、携帯電話では、Cokkie を保存するメモリやディスクが存在しないため)
WWW サーバとは別の何らかのネットワーク機器を別に導入する必要があります。
    • good
    • 0

このQ&Aに関連する人気のQ&A

お探しのQ&Aが見つからない時は、教えて!gooで質問しましょう!

このQ&Aを見た人が検索しているワード

このQ&Aと関連する良く見られている質問

Qmaillogのwarningメッセージの原因について

maillogを確認していたところ以下のログがありました。

warningのメッセージで検索したのですが、情報がみあたらず、
以下のログにはどういったことが原因で発生したのかが分からない状態です。

もし原因を御存じの方がいらっしゃいましたら、ご教授いただけないでしょうか。
~~~~~
■ログ
Dec 2 12:43:13 mail postfix/smtpd[27943]: SSL_accept error from unknown[xxx.xxx.xxx.xxx]: -1
Dec 2 12:43:13 mail postfix/smtpd[27943]: warning: TLS library problem: 27943:error:140760FC:SSL routines:SSL23_GET_CLIENT_HELLO:unknown protocol:s23_srvr.c:628:
Dec 2 12:43:13 mail postfix/smtpd[27943]: lost connection after CONNECT from unknown[xxx.xxx.xxx.xxx]
Dec 2 12:43:13 mail postfix/smtpd[27943]: disconnect from unknown[xxx.xxx.xxx.xxx]
~~~~~

■mailサーバ環境
# cat /etc/redhat-release
CentOS release 6.5 (Final)
# postconf | grep mail_version
mail_version = 2.6.6
# dovecot --version
2.0.9
※SSLv2は無効化されていた。
-----
・main.cf ※コメントアウト部分を手動で削除
queue_directory = /var/spool/postfix

command_directory = /usr/sbin

daemon_directory = /usr/libexec/postfix

data_directory = /var/lib/postfix

mail_owner = postfix

mydomain = test-hogehoge.local

myorigin = $mydomain

inet_interfaces = all
inet_protocols = ipv4

mydestination = $myhostname, localhost.$mydomain, localhost, $mydomain

unknown_local_recipient_reject_code = 550

mynetworks = xxx/xxx/xxx/xxx/32, xxx.xxx.xxx.xxx/24

relay_domains = $mydestination

alias_maps = hash:/etc/aliases, hash:/var/spool/ml/etc/aliases, regexp:/etc/postfix/aliases.reg

alias_database = hash:/etc/aliases, hash:/var/spool/ml/etc/aliases

home_mailbox = Maildir/

header_checks = regexp:/etc/postfix/header_checks

smtpd_banner = $myhostname ESMTP unknown

debug_peer_level = 2

debugger_command =
PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin
ddd $daemon_directory/$process_name $process_id & sleep 5
sendmail_path = /usr/sbin/sendmail.postfix

newaliases_path = /usr/bin/newaliases.postfix

mailq_path = /usr/bin/mailq.postfix

setgid_group = postdrop

html_directory = no

manpage_directory = /usr/share/man

sample_directory = /usr/share/doc/postfix-2.6.6/samples

readme_directory = /usr/share/doc/postfix-2.6.6/README_FILES

disable_vrfy_command = yes

virtual_mailbox_maps = mysql:/etc/postfix/mysql_virtual_mailbox_maps.cf
virtual_alias_maps = mysql:/etc/postfix/mysql_virtual_alias_maps.cf, hash:/etc/postfix/redmine_aliases
virtual_mailbox_domains = owncloud.jp, trustdrive.jp, test-hogehoge.my, test-hogehoge.com.my, test-hogehoge.net $myhostname, localhost.$mydomain $mydomain

virtual_mailbox_limit = 0

virtual_mailbox_base = /home/virtual
virtual_minimum_uid = 5000
virtual_uid_maps = static:5000
virtual_gid_maps = static:5000

### for SMTP-AUTH
smtpd_sasl_type = dovecot
smtpd_sasl_auth_enable = no
smtpd_sasl_path = private/auth
smtpd_sasl_security_options = noanonymous
smtpd_recipient_restrictions =
permit_mynetworks
permit_sasl_authenticated
reject_unauth_destination
broken_sasl_auth_clients = yes

### for TLS
smtpd_use_tls = yes
smtp_tls_loglevel= 1
smtpd_tls_cert_file = /etc/pki/bgt/test-hogehoge.net.crt
smtpd_tls_key_file = /etc/pki/bgt/test-hogehoge.net.key
smtpd_tls_CAfile = /etc/pki/bgt/intermediate.crt
smtpd_tls_session_cache_database = btree:/etc/postfix/smtpd_scache
smtpd_tls_session_cache_timeout = 3600s

### for fml
allow_mail_to_commands = alias, forward, include

default_process_limit = 200
default_destination_concurrency_limit = 50
-----

maillogを確認していたところ以下のログがありました。

warningのメッセージで検索したのですが、情報がみあたらず、
以下のログにはどういったことが原因で発生したのかが分からない状態です。

もし原因を御存じの方がいらっしゃいましたら、ご教授いただけないでしょうか。
~~~~~
■ログ
Dec 2 12:43:13 mail postfix/smtpd[27943]: SSL_accept error from unknown[xxx.xxx.xxx.xxx]: -1
Dec 2 12:43:13 mail postfix/smtpd[27943]: warning: TLS library problem: 27943:error:140760FC:SSL rou...続きを読む

Aベストアンサー

>warning: TLS library problem
明らかにTLSライブラリでのエラーですが・・・。

>### for TLS
>smtpd_use_tls = yes
TLSが有効になっているのは正常ですか?


人気Q&Aランキング