RedHatLinux7.1をやっと導入し、これから勉強しようとしている初心者です。

やっとインストールも完了し、
いろいろなコマンドを試して勉強中です。
ここで、「man」コマンドでヘルプを見ようと思ったら、
B5G5#%l%・・・・ とか、 B$3$N%^%・・・・ とかいった
意味不明な文字がどんどん出てくるのですが、
これは文字化けですか?それとも正常なのでしょうか?

もし、文字化けなら対処法など宜しくお教え下さい。

このQ&Aに関連する最新のQ&A

A 回答 (2件)

コンソール画面でしたら単純にkonが立ち上がっていないのでは?



$./kon

としてみてください。
    • good
    • 0
この回答へのお礼

早速試してみました。
出来ました!日本語で表示されています。
ありがとうございます。
原因は・・・・??
たしか、日本語システムを使用しますか?→NO
とやって、途中、言語設定は「Japanese」と答えたような気がします。

お礼日時:2001/12/04 06:15

異常でもなければ、正常でもないと思えるようだ。


Xの環境で、日本は表示されていますか?
ひょっとして、英語環境で導入してしまったとか?
もしそうすると、漢字入力も出来ない可能性もあるようだ。


コンソールで、
$ echo $LANG
または、
env | grep LANG
でも、同じ。
LANG="ja_JP.eucJP"
を表示しませんか?

ルートユーザでログインして、
# vi /etc/sysconfig/i18n
LANG="en_US"
となっていたら、
LANG="ja_JP.eucJP"
に変更。

SUPPORTED="ja_JP.eucJP:ja_JP:ja"
SYSFONT="lat0-sun16"
SYSFONTACM="iso01"

私のRedHatでは、"i18n"には、上記のように記述されていた。

一時的には、
$ export LANG=ja_JP.eucJP
でも、確認できるが、"i18n"ファイルに設定しておかないと、再起動するたびに、設定しなければならなくなる。

違うところに原因があるかもしれないので、その場合は、ご免なさい。
    • good
    • 0
この回答へのお礼

ご丁寧にありがとうございます。
う~ん。。。その設定にはなっているようです。
他に原因があるようです。

お礼日時:2001/12/04 06:07

お探しのQ&Aが見つからない時は、教えて!gooで質問しましょう!

このQ&Aと関連する良く見られている質問

Qmailコマンドでは化けないSubjectがPOPで受信すると文字化け

mailコマンドで、メールのタイトル一覧を表示した時には、Subjectは文字化けしていないのですが、
POP3でメーラ(WindowsのBecky)で受信すると
Subjectが文字化けしてしまいます。
ヘッダ情報は以下のようになっています。

MIME-version: 1.0
Content-Type: text/plain; charset="iso-2022-jp"
Content-Transfer-Encoding: 7bit

原因は何でしょうか?

Aベストアンサー

charset="iso-2022-jp"
これは、JISコードです、

Windowsの方では
シフトJISを使って文字を
画面に表示しているからだと
思います。

Qmanで文字化け

コンソールではちゃんと日本語が表示されているんですがmanコマンドを使うとBD9$$%*W%・・・・といった文字化けになってしまいます。どこをどう直せばよいのでしょうか。

laser5 7.2使用 KDEです。

Aベストアンサー

・manコマンドが日本語に対応していない。
・manで使っているPAGERが日本語に対応していない。
・manで使っているPAGERは日本語に対応しているけど,出力の際の文字コードが間違っている。

このあたりに原因はないですか?

今回の場合は違うと思いますが,以前こんなこともありました。
・偶々,7bit-JISで書いてあるman pagesを引いたら,man周りのコマンド(groff)が7bit-JISに対応していなかった。

Qlinux RedHat7.3でmanページが文字化けする

manページを見ると文字化けしてしまいます。
startxした後の、ターミナルエミュレータからのmanは文字化けしません。
「export LANG=ja_JP.ujis」をしてもだめでした。

Aベストアンサー

当たり前ですな。konなりjfbtermなりを動かさなければ
ね。konの方が簡単かも。konコマンドが動かなければ、

kon2-何とか.rpm

のパッケージを取ってきてインストールすれば良いはず。

QRedHatLinux7.1でjavaのインストール

RedHatLinux7.1でjavaのインストールがうまくいきません。

<javaインストール>
1)Java 2SDK,StandardEdition
上記は書籍のcd_romに添付分を使用。

2)Java2SDK,EnterprizeEdition バージョン1.2.1
サイトからDounload分を使用

3)J2EESDK 日本語版追補バージョン1.2.1
サイトからDounload分を使用

4)CD-ROMをマウント
  mount /dev/cdrom /mnt/cdrom
5)インストール手順
cd /usr/local
/mnt/cdrom/linux/java/j2sdk-1_3_0_02-linux.bin
tar zxvf /home/jin/j2sdkee-1_2_1-linux.tar.gz
tar zxvf /home/jin/j2sdkee-1_2_1-linux-ja.tar.gz

6)環境変数の設定
開発に使用するUSER(jin)でログインしなおし、ホームディレクトリの.bashrcの最下行に追加
export PATH=$PATH:/usr/local/jdk1.3.0_02/bin
export JAVA_HOME=/usr/local/jdk1.3.0_02
export CLASSPATH=$CLASSPATH:/usr/local/j2sdkee1.2.1/lib/j2ee.jar
export CLASSPATH=$CLASSPATH:/usr/local/jdk1.3.0_02/lib/tools.jar

7)javaのバージョン確認した所下記エラーが出ます。
java -version
[jin@tsl jin]$ /usr/local/jdk1.3.0_02/bin/java: /usr/bin/cut: そのようなファイルやディレクトリはありません
/usr/local/jdk1.3.0_02/bin/i386/native_threads/java: error while loading shared libraries: libjvm.so: cannot load shared object file: No such file or
directory

8)それで、ln -s /bin/cut /usr/bin/cut
でcutのリンクをはったところ
java -versionが帰ってこなくなりました。
java -?はすぐ結果がでます。

何が悪いのでしょうか??ヒントをお教えください。

p.s.
CGIの件はScriptAliasでユーザーフォルダ以外を指定してやれば上手く動きました。
そのときAddHandler cgi-script .cgiはあくまでもコメントアウトしております。(笑)
その節はご回答有難う御座いました。

RedHatLinux7.1でjavaのインストールがうまくいきません。

<javaインストール>
1)Java 2SDK,StandardEdition
上記は書籍のcd_romに添付分を使用。

2)Java2SDK,EnterprizeEdition バージョン1.2.1
サイトからDounload分を使用

3)J2EESDK 日本語版追補バージョン1.2.1
サイトからDounload分を使用

4)CD-ROMをマウント
  mount /dev/cdrom /mnt/cdrom
5)インストール手順
cd /usr/local
/mnt/cdrom/linux/java/j2sdk-1_3_0_02-linux.bin
tar zxvf /home/jin/j2sdkee-1_2_1-linux.tar.gz
ta...続きを読む

Aベストアンサー

私のLinuxも日経LinuxのFTP版です。
Server製品以外は、全て、雑誌の付録で製品は購入したことはありません。

合性の問題はありません。
日経Linux12月号のRedHatは、7.1.94 Roswell Cut-2(Public Beta)でも確認しております。この中に、j2sdk-1_3_0_01-linux-i386.binはあるのですが、 j2sdk-1_3_0_02-linux.binは、サンのサイとにも見つかりません。また、
http://www.blackdown.org/にも見つかりません。
また、問題点の再現ができません。

再度、このディレクトリィが存在するかを確認してください。
/usr/local/jdk1.3.0_02

口をだした以上、動作するまで、お付き合いいたします。
遠慮なく問い合わせてください。

現在言えることは、
1.RedHatを再導入する。
2.jinユーザを作成する。
3.js2dkを導入する。
4..bash_profileにパスなどを設定する。

cutが、/bin/cut
であれば、正常に導入されています。

jinユーザの、.bash_profileのパスに、
一部省略

Get the aliases and functions
if [ -f ~/.bashrc ]; then
.~/.bashrc
fi

# User specific environment and startup programs

PATH=$PATH:$HOME/bin

export PATH
unset USERNAME

新規ユーザを作成した場合、上記の状態です。

export PATH=$PATH:/usr/local/jdk1.3.1_01/bin
export JAVA_HOME=/usr/local/jdk1.3.1_01

以上は、JDKを導入した場合です。

どこかで、PATHを書き換えるような、記述になっていないかを確認してください。

.bash_profiel→.bashrc→/etc/basrcと実行されて行きます。

私のLinuxも日経LinuxのFTP版です。
Server製品以外は、全て、雑誌の付録で製品は購入したことはありません。

合性の問題はありません。
日経Linux12月号のRedHatは、7.1.94 Roswell Cut-2(Public Beta)でも確認しております。この中に、j2sdk-1_3_0_01-linux-i386.binはあるのですが、 j2sdk-1_3_0_02-linux.binは、サンのサイとにも見つかりません。また、
http://www.blackdown.org/にも見つかりません。
また、問題点の再現ができません。

再度、このディレクトリィが存在するかを確認してください...続きを読む

QRedhatLinux7.1J-apacheのアップグレード失敗します

RedhatLinux7.1Jを使用しています。

http://www.jp.redhat.com/support/errata/RHSA/RHSA-2001-126J.html

以上のサイトから、7.1用のApache最新版を入手し、
インストールしようとした所、以下のエラーが表示されて
インストールに失敗してしまいます。


apache本体を導入しようとすると、「mod_~.rpm」がないって怒られて、
「mod_~.rpm」を導入しようとすると、apacheと競合すると怒られ、
結局アップグレードできないんです・・・。


<その1>
 rpm -Fvh apache-1.3.22-1.7.1.i386.rpm
  ↓
 エラー: 依存性の欠如:
  mod_bandwidthは apache-1.3.22-1.7.1 に必要とされています
  mod_putは apache-1.3.22-1.7.1 に必要とされています
  mod_throttleは apache-1.3.22-1.7.1 に必要とされています

<その2>
 rpm -ivh mod_bandwidth-2.0.3-2.i386.rpm
 rpm -ivh mod_put-1.3-2.i386.rpm
 rpm -ivh mod_throttle-3.1.2-3.i386.rpm
  ↓
 エラー: 依存性の欠如:
  apache < 1.3.22-1 mod_bandwidth-2.0.3-2 と競合します

RedhatLinux7.1Jを使用しています。

http://www.jp.redhat.com/support/errata/RHSA/RHSA-2001-126J.html

以上のサイトから、7.1用のApache最新版を入手し、
インストールしようとした所、以下のエラーが表示されて
インストールに失敗してしまいます。


apache本体を導入しようとすると、「mod_~.rpm」がないって怒られて、
「mod_~.rpm」を導入しようとすると、apacheと競合すると怒られ、
結局アップグレードできないんです・・・。


<その1>
 rpm -Fvh apache-1.3.22-1.7.1.i386.rpm...続きを読む

Aベストアンサー

全部まとめて指定してください。
こんな感じです。

rpm -Uvh mod* apache*


このカテゴリの人気Q&Aランキング

おすすめ情報