ホームページをソフトで作成して、FTPで転送しているのですが、ここ最近おかしなことがおきています。ページの何部分かがぽっかりと抜けてしまうんです。自分でも色々とやってみたのですが駄目です。何か解る方いたら、教えていただけないでしょうか。お願いします。

このQ&Aに関連する最新のQ&A

A 回答 (4件)

HTMLファイルが文字化けしているのではないでしょうか?


自動設定でアップロードすると多くのFTPツールでは、HTMLは、ASCCIモードになります。その場合は、相手のホストの文字コードをEUCなのか、S-JISなのか、設定しておかないとアップロードしたときに文字化けが起こる可能性があります。
自分のマシンでOKということは、相手は、EUCの可能性が大きいので、そこを設定してみてはいかがでしょうか?FTPサーバーの文字コードをEUCに設定してASCCIモードで転送するということです。
がんばってみてください。
    • good
    • 0
この回答へのお礼

ご丁寧にどうもありがとうございました。
ken2さんの教えてくださったことをしてみたのですが、変わりはありませんでした。
問題は文字化け、というよりはHTMLタグの一部改ざんにあると思ってるのですがその解決法が見つからなくて…

何はともあれ、知恵を分けてくださってどうもありがとうございました。

お礼日時:2002/01/10 09:39

アップロードしおわったデータのソースとアップロードする前のソースは同じでしょうか?


もし、変わっているならそのへんに原因があるのかも?
そのソフトは使ったことがないので解りませんが…
同じであれば、たとえばその抜けた画像のURLを直接IEに貼り付けて表示されるかどうかとか。
自分のPCで表示できて、他のPCで表示できない理由としてファイル名にスペースを使った、なんて経験がありますけど…
以前にタグの記述が間違っているとその部分を受付けないサイトがあるって聞いたことあるのですが…
関係ないですよね。

この回答への補足

調べてみたら、アップロード前後のソース、違いました。
それで、いろいろと修正してみたのですが変わりがなくて…。
FTP内でアップロード後のソースが見れるんですが、
それはアップロード前と同じでした。

アップロードの時に勝手にソースが書き換えられてしまっているのかな?
と思ったのですが…。
リンクを、テキストに張らなければテキストはちゃんと表示されるのですが、
リンクを張ると消えてしまう部分がでてきます。
IMGタグの最初の"<IMG…"が"<!--"になってしまっているようで…。

beeyanさんがアドバイスしてくださったことを調べてみましたが
スペースを使ってはいませんでした。

わかりにくい説明で申し訳ないのですが、何かおわかりでしたら教えてください。お願いします。

補足日時:2002/01/07 14:22
    • good
    • 0

>ページの何部分かがぽっかりと抜けてしまうんです



具体的にどういう状態なのか上の表現ではよくわかりませんが…。

画像部分が抜けてしまうんですか?画像ファイルをアスキーモードで転送しているとか…。自分のパソコンではちゃんと表示されているんですね?

この回答への補足

具体的に言うと、画像も抜けますし、普通にテキストも抜けてしまうんです。
自分のパソコンではちゃんと表示はされています。
っていうことは何が根本的な原因なんでしょう…。

補足日時:2002/01/07 00:43
    • good
    • 0

ホームページソフトとFTPソフトは何をお使いでしょうか?


それが解らないと・・・

この回答への補足

ホームページソフトはAdobeのPage Mill 3.0Jで
FTPソフトはNext FTPです。

補足日時:2002/01/07 00:46
    • good
    • 0

お探しのQ&Aが見つからない時は、教えて!gooで質問しましょう!


人気Q&Aランキング

おすすめ情報