現在職場で、つぎのようなLAN構成があります。
 インターネット-ルータ-server1-各PC
このserver1の下にRedHat6.2をつかってFailサーバを作ろうとしているのですが
SambaがWindowsから見えません。現在の設定は以下の通りです。

server1・・・hostname=server1.aaa.or.jp・・・ISP指定のドメイン
       eth0=ISP指定のIPaddress
       eth1=192.168.1.1
       DHCP・・・範囲192.168.1.10~192.168.1.250
       ゲートウェイ=ルータのIPaddress
server2・・・hostname=server2.aaa.or.jp
       eth0=192.168.1.2
       ゲートウェイ=192.168.1.1・・・これでよいのでしょうか?
       プライマリーDNS=空欄・・・・これでよいのでしょうか?
Sambaの設定・・・workgroupe=job-1・・・・適当につけてよいのでしょうか?
        Sambaパスワード=XXXX・・・Windows側の設定(NTドメイン                       等)との関係は?
とんちんかんな質問かもしれませんが、何でも結構です。アドバイスおねがいします。tomosato

このQ&Aに関連する最新のQ&A

A 回答 (1件)

Windowsネットワークの持病として、端末の起動直後にはブラウズリストには掲載されません。


表示されるまでに時差があります。

まず、
・smbdとnmbdに起動方法はどうなっていますか?
・smbdとnmbdは起動していますか?

この2つを確認しましょう。
通常、inetd(xinetd)またはデーモンモードでの起動の何れかの設定をします。
デーモンモードで起動した場合はsmbd/nmbdが-Dのオプション付きで起動しているはずです。

一度、sambaのドキュメントを読みましょう。

参考URL:http://www.samba.gr.jp/
    • good
    • 0
この回答へのお礼

selenity様
早速のアドバイスありがとうございました
早速試してみたいと思います
取り急ぎおれいまで

お礼日時:2002/01/12 13:43

このQ&Aに関連する人気のQ&A

お探しのQ&Aが見つからない時は、教えて!gooで質問しましょう!

このQ&Aを見た人が検索しているワード

このQ&Aと関連する良く見られている質問

Qeth0を認識させる方法

Dellのpower edge 2400でredhat6.2をインストールしたら、
ipconfig・netstatを使ってもIPが見えません
どうやら、認識されていないようです。
dell用のドライバなどはすべてインストール済みです。

ifupをすれば認識できるのですが、
サーバマシンのためリモートからリブートをしたりすることが
予想されるので、解決方法を探しています。

linux/dellに詳しい方宜しくお願いします。

Aベストアンサー

起動時に、eth0 を up できない原因として
考えられるのは、

[/etc/sysconfig/network]の中で
NETWORKING=yes

になっていないと起動時に eth を up しません.

また、
[/etc/sysconfig/network-scripts/ifcfg-eth0]の
中も関係ありそうですが、ifup で up できるので
あれば、これは関係ないかもしれません.

==

"linuxconf" というコマンドで、適当に
設定してみるとか.

Qeth0 とホストのアドレスは同じでいい?

こんにちは。

Linux初心者で、思いっきり間抜けな質問かもしれませんが、確認しておかないと気持ち悪いので質問します。

タイトル通りなのですが、eth0(唯一のネットワークカード)とホストのIPアドレスは同じでいいのですよね?

RedHat8
DELLのマシン(オンボードLANソケット)

Aベストアンサー

同じでいいでーす。

以上

QNICからのkernel: eth0: Something Wicked happened! 2008.

TL6.1Jにてサーバーを運用しています。
サーバーには、DNS,Mail,Ftp,Sambaがあります。
そこで、タイトルのエラーが最近になって頻発しています。

また、kernel: ip_masq_ftp OUT: got PASV
もたまに出ます。eth0はLAN側です。
この原因と対処について経験があるかたお願いします。

マシンスペックは下記の通り

CPU:Pentium(3)550MHz
MB:AX6BCR VSPEC
RAM:SDRAM128M PC100
HDD:DPTA-372050
Video:Mill G200 8MB/AGP
NIC:LD10/100AL×2枚

Aベストアンサー

>NICの2枚挿しなのですが、出るのはLAN側のみで、WAN側に
>出たことはありません。これは、つまりLAN側に相当な負荷
>やパケットがあるために警告としているものなのでしょうか?

原因がわからないために,NICドライバのソースから原因を見つけるという話のつもりだったのですが,いまいち伝わらなかったようで…

実際に調べたので手順をちょいとまとめてみました。
(バージョンの違いにより行数が異なるかもしれません)

カーネルのソースが必要なので,インストールしていなければインストールCDからカーネルソースをインストール。

"2008"でgrepしても,有益な情報が得られなかったので,
"Something Wicked happened"で調べることにする。

$ grep -n "Something Wicked happened" /usr/src/linux/drivers/net/*
old_turip.c:2315: ……
via-rhine.c:1123: ……
yellowfin.c:1175: ……

jotarouさんのNICはvia-rhineなので,via-rhine.cに狙いを定める。

less,viなどで"/usr/src/linux/drivers/net/via-rhine.c"を1123行から見ると
1123: printk(KERN_ERR "%s: Something Wiched happend! %4.4x.\n",
1124: dev->name, intr_status);

"2008"はintr_statusの16進表示0x2008であることがわかる。

このファイルの頭からintr_statusで検索すると,297行目から

enum intr_status_bits{ ....
..., intrTxAbort=0x0008, ...
..., intrTxAbort=0x2000, ...
};

とあるので,0x2008はTxAbortの割り込みがLANカードから発生してる事がわかります。んで,ちょいとWebで調べると…

the VT86C100A data sheet says this TxAbort bit is set when
there are excessive collisions.

てのが,ありました。コリジョンが沸いてるみたいですね。

>NICの2枚挿しなのですが、出るのはLAN側のみで、WAN側に
>出たことはありません。これは、つまりLAN側に相当な負荷
>やパケットがあるために警告としているものなのでしょうか?

原因がわからないために,NICドライバのソースから原因を見つけるという話のつもりだったのですが,いまいち伝わらなかったようで…

実際に調べたので手順をちょいとまとめてみました。
(バージョンの違いにより行数が異なるかもしれません)

カーネルのソースが必要なので,インストールしていなければインストールCDから...続きを読む

Qhostnameの設定方法

とても基本的な質問だと思うのですが、手元にある資料でやり方をみつけられなかったので質問させてください。

RedHat Linux 9において
インストール時のネットワークの設定の際「ホスト名」のところで「DHCPを通して自動的に」にチェックを入れてしまいました。
このためか、ADSLモデム側のLANカードにケーブルを接続していると起動に非常に時間がかかってしまいます。

「DHCPを通して自動的に」ではなく「手動」で設定したいのですが、どのようにすればよいのでしょうか?

/etc/host.confあたりをいじればいいのかもしれませんが、いまいちよくわかりません。
ちなみに、/etc/host.confは、
order hosts,bind
と書かれていました。

ADSLは、YahooBBです。
以上、よろしくお願いいたします。

Aベストアンサー

IPを固定にしたいのかと勘違いしてましたm(__)m

/etc/sysconfig/network に hostname を書いてもDHCPで
上書きされちゃうんでしょうか?

NETWORKING=yes
HOSTNAME=hogehoge

それと,「起動に非常に時間がかかる」というのはどのあたりでおこっていますか?

おそらく,何かデーモンを起動する部分なのでは無いかと思うのですが…本当にhostnameが原因なのかどうか,状況がよくわかりません.

Qeth0が表示されない

VineLinuxのデスクトップPCです。
LANアダプタはアイ・オー・データのET/TX-PCIを使用しております。

ネットワークに繋がらないのでとりあえず

>ifconfig -a

で、「lo」と「tap0」というのがでます。

>ifconfig

だけでは「lo」だけです。
etc/conf.modulesの内容を見てもeth0という表示がありません。
netcfgを使ってみてもloとtap0というものしかありませんでした。

正しくLANアダプタを認識して、eth0を表示さすにはどういう設定がいるのでしょうか?

情報不足なら補足します。
よろしくお願いします。

Aベストアンサー

カーネルがちゃんとNICを認識してますか?
dmesgコマンドで起動時のメッセージ、
lspciコマンドでPCIバスの状態やIRQなど確認してみてください。
NICを認識してなかったら、カーネルの再構築やNICのモジュールを
探してきて組み込む必要があるかも。

以下はIntel EtherExpress100の場合です。


# dmesg | less

eepro100.c:v1.09j-t 9/29/99 Donald Becker http://cesdis.gsfc.nasa.gov/linux/drivers/eepro100.html
eepro100.c: $Revision: 1.18 $ 1999/12/29 Modified by Andrey V. Savochkin <saw@msu.ru>
eth0: Intel PCI EtherExpress Pro100 at 0xdc079000, 00:90:27:70:75:DF, IRQ 10.
Receiver lock-up bug exists -- enabling work-around.
Board assembly 721383-006, Physical connectors present: RJ45
Primary interface chip i82555 PHY #1.
General self-test: passed.
Serial sub-system self-test: passed.
Internal registers self-test: passed.
ROM checksum self-test: passed (0x04f4518b).


# lspci -v

00:10.0 Ethernet controller: Intel Corporation 82557 [Ethernet Pro 100] (rev 08)
Subsystem: Intel Corporation EtherExpress PRO/100+ Management Adapter
Flags: bus master, medium devsel, latency 32, IRQ 10
Memory at da100000 (32-bit, non-prefetchable)
I/O ports at ec00
Memory at da000000 (32-bit, non-prefetchable)
Capabilities: [dc] Power Management version 2

カーネルがちゃんとNICを認識してますか?
dmesgコマンドで起動時のメッセージ、
lspciコマンドでPCIバスの状態やIRQなど確認してみてください。
NICを認識してなかったら、カーネルの再構築やNICのモジュールを
探してきて組み込む必要があるかも。

以下はIntel EtherExpress100の場合です。


# dmesg | less

eepro100.c:v1.09j-t 9/29/99 Donald Becker http://cesdis.gsfc.nasa.gov/linux/drivers/eepro100.html
eepro100.c: $Revision: 1.18 $ 1999/12/29 Modified by Andrey V. Savochkin <sa...続きを読む


人気Q&Aランキング

おすすめ情報