JBuilder5 professionalを使用しています。
あるサンプルを再現しようと思い、作業しているのですが
そのサンプルはJDK1.4.0Beta2で作られているとのこと。
私の使っているJDK(1.3.2)も同様にしようと思い、
JDK1.4.0Beta3をインストールし、設定したのですが、
コンパイル時、下記の警告がでてしまいます。
--------------------------------------------------------------------------
警告 #: 910 : クラス java.lang.Object;クラスファイルのバージョンが不正です:
      48.0; をチェックできません. java.lang パッケージがステーブルである
      ことが想定されます。-nomakestable の使用をお勧めします
警告 #: 910 : クラス CardMakerServlet;クラスファイルのバージョンが不正です:
      48.0 はインポートに問題があります; をチェックできません. .
      パッケージがステーブルであることが想定されます。-nomakestable の使用を
      お勧めします
--------------------------------------------------------------------------

JDKの設定をJBuilderでかえただけなんですが、
ほかに設定しないといけないことがあるのでしょうか?
教えてください。

このQ&Aに関連する最新のQ&A

A 回答 (1件)

こんにちは。



JBuilderのヘルプでコンパイルについて見てみました。(しかしVer4ですが。)
その中のコンパイラオプションの設定にある、
・ステーブルパッケージのチェック
・ステーブルパッケージの作成
のチェックをはずしたら、エラーは消えませんか??

Ver4で言うと、
メニューの[プロジェクト]から[プロジェクトプロパティ]
プロジェクトプロパティ画面の[ビルド]タブにあります。

はずしていたら、すいません。
    • good
    • 0

このQ&Aに関連する人気のQ&A

お探しのQ&Aが見つからない時は、教えて!gooで質問しましょう!


人気Q&Aランキング

おすすめ情報