ちょっと変わったマニアな作品が集結

上記ルータのセットアップをしようとしています。
現在の設定状況は以下のとおりです。
FastEthernet1に対してIPアドレスを設定しようとしていますが、
うまく設定できません。設定方法は間違えていないと思いますが・・
いろいろ調べているところですがが、なかなか解決できません。
解決方法を教えてください。
よろしくお願いします。

router1#configure
Configuring from terminal, memory, or network [terminal]?
Enter configuration commands, one per line. End with CNTL/Z.
router1(config)#interface FastEthernet 1
router1(config-if)#ip address 192.168.2.1 255.255.255.0

% IP addresses may not be configured on L2 links.

router1(config-if)#


---現在のshow conf---
interface BRI0
no ip address
no ip route-cache
shutdown
no cdp enable
!
interface FastEthernet0
ip address 192.168.1.1 255.255.255.0
no ip route-cache
speed auto
half-duplex
no cdp enable
!
interface FastEthernet1
no cdp enable
!
interface FastEthernet2
shutdown
no cdp enable
!
interface FastEthernet3
shutdown
no cdp enable
!
interface FastEthernet4
shutdown
no cdp enable
!
interface Vlan1
description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$
no ip address
no ip route-cache
ip tcp adjust-mss 1452
shutdown
!
ip classless
ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 5 life 86400 requests 10000

このQ&Aに関連する最新のQ&A

A 回答 (4件)

Router>enable


Router#vlan database
Router(vlan)#vlan 2
Router(vlan)#exit
Router#conf t
Router(config)#interface Vlan 2
Router(config-if)#ip address 192.168.2.1 255.255.255.0
Router(config-if)#interface FastEthernet 1
Router(config-if)#switchport access vlan 2
Router(config-if)#no shutdown
Router(config-if)#end
Router(config)#exit
Router#

※vlan 2 は (2-1001)の範囲の任意の数

上記の様に設定すれば良いと思います。
    • good
    • 2

1712は、IEEE 802.1Q VLAN(Mux:16VLAN)をサポートしているようなので、



ポートの数だけVLAN切って、それぞれ別NWのIP振って、
物理IFにVLAN-IDを割り当てれば、
見掛け上、各IFにアドレスを振ることも可能でしょう。

まあ、CISCOのサイトに知りたい事は書いてあると思いますよ。
見つけるのが大変ですが。

参考URL:http://www.cisco.com/japanese/warp/public/3/jp/p …
    • good
    • 2

interface FastEthernet1は、スイッチポートですね。



ipは当てられないですよ。

当てたいのであれば、vlan1で、ipを当てるなりして、やれば、interface FastEthernet1にpingを通すことは可能です。
    • good
    • 2

このルータは LAN 側に Fastt-Ethernet Swich を内蔵したものですよね。



4ポートあってもスイッチング・インターフェイスですからIPアドレスのレイヤから見て論理的に1つのインターフェイスですから正常な反応ですよ。
    • good
    • 1

このQ&Aに関連する人気のQ&A

お探しのQ&Aが見つからない時は、教えて!gooで質問しましょう!

このQ&Aを見た人はこんなQ&Aも見ています

このQ&Aを見た人が検索しているワード

このQ&Aと関連する良く見られている質問

QCISCOルータのIPアドレスの確認方法。

CISCOルータ自身のIPアドレスの取得方法が知りたいです。ブラウザから設定をしたいので、IPアドレスを知りたいのですが、そういったコマンドはあるでしょうか?(初心者すぎで、トンチンカンなことを言っているかもしれません)

ターミナルソフト?で特権モードに入るまではできたのですが…。

Aベストアンサー

> すみません、常識以前の質問なのでしょうが、IPアドレス等は、CISCOルータに直接設定しなくてはならないのでしょうか?

以前の回答のように、BBルータであればWAN側をDHCPで運用みたいなことはあるでしょうけど.......
(CiscoでもCisco1812Jみたいな機種はそのような運用はありかもしれません)

基本的には各interfaceに固定でIPアドレスを振って使うのが普通です
あと、interfaceに振られたIPアドレスを確認する方法として、
show interface
(省略形はsh int)
を実行すればinterfaceに割り振られたIPアドレスも含めてinterfaceの状態も確認することができます

Qサブインタフェースは必要?

CCNAの勉強をしているのですが、VLANを作成する際にルータでサブインタフェースの設定をしなければならないとあります。
何故ですか?

例えばルータにスイッチが接続され、更にその下にホストA、Bが接続されているとします。
ホストA、Bを異なるVLANに所属させ、なおかつ同じネットワークアドレスを持つようには出来ないということですよね?
ルータで、タグだけ付け替えて、受信したポートに転送することはできないんですか?

Aベストアンサー

全体的に、L2/L3に関してこんがらがっているようです。
・VLANは単に、線の仮想化
・ルータはパケットの宛先IPアドレスを見て別のインターフェイスから転送をする、だけ
 ・VLANタグとか見ない

ルータのフォワーディング機能が働く段階では、VLANタグは取れてます。
IPヘッダ・イーサネットフレーム・802.1Qのフォーマットを改めて見てみて、ネットワークのどこで何が起きているのかを想像してみてください。

蛇足になりますが、、
> ホストA、Bを異なるVLANに所属させ、なおかつ同じネットワークアドレスを持つようには出来ないということですよね?
スイッチとPCで設定するぶんには、出来るっちゃできます(そういう設定が必要な状況もあります)

QCiscoルータを初期設定(工場出荷)に戻すには

Ciscoルータを初期設定(工場出荷)に戻すにはどうすればいいのでしょうか?enableパスワードがわかる場合とわからない場合で教えていただければとおもいます。
よろしくお願いいたします。

Aベストアンサー

Ciscoルータは他のルータと違ってマニュアルなどもついてないので初心者には大変ですよね(^^;

enableパスワードがわかるなら特権モードに入った状態で「erace startup-config」と入力します。
※ただしIOSのバージョンが古い場合は上記のコマンドが使えないので「write erace」と入力してください。

上記コマンドを入力した後再起動「reload」すればOKです。


次にenableパスワードがわからない場合。これは厄介ですね。
ルータのレジスタをいじるので注意が必要です。
下記URLにCisco2500の初期化方法が紹介されているので参考にしてください。

参考URL:http://bird.dip.jp/computing/cisco.html

QルータでLAN側WAN側を同じネットワークアドレスにするとエラー

はじめまして。初心者です。ルータの機能について教えてください。
機種はcisco 1721です。

ルータの設定で以下のように間違えて設定したところ、エラーになりました。

 LAN側:IP 172.17.1.1 サブネットマスク 255.255.0.0
 WAN側:IP 172.17.2.1 サブネットマスク 255.255.0.0

 エラー: % 172.17.0.0 overlaps with Ethernet0

 *エラーの原因はネットワークアドレスが重複したためです。

「ルータとは、異なるネットワークアドレスを結ぶもので、
 WAN側とLAN側は同じネットワークアドレスではいけない」
という基本的な理屈は理解しています。

ここから質問なんですが、
 1.ルータ側で設定を禁止しないといけないものなのでしょうか。
   実際に運用するかは別として、上記のように使用してもルータに問題は
   無いように思うのですが

 2.上記のように同じネットワークアドレスに設定する方法はあるのでしょうか。
   それとも絶対に許されない設定なのでしょうか。

ルータの設計思想のような質問です。
勉強不足で申し訳ございませんが、ご教授をお願いいたします。

はじめまして。初心者です。ルータの機能について教えてください。
機種はcisco 1721です。

ルータの設定で以下のように間違えて設定したところ、エラーになりました。

 LAN側:IP 172.17.1.1 サブネットマスク 255.255.0.0
 WAN側:IP 172.17.2.1 サブネットマスク 255.255.0.0

 エラー: % 172.17.0.0 overlaps with Ethernet0

 *エラーの原因はネットワークアドレスが重複したためです。

「ルータとは、異なるネットワークアドレスを結ぶもので、
 WAN側とLAN側は同じネットワ...続きを読む

Aベストアンサー

こんにちは
>1
大多数のルータは、ネットワークのオーバーラップを避けるため、
警告メッセージを出します。


>2
基本的にはできても通信異常が起こりえるため、
設定できないのと同じ状況です。

--------------------
以下余談ですが、、、
仮にI/F1 で172.17.1.1/16 を設定した場合、
I/F1 が所属するNW アドレスは、172.17.0.0/16 になります。
この状態で、I/F2 に172.17.2.1/16 を付与できたとすると、
I/F2 の所属するNW アドレスも、172.17.0.0/16 になります。

そして以下のような構成を組んだ場合の通信を説明します。

[PC1:172.17.1.100/16]---[I/F1|ルータ|I/F2]---[PC2:172.17.2.100/16]

このとき、PC1 からPC2 宛ての通信を行うと、
以下のような通信フローが取られます。

1)PC1 からPC2 のMAC アドレスを取得するための
 ARP リクエストが送信されます。
2)I/F1 側にはPC2 がいないため、誰もARP の返答を返しません。

このときルータはI/F1 側のNW 内での通信のため、
I/F2 にルーティングしません。
そもそも、ARP はブロードキャストなので、
異なるNW に通信しません。


もし、以下のように適正に設定している場合は、
次のような通信フローがとられます。

[PC1:172.16.1.100/16]---[I/F1|ルータ|I/F2]---[PC2:172.17.2.100/16]

I/F1:172.16.1.1/16
I/F2:172.17.2.1/16

1)PC1 からPC2 宛ての通信は、ネットワークが異なるため、
 ルータのMAC アドレスを取得すべく、ARP リクエストが送信されます。
2)I/F1 でARP リクエストを受信したルータは、
 PC1 にARP リプライを送信し、MAC アドレスを知らせます。
3)PC1 は送信先のIP アドレスにはPC2 のIP ドレスを、
 送信先のMAC アドレスにはルータのMAC アドレスを入れ、
 ルータにデータを送信します。
4)ここで、ルータのARP テーブルにPC2 のIP と
 MAC アドレスが登録されていれば、
 そのままPC2 に送されます。
 登録されていない場合は、ルータがPC2 にARP リクエストを送信します。

こんにちは
>1
大多数のルータは、ネットワークのオーバーラップを避けるため、
警告メッセージを出します。


>2
基本的にはできても通信異常が起こりえるため、
設定できないのと同じ状況です。

--------------------
以下余談ですが、、、
仮にI/F1 で172.17.1.1/16 を設定した場合、
I/F1 が所属するNW アドレスは、172.17.0.0/16 になります。
この状態で、I/F2 に172.17.2.1/16 を付与できたとすると、
I/F2 の所属するNW アドレスも、172.17.0.0/16 になります。

そして以下のような...続きを読む

Qループバック、pingに詳しい方

Pingについて教えて下さい。
ループバックアドレスに対してPingが通るという事と自分のIPに対してPingが通るという事の違いは何でしょうか?「ループバックアドレスにPingが通る」という事実から判断できるのはTCP/IPは正常にインストールされているという事のみで、NICまで正常とは言えない。自分のIPにPingが通ればNICは正常(デバイスドライバでNIC項目に!?等の表示はないはずである)という認識であっていますでしょうか?それともGWまでPingが通らないと
NICは正常とは言えないのでしょうか?詳しい方がいらっしゃいましたら
ご教授ください。

Aベストアンサー

正解は
> TCP/IPは正常にインストールされているという事のみで、NICまで正常とは言えない。
> GWまでPingが通らないとNICは正常とは言えない
です。

試しに、ネットワークケーブルを抜いた状態で自分のPCのIPにpingを打ってみてください。応答が帰ってくるはずです。
(DHCPによるIP自動取得だとうまくいかないので、IPを静的に設定してやってみてください)

ネットワーク関係の知識がある場合は、"netstat -rn" コマンドを実行してみてください。自分のIPアドレスに対するインタフェースがループバックIPに割り当てられているのがわかると思います。

なお、Windowsのデバイスマネージャの画面で異常がわかるような状態だと、そもそもIPの設定そのものができない可能性が高いです。

Qciscoスイッチ VLANが違うポート同士の通信について

自社のネットワークの構成で対向するポート同士のVLANが違うのに通信しているのをみかけました。自分がCCNAの勉強をしていた時は対向するポート同士は同じVLANでないと通信出来なかったと記憶しているのですが。。。

以下に詳細を記載させて頂きます。

[ L3スイッチ ]PortA ---- PortB[L2スイッチ]

L3スイッチのコンフィグ
interface vlan 100
ip address 192.168.1.1 255.255.255.0

PortAのコンフィグ
switchport mode dynamic desirable
switchport acccess vlan 100

L2スイッチのコンフィグ
interface vlan 150
ip address 192.168.1.2 255.255.255.0

PortBのコンフィグ
switchport mode access
switchport access vlan 150

試しにシミュレータを使って違うVLANに属するPort同士で通信を試みましたがping失敗しました。。

あくまで自分の予想なのですが、
L3スイッチの場合スイッチングだけでなくルーティングも可能なので同じサブネット内であってもVLAN間の通信が可能?
traceroute打っても結局はportAのIPアドレスしか出てこないので内部でどういう処理をしているのか確認できませんが。。。

どこかで勘違いしているのかもしれません。。よろしくお願いします。

自社のネットワークの構成で対向するポート同士のVLANが違うのに通信しているのをみかけました。自分がCCNAの勉強をしていた時は対向するポート同士は同じVLANでないと通信出来なかったと記憶しているのですが。。。

以下に詳細を記載させて頂きます。

[ L3スイッチ ]PortA ---- PortB[L2スイッチ]

L3スイッチのコンフィグ
interface vlan 100
ip address 192.168.1.1 255.255.255.0

PortAのコンフィグ
switchport mode dynamic desirable
switchport acccess vlan 100

L2スイッチのコンフ...続きを読む

Aベストアンサー

アクセスポート同士の接続であれば通信は可能です。
なお、cdpが有効になっていると「接続先のVLANが違う」というメッセージが表示されるかもしれません。
トランクポートであればVLANを合わせる必要があります。

仮にVLAN100のアクセスポートに普通のPCやダムハブを接続すれば通信が可能ですよね?これと同じ事です。

QVLANインターフェースがDownする状況

有識者の方アドバイスを頂けたらと思います。

物理インターフェースに異常がない前提で、論理インターフェースであるVLANインターフェースがDownする状況ってどんな状況があると思いますか?

Aベストアンサー

catalystに限った情報でよろしければ以下のとおりです。
(1)対象のVLANが作成されていない。
(2)VLANメンバーのL2ポートが全て落ちている。

確認&対策としては

switch#show vlan で対象のvlanがエントリされていて、物理ポートがメンバーに加わっていることを確認する。
→エントリされていなかったらvlanを作成、メンバーが足りなかったら追加。

switch#show interface status  でポートの生き死にを確認する。
→あがっていないポートを生かす。(ケーブルを挿すとか。)

vlanインタフェースを作ったときにvlanを自動的に作成してくれるかは機種依存のようですので、ご確認を。

QL2スイッチからpingを打つ時について。

L2スイッチからpingを打つ時について。

VLANが設定できるL2スイッチであれば、ポートによって所属しているネットワークが異なる場合があると思うのですが、pingを打つ際、ping元のIPアドレスおよび送出されるネットワークは、管理IPアドレスと管理VLANから、になるのでしょうか?
(たとえば、↓はL2スイッチだと思いますが、このような場合、どのような動作をするのでしょう)

http://www.alaxala.com/jp/techinfo/archive/manual/AX2400S/HTML/11_4/COMMINDX/INDEX.HTM

Aベストアンサー

通常、L2SWに付与できるIPアドレスは1つ、そのIPアドレスをくくりつけられるVLANは1つです
ですので、

> pingを打つ際、ping元のIPアドレスおよび送出されるネットワークは、管理IPアドレスと管理VLANから、になるのでしょうか?

ということになります

QCatalystのL2スイッチのIPアドレス設定

CCNA取得勉強の為に教えてgoo!の過去の質問を見ていたときに疑問が発生しました。
分かる方がいらっしゃいましたら教えてください。

http://oshiete1.goo.ne.jp/kotaeru.php3?q=1199795

疑問が発生したのは↑の質問なのですが、

Catalyst2950に、インターフェースに対してIPアドレスを割り当てることができるのですか?

自分の認識だと、
・Catalyst2950はL2SWなので、データリンク層の機器であるため、インターフェースに対しIPアドレスは振れない
・但し、TELNETでアクセスしたり、snmpTRAPをあげるため、(管理的な意味で)管理VLAN(デフォルトでは1)に対し、IPアドレスを割り当てることが出来る。

なのですが。もしこの認識が間違っていた場合、インターフェースにIPアドレスを割り当てる方法をご教示いただきたいです。
よろしくお願いします。

Aベストアンサー

ネットワークエンジニアをしております。

>Catalyst2950に、インターフェースに対してIPアドレスを割り当てる
>ことができるのですか?

言葉の問題になってしまいますよね。インターフェースという言葉は、「その対象に出入りするための口」という意味なので、使い方やその人の認識に依存する話だと思います。。。

「インターフェースに割り当てることができるか」ということであれば
可能でしょう。要は「どういうインタフェースを意味しているのか」というのが問題です。

No.3さんが回答されている通り、Catalyst2950のスイッチポート(物理インタフェース)にはMACアドレスは振られますが、IPアドレスは振れません。

スイッチの「管理VLAN」は「論理インタフェース」です。これにはIPアドレスを振ることができます。
このVLANに振るIPアドレスは、スイッチ装置自身を特定するアドレスだと思ってよいと思います。(PCに振るIPアドレスと同様です)

理解されていると思いますが
紹介されているURLでは、telnetでCatalyst2950にアクセスする方法を聞かれているものだと思いますが、
telnet経由でCatalyst2950スイッチにアクセスするためには、スイッチポートを管理VLANと同じVLANに所属させておけば、スイッチポート経由でスイッチにアクセスできます。

スイッチポートで認識するPDU(プロトコルデータユニット)はフレームであり、そのアドレスはMACアドレスなど(メディアに依存)です。そのフレーム中にカプセル化されているパケットの(使うプロトコルがIPであれば)IPアドレスやそのほかのデータはフレーム中にカプセル化されていて、スイッチポートでは認識されません。
スイッチポートでフレームのMACアドレス(タグVLANを使用していればVLAN他)などが認識されて、スイッチポートからスイッチ内部に入ることを許可されればカプセル化がはずされ(フレームヘッダがはずされ)、パケット(IPアドレス等)が検査されることになります。

ネットワークエンジニアをしております。

>Catalyst2950に、インターフェースに対してIPアドレスを割り当てる
>ことができるのですか?

言葉の問題になってしまいますよね。インターフェースという言葉は、「その対象に出入りするための口」という意味なので、使い方やその人の認識に依存する話だと思います。。。

「インターフェースに割り当てることができるか」ということであれば
可能でしょう。要は「どういうインタフェースを意味しているのか」というのが問題です。

No.3さんが回答されてい...続きを読む

Qp directed-broadcastとip forward-protocol

わけがありまして、今まで関係なかったシスコルータの
コンフィグに仕事で携わることになりまして
日々どうしたものかと右往左往中です(>_<)

質問のレベルもご存じの方からすればとても低いと
思いますが、よろしくお願いします。

さて、ip directed-broadcastとip forward-protocol
コマンドについて伺いたく存じます。

両方とも以下のサイトで詳細を記載しているのですが、
さっぱり意味がわかりません。
・ip directed-broadcastについて
 1.「指定ブロード キャストから物理ブロードキャストへの変換」
   とはどういうことでしょうか?

 2.このコマンドはどのような場面で使用するのでしょうか?

・ip forward-protocolについて
 1.「nd ― Network Disk(ND)データグラムを転送します。」
   とありますが、etwork Disk(ND)データグラムとは
   何でしょうか?

いろいろグーグったりしたんですが、上記について
わかりやすく記載しているものがなく非常に困っています。

何とぞご教授のほどお願い致します。

わけがありまして、今まで関係なかったシスコルータの
コンフィグに仕事で携わることになりまして
日々どうしたものかと右往左往中です(>_<)

質問のレベルもご存じの方からすればとても低いと
思いますが、よろしくお願いします。

さて、ip directed-broadcastとip forward-protocol
コマンドについて伺いたく存じます。

両方とも以下のサイトで詳細を記載しているのですが、
さっぱり意味がわかりません。
・ip directed-broadcastについて
 1.「指定ブロード キャストから物理ブロードキャス...続きを読む

Aベストアンサー

多少語弊があることをご了承ください。

・ip directed-broadcastについて
 1.「指定ブロード キャストから物理ブロードキャストへの変換」
   とはどういうことでしょうか?
>>ブロードキャストの中継です。
  例えば以下のようなネットワーク構成があるとします。
   ・事務所フロア (192.168.1.0/24) ;従業員が作業している部屋
      □ルーター(↑:eth0で接続、↓:eth1で接続)
   ・サーバールーム(192.168.100.0/24);サーバがある部屋
  
  通常、ブロードキャストはルーターの壁を越えられません。
  事務所のパソコンから、サーバールーム向けのブロードキャストがあった場合に、
  eth1を経由(指定する)してサーバルームへのブロードキャストに変換します。

 2.このコマンドはどのような場面で使用するのでしょうか?
>>例えば、
  事務所にあるOS(パソコン)を起動したとき、
  OSはIPアドレス取得のためブロードキャストを流します。
  (事務所のパソコンには固定IPを割り当てない前提)
  サーバルームにDHCPサーバがあった場合、
  運用管理フロアからサーバルームへの
  ブロードキャスト変換がされないと、IPアドレスを取得できません。
  そこで、ルーターに「ルータ越え」ができるような設定を行います。

  このように、ネットワークが異なる場所に対してブロードキャストを
  行うような場面で使用されています。
  その他の例として、Wake on Lan(遠隔のパソコンを起動させる)
  などがあります。

・ip forward-protocolについて
 1.「nd ― Network Disk(ND)データグラムを転送します。」
   とありますが、etwork Disk(ND)データグラムとは
   何でしょうか?
>>パケットと考えてよいと思います。(携帯電話のパケット代とか)
  NDって多分SUN-NDだと思うのですが、UDPとかと同じプロトコルです。
  #UDPしか指定したことないので、あまり自信がありません。

多少語弊があることをご了承ください。

・ip directed-broadcastについて
 1.「指定ブロード キャストから物理ブロードキャストへの変換」
   とはどういうことでしょうか?
>>ブロードキャストの中継です。
  例えば以下のようなネットワーク構成があるとします。
   ・事務所フロア (192.168.1.0/24) ;従業員が作業している部屋
      □ルーター(↑:eth0で接続、↓:eth1で接続)
   ・サーバールーム(192.168.100.0/24);サーバがある部屋
  
  通常、ブロードキ...続きを読む


このQ&Aを見た人がよく見るQ&A

人気Q&Aランキング