CGI書いて、アップ(FTP)まではできるんですが、サーバエラー(エラー500)等になってしまいます。

★環境です:
サーバは、レンタル物で、CGI可。他のCGIは動いています。
繋げられるプトロコルは、FTP/TELNET/HTTPです。自分の環境の都合上、TELNET不可です。

●さて、構文等が間違えているのは確かなのですが、デバック(特にエラー行の明確化)ができないのでどうにもなりません。
プログラミングは、多少知識があるので、その方法(コマンド)さえいただければ大丈夫だと思いますが、よろしくお願いします。

このQ&Aに関連する最新のQ&A

A 回答 (5件)

使用OSが、Win9x系でしたら、簡易HTTPサーバを作って


テストしてみましょう!!

HTTPD(HTTPサーバのサービスを提供する技術)について:
私は、AN HTTPを使ってます。
簡単にHTTPサーバが出来ますので、これで環境はOK

Perlについて:
Active Perlを使っています。
詳しくは、shigatsuさんの回答を参照して下さい。
全Perlバージョンに関して言えますが、"-w"オプションをつけると、
デバックモードになります。


設定方法等は、Kent Webさんのページで確認して下さい。

参考URL:http://www.kent-web.com/www/

この回答への補足

ありがとうございます。
これなら、ウチのわがままNOTEでも、動きそうです。

ただ、”MSI”という謎の拡張子が。
上記ページには、自己解凍ファイルとありますが、何も起こりません。(Windowsマーク)
何かの解凍ツール(ランタイム等)が必要なのでしょうか?

補足日時:2001/01/04 14:22
    • good
    • 0

CGIのデバッグは面倒ですが、次のような手順でやるといいと思います。



1:Perlの実行環境があるなら、
  perl -cw ファイル名
とすると、文法チェックをしてくれます。
2:ローカルマシンにApacheがインストールされてるならローカルにブラウザから呼び出してみる。
3:エラーがでたら、Apacheのエラーログを見るとなんかのヒントが書かれているかもしれません。
4:それでもわからないなら、URL引数などをプログラムの最初に(取得して変数に入れるのではなく)明示的に変数にたとえばの値を代入してperlのプログラムとしてテスト。(ここらへんは普通のプログラムのテストと同じですね。)
    • good
    • 0

Perlのダウンロード行ったページで、


近くに「Windows....」と言うリンクはありませんでした?

それが、Perlのインストーラです。
これを、まずインストールを行ってから、
”.MSI”のファイルを開いてみて下さい。

すると、インストーラが起動します。

しかし、英語なので、自信が無ければNEXTをクリックしていきましょう。
英語が苦手な、私にもインストールが行えました。
きっと、大丈夫です。
    • good
    • 0

細かいデバッグが必要であれば、参考URLのページを参考にしてご自身のマシン環境にPerlをインストールするのがいいと思います。



また、以前にも同じような質問がありますので、まずトップページで検索してみましょう。
「CGI デバッグ」で検索すれば4件出てきます。

参考URL:http://www.harukaze.net/~mishima/perl/

この回答への補足

ありがとうございます。
早速、インストールしてみます。

※直接質問/解答に対する補足ではありませんが。
”検索”は質問前にかけましたが、内容でHitするものが無かった為、「新規投稿」といたしました事、ご了承ください。

補足日時:2001/01/04 13:53
    • good
    • 0

手元にPerl実行環境を用意すれば良いのではないでしょうか?


そうでなければtelnet loginするよりしょうがないとおもいます。
CGI telnetのようなものはセキュリティーホールにもなるので
使うべきではないし、場合によっては管理者に失礼です。
    • good
    • 0

お探しのQ&Aが見つからない時は、教えて!gooで質問しましょう!


人気Q&Aランキング

おすすめ情報