始めまして。

SONYのVAIO(PCV-L450G)を使用しています。WIN98(購入時にインストールされていた)に加えて、REDHAT7.0Jとのデュアルブート環境を作りたいと思っていますが、うまく行きません。
 ・書店でCD-ROMを購入(REDHAT LINUX7.0 QUICK START /
     ソフトバンクパブリッシング社、金井やよい著)
 ・ディスクパーティションはLINUX NATIVEで構成。(4Gほど取ってあります)
 ・ディスプレー、ディスプレーアダプターの設定に間違えは無い筈です。
にもかかわらず、
 1.インストール開始時の英語、日本語選択で、日本語が選べない。
   選ぶと、画面が白々と四隅から色が塗られていく。
 2.X-WINDOWSのテストは失敗
 3.RUN level 3では起動するので、そこでkonを開くと、1と同じになる。
 4.RUN level 3から、無理やりstartxとすると、やはり1と同じになる。
   画面がほとんど真っ白になった状態で、exitをうつと、戻る。
と言う状態で、RUN level5が走りません。どうやら、画面設定と日本語フォントが全く機能していない模様です。
 この先どうするか、ですが、下記のような事を考えています。
 (1)ダウンロード版でやってみる。(CD-ROM破損の疑い)
 (2)アップグレード版のCDを手に入れて、いくつかのデーモンのバージョンを上げる。
 (3)画像設定を、全パターン試してみる。
 (4)泣く泣く製品版を買う
 (5)ハードのせいとして、あきらめる。

どなたかよろしくお教え下さい。

このQ&Aに関連する最新のQ&A

A 回答 (5件)

問題はチップの名前にあるのではなく、それによって検出されたXサーバーに問題があるのです。

もし試してなければSVGAサーバーを試してみて下さい。
    • good
    • 0

先ほどの補足ですが、


インストールしたPCはノートです。
    • good
    • 0

僕の研究室でREDHAT7.0をインストールしましたが、


問題はありませんでした。

Xの設定時のテストで失敗するのであれば、
無理矢理startxやRUNlevelを5にして起動しても
これらのコマンドはXを立ち上げるものなんですから
まともに起動することは無いでしょう。
とりあえずビデオカードの設定で手当たり次第の組み合わせ(ビデオカード&解像度)を試してみるのが良いかと思います。
あと、再インストールがめんどくさいのであればXFree86conf(だったかな)をいじるのもてですが、中身の意味が分からないのであればさわらない方がよいですね。

ackyさんもおっしゃってるように、RedHat7.0にはバグがあります。
RUNlevel3で起動してコマンド入力でパッチを当てるしかないですね。

ちなみに研究室でインストールしたPCはゲートウェイのものです。
(パッチを当てなくてもインストールは正常にできました)

この回答への補足

それでは、
 ・Xの設定
   手当たり次第組み合わせを試す。 (うーむ)
 ・日本語環境
   アップグレード版のCDでパッチをあてる
             (こっちは入手ルートがあるのでなんとか。。)
という対応になるわけですね。ひとまずやってみます。

補足日時:2001/01/17 10:53
    • good
    • 0

結論から言うと「(5)ハードのせいとして、あきらめる。

」です。
PCV-L450Gって液晶ディスプレイですよね。液晶デスクトップ・ノートで表示できない(真っ黒、青い画面など)と言う例を3件知っています。あくまでも推測ですが、入力周波数(ビデオチップの出力)が液晶ディスプレイのサポート外に成っているものと思われます。CRTはアナログ信号の為、多少周波数が外れていても、おかしいなりに表示されますが、液晶ディスプレイはデジタル信号なので、その辺がシビアなのだと思います。
    • good
    • 0

RedHat7Jには既知の問題として正しく日本語環境が構築できないということが分かっており、これについてはアップデートパッケージを適用することで回避できるようです(他の不具合も含めて)。


ところで3番のkonを起動してから日本語選択というのはどういう意味でしょうか? konそのものは日本語表示可能なので、わざわざ選択するようなものはないはずですが。。。
それとXの設定に間違いはないはずだ、とおっしゃいますが、間違いがなければ文字化けすることはあってもXは起動するはずです。ですので根本的に設定が間違っているのです。ATIは設定がXで検出されたものと違うものを設定する必要があったような記憶があります。正しくチップを認識してくれないんですよ。

この回答への補足

ご回答ありがとうございます。

konについてですが、(書き方がまずかった)CUI画面からkonコマンドを入れると、すぐに画面がおかしくなる、という意味でした。(画面の現象のみ(1)と同じ、のつもりでした。)
Xの設定ですが、ディスプレーアダプター、モニターともにWIN98側で認識しているものを設定しています。G-メモリも同様に確認済みで、解像度は3~4個くらい、(win98側で使用しているものの周辺を)選んでいます。
ちなみにインストール中に自動認識したチップが、そのWIN98で認識しているものでしたが、やはりこれも無理やり変える必要があるのでしょうか?

補足日時:2001/01/17 10:36
    • good
    • 0

お探しのQ&Aが見つからない時は、教えて!gooで質問しましょう!

このQ&Aと関連する良く見られている質問

QRedHat linux 7.0J +DNS(master&slave) + routerの問題の1

linuxの設定についての問題があるので
宜しくお願いします。
lserver1.tb-out.co.jp lserver2.tb-out.co.jp
192.168.100.16(eth0) --- 192.168.100.17(eth0)
lrouter.tb-in.co.jp
192.168.1.2(eth1)
-------------------------------+---
内部LAN |     Windows98 WS
tbserver.tb-in.co.jp------(192.168.1.XX)
(192.168.1.16)

lserver1(RedHat linux 7.0J eth0:Intel eepro100+):
DNS(master)
Apache(www)
Wu-FTP(ftp)
Sendmail(mail)
routed(default gateway : 192.168.100.17)
squid
...
lserver2(RedHat linux 7.0J eth0:Intel eepro100+;eth1:3COM 90X):
DNS(slave)
routed(default gateway : 192.168.100.17)
ipchains
SambaServer
snmp
...
tbserver( Windows NT 4.0 Server)
DNS(内部LAN DNS)
DHCP
...
症状:
lserver1とlserver2が始めて起動した時に、正常
しかし、数分後、故障した
1>#less /var/log/messages
...
routed[633]:deleting route to interface eth1(time out)
routed[633]:deleting route to interface eth0(time out)
...
2>内部LANのWin98PCから[検索他のコンピュータ]を利用して、該当
SambaServer(lserver2)を見つかりませんでした。その後、たまに、
見えたこともあります。不安定
3>#nslookupを入力しますと、
lserver1(master DNS)を認識できたけど、非常に遅くなり、時々、
lserver1(master DNS)を認識できませんでした。不安定

linuxの設定についての問題があるので
宜しくお願いします。
lserver1.tb-out.co.jp lserver2.tb-out.co.jp
192.168.100.16(eth0) --- 192.168.100.17(eth0)
lrouter.tb-in.co.jp
192.168.1.2(eth1)
-------------------------------+---
内部LAN |     Windows98 WS
tbserver.tb-in.co.jp------(192.168.1.XX)
(192.168.1.16)

lserver1(RedHat linux 7.0J eth0:Intel eepro100+):
DNS(master)
Apache(www)
W...続きを読む

Aベストアンサー

どうしてこの構成なのかがよくわかりませんが、この構成は不自然です。(設定がきちんとしていれば問題ありませんが、設定の詳細がわからないし、うまくいっていないということなので、わかって組んでいるのではないと判断します)
まずネットワークの構成をしっかりしてください。lserver1は、DNSクライアントとしてどのDNSサーバーを見ているのでしょう。また、現在表示されているIPアドレスは、プライベートですが、どこかでNATを使っているのでしょうか?(たとえば、ルーター)それとも、仮に振ってあるのでしょうか?
lserver2は、ルーター、もしくは、FWの機能をしているようですが、ipchain等の設定はどうなっているのでしょうか?通常マスカレードしているはずですよね?
すべては、気持ちよくpingがとおるのでしょうか?
普通に設定するのなら、lserver1をルーターにして、現状の機能とipchainsを動かします。lserver2を内部に持ってきてSambaサーバーを動かすのが普通でしょう。
その場合、基本的には、すべてのサーバーは、内側のDNSサーバーのクライアントにするのが普通でしょう。
こんな風に構成すれば、普通に動くと思いますが、いかがでしょうか?

どうしてこの構成なのかがよくわかりませんが、この構成は不自然です。(設定がきちんとしていれば問題ありませんが、設定の詳細がわからないし、うまくいっていないということなので、わかって組んでいるのではないと判断します)
まずネットワークの構成をしっかりしてください。lserver1は、DNSクライアントとしてどのDNSサーバーを見ているのでしょう。また、現在表示されているIPアドレスは、プライベートですが、どこかでNATを使っているのでしょうか?(たとえば、ルーター)それとも、仮に振ってあるのでしょ...続きを読む

Qredhat 7.0 でApacheでCGI

今、ApacheでWEBサーバーつくったのはいいでんすが、なぜかどのCGIも動きません。Internal Server Eroor がでます。
おそらくhttpd.confの設定だろうと思うのですが、どうやってもうまくいきません。
ちなみにCGIの中身はちゃんとチェック済みです(フリーのCGIスクリプトを3っつくらいためしました)あと、パーミッション設定もチェック済みで、テキストをただ表示させるだけのCGIすら動きません。
よければどなたかhttpd.confの中身のせときます。
どなたかアドバイスと、くわしくhttpd.confの設定がのってるサイトを教えていただけないでしょうか?
あと、できればWebminでの設定方法を知っている方おしえていただけないでしょうか?
http://ks-pro.dns2go.com/httpd.conf.txt

Aベストアンサー

apacheの開始/停止/再起動は/etc/rc.d/init.d/httpdを使います。
この辺は最低限含まれています。

んで、話を本題に戻して、以下のURLは読みました?
環境変数、.htaccessの編集(それに伴うhttpd.confの設定も含む)が必要そうです。
そんなに無理しなくても通常の使い方で良いのでは?
まず通常のインストールで動かす方が先のような気がします。

参考URL:http://www.webmin.com/webmin/apache.html

QRedHat Linux 7.0Jのfilesystemの修復???

先程、xWindow画面で、使っていて、突然、停電しました。
再起動して、Checking root filesystem段階でerrorが発生しました。
...
Uttached innode 43057
...
メッセージによって、rootのパスワードを入力して、以下の状態に
なりました。
(Repair filesystem) 1#
rootの権限で回復できるようです。でも、次にどうやっていいかな?
良く分かりません。今、けっこ、困っています。
RedHat Linux 7.0J

よろしくお願いします

Aベストアンサー

fsckを使う(100%修復できるとは限りません)

詳しくはgoogle等で検索

以上filesystemがext2の場合です

#FAQのような気が...

参考URL:http://www.linux.or.jp/JM/html/e2fsprogs/man8/fsck.8.html

QREDHAT7.0 でコンパイル時にGCCのエラーがでます

普通にREDHAT7.0をインストールし、まずインストールされたapache、SSLをアンインストール。
そしてpostgres、apacheを正常にインストールして、PHP3をインストールしようとしたところ、makeの段階で

gcc: unrecognized option `-02'

というコメントが何度も表示され、うまくコンパイルできません。
gccとか意識したこともないので、途方にくれております。
分かる方がいましたら、ご助言ください。

Aベストアンサー

これは単なる記入ミス(コピーミス)でしょうか?
「-02(マイナス ゼロ ニ)」ではなく、「-O2(マイナス オー ツー)」です。
php3なら、
configure <options>
make
make install
で一発のはずですが、、、

もう一度
make distclean
configure <options>
make
make install
とやり直してみても同じエラーが出ますか?

QRedHat Linux 7.2とCD-ROMのマウント

以前に全く同じ質問をしたものですが、再度御願いします。
RedHat Linux 7.2を投入しまして正常に作動を確認後、必要が在ってCD-ROMのマウント使用としたのですが、マウントされません。
mount: /dev/cdrom is not a valid block deviceと表示されます。ちなみにfstabの関連のラインは次の通りです。
/dev/cdrom /mnt/cdrom iso9660 noauto,owner,kudzu 0 0となっています。mount -t iso9660 -o ro /dev/cdrom /mnt/cdromも作動しませんでした。どなたか解決策が在りましたら、教えてください。

Aベストアンサー

Redhat7.2だと,IDE CD-ROMモジュール(ドライバ)のファイルは,KernelのRPMに含まれているので,明示的にコピー(インストール)する必要はありません。

カーネルソースからカーネルをコンパイルした際に,モジュールの組み込みを忘れた,なんてことはありませんよね?

rootユーザで(#はrootの意)
# insmod cdrom
# insmod ide-cd
とやってみると,mountできるかな?


人気Q&Aランキング

おすすめ情報