Solaris2.6でpoppassdを使用したいのですが、うまく動いてくれません。ユーザ名を入れて、oldパスワードと入力まではうまく動いているようですが、newパスワードを入れると落ちます。何方か教えて下さい。宜しくお願いします。

A 回答 (2件)

Solaris では使ったことがないのですが


Solaris2.6 ではシャドーパスワードを利用していませんか?

poppasswd のコンパイル時に -DSHADOW のような
シャドーパスワードに対応するコンパイルが必要だったような気がします。

poppasswd のコンパイルオプションをもう一度確認してみたらいかがでしょうか。
    • good
    • 0
この回答へのお礼

ありがとうございました。早速試してみます。追加でご存知でしたら教えて下さい。poppassdの最新版はどこで手に入りますか??すみません。宜しくお願いします。

お礼日時:2001/02/02 10:57

poppasswd は枯れたソフトウェアだったと思うので


現在はヴァージョンアップしてないのではないかと思います。

もし NSUG に入っているのであれば NUSG の CD-ROM にあります。
NSUG CD-ROM には Solaris2 用のバイナリも入っているようです。

<ftp://ftp.iis.u-tokyo.ac.jp/pub/network/mail/pop …

NSUG の FAQ にも同様な質問があるようです。

参考URL:http://www.nsug.or.jp/_maillist/faq/22FAQ.html#Q8
    • good
    • 0
この回答へのお礼

ありがとうございました。紹介してもらったURLに記載してあったように、Passwdから受けとるメッセージが問題でした。本当に助かりました。

お礼日時:2001/02/05 11:35

お探しのQ&Aが見つからない時は、教えて!gooで質問しましょう!

このQ&Aと関連する良く見られている質問

Qsolaris8でrootのパスワードがわからない場合

solaris8でrootのパスワードがわからない場合に,solarisを起動して新たにパスワードを変更することは可能なのでしょうか?ある本に,solarisの場合はシングルユーザーモードでもパスワードの入力が必要であると書いてあるためシャットダウンできないことを考えると電源を入れることすらできません.よろしくお願いします.

Aベストアンサー

OSメディア(CD-ROM)でbootをします。
インストーラが走り始めたら、なんでもないところで右クリックでshell toolを起動することができます。
/を/aなどにマウントします。
マウントできたら、/etc/shadowファイルのrootのパスワード欄を消せば直ります。

ただ、今運用しているならば念のためにバックアップは取っておいたほうが無難です。

大雑把な説明でごめんなさい・・・

QWinampがうまく動かない

先日、5.09にVer.UPして以来、ライブラリの曲などがうまく再生されなくなってしまいました。
具体的には一曲だけで再生が終わってしまい、次の曲へ進まないといった具合です。
誰か原因がわかる方いっらっしゃいますでしょうか?
OSはWindows XP SP1です。

Aベストアンサー

どうやら5.09はメモリリークが起こっているようです。
タスクマネージャを立ち上げてごらんください。どんどん使用メモリが増えて行きます。

私は使っていませんけど最新版をDLしてみてください。
Ver.5.092
http://www.winamp.com/player/free.php

今ご使用が5.092ならば修正があるまで待つか以前の物を使って下さい。

Qグーグル・アースがうまく動きません

 ダウンロードしてインストールし、起動したのですが、「could not find image」というメッセージがでてそこから動きません。おまけにそのメッセージウインドウ自体「×」を押しても閉じません。

 マシン自体は最近買ったものなので、スペックには問題がないと思います。OSはXPです。
 また、ファイアウォールの関係かと思い、一時的にウィルスバスターを止めて試みたのですが、やはりダメ。

 何度もやっていますが、同じ結果です。
 以前の質問を見たら、インストールの場所を変えたらうまくいった例が載っていましたが、私のマシンにはCドライブしかありません。
 具体的にどうすればいいかよくわかりません。

 どうかお助けください。

Aベストアンサー

#1さんが言っているのは、マイコンピュータ → Documents and setting の中にある
All Userのフォルダと もう一つのあなたが作ったフォルダの名前です。

これが全角文字を使っていると、うまくいきません。新たにIDを作り直すか何かしないとだめでしょう。

Qアクセス解析CGIがうまく動きません。

http://www.futomi.com/index.html
こちらのサイトにある「高機能アクセス解析 CGI」
というCGIを利用させてもらおうと思ったのですが
うまく動かなくて困っています。
Q&AやHPレンタルスペース別の設置方法も
試したのですがどうやら動いていないようなので困っています。

解析結果のページはちゃんと表示されるのですが
「概要」の一番下にある「解析対象期間」が
最初に設置をした日時から動いていないのが謎です。

お手数ですが教えていただけたらうれしいです。
よろしくおねがいします。

Aベストアンサー

No.2さんのとおりですね。
始めacclog.cgiをacc.cgiにリネームしたのかと思いましたが、acc.cgiとacclog.cgiの2つのcgiがあるようですね。
acc.cgiがログ表示用
acclog.cgiがロギング用
となっているようなので、解析したい(ログを残したい)ページで
document.write("<img src='http://xxx.xxx/acc/acclog.cgi?");
とやれば解決できると思いますよ。

Qおまかせ鍵助がvistaでうまく動かない

おまかせ鍵助 はXpでもVistaでもokとのことなので、Xpで使ったらうまく動きました。そして今度は vistaにインストールして インタネットの或るサイトにつなぎ、ID ,パスワードを入れる画面で使ったら Wundows Internet Explorerというタイトルの小さな警告窓が現れて 黄色い! の△アイコンと権限がありません というメッセージが出て
パスワードが自動入力いたしません。
(Xpパソコンで同じサイトで使ったら 自動入力されてサイトが開けます)
vistaで使うとき (或いはインストールするとき)Xpとどこか違う操作があるのでしょうか。お教えください。

Aベストアンサー

readme.txtに
「VistaについてもHome Editionで動作確認していますが、その他のエディションは未確認です。」
と書かれています。
あなたのVistaのEditionを確認してください。

また、ヘルプの注意・制限事項には
「Vista+IE7においてIE7のコンテキストメニューから実行するとコントロールへの自動入力が正しく動作しません。ホットキーまたはメインウィンドウのツールバーによる入力を使ってください。」
とあります。


人気Q&Aランキング

おすすめ情報