個人事業主の方必見!確定申告のお悩み解決

ものすごく簡単なことかもしれませんが
zip.lib.phpについて質問します。

ファイル圧縮をしたくて「zip.lib.php」を使おうと思い

require_once('zip.lib.php');

と書いていますが、実行されません。
レンタルサーバで「zip.lib.php」使いたいときは
単にこの書き方だけではダメなのでしょうか?

PHPは4.3.10
MySQLはバージョンは3.23以上

勉強不足で申し訳ありませんが、
困っているのでお願いします。

このQ&Aに関連する最新のQ&A

A 回答 (1件)

> ファイル圧縮をしたくて「zip.lib.php」を使おうと思い



どちらでそのような方法をお知りになったのでしょうか?
「zip.lib.php」は phpMyAdmin というツールに入っているライブラリ
かと思われますが?

phpMyAdmin | MySQL Database Administration Tool | www.phpmyadmin.net
http://www.phpmyadmin.net/

お使いになりたいのであれば、ソースコードのライセンスをお読みに
なった上でご自身の判断でどうぞ。

> レンタルサーバで「zip.lib.php」使いたいときは
> 単にこの書き方だけではダメなのでしょうか?
> require_once('zip.lib.php');

PHP の設定でインクルードパスが指定されてない場合はその書き方
ではなくフルパスで指定します。
    • good
    • 0
この回答へのお礼

返事が遅くなり大変申し訳ありません。
ご指摘どおり、phpMyAdmin というツールに入っているライブラリ
の「zip.lib.php」が使いたいのです。

フルパスで書けばいいのですね。
不勉強でした。ありがとうございます。

お礼日時:2008/04/17 06:43

このQ&Aに関連する人気のQ&A

お探しのQ&Aが見つからない時は、教えて!gooで質問しましょう!


人気Q&Aランキング