こんにちは。宜しくお願いします。

RedHat7Jで、Apache_1.3.17+PHP4.0.4+PostgreSQL7.0.2のインストールをしています。
いろんなHPを参考にしてその通りインストールしています。
で、現状はApacheとPHPはインストールできて、PostgreSQLのインストールで止まっています。
PostgreSQLのユーザーを用意しようとして
「useradd postgres」と入力したら、ユーザーがあるとメッセージが出てきたので「su - postgres」でログインしたら、プロンプトに「bash-2.04$」とでてきました。
これは、ログイン出来てるのですか?
この時、パスワードを聞いてこなかったんですが、「LOGON:」の時に「postgres」と入力してログインしようとすると、パスワードを聞いてきます。最初からあったユーザーなので、パスワードがわからずログインできません。デフォルトで何か決っているのですか?このパスワードも知っていたら教えてください。

プロンプトに「bash-2.04$」が表示されたのが、ログインできたのと仮定して、「ls -al」でそのディレクトリの内容を見ると、「backups」「data」というディレクトリしかなく、環境変数等が入った「.bashrc」「.bash_profile」などのファイルが存在しません。
PostgreSQLの起動のための初期設定ってのをしようとしているのですが、ここから先にすすめません。

ユーザー「postgres」について、どうか教えてくだざい。
よろしくお願いいたします

このQ&Aに関連する最新のQ&A

A 回答 (2件)

>/rootの下のをコピーしたのですけど、コピーした設定ファイル動いていないような



多分、permissionがpostgresユーザで読めない設定になっていると思います
chmodとchownで設定してやってください

>「export LANG=C」と設定しているんですけど、「ls -al」とした時に文字が化けてしまいます。

LANG=Cでは英語圏モードだと判別され、漢字などは\nnn(nは1から7の数字)で表示されたりします
日本語を表示する場合はLANG=ja_JP.ujisにしてください
そのようにしても化けるようであれば、ターミナルが漢字対応でないか、リモートターミナルであれば文字コード変換が間違っている可能性があります
前者であればX Window System上からktermなどの漢字対応ターミナルを使ってください
後者であればターミナルソフトのコード変換の設定を変えてみてください


老婆心ながら・・・
 とりあえずコマンドリファレンスやUNIXの入門書を用意なされてはいかがでしょうか?周りにヒントを用意せずにトライ&エラーで環境になれていくのも、それはそれで楽しいものですが(^^; それだけでは解決が難しいorできない事も出てくると思います
 特にviやEmacsなどはWindowsなどのエディタに比べてかなりクセの強いエディタですから簡単なリファレンスは必須かと思います
    • good
    • 0

suコマンドでpostgresユーザに移行した時にpasswordを聞かれなかったのはrootからsuコマンドを使ったからだと思います


super user(root)はuser操作系のコマンドを実行する時にpasswordを聞かれません

インストーラから入れられたpostgres userはpasswordが設定されていない(=ログインプロンプトからはログインできない)のでloginプロンプトからpostgres userで入りたいのであればpasswordを設定してやる必要があります

passwdコマンドをrootユーザで実行してください
使い方はman passwdなどで調べてください

>~/.bashrcや~/.bash_profileが無い
のは自分で作ってやれば大丈夫です
viやemacsエディタで作るなり、cpで別ユーザのものを持ってきて変更するなりしてください

この回答への補足

どうもありがとうございます。

パスワードを設定したら、無事ログインすることが出来ました。


>>~/.bashrcや~/.bash_profileが無い
>のは自分で作ってやれば大丈夫です
>viやemacsエディタで作るなり、cpで別ユーザのものを持ってきて変更するなり
>してください
これは、うまい事いきませんでした。/rootの下のをコピーしたのですけど、コピーした設定ファイル動いていないような感じです。プロンプトに今のディレクトリが表示されるはずなんですけど、表示されませんし、「.bashrc」に「export LANG=C」と設定しているんですけど、「ls -al」とした時に文字が化けてしまいます。
コピーするだけではダメなんでしょうか?

宜しくお願い致します。

補足日時:2001/03/02 18:07
    • good
    • 0

このQ&Aに関連する人気のQ&A

お探しのQ&Aが見つからない時は、教えて!gooで質問しましょう!


このカテゴリの人気Q&Aランキング

おすすめ情報