出産前後の痔にはご注意!

L2スイッチからpingを打つ時について。

VLANが設定できるL2スイッチであれば、ポートによって所属しているネットワークが異なる場合があると思うのですが、pingを打つ際、ping元のIPアドレスおよび送出されるネットワークは、管理IPアドレスと管理VLANから、になるのでしょうか?
(たとえば、↓はL2スイッチだと思いますが、このような場合、どのような動作をするのでしょう)

http://www.alaxala.com/jp/techinfo/archive/manua …

このQ&Aに関連する最新のQ&A

A 回答 (1件)

通常、L2SWに付与できるIPアドレスは1つ、そのIPアドレスをくくりつけられるVLANは1つです


ですので、

> pingを打つ際、ping元のIPアドレスおよび送出されるネットワークは、管理IPアドレスと管理VLANから、になるのでしょうか?

ということになります
    • good
    • 0

このQ&Aに関連する人気のQ&A

お探しのQ&Aが見つからない時は、教えて!gooで質問しましょう!

このQ&Aを見た人はこんなQ&Aも見ています

このQ&Aを見た人が検索しているワード

このQ&Aと関連する良く見られている質問

QCatalystのL2スイッチのIPアドレス設定

CCNA取得勉強の為に教えてgoo!の過去の質問を見ていたときに疑問が発生しました。
分かる方がいらっしゃいましたら教えてください。

http://oshiete1.goo.ne.jp/kotaeru.php3?q=1199795

疑問が発生したのは↑の質問なのですが、

Catalyst2950に、インターフェースに対してIPアドレスを割り当てることができるのですか?

自分の認識だと、
・Catalyst2950はL2SWなので、データリンク層の機器であるため、インターフェースに対しIPアドレスは振れない
・但し、TELNETでアクセスしたり、snmpTRAPをあげるため、(管理的な意味で)管理VLAN(デフォルトでは1)に対し、IPアドレスを割り当てることが出来る。

なのですが。もしこの認識が間違っていた場合、インターフェースにIPアドレスを割り当てる方法をご教示いただきたいです。
よろしくお願いします。

Aベストアンサー

ネットワークエンジニアをしております。

>Catalyst2950に、インターフェースに対してIPアドレスを割り当てる
>ことができるのですか?

言葉の問題になってしまいますよね。インターフェースという言葉は、「その対象に出入りするための口」という意味なので、使い方やその人の認識に依存する話だと思います。。。

「インターフェースに割り当てることができるか」ということであれば
可能でしょう。要は「どういうインタフェースを意味しているのか」というのが問題です。

No.3さんが回答されている通り、Catalyst2950のスイッチポート(物理インタフェース)にはMACアドレスは振られますが、IPアドレスは振れません。

スイッチの「管理VLAN」は「論理インタフェース」です。これにはIPアドレスを振ることができます。
このVLANに振るIPアドレスは、スイッチ装置自身を特定するアドレスだと思ってよいと思います。(PCに振るIPアドレスと同様です)

理解されていると思いますが
紹介されているURLでは、telnetでCatalyst2950にアクセスする方法を聞かれているものだと思いますが、
telnet経由でCatalyst2950スイッチにアクセスするためには、スイッチポートを管理VLANと同じVLANに所属させておけば、スイッチポート経由でスイッチにアクセスできます。

スイッチポートで認識するPDU(プロトコルデータユニット)はフレームであり、そのアドレスはMACアドレスなど(メディアに依存)です。そのフレーム中にカプセル化されているパケットの(使うプロトコルがIPであれば)IPアドレスやそのほかのデータはフレーム中にカプセル化されていて、スイッチポートでは認識されません。
スイッチポートでフレームのMACアドレス(タグVLANを使用していればVLAN他)などが認識されて、スイッチポートからスイッチ内部に入ることを許可されればカプセル化がはずされ(フレームヘッダがはずされ)、パケット(IPアドレス等)が検査されることになります。

ネットワークエンジニアをしております。

>Catalyst2950に、インターフェースに対してIPアドレスを割り当てる
>ことができるのですか?

言葉の問題になってしまいますよね。インターフェースという言葉は、「その対象に出入りするための口」という意味なので、使い方やその人の認識に依存する話だと思います。。。

「インターフェースに割り当てることができるか」ということであれば
可能でしょう。要は「どういうインタフェースを意味しているのか」というのが問題です。

No.3さんが回答されてい...続きを読む

QL2スイッチ、L3スイッチ間pingについて

初歩的な質問ですいません。
L2スイッチとL3スイッチに同じセグメントのIPアドレスを付与した場合について教えてください。
(L2スイッチスイッチには管理用VLAN1にIPアドレスを振っています)

上記の場合、L2スイッチからL3スイッチへのpingは飛ぶのでしょうか。また、L3スイッチからL2スイッチへのpingは飛ぶのでしょうか。

Aベストアンサー

フィルタをかけてたりしなければ飛びますね。
正しく設定されていれば問題ありません。

Qpingでポートの指定

pingでIPアドレスを指定して、通信できるかどうかというのは
よく使いますが、pingでポートを指定して応答するかどうかは調べられるのでしょうか?

よろしくお願いします

Aベストアンサー

pingを含むICMPというプロトコルは、OSIの7レイヤで言うところのL2(同一セグメント内通信)とL3(IPルーティングされた通信)の両方にまたがる、ちょっと珍しいプロトコルです。

IPアドレスは指定できますが、別サブネットに属するIPアドレスに到達できればL3通信、できなければゲートウェイと呼ばれる同一サブネットに属する中継装置からの回答を得るという点でL2(MAC通信ではなく、同一セグメント内通信という意味)通信です。

ポート番号はL4で使用されるアドレスですから、L4機能の疎通確認はping(を含むICMP)ではできません。

FTPの疎通確認であれば、クライアントからサーバに対するTCP/21通信(FTP-CMD)が可能であること(サーバからクライアントへのTCP/21からの応答を含む)+サーバからクライアントに対するTCP/20通信(FTP-DATA)が可能であること(クライアントからサーバへのTCP/21からの応答を含む)が必要でしょう。

監視ソフトによるものであれば、
・クライアントからサーバへのログイン(TCP/21)
・クライアントからサーバへのlsの結果(TCP/20)
で確認すればよいでしょう。

pingを含むICMPというプロトコルは、OSIの7レイヤで言うところのL2(同一セグメント内通信)とL3(IPルーティングされた通信)の両方にまたがる、ちょっと珍しいプロトコルです。

IPアドレスは指定できますが、別サブネットに属するIPアドレスに到達できればL3通信、できなければゲートウェイと呼ばれる同一サブネットに属する中継装置からの回答を得るという点でL2(MAC通信ではなく、同一セグメント内通信という意味)通信です。

ポート番号はL4で使用されるアドレスですから、L4機能の疎通確認はping(を含む...続きを読む

Qpingが飛ばない原因が知りたい

いつもお世話になっております。

IPアドレスについての不具合です。

A端末にIPアドレスが設定されているのですが、
B端末、C端末からPINGをとばしたところ、LOSTしてしまいます。


A端末からはB,C端末へのPINGは返ってきています。
IP アドレスは 128.1.1.*(この部分が三台異なる)
サブネットマスク 三台同じ
デフォルトゲートウェイ 三台同じ

なにか考えられる原因はありますでしょうか。

Aベストアンサー

#3の方が言うように、128.1.1.*がグローバルアドレスなのが気になります。
自分では、グローバルアドレス=管理されているアドレス=自由に使ってはいけないという認識です。
昔、ケーブルテレビのインターネットで接続が2日程ダウンした事があり、復旧後に原因を聞いた所、「契約者の一人が使っていけないIPアドレスを設定した為」との事。
こちらとすれば2日接続が出来なかったので、「損害賠償モノだなぁ」と思ったり。

間違ってグローバルアドレスを使っているのであれば、プライベートアドレスの192.168.0.0~192.168.255.255(Cクラス)を使ってみてはどうでしょう?

Qスイッチで挟んでもpingは通らない?

図のように、スイッチでPCを2つつないで(それぞれのPCには、手動でIPアドレスを設定、サブネットマスクは255.255.255.0)、pingは通じるのでしょうか?

単なるスイッチだと(レイヤ2だから?)つながらないのでしょうか?

もし、つながらないとすると、どのようにすればpingできるようになるのでしょうか?(ルータをはさむなど?)

Aベストアンサー

ネットワークアドレスを同じ設定にしているPC同士なら
スイッチを挟んでpingは通るでしょ?

Qポートの80と443

こちらのサービス(https://secure.logmein.com/)を利用すると、インターネットを見られるサーバーのポートの80と443が空いていればルータやファイアウォールに特段の設定なく外部からサーバーを操作できるそうですが、逆にサーバーのポートの80や443を空けることには何か危険性があるのでしょうか。

Aベストアンサー

ポート80は一般的なHTTP、ポート443はHTTPSです。
この2つのポートがあいていなければインターネット接続(WEBブラウジング)は出来ません。
ですから、ほとんどのファイアウォールでこのポートは開いています。(インターネット接続を制限している社内LANでは当然閉じていますが)

ちなみに、よく使うポートとしてはFTPで20、21、SMTP(送信メール)で25、受信メールPOP3で110あたりです。セキュリティポリシー上、この辺は制限される事も多いですが、HTTP 80、HTTPS(暗号化用)443は通常閉じません。


危険性?
WEBプロトコルを使ってFTP的なファイル転送(WebDAV)やVPN等も出来るようになっています。当然そこにはある種の危険はつきものですが、WEBブラウジングに伴う危険と大きく変わりません。ウィルス等に感染していればこの2つのポートだけでも相当危険でしょうね。

参考まで。

QCISCOルータのIPアドレスの確認方法。

CISCOルータ自身のIPアドレスの取得方法が知りたいです。ブラウザから設定をしたいので、IPアドレスを知りたいのですが、そういったコマンドはあるでしょうか?(初心者すぎで、トンチンカンなことを言っているかもしれません)

ターミナルソフト?で特権モードに入るまではできたのですが…。

Aベストアンサー

> すみません、常識以前の質問なのでしょうが、IPアドレス等は、CISCOルータに直接設定しなくてはならないのでしょうか?

以前の回答のように、BBルータであればWAN側をDHCPで運用みたいなことはあるでしょうけど.......
(CiscoでもCisco1812Jみたいな機種はそのような運用はありかもしれません)

基本的には各interfaceに固定でIPアドレスを振って使うのが普通です
あと、interfaceに振られたIPアドレスを確認する方法として、
show interface
(省略形はsh int)
を実行すればinterfaceに割り振られたIPアドレスも含めてinterfaceの状態も確認することができます

Qciscoスイッチ VLANが違うポート同士の通信について

自社のネットワークの構成で対向するポート同士のVLANが違うのに通信しているのをみかけました。自分がCCNAの勉強をしていた時は対向するポート同士は同じVLANでないと通信出来なかったと記憶しているのですが。。。

以下に詳細を記載させて頂きます。

[ L3スイッチ ]PortA ---- PortB[L2スイッチ]

L3スイッチのコンフィグ
interface vlan 100
ip address 192.168.1.1 255.255.255.0

PortAのコンフィグ
switchport mode dynamic desirable
switchport acccess vlan 100

L2スイッチのコンフィグ
interface vlan 150
ip address 192.168.1.2 255.255.255.0

PortBのコンフィグ
switchport mode access
switchport access vlan 150

試しにシミュレータを使って違うVLANに属するPort同士で通信を試みましたがping失敗しました。。

あくまで自分の予想なのですが、
L3スイッチの場合スイッチングだけでなくルーティングも可能なので同じサブネット内であってもVLAN間の通信が可能?
traceroute打っても結局はportAのIPアドレスしか出てこないので内部でどういう処理をしているのか確認できませんが。。。

どこかで勘違いしているのかもしれません。。よろしくお願いします。

自社のネットワークの構成で対向するポート同士のVLANが違うのに通信しているのをみかけました。自分がCCNAの勉強をしていた時は対向するポート同士は同じVLANでないと通信出来なかったと記憶しているのですが。。。

以下に詳細を記載させて頂きます。

[ L3スイッチ ]PortA ---- PortB[L2スイッチ]

L3スイッチのコンフィグ
interface vlan 100
ip address 192.168.1.1 255.255.255.0

PortAのコンフィグ
switchport mode dynamic desirable
switchport acccess vlan 100

L2スイッチのコンフ...続きを読む

Aベストアンサー

アクセスポート同士の接続であれば通信は可能です。
なお、cdpが有効になっていると「接続先のVLANが違う」というメッセージが表示されるかもしれません。
トランクポートであればVLANを合わせる必要があります。

仮にVLAN100のアクセスポートに普通のPCやダムハブを接続すれば通信が可能ですよね?これと同じ事です。

Q「宛先ホストに到達できません」とは

下記サイトのみ「宛先ホストに到達できません」となります。
その他のサイト(goo等)は接続できます。(ping応答あり)

「宛先ホストに到達できません」とはどういう時に出るのでしょうか?

自宅にある他PCも同現象です。

<ネット接続構成>
インターネット-無線LAN(WZR-G144N)-PC

<ping結果>
Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation. All rights reserved.

C:\Users\xxxxx>ping sfp.kyoraku.jp

sfp.kyoraku.jp [1.1.81.114]に ping を送信しています 32 バイトのデータ:
192.168.11.1 からの応答: 宛先ホストに到達できません。
192.168.11.1 からの応答: 宛先ホストに到達できません。
192.168.11.1 からの応答: 宛先ホストに到達できません。
192.168.11.1 からの応答: 宛先ホストに到達できません。

1.1.81.114 の ping 統計:
パケット数: 送信 = 4、受信 = 4、損失 = 0 (0% の損失)、

C:\Users\xxxxx>ping www.goo.ne.jp

www.goo.ne.jp [218.213.142.230]に ping を送信しています 32 バイトのデータ:
218.213.142.230 からの応答: バイト数 =32 時間 =67ms TTL=242
218.213.142.230 からの応答: バイト数 =32 時間 =66ms TTL=242
218.213.142.230 からの応答: バイト数 =32 時間 =66ms TTL=242
218.213.142.230 からの応答: バイト数 =32 時間 =56ms TTL=242

218.213.142.230 の ping 統計:
パケット数: 送信 = 4、受信 = 4、損失 = 0 (0% の損失)、
ラウンド トリップの概算時間 (ミリ秒):
最小 = 56ms、最大 = 67ms、平均 = 63ms

C:\Users\xxxxx>

下記サイトのみ「宛先ホストに到達できません」となります。
その他のサイト(goo等)は接続できます。(ping応答あり)

「宛先ホストに到達できません」とはどういう時に出るのでしょうか?

自宅にある他PCも同現象です。

<ネット接続構成>
インターネット-無線LAN(WZR-G144N)-PC

<ping結果>
Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation. All rights reserved.

C:\Users\xxxxx>ping sfp.kyoraku.jp

sfp.kyoraku.jp [1.1.81.114]に ping を送信しています 32 ...続きを読む

Aベストアンサー

状況からバッファローのルーターの問題であるような気がします。
ファームウェアのバージョンが低い場合は、アップデートで改善される「こと」もありますのでダメ元で試してみてはいかがでしょう?
あと、ルーターの経路情報や、ルーターにログインしてからpingテストをやってみて状況を確認してください。
ルーターからもpingが通らなければ(多分通らないと思いますが)、バッファローに問い合わせてみるのが解決への近道のような…。
他のルーターをお持ちでしたら、ルーターを変えてみるのもいいかもしれません。

QSW、HUBのIPアドレスの調べ方

IPアドレスを割り当てられるSW、HUBが、
自PCと同じネットワークに存在する場合の
そのSW、HUBのIPアドレスの調べ方を教えてください。

たとえば、pingをブロードキャストで飛ばして、
arpテーブルを確認するとIPアドレスが載ってくるのでしょうか?

または、
Internet-----ルータ-------SW,HUB---------PC
という構成であるときに
Internetにtracerouteを打つとSW,HUBのIPアドレスは確認できますか?

Aベストアンサー

> たとえば、pingをブロードキャストで飛ばして、
> arpテーブルを確認するとIPアドレスが載ってくるのでしょうか?

PCと同じネットワークのIPアドレスが振られているのであれば可能性はあります
ただ、最近はブロードキャストアドレスにpingを打っても答えない機器も多いです

> Internetにtracerouteを打つとSW,HUBのIPアドレスは確認できますか?

普通のSW-HUBではTTLの減算を行わないので無理です


このQ&Aを見た人がよく見るQ&A

人気Q&Aランキング