先日、RedHat 7.0.1J をデュアルブートでインストールしようとしたところ X がうまく起動しませんでした。
一応起動するのですが、アイコン等が大きすぎて(画面の領域が小さすぎて)何もできません。
あと、使用しているパソコンはDynaBookの DB60P/4RA2 で ビデオカードは S3 Inc. Savage/IX w/MV です。
東芝のユーザーサポートを見てみたらそれらしい答えが書いてあって、
http://linux.toshiba-dme.co.jp/ML/tlinux-users-j …に書いてあった
http://www.probo.com/timr/savagemx.htmlに行って、xf336sav.tgz をDLしてきたんですが、どうすればいいのかさっぱり分かりません。
別にRedHatにこだわるつもりはないので、Xを起動できるLinuxを使いたいです。
PC初心者ですがよろしくお願いします。

A 回答 (3件)

> RedHat7J はXFree86 4.0.1 みたいなので例のXF86_SVGAを


> 上書きしただけで、Xは動かないようです。

RedHat7J の場合

/usr/X11R6/bin/X → Xauth

という風にシンボリックリンクされており、最終的には

/etc/X11/X にシンボリックリンクされたサーバが起動するようです。
% su
# cd /etc/X11
# mv X X.old
# ln -s /usr/X11R6/bin/XF86_SVGA ./X

とすれば 3.3.6が起動するはずです。(というか、会社のRedHat7はそう
なってる...(^_^;; )

あとは、/usr/X11R6/lib/modules/codeconv/ というディレクトリが
ある場合、*.soというファイルがあるか確認してください。
もし、*.soがあるかcodeconvと言うディレクトリがない場合は
上記でOKなはず...

lib*.aというのしかない場合は2つ方法が考えられます。

案ア) xfree86 4.0.1→4.0.2までアップグレードする。
ダウンロードは大変なので4.0.2は雑誌の付録に付いて
いるのをいれるのが良いです。
http://www.probo.com/timr/savage40.htmlの説明に従い
ftp://ftp.probo.com/pub/xf40sav.tgz
ftp://ftp.probo.com/pub/s3s.tgz
をダウンロードしインストールする。

案イ) rpm で xfree86 4.0.1を一旦アンインストールし
RedHatのCDから xfree86 3.3.6を一式インストールする。
その後ダウンロードした XF86_SVGAを入れ替える。

といったところかとおもいます。

# linux関係のおすすめサイトだと...www.linux.or.jpから
# 日本語による各種情報にアクセスできるとおもいます。

この回答への補足

Linuxの勉強をしていたら解答補足が非常に遅くなりました。すいません。
h_hikitaさんが言われたように、
% su
# cd /etc/X11
# mv X X.old
# In -s /usr/X11R6/bin/XF86_SVGA ./X
と、コマンドを打って/usr/X11R6/lib/modules/codeconv/ に*.soというファイルがあるかどうか確認したところ、
lib*.aというファイルしかありませんでした。。(涙)
とすると、アップグレードか、XFree86 4.0.1をアンインストールした後、XFree86 3.3.6をインストールすればよいんですよね?
しかし…インストールの仕方そのものがよくわかりません。。。
インストールしたいファイル(XFree86 4.0.2)を持ってきて、
# install (ファイル名)
とするだけでいいのでしょうか?
ホントにパソコン初心者ですみません。よろしくお願いします。

補足日時:2001/05/05 08:51
    • good
    • 0

□fontが見つからないと言って落ちているのでフォントサーバ(xfs)や


FontPathの設定が正しいか確認してください。

フォントサーバの設定が面倒だったら /etc/XF86Config の Filesの
部分でフォントのある場所を指定して下さい。

例)
Section "Files"
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "/usr/X11R6/lib/X11/fonts/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/TrueType"
FontPath "/usr/X11R6/lib/X11/fonts/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/Speedo"
FontPath "/usr/X11R6/lib/X11/fonts/Wadalab"
FontPath "/usr/X11R6/lib/X11/fonts/misc"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi"
EndSection

□あとは、インストール時にXの設定を行っていないのなら
/usr/X11R6/bin/XF86Setupを実行し設定を行っておくと
よいと思います。

□XFree86 4.0.xを入れるかどうかは好みによると思います。
新しいのを試してみたいのなら良いかも。

この回答への補足

せっかく、いろいろ指摘していただいたのにすいません、肝心なことを見落としていました。
どうやらXF86_SVGAを上書きして、Xが起動するというのは、
XFree86 3.3.6 の話のようでした。
RedHat7J はXFree86 4.0.1 みたいなので例のXF86_SVGAを上書きしただけで、Xは動かないようです。
とすると、XFree86 4.0.1 をXFree86 3.3.6 に入れ替えて、
その上でXF86_SVGAを上書きすればいいみたいです。
でも、その仕方がわかりません・・・(無知ですいません)
どうか、教えていただけませんか?
または、Linux関連のおすすめサイト等がありましたら教えていただけるとありがたいです。
よろしくお願いします。

補足日時:2001/04/23 14:15
    • good
    • 0

tar xvzf xf336sav.tgz とかしてできた


XF86_SVGAを /usr/X11R6/bin/XF86_SVGAと
いれかえれば大丈夫だとおもいます。

% tar xzf xf336sav.tgz
# mv /usr/X11R6/bin/XF86_SVGA /usr/X11R6/bin/XF86_SVGA.old
# mv ./XF86_SVGA /usr/X11R6/bin/
# chmod 755 /usr/X11R6/bin/XF86_SVGA

とかすればいけます。

この回答への補足

Window環境でDLした xf336sav.tgz をgnomeのdesktopにコピーしてから h_hikita さんに教えていただいたコマンドを試行したあと、X を起動させたら、

(--) SVGA :Maximnm alllowed dot-clock : 250.000 MHz
(**) SVGA :Mode "640×480" mode clock = 25.175
(--) SVGA :Virtual resolution set to 640×480
(--) SVGA :Speedup code selection modifide because virtual1X != 1024
(--) SVGA :S3_savage : Using hardware cursor
Chose mode 101 at 60Hz
(--) SVGA : Using XAA (XFree86 Acceleration Architecture)
(--) SVGA : XAA : Solid filed rectangles
(--) SVGA : XAA : Screen-to-screen copy
(--) SVGA : XAA : 8×8 pattern fill
(--) SVGA : XAA : 8×8 color expand pattern fill
(--) SVGA : XAA : CPU to screen color expantion (TE/NonTE imagetext, TE/NonTE play text)
(--) SVGA : XAA : Using 5 128×128 areas for pixmap caching
(--) SVGA : XAA : Caching tiles and stipples
(--) SVGA : XAA : General lines and segments
filed to sel default font path '/usr/X11R6/lib/X11/fonts/Truetype,unix/:7100' Fatal server error:
could not open default font 'fixed'

When reporting a problem relation to a server crash , please send
the full server output , not just the last messages
X connection to :0.0 broken (explicit kill or server shutdown).

というエラーメッセージが出てXが起動しませんでした。
                (読めた範囲で書き記しました)
これは、もしかして、今上書きした XF86_SVGA も私のパソコンのビデオカードに対応していないってことなのでしょうか?
もしそうなら、XF86 4.*.* 等の新しいバージョンを入れたほうがいいのですか?
どうか、教えてください。

補足日時:2001/04/21 12:03
    • good
    • 0

このQ&Aに関連する最新のQ&A

お探しのQ&Aが見つからない時は、教えて!gooで質問しましょう!


このカテゴリの人気Q&Aランキング

おすすめ情報

カテゴリ