どうしてもインターネット接続が出来ないので教えてください。
Redhat7jを使ってます。

rootで次のように設定を行いました。
#/usr/sbin/adsl-setupコマンドで
USERNAME:xxx@atson.net(アサヒネット)
INTERFACE:eth0
Activate-on-demand:no
DNS:Do not adjust
Firewalling:0(NONE)
のように設定しました。
#/usr/sbin/adsl-startを実行して接続させました。
#/usr/sbin/adsl-statusのコマンドを投入するとIPアドレスもちゃんと
割り当てられてます。
x-Windowを起動してNatscapeブラウザーを立ち上げてWebページを見ようとすると
サーバが見つかりませんというメッセージが出ます。
どういうことでしょう。

このQ&Aに関連する最新のQ&A

A 回答 (4件)

どこまで作業が進んでいるのかちょっと分かりませんので参考になりそうなページを載せておきます。



参考URLのところと
http://www1.ttcn.ne.jp/~naka54/linux/how.html

が、参考になると思います。

参考URL:http://www.sh.rim.or.jp/~ssato/adsl-linux.html,h …
    • good
    • 0
この回答へのお礼

ははは、、、
つながりました。どうもありがとうございました。
原因はNICの設定にあったようです。
/etc/sysconfig/network-scripts/ifcfg-eth0のなかみを
1.起動時に有効かしない。
2.アドレスを割り当てない。
に直したところインターネットにつながりました。

ただし、良く分かりませんけれども途中でブラウザが良く消えちゃうんですけれどもこれはゆっくり調べてみます。
もう一度、ありがとうございました。

お礼日時:2001/05/05 19:51

ASAHIネットのHPを調べたらDNSの設定が載っていました。



202.224.32.1
202.224.32.2

です。

これでやってみてください。

参考URL:http://www.asahi-net.or.jp/info/guide/servers.htm

この回答への補足

ありがとうございました。
DNSを入れると確かにブラウザを起動すると直ぐ出たエラーメッセージは
出ませんけれども、やはりずっと読み込み中の状態のままになってます。
Redhatをインストールするときに設定するIPアドレスとか、ゲートウェイ
とか、ホスト名とかの設定とは関係ないでしょうか。

補足日時:2001/05/05 14:37
    • good
    • 0

/etc/resolv.confをvi等で編集して、


serverの所にDNSのIPアドレスを入力してみてください。

通常はプロバイダからDNSのIPアドレスを通知される筈です。
プロバイダから来た資料に全く記載が無いのであれば
ダイアルアップ用のDNSでも入力しておけば良いでしょう。
    • good
    • 0

DNSの設定がうまくいってない場合の症状ですね。


DNSの設定をプロバイダ側からの情報に合わせているか確認してください。

この回答への補足

DNSはプロバイダ側から特に指定が無かったです。
つぎのようも試してみました。
WinMEで接続してDNSをしらべました。
202.234.32.1と202.234.32.2でした。
これをASDL-SETUPで再セットアップして接続しました。
それからブラウザーを起動したら今度はエラーメッセージは出ませんけれども
ずっと読み込み中状態になって最後には止まったままになりました。

補足日時:2001/05/05 05:35
    • good
    • 0

お探しのQ&Aが見つからない時は、教えて!gooで質問しましょう!

このQ&Aと関連する良く見られている質問

Qkernel: kmod: failed to exec /sbin/modprobe -s -k md-personality-3, errno = 2

RHL9.0でRAID1のミラーリングをしています。/var/log/messageにタイトルのようなエラーが出るのですが、何のことなんでしょうか。
以下のように出ています。
kernel: kmod: failed to exec /sbin/modprobe -s -k md-personality-3, errno = 2
keytable:
kernel: md: personality 3 is not loaded!
kernel: md :do_md_run() returned -22
kernel: md: md4 stopped.
kernel: md: unbind<hdb9,1>
kernel: md: export_rdev(hdb9)
rc: Starting keytable: succeeded
kernel: md: unbind<hda9,0>
kernel: md: export_rdev(hda9)
kernel: md: considering hdb8 ...
kernel: md: adding hdb8 ...
kernel: md: adding hda8 ...
kernel: md: created md5
kernel: md: bind<hda8,1>
kernel: md: bind<hdb8,2>
kernel: md: running: <hdb8><hda8>
kernel: md: hdb8's event counter: 00000078
kernel: md: hda8's event counter: 00000078
kernel: md: RAID level 1 does not need chunksize! Continuing anyway.

RHL9.0でRAID1のミラーリングをしています。/var/log/messageにタイトルのようなエラーが出るのですが、何のことなんでしょうか。
以下のように出ています。
kernel: kmod: failed to exec /sbin/modprobe -s -k md-personality-3, errno = 2
keytable:
kernel: md: personality 3 is not loaded!
kernel: md :do_md_run() returned -22
kernel: md: md4 stopped.
kernel: md: unbind<hdb9,1>
kernel: md: export_rdev(hdb9)
rc: Starting keytable: succeeded
kernel: md: unbind<hda9,0>
...続きを読む

Aベストアンサー

うちの自宅サーバ(RedHat9)ですが、raid1組んでます。

/proc/mdstatを確認してはいかがでしょう?


# cat /proc/mdstat

Personalities : [raid1]
read_ahead 1024 sectors
md5 : active raid1 hdb5[1] hda5[0]
   1003904 blocks [2/2] [UU]

md3 : active raid1 hda3[0] hdb3[1]
   522048 blocks [2/2] [UU]

md2 : active raid1 hda2[0] hdb2[1]
   2096384 blocks [2/2] [UU]

md1 : active raid1 hda1[0] hdb1[1]
   8193024 blocks [2/2] [UU]

unused devices: <none>


[UU]となっているので、両系で動作しています。

md1はhda1/hdb1です。
md2はhda2/hdb2です。
md3はhda3/hdb3です。
md5はhda5/hdb5です。


mountコマンドで確認すると、以下です。

# mount

/dev/md1 on / type ext3 (rw)
none on /proc type proc (rw)
usbdevfs on /proc/bus/usb type usbdevfs (rw)
none on /dev/pts type devpts (rw,gid=5,mode=620)
none on /dev/shm type tmpfs (rw)
/dev/md2 on /var type ext3 (rw)
/dev/md3 on /usr/local type ext3 (rw)
/dev/md5 on /home type ext3 (rw)

うちの自宅サーバ(RedHat9)ですが、raid1組んでます。

/proc/mdstatを確認してはいかがでしょう?


# cat /proc/mdstat

Personalities : [raid1]
read_ahead 1024 sectors
md5 : active raid1 hdb5[1] hda5[0]
   1003904 blocks [2/2] [UU]

md3 : active raid1 hda3[0] hdb3[1]
   522048 blocks [2/2] [UU]

md2 : active raid1 hda2[0] hdb2[1]
   2096384 blocks [2/2] [UU]

md1 : active raid1 hda1[0] hdb1[1]
   8193024 blocks [2/2] [UU]
...続きを読む

Q/sbin/lilo が実行できません。

HDの15GB以降にlinux2.6をインストールしました、lilo.confにはlba32が記されています。liloを実施すると「 Reading boot sector from /dev/hda3
Device 0x0300: Invalid partition table, 3rd entry
3D address: 1/0/1022 (16418430)
Linear address: 1/0/1958 (31455270) 」が表示され実行できません、よろしくお願いします。

Aベストアンサー

以下のページに
Device 0x0300: Invalid partition table, 3rd entry
に関する記述があります。

パーティションを切る際、トラック単位にパーティションを割り当ててくれない
ツールを使うと良くない、ような事が書かれています。

参考URL:http://www.linux.or.jp/JF/JFdocs/LILO-README/map-installer-warnings.html

QNICからのkernel: eth0: Something Wicked happened! 2008.

TL6.1Jにてサーバーを運用しています。
サーバーには、DNS,Mail,Ftp,Sambaがあります。
そこで、タイトルのエラーが最近になって頻発しています。

また、kernel: ip_masq_ftp OUT: got PASV
もたまに出ます。eth0はLAN側です。
この原因と対処について経験があるかたお願いします。

マシンスペックは下記の通り

CPU:Pentium(3)550MHz
MB:AX6BCR VSPEC
RAM:SDRAM128M PC100
HDD:DPTA-372050
Video:Mill G200 8MB/AGP
NIC:LD10/100AL×2枚

Aベストアンサー

>NICの2枚挿しなのですが、出るのはLAN側のみで、WAN側に
>出たことはありません。これは、つまりLAN側に相当な負荷
>やパケットがあるために警告としているものなのでしょうか?

原因がわからないために,NICドライバのソースから原因を見つけるという話のつもりだったのですが,いまいち伝わらなかったようで…

実際に調べたので手順をちょいとまとめてみました。
(バージョンの違いにより行数が異なるかもしれません)

カーネルのソースが必要なので,インストールしていなければインストールCDからカーネルソースをインストール。

"2008"でgrepしても,有益な情報が得られなかったので,
"Something Wicked happened"で調べることにする。

$ grep -n "Something Wicked happened" /usr/src/linux/drivers/net/*
old_turip.c:2315: ……
via-rhine.c:1123: ……
yellowfin.c:1175: ……

jotarouさんのNICはvia-rhineなので,via-rhine.cに狙いを定める。

less,viなどで"/usr/src/linux/drivers/net/via-rhine.c"を1123行から見ると
1123: printk(KERN_ERR "%s: Something Wiched happend! %4.4x.\n",
1124: dev->name, intr_status);

"2008"はintr_statusの16進表示0x2008であることがわかる。

このファイルの頭からintr_statusで検索すると,297行目から

enum intr_status_bits{ ....
..., intrTxAbort=0x0008, ...
..., intrTxAbort=0x2000, ...
};

とあるので,0x2008はTxAbortの割り込みがLANカードから発生してる事がわかります。んで,ちょいとWebで調べると…

the VT86C100A data sheet says this TxAbort bit is set when
there are excessive collisions.

てのが,ありました。コリジョンが沸いてるみたいですね。

>NICの2枚挿しなのですが、出るのはLAN側のみで、WAN側に
>出たことはありません。これは、つまりLAN側に相当な負荷
>やパケットがあるために警告としているものなのでしょうか?

原因がわからないために,NICドライバのソースから原因を見つけるという話のつもりだったのですが,いまいち伝わらなかったようで…

実際に調べたので手順をちょいとまとめてみました。
(バージョンの違いにより行数が異なるかもしれません)

カーネルのソースが必要なので,インストールしていなければインストールCDから...続きを読む

Q/usr/lib にあるファイルの一部を誤ってsudoで削除

/usr/lib にあるファイルの一部を誤ってsudoで削除

Mac OS 10.5を使用している者です。
ターミナルで作業中に操作を誤り、/usr/lib にあるファイルの一部を削除してしまいました。
lsなどいくつかのコマンドでエラーが出るようになり、ターミナルもじきに落ちてしまったため、再起動を試みたところ、以降まったく立ち上がらなくなってしましました。
何か対応策をご存じの方がいらっしゃいましたら、ご教授いただけないでしょうか?
まったく恥ずかしい質問で恐縮ですが、よろしくお願いします。

Aベストアンサー

バックアップがあれば、 インストールディスク等から起動 → ファイルを復元で回復するかもしれません。
だめなら、再インストールでしょうね。

QUNIX/uidからusernameを参照するには?

UNIXでuidからユーザネームを参照したいのですが、どこにこの情報があるかわかりません。手がかりだけでもよいのでご存じの方がいらっしゃったら教えてください。

Aベストアンサー

nireportというコマンドを見つけました。
こんなのはどうでしょう。

uidが501番のアカウント名が知りたい時は

# nireport . /users name uid | grep 501 | cut -f 1


人気Q&Aランキング

おすすめ情報