ubuntu 14.04 で firefox 33(for ububntu canonical-1.0)がインストールされています。

これでNHKラジオ深夜便のストリーミングサービスを利用しようとすると「このプラグインは安全ではありません。更新して下さい」と出ます。
「更新を確認する」をクリックすると「mozillaプラグインチェック」になり「shockwave flash 11.2.202.408は最新です」と出ますが同時に「古いfirefoxをお使いのようです」と出るので「firefoxを更新する」をクリックすると
firefox-34.0.5.tar.bz2の画面で出て「プログラムで開く」を「OK」するとダウンロードされアーカイブマネージャでfirefoxフォルダーが表示されますがこのまま作業は進みません。

このfirefoxフォルダーを開くといくつかの下部フォルダーやファイルが見つかります。多分何かファィルをクリックするのでしょうがlinux初心者でこの先がわかりません。

これ以降の進め方がお分かりの方よろしく教えて下さい。

このQ&Aに関連する最新のQ&A

A 回答 (7件)

#1です。


UbuntuはCanonical社が中心となって、開発が進めています。
アプリなどのアップデートはCanonicalにて動作検証されてから
まとめて、「ソフトウェアーの更新」で配布されますので、タイムラグが生じます。
ソフトウェアーの更新がUnityのランチャーに表示されますので、クリックして
手順で操作すれば良いだけなのですが。

私の環境ではFirefoxは34になってます。
未だにアップデートされていなければ、設定の確認ですね。

NHKのストリーミングサービスとは「らじる☆らじる」とは違うのですか?
Shock Wave Flashは2014年12月13日に、11.2.202.425に更新されました。

この回答への補足

システム設定の「アップデート」は問題ないようです。

NHKのストリーミングサービスとは「らじる☆らじる」とは違います。「ラジオ深夜便」などの録音再生サービスです。

補足日時:2014/12/14 16:55
    • good
    • 0
この回答へのお礼

>まとめて、「ソフトウェアーの更新」で配布されます
・確かにそのはずですよね。アップデートの確認は毎日になっているのですが?
・結局はどうにも分からなくて昨日ubuntuを最初からインストールし直ししました。インストール直後のバージョンは28.0でした。
・今日起動時にアップデートがありバージョンは34になりました。

ありがとうございました。

お礼日時:2014/12/15 19:43

設定は何もありません。


日本語版をダウンロードしなおしてみてください。
    • good
    • 0

私の場合、Firefox 34.0 (for Ubuntu canonical-1.0) にアップデート済みですが、


Adobe Flash Playerは、Flash Player 11-2.202.425にアップデートしてあります。
(主に使用する Google Chrome 39.0.2171.95 では、16.0.0.235)

http://www.adobe.com/jp/software/flash/about/
「ubuntuでfirefox更新の仕方に」の回答画像6
    • good
    • 0

こんばんは



アーカイブマネージャで表示させたフォルダの中にあるfirefoxを起動しようとしましたね。
それではダメで、firefox-34.0.5.tar.bz2を一度どこかのフォルダに保存し、それを展開してください。
その上でfirefoxフォルダ直下にあるfirefoxのアイコンをダブルクリックしてください。

この回答への補足

たしかにアーカイブマネージャで表示させたファイルをクリックしていました。

展開して該当のfirefoxを「実行」してもなにも起きません。よくわかりません。

最後の手段としてfirefoxを削除して再インストールしましたら34.0.5.になりました。
ただどこかで設定を見逃したのかfirefoxのタイトルバーほかが英語表示になってしまいました。使いにくいです。

補足日時:2014/12/14 17:09
    • good
    • 1

こんにちは



firefoxの最新版は34.0.5ですね。
これを解凍する所までは行っているんですね。
firefoxフォルダの中にfirefoxと名前のついたファイルがあります。
これをダブルクリックするとfirefoxが起動します。

ついでながら、現在のLinux用flashの最新版は11.2.202.425です。
確かにLinux用は11.2で終了とアナウンスされていますが、マイナーバージョンアップは続いています。

この回答への補足

firefoxと名前のついたファイルをクリックしても「開くアプリが見つかりません」となって奨めませんでした。updateというファイルもありましたのでこれをクリックしても同様でした。

NHKラジオ深夜便のストリーミングサービスをubuntuで開くのは危険が伴うということになりますか。

補足日時:2014/12/13 18:56
    • good
    • 0

結論だけ言うと,


もし仮に”これ以降の進め方”が分かって実行したとしても、
Linux向けのFlashをFirefox上で使っている限り「このプラグインは安全ではありません。更新して下さい」はもう治りません。

Flashはセキュリティーホール等の修正等が行われており現在バージョン 16.0.0.235が最新です。
Linux向けのバージョンは11.2が最終で、今後アップデートの見込みはありません。

http://www.adobe.com/devnet/flashplatform/whitep …
(下から20%くらいの位置に記述あり)
じゃあどうすのよ?という疑問についても上記文書に書かれてています。

この回答への補足

NHKラジオ深夜便のストリーミングサービスをubuntuで開くのは危険が伴うということになりますか。

じゃあどうすのよ?→解読できはませんでした。

補足日時:2014/12/13 18:53
    • good
    • 0

FirefoxはアップデートでVer,34になってませんか?



圧縮ファイルの展開とインストールはこちらで
http://itpro.nikkeibp.co.jp/article/COLUMN/20060 …

Ubuntuで管理している、ソフトウェアーセンター以外からダウンロード
してインストールするのは、初心者の段階では、よした方が宜しいですよ。
Linuxの世界にも悪意を持って配布している輩が居ますので。

この回答への補足

windowsのfirefoxは「Help-firefoxについて」で最新でなければ更新を促してくれますがubuntuのfirefoxは更新の案内がないです。

ソフトウェアーセンターも確認しましたがよくわかりませんでした。(インストール済みに33.0と表示されて「削除」しかありません)

補足日時:2014/12/13 18:48
    • good
    • 0

このQ&Aに関連する人気のQ&A

お探しのQ&Aが見つからない時は、教えて!gooで質問しましょう!

このQ&Aを見た人はこんなQ&Aも見ています

このQ&Aを見た人が検索しているワード

このQ&Aと関連する良く見られている質問

Qapt-get install ****** でinstallしたものをuninstallするには?

御世話になります。
vncserverだけをinstallするつもりが
誤って
apt-get install vncとうってしまいました。
これをuninstallしたいのですが
どのようにすればよろしいでしょうか?

教えて下さい。

Aベストアンサー

# apt-get remove パッケージ名
では、設定ファイルは削除されずに残ります。

完全に削除するときは、
# apt-get --purge remove パッケージ名
です。

Qtar.bz2ファイルのインストール方法

centos6をインストールして一週間の初心者です。
http://detail.chiebukuro.yahoo.co.jp/qa/question_detail/q1391243883
ここのページを見ながら、インストールを試みたのですが、

$ cd <展開したディレクトリ>
$ ./configure
$ make
$ sudo make install

という作業をやってみたのですが、

[dreamqest1970@localhost ~]$ cd /home/dreamqest1970/ダウンロード
[dreamqest1970@localhost ダウンロード]$ ./configure
bash: ./configure: そのようなファイルやディレクトリはありません
[dreamqest1970@localhost ダウンロード]$ cd /firefox-25.0.1.tar.bz2
bash: cd: /firefox-25.0.1.tar.bz2: そのようなファイルやディレクトリはありません
[dreamqest1970@localhost ダウンロード]$

というメッセージが出てきてインストールできません。

当方LINUX初心者ゆえ、初歩的な問題かもしれませんが、どうかよろしくお願いします。

centos6をインストールして一週間の初心者です。
http://detail.chiebukuro.yahoo.co.jp/qa/question_detail/q1391243883
ここのページを見ながら、インストールを試みたのですが、

$ cd <展開したディレクトリ>
$ ./configure
$ make
$ sudo make install

という作業をやってみたのですが、

[dreamqest1970@localhost ~]$ cd /home/dreamqest1970/ダウンロード
[dreamqest1970@localhost ダウンロード]$ ./configure
bash: ./configure: そのようなファイルやディレクトリはありません
[dreamqest1970@localho...続きを読む

Aベストアンサー

ドラッグと言うのは、ダブルクリックして開いた時に表示されたフォルダをどこか適当なフォルダの上まで引っ張っていってください。そうするとそのフォルダに解凍されます。

私もCentOS6 64bitを使っています。
基本的にはMozillaのホームページからLinux版をダウンロードすればいいはずなんですが、私の場合それでは日本語変換出来ない問題が発生しました。そこで64ビット版をダウンロードして使う様にしています。
試してみてください。
ダウンロードはここからできます。
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/25.0.1-candidates/build1/linux-x86_64/ja/

Qubuntuで動画が見られない

XPとubuntu12.04.2をデュアルブートしているものですが、動画を見ようとしても音声は聞こえますが、動画が見られません。TotemでもVLCプレイヤーでもダメです。理由がわかりません。
参考になるかどうかわかりませんが、最初に13.10をライブ起動しようとしましたが出来ず、12.04.2から12.10にアップグレードしようとしてもダメでした。

使用PC シャープPC-AE50L cpu AMD sempron 3000+ メモリ1.2G(増設済) ハードディスク60G(デフォルト) グラフィック VIA/S3G UniChrome Pro
2005年12月発売(2006年6月購入 )です。よろしくお願いいたします。

Aベストアンサー

Linux系OSは、消費者側で開発していると言っても良い体制なので
古いCPUの切り捨ては、あまり厳しく行われません。
逃げ道があるというか、救済策があったりします。

Sempronのスペックは把握していないので、制限がどう生じるかはわかりません。

たとえば、PAE非対応のCPUではUbuntu12.04LTSが導入できないという問題がありますが
これは、もとも性能の低いCPU向けのXubuntu12.04LTSやLubuntu12.04LTSを選べば
PAE非対応のCPUでもインストールができたりします。

こういったXubuntuやLubuntuのような軽量な派生版があること自体が
古いCPUや古いPCにとって有用な選択肢で
Ubuntu標準のUnityによるGUIよりも
Xubuntuが採用しているXfceによるGUIのほうが軽快に扱える可能性があります。

ただ、安定版でもある長期サポート版のLTSに比べれば
12.10から13.10では実験的な性質もあるので、S3のグラフィックチップに対して
うまく認識して動いてくれない可能性はあります。

S3やTridentやLynxは、少数派になりきった感があり
どうやら冷遇されているようです。

起動ディスクが、途中で画面真っ暗で頓挫するような症状なら、そういう問題です。
(対処方法自体はありますが、ここは割愛します)


そういうこともあるので、動画が再生できないのではなく、表示が出ないのであれば
単純に、現在動いているグラフィックのデバイスドライバーが
画面描画において、サポートしていない方法を、再生ソフトが用いている可能性があります。

VLCの場合は[ツール]-[設定]-[ビデオ]-[出力]まで辿って行くと
[デフォルト]になっているではないかと思います。

一般的には、出力にはXVideoが基本という感じなのですが
デバイスドライバーが対応していない場合は、X11ビデオ出力(XCB)を試します。
これでも表示されないとしたら、特殊な問題と考えられます。

なお、X11は普通のGUI描画と同様の描画になっていると理解していますが…
動画再生としては、再生性能が低くなります。
全画面表示が無理になるような場合は
画面解像度自体を落として対処するしかなくなるかもしれません。

Windows用ゲームにはそういう解像度を落として実行する機能があったりしますが
Linuxでの動画再生の場合は、手動で画面モードを切り替える必要があります。
GUIフロントエンドでの変更よりも、xrandrコマンドを使ったり
xrandrコマンドを使ったシェルスクリプトを、アイコンとして置いておくほうが便利です。


この時代のノートPCだと、USB接続のグラフィックアダプターを使うにも無理があるので
X11ビデオ出力で、充分な再生性能が得られないとなると、厳しいことになります。

DVDとか動画に特化した、GeeXboXみたいなアプローチもあったんですけどね。
日本では、さっぱり定着しなかったみたいです。


なお、GeeXboXに比べれば、XubuntuやLubuntuでも複雑で規模の大きいものですが
Xubuntuの場合で、起動直後のメモリー消費は300MBを下回る程度です。
GUIの処理自体も簡素になっているので
xubuntu-desktopという特殊パッケージを追加し
ログアウト後、Xubuntuを選択して再ログインするだけで、GUIをUnityからXfceに切り替えできます。

KafeeineはKDEを標準採用していた頃のTurboLinuxなんかでは標準の動画再生ソフトでしたね。
Ubuntuには、KDEを採用したKubuntuもあり、うちのメインマシンはそれになっています。
まぁKafeeineはTurboLinux以外で使ったことありませんけどね。
Kubuntuは、軽量というわけでも無いので、趣味が合う人以外は、特に選ぶメリットは無いかもしれません。

それぞれ、kubuntu-desktopやlubuntu-desktopというパッケージがあり
これらを追加することで、KubuntuやLubuntuに準ずる構成が得られます。
正確には、よけいなモノが残るので、省メモリーを追求する必然性がある場合だけは
XubuntuやLubuntuでインストールしなおすほうがいいでしょう。

Linux系OSは、消費者側で開発していると言っても良い体制なので
古いCPUの切り捨ては、あまり厳しく行われません。
逃げ道があるというか、救済策があったりします。

Sempronのスペックは把握していないので、制限がどう生じるかはわかりません。

たとえば、PAE非対応のCPUではUbuntu12.04LTSが導入できないという問題がありますが
これは、もとも性能の低いCPU向けのXubuntu12.04LTSやLubuntu12.04LTSを選べば
PAE非対応のCPUでもインストールができたりします。

こういったXubuntuやLubuntuのような軽量な派...続きを読む

Qaptでインストールしたプログラムはどのディレクトリに?(Ubuntu)

Ubuntuを使っています。

aptでインストールしたプログラムはどのディレクトリにインストールするのでしょうか?また、aptでインストールしたプログラムを確認する方法(どんなプログラムをインストールしたのかを確認する方法)はあるでしょうか?

Aベストアンサー

>aptでインストールしたプログラムを確認する方法

見逃してました。

# dpkg -l

とかで。

QUbuntuに必要なSSDの容量について

こんにちは。
UbuntuかLinux mintをインストールするパソコンについてです。
64GBのSSDを使うつもりなのですが、Linuxだとどれくらいの容量のシステムドライブを用意しておくべきなのでしょうか?
Windows8だと100か200は必要なようですが。

あと、無線LAN環境でもSSDの速度を体感できますか?
ネットにつながる速度がボトルネックとなってSSDの意味がなくなったりしますか?
私がパソコンでする作業といえば、ほぼGoogle Chromeで完結しています。

よろしくおねがいします。

Aベストアンサー

質問者さんは恐らくLinuxについては初心者さんという前提で解答します。

>64GBのSSDを使うつもりなのですが
十分ですね。十分すぎます。

ウブンツをインストールしても4Gも使用しないでしょうから、後の60G使いたい放題でしょう。

>Windows8だと100か200は必要
絶対必要じゃありませんね。Windows8をインストールするのに必要は容量はせいぜい20G位でしょう。

あとは、アプリケーションや、データをワンサカ入れれば100や、200はいっぱいになってしまいますから、
そういう意味では、100でも200でも足りない可能性があります。

結局何がやりたいのかによります。

例えば、冷蔵庫を買うとして、冷凍室が400mlで足りるか否かは、どのように使用するかによりますよね?
ひとり暮らしなのか、家族4人で暮らすのか、もしくは飲食店で使用したいのか?

どうように、ウブンツで何をしたいのかによって、必要な容量が変わってきます。

ただ、ウブンツをインストールしてちょっと使ってみる程度であれば64Gもあれば十分です。

また、SSDにするのは正解です。無線LANだろうが、優先LANだろうが、同じ容量であればHDとSSDで比べれば
大抵の場合SSDのほうが早いです。つまりはPCのスペックがよくなりますので、
SSDを搭載できるのであれば、SSDにしたほうがいいです。

質問者さんは恐らくLinuxについては初心者さんという前提で解答します。

>64GBのSSDを使うつもりなのですが
十分ですね。十分すぎます。

ウブンツをインストールしても4Gも使用しないでしょうから、後の60G使いたい放題でしょう。

>Windows8だと100か200は必要
絶対必要じゃありませんね。Windows8をインストールするのに必要は容量はせいぜい20G位でしょう。

あとは、アプリケーションや、データをワンサカ入れれば100や、200はいっぱいになってしまいますから、
そういう意味では、100でも200でも足りない...続きを読む

Qpingでポートの指定

pingでIPアドレスを指定して、通信できるかどうかというのは
よく使いますが、pingでポートを指定して応答するかどうかは調べられるのでしょうか?

よろしくお願いします

Aベストアンサー

pingを含むICMPというプロトコルは、OSIの7レイヤで言うところのL2(同一セグメント内通信)とL3(IPルーティングされた通信)の両方にまたがる、ちょっと珍しいプロトコルです。

IPアドレスは指定できますが、別サブネットに属するIPアドレスに到達できればL3通信、できなければゲートウェイと呼ばれる同一サブネットに属する中継装置からの回答を得るという点でL2(MAC通信ではなく、同一セグメント内通信という意味)通信です。

ポート番号はL4で使用されるアドレスですから、L4機能の疎通確認はping(を含むICMP)ではできません。

FTPの疎通確認であれば、クライアントからサーバに対するTCP/21通信(FTP-CMD)が可能であること(サーバからクライアントへのTCP/21からの応答を含む)+サーバからクライアントに対するTCP/20通信(FTP-DATA)が可能であること(クライアントからサーバへのTCP/21からの応答を含む)が必要でしょう。

監視ソフトによるものであれば、
・クライアントからサーバへのログイン(TCP/21)
・クライアントからサーバへのlsの結果(TCP/20)
で確認すればよいでしょう。

pingを含むICMPというプロトコルは、OSIの7レイヤで言うところのL2(同一セグメント内通信)とL3(IPルーティングされた通信)の両方にまたがる、ちょっと珍しいプロトコルです。

IPアドレスは指定できますが、別サブネットに属するIPアドレスに到達できればL3通信、できなければゲートウェイと呼ばれる同一サブネットに属する中継装置からの回答を得るという点でL2(MAC通信ではなく、同一セグメント内通信という意味)通信です。

ポート番号はL4で使用されるアドレスですから、L4機能の疎通確認はping(を含む...続きを読む

QLinux バイナリ実行できない "cannot execute binary file”

表記ですが、Linuxサーバーに対して、Windowsクライアントから
XWin環境にてユーザー"hoge"でログインを行い、
そのサーバー上でターミナルを立ち上げ
/usr/local/gcc_work
というフォルダを作り、その中で

---ここからーーー
#include <stdio.h>
int main(void)
{
printf("Hello,world\n");
return 1;
}
ーーーここまでーーー

のような、hello.cを作成し、

$ gcc -c hello.c -o hello
でバイナリを作成し

$ ./hello
とすると
bash: ./hello: cannot execute binary file

とのメッセージが出ます。
パーミッションの問題かと思いましたが、
[hoge@localhost gcc_work]$ ls -l
合計 8
-rwxrwxr-x 1 hoge hoge 876 5月 6 18:14 hello
-rwxrwxr-x 1 hoge hoge 83 5月 6 18:13 hello.c

のようになっていて、問題なく感じています。
スーパーユーザになって再度コンパイルしても同じでした。
くだらないところで躓いているのかもしれませんが、お気づきあらば
教授願います。

表記ですが、Linuxサーバーに対して、Windowsクライアントから
XWin環境にてユーザー"hoge"でログインを行い、
そのサーバー上でターミナルを立ち上げ
/usr/local/gcc_work
というフォルダを作り、その中で

---ここからーーー
#include <stdio.h>
int main(void)
{
printf("Hello,world\n");
return 1;
}
ーーーここまでーーー

のような、hello.cを作成し、

$ gcc -c hello.c -o hello
でバイナリを作成し

$ ./hello
とすると
bash: ./hello: cannot execute binary file

と...続きを読む

Aベストアンサー

> $ gcc -c hello.c -o hello

-c オプションをつけたときは実行ファイルまでは作らずに、オブジェクトファイル
(通常は .oの拡張子を持つもの)を作るだけですよ。
それは実行可能形式のファイルじゃありません。

file hello

とかしてみてください。
素直に -c オプションをつけずに

$ gcc hello.c -o hello

で実行可能な hello ができると思いますよ。

Qパスワード設定していないユーザーのログイン

いつもお世話になっております。

linuxで、useraddした後、passwdコマンドでパスワードを設定していないユーザーがいます。ここでは、postgresとします。

このユーザーに一般ユーザーからなるときに、
$su - postgres
としますが、パスワードがきかれて、何も入力しないと、
invalidになります。(centos5)

パスワードを設定しないと、一般ユーザーからログインできないのでしょうか。
ちなみに、rootからpostgresですと、ログインできます。
$su -
$su - postgres

お手数をおかけしますが、なにとぞご教授お願いいたします。

Aベストアンサー

 実際useraddしてみると分かりますが、useradd直後の状態では、パスワードは「設定されていません」。
 設定しとらんのやけん設定はされとらんやろ何を言うてるんアホちゃうんと思うなかれ。パスワードが設定されていないとは、パスワードが空である(=初期値としてランダムパスワードが設定されている訳ではない)という事です。さて、ではどうして一般ユーザーからsuできないのでしょうか。rootになって

# getent shadow postgres

とすると、パスワードの欄が半角びっくりマーク2個のみが印字されたかと思います。この半角びっくりマーク2個というのがLinuxにおいて「アカウントがロックされている」という状態になります。
 試しに/etc/shadowファイルをrootで直接書き換える(びっくり2つを削る)と、一般ユーザーからパスワードなしでsu - postgresできるようになります。もちろんこんな危険な操作(shadowの書き換え)は普通せずに、以下のようにします。

# passwd -u -f postgres

passwd -uというのは、ロックアウトされているアカウントのロックを解除するものですが、現在postgresにはパスワードが設定されていないためpasswd -uだけだと「危険だべ」と拒否されます。ので、-fオプションをつけて強行します。すると先ほど/etc/shadowを直接書き換えたのと同じ状態に変わり、一般ユーザーからパスワードなしでsu - postgresする事ができるようになります。逆にロックする時は

# passwd -l postgres

です。詳しくはpasswd -hなどを参照の事。root(uid 0)はロックされているアカウントもおかまいなしに変身できるという凄い権利を持っています。

 実際useraddしてみると分かりますが、useradd直後の状態では、パスワードは「設定されていません」。
 設定しとらんのやけん設定はされとらんやろ何を言うてるんアホちゃうんと思うなかれ。パスワードが設定されていないとは、パスワードが空である(=初期値としてランダムパスワードが設定されている訳ではない)という事です。さて、ではどうして一般ユーザーからsuできないのでしょうか。rootになって

# getent shadow postgres

とすると、パスワードの欄が半角びっくりマーク2個のみが印字されたかと思...続きを読む

QUbuntuからWindows 7のファイルをアクセスできません

UbuntuにSambaをインストールしていて、同じユーザID、パスワードで起動している状態でWindows 7のファイルにアクセスできません。

UbuntuでWindows 7で共用設定したローカルドライブをオープンする時に、パスワードの入力要求にパスワードを入力しても受け付けられない状態です。

環境はつぎの通りです。
Ubuntu: バージョンは14.04
Samba: ログインと同じユーザID、パスワードを登録設定
Windows 7: Pro. 64bit SP1、Ubuntuからアクセス対象のローカルドライブに対して共用設定

解決方法をご教示して頂きたくよろしくお願いします。

Aベストアンサー

#1、#2です。
かなり苦戦されているようですね。
http://windows.microsoft.com/ja-JP/windows7/What-is-the-difference-between-a-domain-a-workgroup-and-a-homegroup
Windows7からネットワークにホームグループが追加されたので、Windows XP の様に
容易に共有フォルダにアクセス出来なくなって、しまいました。
アウクセス権をいじると、セキュリティでの問題が出て、更にややっこやしい事態に
なる恐れがあります。
Windows XP のユーザーである、私にはWindows7の事は良くわかりませんので、
60万人のユーザー登録が在る、日本語フォーラムに質問されては、如何でしょうか・・
https://forums.ubuntulinux.jp/index.php

Q接続ができません

MySQLに接続するため、コマンドラインで
>mysql -u root
と入力したのですが
ERROR 2003:Can't connect to MySQL server on 'localhost'(10061)
とエラーが出て接続できません。

また、
>mysqladmin -u root password '********'
>mysql -u root -p
もやってみたのですが、
mysqladmin: connect to server at 'localhost' failed
error: 'Can't connect to MySQL server on 'localhost' (10061)'
Check that mysqld is running on localhost and that the port is 3306.
You can check this by doing 'telnet localhost 3306'
とエラーが出てしまいます。

前に同じ質問があったのですが解決されていなかったので、
再度質問させていただきました。
よろしくお願いしますm(_ _)m

OSはWindowsXPです

MySQLに接続するため、コマンドラインで
>mysql -u root
と入力したのですが
ERROR 2003:Can't connect to MySQL server on 'localhost'(10061)
とエラーが出て接続できません。

また、
>mysqladmin -u root password '********'
>mysql -u root -p
もやってみたのですが、
mysqladmin: connect to server at 'localhost' failed
error: 'Can't connect to MySQL server on 'localhost' (10061)'
Check that mysqld is running on localhost and that the port is 3306.
You can check this by doin...続きを読む

Aベストアンサー

MySQLのバージョンとか、もし本を見ているなら何の本なのかとか、設定はどのようにしているとか、そういう除法がないと回答できません。

接続できない原因については、エラーメッセージからして、そもそもMySQLが起動していないものと思われます。
起動しないと(起動できるようにしない)とダメです。
恐らく、設定ファイルに間違いがあってMySQLが起動してないんでしょう。
設定ファイルを見直してみましょう。

※インストール先がC:\mysql以外の場合、後で設定ファイルの basedir でパスを指定する必要があるはずなので、そこら辺も。

もし起動しているなら、ポートがLISTENになっているか確認してみましょう。
コマンドプロンプトで
netstat -an
して、エラーメッセージに出ているポート番号10061,3306がLISTENになっているかどうか確認してみましょう。

パーソナルファイアウォールなどの設定で、ポートがふさがれている可能性もあるのかもしれませんが、色々試してみてください。

以上、随分前にMySQLを触っただけなので、最近の動向はあまり押さえてませんが、参考になれば幸いです。

MySQLのバージョンとか、もし本を見ているなら何の本なのかとか、設定はどのようにしているとか、そういう除法がないと回答できません。

接続できない原因については、エラーメッセージからして、そもそもMySQLが起動していないものと思われます。
起動しないと(起動できるようにしない)とダメです。
恐らく、設定ファイルに間違いがあってMySQLが起動してないんでしょう。
設定ファイルを見直してみましょう。

※インストール先がC:\mysql以外の場合、後で設定ファイルの basedir でパスを指定する必要...続きを読む


このQ&Aを見た人がよく見るQ&A

人気Q&Aランキング