自分のHPで画像をアップした時に、画像のいくつかが表示されません。

具体的な症状
■全ての画像が表示されないのではなく、数枚だけ表示されません。
■HPの編集段階では全ての画像が表示されます。
■違う画像に変えてみても、表示されません。場所(?)がわるいのでしょうか?
■メモ帳にタグを打ち込んで作成したのですが、正常に表示されている画像のソー スをコピー、ペーストしてファイル名だけ変えてみても、表示されません。
 (表示されているもののコピーなので、タグが間違ってる筈はないと思うのです  が。)
■画像が表示されるべき場所には×印が表示されています。
■バイナリファイルとして転送してみても表示されません。

どうしたらよいか本当に分からないので、教えてください…。

Windows98で、IE5.5を使用しています。

このQ&Aに関連する最新のQ&A

作成 タグ」に関するQ&A: タグ作成の依頼

A 回答 (9件)

どうも。

まだお元気ですか?

ふと思い立った事があるので、また来ました。

色々、いじった時、またはアップした時に、再読み込みをやってます??

IEの中にキャッシュファイルと言って、一度読み込んだページのデータが一定期間残っているので、何か変更した時は、必ずこれをやって確かめましょう。これは、ページごとにいじったページは全部やる必要があります。

# 私も以前、これで、何回変更しても更新されないのでイライラした事があります。

また外してたら m(__)m ね。
    • good
    • 0
この回答へのお礼

何度も有難うございます!返信が遅くなってゴメンナサイ…。
試してみたのですが、やっぱり上手くいかないので、
とうとう前のフォルダは見捨てて新しくフォルダを作って
そこに全ての画像を移し変え、
FFFTPの設定の、「ローカルの初期フォルダ」もそれに変えました。

すると、ちゃんと全ての画像が映るようになったのです。
ただ、前のフォルダで一体何が悪かったのかが分からないままで。

ところが、新しくつくったフォルダでも
前述の引越し後に新しく加えた画像のうち、
また映らない画像が出てきました。

しょうがないので今度は、
画像だけ別のフォルダに入れるのをやめて、
全てHP用のファイルは同じ階層に置くようにしてみたところ
全て表示されるようになりました…。
今は、そういう状態で、一応人段落ついています。(--;

何なんでしょうか一体・・・・・

とりあえず、何度も教えてくださって有難うございました!
また何かあったときはよろしくお願いいたします。

お礼日時:2001/07/02 09:30

 No.1です。

 そっかぁ、拡張子は変化してませんでしたか。もういっこ思い出したので書きますね。
 houkiさんが作った画像は同じものですか?っていうか、画像としてはgif、jpg、bmp などありますが、全部同じで作ってますでしょうか? というのも、レンタルサーバによっては扱える種類に制限があるのですよ。(もちろんALL OKのとこもありますけど) そのレンタルサーバの使用方法の説明とかで書いてあるかと思いますので、照会してみては?

 で、もし例えばbmpだった! これはこのサーバでは適用されない! となったら対応する形式に変更する必要がありますが、簡単ですよ(多分)。bmpファイルを開いて、
 ファイル → 名前をつけて保存 → 「ファイルの種類」でgifなりjpgなりにする
 これで、変更できます。 さて、今度はどうかな?

この回答への補足

何度もアドバイス有難うございます。(T-T。

画像は全てjpgになってます。
それで表示される画像とそうでない画像があるので、
ファイル形式の違いが原因ではないように思います…。
もし、また何かお気づきの点がありましたら
教えてください。
お願いします。

補足日時:2001/06/17 19:29
    • good
    • 0

こんにちは。

また来ました。

名前間違えじゃないとすると、ディレクトリの間違えでしょうかね。

そのページのhtmlファイルがあるディレクトリと同じ所にその画像ファイルがあるのなら、単純にそのファイル名が書いてあるか、./ を付けて書きます。例えば、

 fujisan.jpg 若しくは、./fujisan.jpg という具合。

そのhtmlファイルと同じディレクトリの中にもう一つディレクトリ、xyz があってその中にあるのなら、xyz/ もしくは、./xyz/ を付けます。

 xyz/fujisan.jpg もしくは、./xyz/fujisan.jpg こんな感じ。

もし、一つ上のディレクトリなら、../ をつけます。二つ上なら、../../ です。

 ../fujisan.jpg ../../fujisan.jpg という具合。

また、一つ上に上がって、別のディレクトリ abc ディレクトリなら、../abc/ を付けます。

 ../abc/fujisan.jpg とまあ、こんな具合で、そのhtmlファイルと画像ファイルの位置関係の問題が考えられます。

一度、その変なページをIEで表示し、「表示」→「ソース」で、その画像のところの記述がどうなってるか見て、画像ファイルが実際にある位置と比べて見てください。

あと、まさかと思うんですが、「.」が抜けてるってのはないでしょうね?

見やすくするために全角で書きますけど、

fujisan.jpg と書くべきところを、fujisanjpg とか。

この回答への補足

何度もアドバイス有難うございます(T-T。
画像を入れているのは、
htmlファイルがあるディレクトリ中にもう一つあるディレクトリです。

したがって、仮に、
画像の入っているディレクトリを「img」、画像を「gazou」とすると


「img/gazou.jpg」

のように打ち込んでいます。
これで表示される画像とそうでない画像があるのです…。

でも、先日他の人に見てもらったところ、
表示されない画像は「img」フォルダに入っていないことになっているから
「img/gazou.jpg」の「img/」の部分を消すように、と言われました。
でも、何度確認してもちゃんと入っているのです。

一応その人の言われる通りに「img/」を消してみた…(A)ところ、
アップした画像がオンラインでは表示されるようになりました!
…が、今度は編集の時に表示されなくなりました。

繰り返しますが、「gazou」は「img」フォルダの中に確かに入っています。

更に、別の人から、<base href="***">というタグを
<head>~</head>の中に組み込めば
ファイルを参照する時に***(←URLを、htmlファイルのファイル名の前まで記入)を
基準にして探してくれるようになる、と言われたので
使ってみた…(B)ところ、編集時にも画像が表示されるようになりました。

これで一応表示はされるようになった、と思っていたのですが
新しく作ったページには、また以前のように画像が表示されない
(表示される画像とそうでない画像がある)のです。
今度は上記の(A),(B)を踏まえてタグを打っているのですが。

長くなりましたが、何かお気づきの点があれば
教えていただきたく思います…。お手数かけましてすみません…。(T-T

補足日時:2001/06/17 18:47
    • good
    • 0

×印が表示されているときというのは、


インターネットエクスプローラで見ることのできない画像が、
アップロードされているか、もしくは、タグの記述が間違っているかです。

数枚だけ見えないということですので、タグの記述の間違いはないとおもいます。

もしかして、拡張子が、.bmpではないですか?
オフライン上では見えますが、オンライン上では見えません。

画像の、拡張子を、.gifか、.jpegで保存しなおして、アップロードしてみてください。
.bmpの拡張子名だけを変更しても、.bmpから、.gifなどには、変更できません。
その場合は、窓の杜などへ行って、拡張子変換ソフトを導入する必要があります。

この回答への補足

アドバイス有難うございます。
確認してみたのですが、拡張子は「.jpg」となっていましたので、
それが原因ではないようです。
何か他に思い当たることがありましたら教えてください…。

補足日時:2001/06/17 18:44
    • good
    • 0

Front-Pageで拡張子 JPG とjpg ローカルでは正常動作しますが


アップすると全滅します。大文字小文字チェックお奨めします。
フロントページのフォルダービューでなく、Windowsからフォルダのぞくと
違う表示らなっていたりします。 爆
マクロメディアやアドビのHTMLエディターではこんなアホバグはないようです。笑

この回答への補足

アドバイスありがとうございます。
確認してみたのですが、拡張子全て小文字で表記していました。

また、色々な画像で試してみたのですが、同じソースなのに
画像によっては映るものと映らないものがあるようです。
でも、映る画像と映らない画像の違いが何処にあるのかは分かりません。
何か心当たりがありましたらアドバイスいただければと思います。

補足日時:2001/06/14 22:23
    • good
    • 0
この回答へのお礼

今回の最大の原因では無かったのですが、
途中で何回か映らない事があったときに、このアドバイスのおかげで
大文字と小文字の違いのせいだったことに気付きました。有難うございました!

お礼日時:2001/07/02 09:34

こんにちは。

私も、zenra さんみたいな経験をしたんですけど、ちょっと原因が違ったので一応回答しちゃいます。

私の時は、ファイル名に Fujisan.jpg とやって、記述するときに、fujisan.jpg とやっちゃいました。

Windowsの器械の中にあるときは試しに見るとちゃんと出ちゃうんだけど、アップするとダメになります。

ファイル名はちゃんと大文字小文字を使い分けるか、間違わないように小文字だけにするとかした方がいいみたいです。

この回答への補足

アドバイスありがとうございます。
確認してみたのですが、編集の時もアップしたときも、
全てアルファベットの小文字で表記してました。
何故なんでしょうか…(泣

補足日時:2001/06/14 22:21
    • good
    • 0

画像のファイル名を日本語で書いていませんか。


例えば「富士山.jpg」などとしていませんか。

私も経験しましたが、「fujisan.jpg」にしたら表示できました。

この回答への補足

アドバイスありがとうございます。
ファイル名は小文字のアルファベットで書いていますので、
何か別に原因があるのではないかと思います、解明に向けて努力を続けます…

補足日時:2001/06/14 22:17
    • good
    • 0

サーバーにアップされていないだけではないでしょうか?


もしくは、名前が間違っているとか?

この回答への補足

アドバイスありがとうございます。
「サーバーにアップされていない」というのは、どういう状態なのでしょうか??
一応転送は済んでいるようですし、
画像以外の部分はネット上で見ることができるのですが…
(初心者なもので、的外れな事言ってたら指摘してもらえると助かります(汗))
名前は違っていないと思います。何度も確認しましたので…

補足日時:2001/06/14 22:12
    • good
    • 0

 houkiさんはどのような方法でデータをアップロードしていますか? FTPとか?もしかしたら、アップロードの時に、画像データファイルの拡張子が変わってしまっている可能性があります。

といっても小文字が大文字に、ってとこなんですけど、たくさんUPすると時々出る症状です。
 そうなると、HTMLで書いたソースの拡張子と不整合(表示してくれることも多いのですが)となってネットで見た時に表示されません。
 転送後にアップロードしたフォルダ内での拡張子の表示を確認してみて下さいね。

この回答への補足

アドバイスありがとうございます。アップロードはFTPで行っていますが、
確認してみたところ、アップロードした後でも拡張子は変わっていませんでした。
何か別の原因があるのでしょうか。
他にも何かお気づきの点がありましたら、お知らせ下さると助かります(TT

補足日時:2001/06/14 22:09
    • good
    • 0

お探しのQ&Aが見つからない時は、教えて!gooで質問しましょう!

このQ&Aと関連する良く見られている質問

Q■□windowの×□-が表示されない

Win98ユーザーです。

先日、突然PCを立ち上げたところ、ウィンドウ枠右上に通常であれば、綴じる(×ボタン)、最大化(□)、最小化(-)ボタンが文字化けしたように表示されていて困っています。

その他、チェックボックスについても「入」のような変な記号になって困っています。

これだけであれば、まだ我慢できるのですが、今日、フォントもずいぶん減っていることに気付きました(上記が原因かは不明ですが・・・)
行書体などもすべてゴシックでしか表示されません。

再起動しても同様の状況です。
解決方法、至急教えてください。

よろしくお願いいたします。

Aベストアンサー

非常によくある9x系OSの仕様の問題です。
参考URLの手順に従って対処してください。

参考URL:http://homepage2.nifty.com/winfaq/fontstrouble.html

QMozilla Firefox で画像がみれない。

パソコンが一時期調子が悪かったために、リカバリーしました。
するともっとパソコンがわるくなり、インターネットで見れないページが出て来たりしました、なのでMozilla Firefox をダウンロードしていま使っていますが、
ページ自体は開くのですが、画像が見れない事が多くあります。
普通なら画像や動画が表示されるのに、
(ここをクリックするとプラグインをダウンロードします)とでます。
なのでここをクリックしてダウンロードすると、逆にパソコンがおかしくなり、インターネット自体が開けなくなります。
クリックすると不正なので強制終了しますと表示がでて、かってに閉じてしまいます。
これはどういう事なんでしょうか?
どうしたらいいのですか?

Aベストアンサー

補足になりますが。
FirefoxでFlash playerを入れて試してみるのもいいと思います。
詳しくは下記で説明して下さっています。

ただ気になるのがリカバリー後さらに調子が悪くなったという点です。これはリカバリーによって自分で入れたソフトやOSの更新が消えてしまったからという可能性が考えられます。リカバリーはPCを出荷状態に戻す(その後の更新は反映されない)のであって調子が悪くなったと感じる直前の状態に戻すのではないからです。解決方法としてはまずはOSの更新(まだサポートしていたかは定かではないのですが)、その後記憶を辿って自分の入れたソフトを入れるしかありません。まずはOSの更新からすることをお勧めします。
ただこれは可能性があるということであって、悪くなったというのがブラウザ関連のこと以外(その他の動きも遅くなった等)にも起こるのであれば、リカバリー前に調子が悪くなった点も考慮して、やはり物理的損傷の可能性が高いと思います。

参考URL:http://oshiete1.goo.ne.jp/qa3071396.html

QWIN98■JPEG,GIFなどのアイコンが表示されない

すべてWINマークのアイコンになっていました。
しかし先程ココでこの内容のものを検索したら
マイコンピューター→フォルダオプ→ファイルの種類で変更できるとのことだったのでやってみたら、全部eアイコンになってしまいました。間違えてしまいました・・・・
どうやったらJPEG等のアイコンに戻せるのでしょうか。
宜しくお願い致します!!

Aベストアンサー

アイコンのキャッシュが破損したのかもしれません
参考URLの方法を試してください。

Qテキスト文書に記述したタグを、HPビルダーではなく,IEで開く方法は?

テキスト文書に記述したタグを、HPビルダーではなく、IEで開く方法を教えてください。

Aベストアンサー

質問の内容が簡潔なのでhikarika1さんの聞きたいことが読みとりにくいのですが、拡張子を変えたいだけなのであれば、一般的な拡張子の変え方を書かせてもらいます。
もし拡張子が表示されてる状態であれば(5)からしてください。
(1)適当なフォルダ(デスクトップのマイドキュメント)を開きます。

(2)ウィンドウ上部の[表示(V)]もしくは[ツール(O)]→[フォルダオプション(O)]を選択(クリック)

(3)出てきたウィンドウの[表示]タブを選択…
詳細設定の囲みの中にある
□「登録されているファイルの拡張子は表示しない」
のチェックをはずして[OK]

(4)その後HTMLで書いたテキストファイル名が
ファイル名.txtと表示されてます。

(5)ファイルを右クリックして「名前の変更(N)」を選択

(6)テキストファイルの名前を
ファイル名.htmまたはファイル名.html
にしてEnter

(7)「名前の変更」
拡張子を変更すると、ファイルが使えなくなる可能性があります。
変更しますか?

と、確認のメッセージが出てくるので「はい」を選択
アイコンがIEのアイコンそっくりなものに変わるはずです。以上で完了です。
追記ですが拡張子変更後のHTMLファイルの編集方法も…
スタート→設定→コントロールパネル→インターネットオプション→[プログラム]タブに「HTMLエディエタ」
がありますが、
そこが空欄であれば[▼]をクリックすると「Notepad」と書かれてますのでそちらを選択→[OK]
HTMLに拡張子を変えられたアイコンを右クリックすると「開く」の下に「編集」が出てきます。
編集で開くとテキスト形式で開かれるのでいちいち拡張子を変えなくても編集できます。
もしくはIEで開いた窓内で右クリック→[ソースの表示]でも、同じことができます。

質問の内容が簡潔なのでhikarika1さんの聞きたいことが読みとりにくいのですが、拡張子を変えたいだけなのであれば、一般的な拡張子の変え方を書かせてもらいます。
もし拡張子が表示されてる状態であれば(5)からしてください。
(1)適当なフォルダ(デスクトップのマイドキュメント)を開きます。

(2)ウィンドウ上部の[表示(V)]もしくは[ツール(O)]→[フォルダオプション(O)]を選択(クリック)

(3)出てきたウィンドウの[表示]タブを選択…
詳細設定の囲みの中にある
□「登録...続きを読む

Qタクスバ゛ーに表示されていたスピーカーが表示されなくなった

タイトル通りの質問ですが、スピーカーが表示されなくなりました。アクセサリーのエンターテーメントの
中にも有りません 削除した覚えはありません
どこかに有ると思いますが、操作がわかりません
色々有ると思いますがよろしくお願いします。

Aベストアンサー

スタートからファイル名を指定して実行で『Systray.exe』を実行すれば、表示されると思います。
場所は、『C:\WINDOWS\SYSTEM』にあります。

スタートからファイル名を指定して実行で『msconfig』と入力してタブのスタートアップで『Systray』にチェックをいれれば、起動時に表示されるとおもいます。


このカテゴリの人気Q&Aランキング

おすすめ情報