僕はeclipse3.2を使っています。
Scannerクラスを使うためにjava.util.*をインポートしたのですが、
java.utilにScannerがみつからないというエラーが出たのですが、どうしたらいいのでしょうか?

A 回答 (3件)

>僕はeclipse3.2を使っています。



Eclipseで使用しているJavaVMは問題ないですか?
もしかしたらjdk1.4の方を使っているかもしれません。
詳しくは参考URLをどうぞ。
Eclipseのバージョンは3.1ですが、設定の所は一緒のはずです。

参考URL:http://www.02.246.ne.jp/~torutk/swetools/eclipse …
    • good
    • 0

>そこでJDK1.5をインストールしたのですが解決されません。


環境変数CLASSPATHが1.4のまんまとか?
    • good
    • 0
この回答へのお礼

新しいプロジェクトを立ち上げるときにjreの設定項目があったのでそこでjre1.5に変更することができました。
ありがとうございました。

お礼日時:2007/04/19 01:42

JDK1.4以前を使ってないですか?


java.util.Scannerは、1.5からのものらしいです。
    • good
    • 0
この回答へのお礼

ありがとうございます。
そこでJDK1.5をインストールしたのですが解決されません。
JDK1.5はC:\Program Files\Javaにあり
eclipseのディレクトリとjdk1.4のディレクトリがC:におかれているのですが、これが問題なのでしょうか?

お礼日時:2007/04/17 07:29

お探しのQ&Aが見つからない時は、教えて!gooで質問しましょう!

今、見られている記事はコレ!

おしトピ編集部からのゆる~い質問を出題中

お題をもっとみる


このカテゴリの人気Q&Aランキング

おすすめ情報

カテゴリ