人に聞けない痔の悩み、これでスッキリ >>

MT3.2からMT4.01へアップグレードしたいのですが、
ここ(http://www.movabletype.jp/documentation/upgrade/)の手順をを参考に進めたところ、mt.cgiへアクセスすると下記のエラーが出てしまいます。
------------------------------------------------------------------------------------------------------
エラーが発生しました。
Can't connect to data source , no database driver specified and DBI_DSN env var not set at
************/mt/extlib/Data/ObjectDriver/Driver/DBI.pm line 54 at
************/mt/extlib/Data/ObjectDriver/Driver/BaseCache.pm line 234
------------------------------------------------------------------------------------------------------
************はサーバーのパスです。
ちなみに旧サイトではMySQLなどのデータベースは使用していませんでした。

よろしくお願いいたします。

このQ&Aに関連する最新のQ&A

A 回答 (1件)

データベースの動作環境


http://www.movabletype.jp/documentation/system_r …

MySQL 4.0 以降
PostgreSQL 8 以降
SQLite
以上のいずれかが必要ですが、お使いのサーバーはこの要件を満たしていますか?

>MySQLなどのデータベースは使用していませんでした

もしBerkeley DBをお使いだったのでしたらMT4ではBerkeley DBをサポートしてないようなので、アップグレードの前にBerkeley DBからいずれかのSQLデータベースへ移行しておく必要があるのでは。

http://www.movabletype.jp/documentation/changing …
http://code.as-is.net/public/wiki/MT_Database_Co …
こちらのコンバーターいいみたいです。参考までに。
    • good
    • 0
この回答へのお礼

回答ありがとうございます。無事解決いたしました。

お礼日時:2007/10/12 13:01

お探しのQ&Aが見つからない時は、教えて!gooで質問しましょう!


人気Q&Aランキング