タイトルの通りNT4.0WSと98間でTCP/IPのみでのLAN接続をしたいのですが
どうも上手くいきません。どなたか解決法教えてください!!

http://plaza6.mbn.or.jp/~veribest/hide/TCPIP.html

ここのページを参考にして 書かれている通りにやってみた
のですが何が間違ってるのかが皆目見当つかない状態です。

A 回答 (8件)

また、くまです。


今度は、判らないのでflipperさんと同じ環境を作りました。(^^;

WinNT(ws)SP6+Win98se です。

1.WinNTで、新しくNICのドライバーを追加していれば、再度SP6を当てる必要があります。つまり、ドライバーの変更追加->SP6と当てておくことです。バグ修正の効果があるとか。

2.WinNT側に問題ありと見ました。独断ですが(^^;;
まず確認個所から、ネットワークコンピュータのアイコンで右クリック->プロパティ
[識別タブ]
コンピューター名:A
ワークグループ:C

[サービス]
NetBiosインターフェイス
RPC構成
コンピューターブラウザ
サーバー
ワークステーション

この5点

[プロトコル]
TCP/IPプロトコル

[アダプター]
SIS900PCIFastEtherAdapter<-私の場合

[バインド]
+NetBiosインターフェイス
+サーバー
+ワークステーション

+の中身はWinsになっている

それで、host,lmhostsの定義はNTとWin98共不用です。

これで、私の場合は通信できます。
    • good
    • 0
この回答へのお礼

わざわざ同じ環境まで作って検証していただいて本当にありがとうございます。
おかげさまでやっと繋がるようになりました(^^)

SP6をあてなおしたらあっさりと繋がるようになりました。
道理でどこをどういじっても繋がらない訳だ(^^;
しかし今回のことでネットワークの勉強になりました。

IE5.5入れてたのでSP6あて直すのにもだいぶ悩みましたが(笑

くまさんkazuya-iさん 本当にありがとうございました。

お礼日時:2001/07/13 02:25

補足見ました。


私の説明不足と一括しての確認をすれば早く解決できるのですが、分割したようなアドバイスと回答で申し訳ありません。
では、
1.それぞれ、NTとWin98の自分のアドレスでpingで通信できるようになっているとのことなので、ケーブルは問題ないですかね?PC同士つなぐのであれば、クロスをハブ経由ならストレートを利用していると思いますが・・。

2.相手のPCに向けて、大量のpingを送るようにしてください。
出し方は、ping□192.168.1.10□-t(□は空白を意味します)
止める時は、ctrl+cで停止できます。
それで、まずハブに付いている通信ランプが規則正しく点滅すると思います。さらに、送信・受信のNICの通信ランプも点滅していますか?
点滅しているのであれば、やはり定義に問題あり、点滅しないのであれば通信系統に問題ありです。どうですか??

この回答への補足

本当に手取り足取りでご迷惑かけます。

1 現在ピアtoピアで接続しています。クロスケーブル使用してます。

2 ping 192.168.1.10 -t
これをやるとNT側も98側のNICのランプも定期的に点滅します。


ということは定義の問題ということですね?

補足日時:2001/07/12 01:09
    • good
    • 0

再度確認致しますが、定義は下記のようになっていて通信できないのですね??



WinNTのLmhosts(winnt\system32\drivers\etc\Lmhosts )
#End of file
192.168.1.11 B

Win98のlmhosts(win98\system\Lmhosts )
#End of file
192.168.1.10 A

大概、これでうまくいくはずですが??

この回答への補足

はい。

127.0.0.1 localhost
192.168.1.10 A
192.168.1.11 B

この内容でNTと98に入ってます。

くまさんの書かれたように 相手側PCのIP マシン名
だけ書いたものも入れてみたのですが駄目でした。

補足日時:2001/07/10 23:26
    • good
    • 0

問題の切り分けできていますか?



ip直打ちのpingは通るのですか?
名前解決だけの問題ですか?

この回答への補足

>問題の切り分けできていますか?

何が何の役割を果たしてるのかまだ完全に理解してないです(^^;

>ip直打ちのpingは通るのですか?
>名前解決だけの問題ですか?

pingは通らないままです。
うぅん・・・

補足日時:2001/07/09 23:03
    • good
    • 0

くまです。

確認です。
>Lmhosts.samにも同じように修正は加えてあるんです
単にsamファイルを修正されているのであればだめですよ。
samを取ったファイルを新規に作らないと!

この回答への補足

.samっていうのはサンプルファイルのことなんですよね?
現在 Winnt\system32\drivers\etc の中に
Hosts
lmhosts
Lmhosts.sam
と3つのファイルがあり、lmhostsはLmhosts.samを
コマンドプロンプトで拡張子を抜いて保存したものです。

以前書いた他にもかなりの数のLANについて説明されてるHPを
参照したのですが、他に設定しなければならないところも見当たらないし
何か根本的な間違いを犯してるのかOSのインストールをミスってるか・・・

もう一度 一から設定し直してみます

補足日時:2001/07/08 23:53
    • good
    • 0

まず。

NIC(ネットワークカード)にどのIPが設定されているか
確認してください

win9xは winipcfg
win nt/2000 はコマンドライン(DOS窓っていうのかな)で ipconfig

を実行してみてください。

ソフトウエアの設定的に接続(tcp/ipレベルでお話すること)に関わるものは
サブネットマスクと名前解決のための手段(例えばhostsなど)のみです

NICにちゃんとしたIPが設定されているのであれば
ip直うちでping を投げてみてください。

IPがちゃんと設定されてないのであれば設定を見なおしてください。
ip直うちのみでpingが届く場合は名前解決の手段を見なおしましょう。

この回答への補足

回答ありがとうございます。
NICに設定してあるIPも どうやら間違えてはいないようなんです。
くまさんにも指摘されたhosts関連がどうも怪しいような気がするので
もっと調べてみます。

補足日時:2001/07/08 00:23
    • good
    • 0

くまです。


>WINSアドレス LMHOSTS参照を行うにチェック
Winsサーバーが無い場合の記述ですが、 HOSTS同様に
winnt\system32\drivers\etc\Lmhosts
も修正しファイル作成されたのでしょうか?

たぶん、拡張子samファイルがありますので、MS-DOSプロンプトからeditして、ソース最後にIPアドレスとPC名を記述し、新規ファイルを作成、拡張子をはずし保存してみてください。

この回答への補足

早速ありがとうございます。
Lmhosts.samにも同じように修正は加えてあるんです。
コマンドプロンプトから修正したものでやってみましたが
やはり繋がりません。

補足日時:2001/07/08 00:19
    • good
    • 0

解答者となっていますが質問者のflipperです。


補足が入りきらなかったのでここに書き込みます。
見辛くて申し訳ありません。

構成は以下のようになってます。

NT側
WINDOWS NT4.0WS SP6
プロトコルはTCP/IPのみ
コンピューター名 A
ワークグループ C
IPアドレス 192.168.1.10
サブネットマスク 255.255.255.0
DNS ホスト名 A 他は未入力
WINSアドレス LMHOSTS参照を行うにチェック
winnt\system32\drivers\etc\Hosts の内容は
127.0.0.1 localhost
192.168.1.10 A
192.168.1.11 B
全てのコンボボックスでアダプタは確認されてます。
バインド
NetBIOSインターフェイス
サーバー
リモートアクセスサーバー
ワークステーション
これら全てに
WINSクライアント(TCP/IP)
NIC
リモートアクセスWANラッパー

98側
WINDOWS98SE
プロトコルはTCP/IPのみ
コンピューター名 B
ワークグループ C

ネットワークコンポーネントには
Microsoftネットワーククライアント
LAN Card
ダイヤルアップアダプタ
TCP/IP->LAN Card
TCP/IP->ダイヤルアップアダプタ
Microsoftネットワーク共有サービス

IPアドレス 192.168.1.11
サブネットマスク 255.255.255.0
DNSを使わない
WINSの解決をしない
NetBIOSはTCP/IP上でNetBIOSを使用可能にする のチェックがグレー表示
全てのコンボボックスでアダプタは確認されてます。
バインド
Microsoftネットワーククライアント
Microsoftネットワーク共有サービス
両方にチェックが入っています。
アクセスの制御は共有レベルでアクセスを制御

98はNTと同じアドミニストレータでNTと
同じパスワードでログオンします。
この状態で双方共にネットワークコンピューターで
お互いが見えません。pingも通りません。
NTと98にNetBEUIを入れると何の問題も無くお互いの
ドライブが操作できるようになるのですが・・・
    • good
    • 0

このQ&Aに関連する最新のQ&A

お探しのQ&Aが見つからない時は、教えて!gooで質問しましょう!


このカテゴリの人気Q&Aランキング

おすすめ情報

カテゴリ