自分のお店を開く時の心構えとは? >>

先日、社命でセミナーに参加して簡単なandroidアプリの作り方を教わりました。

会社でeclipseを使ってプログラムを作り、エミュレーターで確認しようとすると、

AVD 'AVD_for_Xperia' のエミュレーターを開始中
PANIC: Could not open: AVD_for_Xperia

というエラーメッセージが出て立ち上がりません。

また実行してもタブレットを認識してくれません。

解決方法を教えて下さい。

ソースコードはセミナーで教わったものを入力していて、エラーは出ていません。

Win7、32ビットマシン。
Java JDKはjdk-6u45-windows-i586.exeをインストール。
eclipseはpleiades-e4.3-ultimate-32bit-jre_20130626(Ultimate)をインストール。
AndroidSDKは、installer_r22.3-windows.exe をインストール。
ADTはeclipseのヘルプで「新規ソフトウエアのインストール」でインストール。
AndroidSDK(API)は「Tools」「Android4.4」「Extras」にチェックを入れインストール。

タブレットは
SONY XPERIA-Z SGP312JP/W。
Androidバージョン4.2.2。
PCにはSONYのサイトからドライバーをダウンロード済み。

JAVAは30時間程度で、eclipseも初めてです。
セミナーではeclipse4.2を使っていました。
最初は4.2をインストールしましたが、日本語化が上手くいかなかったので、日本語化されているパッケージをインストールしました。

IT関連の会社ではないので分かる同僚もおらず、何の知識もないままセミナーに参加している全くの初心者です。

よろしくお願いいたします。

このQ&Aに関連する最新のQ&A

A 回答 (1件)

こんばんわ。



エラーメッセージの後に、以下のようにAVDのフォルダパスが出ていませんか。

PANIC: Could not open: C:\Users\xxx\.android/avd/xxx.ini

上記の場合、AVDフォルダにアクセスできずエラーとなっているので、
環境変数にSDK_HOMEなる変数を設定しAVDフォルダへパスを通してください。
詳しいやり方は、参考URLを参照ください。

環境構築系のエラーはハマるととんでもなく時間をくうので、
すぐに解決されることを願っています。
頑張ってください!

参考URL:http://digital4johnny.blog.fc2.com/blog-entry-11 …
    • good
    • 0
この回答へのお礼

早々のアドバイスありがとうございます。

エラーメッセージは異なりますが、原因はPATHのようでした。

全てを入れなおしてeclipseのフォルダを「C]の直下に置いて設定したら何とか動くようになり、タブレットにもインストールできました。

ありがとうございました。

お礼日時:2013/11/14 16:07

このQ&Aに関連する人気のQ&A

お探しのQ&Aが見つからない時は、教えて!gooで質問しましょう!


人気Q&Aランキング