今なら家電が全品9%OFF!

CCNA取得勉強の為に教えてgoo!の過去の質問を見ていたときに疑問が発生しました。
分かる方がいらっしゃいましたら教えてください。

http://oshiete1.goo.ne.jp/kotaeru.php3?q=1199795

疑問が発生したのは↑の質問なのですが、

Catalyst2950に、インターフェースに対してIPアドレスを割り当てることができるのですか?

自分の認識だと、
・Catalyst2950はL2SWなので、データリンク層の機器であるため、インターフェースに対しIPアドレスは振れない
・但し、TELNETでアクセスしたり、snmpTRAPをあげるため、(管理的な意味で)管理VLAN(デフォルトでは1)に対し、IPアドレスを割り当てることが出来る。

なのですが。もしこの認識が間違っていた場合、インターフェースにIPアドレスを割り当てる方法をご教示いただきたいです。
よろしくお願いします。

このQ&Aに関連する最新のQ&A

A 回答 (4件)

ネットワークエンジニアをしております。



>Catalyst2950に、インターフェースに対してIPアドレスを割り当てる
>ことができるのですか?

言葉の問題になってしまいますよね。インターフェースという言葉は、「その対象に出入りするための口」という意味なので、使い方やその人の認識に依存する話だと思います。。。

「インターフェースに割り当てることができるか」ということであれば
可能でしょう。要は「どういうインタフェースを意味しているのか」というのが問題です。

No.3さんが回答されている通り、Catalyst2950のスイッチポート(物理インタフェース)にはMACアドレスは振られますが、IPアドレスは振れません。

スイッチの「管理VLAN」は「論理インタフェース」です。これにはIPアドレスを振ることができます。
このVLANに振るIPアドレスは、スイッチ装置自身を特定するアドレスだと思ってよいと思います。(PCに振るIPアドレスと同様です)

理解されていると思いますが
紹介されているURLでは、telnetでCatalyst2950にアクセスする方法を聞かれているものだと思いますが、
telnet経由でCatalyst2950スイッチにアクセスするためには、スイッチポートを管理VLANと同じVLANに所属させておけば、スイッチポート経由でスイッチにアクセスできます。

スイッチポートで認識するPDU(プロトコルデータユニット)はフレームであり、そのアドレスはMACアドレスなど(メディアに依存)です。そのフレーム中にカプセル化されているパケットの(使うプロトコルがIPであれば)IPアドレスやそのほかのデータはフレーム中にカプセル化されていて、スイッチポートでは認識されません。
スイッチポートでフレームのMACアドレス(タグVLANを使用していればVLAN他)などが認識されて、スイッチポートからスイッチ内部に入ることを許可されればカプセル化がはずされ(フレームヘッダがはずされ)、パケット(IPアドレス等)が検査されることになります。
    • good
    • 0
この回答へのお礼

お礼が遅くなり申し訳ありません。

確かに、「インターフェース」という言葉がどういう意味を意図しているか、相手にしっかりと伝えないといけませんね。今後気をつけていこうと思います。

>telnet経由でCatalyst2950スイッチにアクセスするためには、スイッチポートを管理VLANと同じVLANに所属させておけば、スイッチポート経由でスイッチにアクセスできます。

これは逆に言えば、「管理VLAN」に所属していないスイッチポートに接続されている端末からは、直接telnet経由でアクセスできないということですよね。(設定にもよるでしょうけど、ルータを介する形になるのでしょうか)

これからも精進していこうと思います。ありがとうございました。

お礼日時:2006/09/04 00:07

>・Catalyst2950はL2SWなので、データリンク層の機器であるため、インターフェースに対しIPアドレスは振れない



お考えの通り、Cat2950はL2SWなので物理インターフェースに対してIPアドレスを割り当てることはできません(ルーティングできないですからねL2SWは)。L2SWの物理インターフェースはあくまでもスイッチポートです。スイッチングHUBのポートの扱いと同じです。スイッチの物理インターフェースにIPアドレスが割り当てることができるのは、L3SW以上のスイッチになります。

>・但し、TELNETでアクセスしたり、snmpTRAPをあげるため、(管理的な意味で)管理VLAN(デフォルトでは1)に対し、IPアドレスを割り当てることが出来る。

L2SWに割り当てることができるのは論理インターフェースであるVLANインターフェースに対してです。VLANに対して割り当てたIPアドレスは、Telnet用、管理用などに使います。ちなみにデフォルトVLANであるVLAN1だけではなく新たに作成したVLANにも同様にIPアドレスを割り当てることは可能です。

OSI参照プロトコルをしっかり勉強して、各層の役割、実機がどの層に属しているものであるかを理解することが大事です。CCNA取得がんばってください。
    • good
    • 0
この回答へのお礼

お礼が遅くなりすみませんでした。(出張しておりました)

丁寧な解説で大変参考になりました。
>CCNA取得がんばってください。

ありがとうございます。1発で受かるようがんばります。

お礼日時:2006/09/04 00:01

Catalystは、リモートアクセスでポートの状況の管理ができます


そのためのアクセス用です
L2スイッチとしてのインターフェースにIPアドレスを設定するのとは意味が違うと思います

この回答への補足

>Catalystは、リモートアクセスでポートの状況の管理ができます
>そのためのアクセス用です

つまり、管理用IPのことですよね?

>L2スイッチとしてのインターフェースにIPアドレスを設定するのとは意味が違うと思います

こちらがあまりよく分からないのですが、Catalystの物理インターフェースにIPアドレスを設定することができるのでしょうか?

補足日時:2006/08/24 10:56
    • good
    • 0

すまんですカタリスト2950に付いては存じませんが



L2SWであってもインテリジェントだとIP振れます。
またL2SWのように動作するもしくはブリッジのように
動作するセグメント・ルータなんてものもあります

この回答への補足

VLANにではなく(複数)インターフェースに対し、IPを振れるということでしょうか?

補足日時:2006/08/24 10:54
    • good
    • 0

このQ&Aに関連する人気のQ&A

お探しのQ&Aが見つからない時は、教えて!gooで質問しましょう!

このQ&Aを見た人はこんなQ&Aも見ています

このQ&Aを見た人が検索しているワード

このQ&Aと関連する良く見られている質問

QL2SWのVLANに割り当てるIPアドレスについて

L2SWに複数のVLANを割り当てる場合、それぞれのVLANのインタフェースに、必ず一つはIPアドレスを付与するべきなのでしょうか?

また、VLANが複数のスイッチにまたがる場合、そのVLANのインタフェースとして付与したIPアドレスは、複数のスイッチで同じIPアドレスにするのでしょうか?それとも、同じネットワークだけれど、違うIPアドレスを付与するのでしょうか?

Aベストアンサー

> L2SWに複数のVLANを割り当てる場合、それぞれのVLANのインタフェースに、必ず一つはIPアドレスを付与するべきなのでしょうか?

L3SWならまだしも、L2SWでVLANごとにIPアドレスが振れるような機種はいまだに見たことがありません
通常のL2SWであれば、どれか1つのVLANに対し1つだけIPアドレスが振れます
これは基本的に管理用(TELNET/SSH/HTTPで遠隔から設定を行ったり、SNMPで通信するためのもの)として振るものです
ですので、すべき、というよりできないというのが答えだと思いますが、万が一複数のIPアドレスを振れるL2SWがあったらぜひ教えて下さい

> VLANが複数のスイッチにまたがる場合、そのVLANのインタフェースとして付与したIPアドレスは、複数のスイッチで同じIPアドレスにするのでしょうか?それとも、同じネットワークだけれど、違うIPアドレスを付与するのでしょうか?

例えば複数のL2SWを接続し、管理用のVLANだけにIPアドレスを振っていった場合は違うIPアドレスを振る必要があります

> L2SWに複数のVLANを割り当てる場合、それぞれのVLANのインタフェースに、必ず一つはIPアドレスを付与するべきなのでしょうか?

L3SWならまだしも、L2SWでVLANごとにIPアドレスが振れるような機種はいまだに見たことがありません
通常のL2SWであれば、どれか1つのVLANに対し1つだけIPアドレスが振れます
これは基本的に管理用(TELNET/SSH/HTTPで遠隔から設定を行ったり、SNMPで通信するためのもの)として振るものです
ですので、すべき、というよりできないというのが答えだと思いますが、万が一複数のIPア...続きを読む

QL2スイッチからpingを打つ時について。

L2スイッチからpingを打つ時について。

VLANが設定できるL2スイッチであれば、ポートによって所属しているネットワークが異なる場合があると思うのですが、pingを打つ際、ping元のIPアドレスおよび送出されるネットワークは、管理IPアドレスと管理VLANから、になるのでしょうか?
(たとえば、↓はL2スイッチだと思いますが、このような場合、どのような動作をするのでしょう)

http://www.alaxala.com/jp/techinfo/archive/manual/AX2400S/HTML/11_4/COMMINDX/INDEX.HTM

Aベストアンサー

通常、L2SWに付与できるIPアドレスは1つ、そのIPアドレスをくくりつけられるVLANは1つです
ですので、

> pingを打つ際、ping元のIPアドレスおよび送出されるネットワークは、管理IPアドレスと管理VLANから、になるのでしょうか?

ということになります

QL3スイッチとL2スイッチのVLANについて

以下、L3スイッチとL2スイッチのVLANについてご存知の方、教えてください。

少し長文ですが、困っているのでよろしくお願いします。

質問の部分は☆印のところです。

L3スイッチ(Catalyst3560)にVLANを3つ作成し、各VLAN間通信を許可する。
・VLAN1:192.168.10.0/24 (1port~8portを使用)
・VLAN2:192.168.20.0/24 (9port~16portを使用)
・VLAN3:192.168.30.0/24 (17port~24portを使用)

L2スイッチ(Catalyst2960)にVLANを3つ作成し、各VLANの1ポートは、L3のVLANに接続する。
・VLAN1:1port~8portを使用 →L3の1ポート目に接続
・VLAN2:9port~16portを使用 →L3の9ポート目に接続
・VLAN3:17port~24portを使用 →L3の17ポート目に接続

ネットワークアドレスが異なる各PC群を、L2に接続し、全PC間通信を可能とする。
→最終目標


質問の背景としては、もともとPCをL3に直接接続して、全PC間の通信を行う予定が、
PCが激増し、L2を介して通信することとなりました。
実際、L2スイッチは48ポートです。
L3スイッチに対する、VLANの設定、VLAN間通信の設定はできています。

質問事項
☆L3スイッチの設定
おそらく、現在のVLANの設定はポートVLANだと思われます。
L2スイッチとVLAN間同士で通信する場合、タグVLANという考え方が必要になるのでしょうか。

この構成におけるL3スイッチに必要な設定を教えてください。

現在行っている設定は、以下のサイトを参考に設定しました。
http://www.infraexpert.com/study/vlan1.1.htm

☆L2スイッチ
VLANを作成するにあたって、L3スイッチとVLAN-IDやVLAN-NAMEを合わせる必要があるのでしょうか。
また、L2スイッチにはIPアドレスを1つしか設定できないという認識で、且つL2スイッチにIPアドレスの
設定は不要という認識です。

この構成の場合、特にIPアドレスの設定は必要ないでしょうか。

以下、L3スイッチとL2スイッチのVLANについてご存知の方、教えてください。

少し長文ですが、困っているのでよろしくお願いします。

質問の部分は☆印のところです。

L3スイッチ(Catalyst3560)にVLANを3つ作成し、各VLAN間通信を許可する。
・VLAN1:192.168.10.0/24 (1port~8portを使用)
・VLAN2:192.168.20.0/24 (9port~16portを使用)
・VLAN3:192.168.30.0/24 (17port~24portを使用)

L2スイッチ(Catalyst2960)にVLANを3つ作成し、各VLANの1ポートは、L3のVLANに接続する。
・VLAN1:1port~8portを使用 →L3...続きを読む

Aベストアンサー

とりあえずコマンドだけ書くと

※L2とL3共通

interface range fa 0/1 - 8
switchport mode access
switchport access vlan 1

interface range fa 0/9 - 16
switchport mode access
switchport access vlan 2

interface range fa 0/17 - 23
switchport mode access
switchport access vlan 3

interface fa 0/24
switchport mode trunk
switchport trunk encapsulation dot1q

でお互いのfa0/24同士を接続すればタグ通信出来ます。

下の方が仰っているように、普通は冗長性を考えてchannelを使いますが、業務なのかどうかすら質問内容からは分かりかねるので、とりあえずトランク設定だけを載せておきます。

Qpingでポートの指定

pingでIPアドレスを指定して、通信できるかどうかというのは
よく使いますが、pingでポートを指定して応答するかどうかは調べられるのでしょうか?

よろしくお願いします

Aベストアンサー

pingを含むICMPというプロトコルは、OSIの7レイヤで言うところのL2(同一セグメント内通信)とL3(IPルーティングされた通信)の両方にまたがる、ちょっと珍しいプロトコルです。

IPアドレスは指定できますが、別サブネットに属するIPアドレスに到達できればL3通信、できなければゲートウェイと呼ばれる同一サブネットに属する中継装置からの回答を得るという点でL2(MAC通信ではなく、同一セグメント内通信という意味)通信です。

ポート番号はL4で使用されるアドレスですから、L4機能の疎通確認はping(を含むICMP)ではできません。

FTPの疎通確認であれば、クライアントからサーバに対するTCP/21通信(FTP-CMD)が可能であること(サーバからクライアントへのTCP/21からの応答を含む)+サーバからクライアントに対するTCP/20通信(FTP-DATA)が可能であること(クライアントからサーバへのTCP/21からの応答を含む)が必要でしょう。

監視ソフトによるものであれば、
・クライアントからサーバへのログイン(TCP/21)
・クライアントからサーバへのlsの結果(TCP/20)
で確認すればよいでしょう。

pingを含むICMPというプロトコルは、OSIの7レイヤで言うところのL2(同一セグメント内通信)とL3(IPルーティングされた通信)の両方にまたがる、ちょっと珍しいプロトコルです。

IPアドレスは指定できますが、別サブネットに属するIPアドレスに到達できればL3通信、できなければゲートウェイと呼ばれる同一サブネットに属する中継装置からの回答を得るという点でL2(MAC通信ではなく、同一セグメント内通信という意味)通信です。

ポート番号はL4で使用されるアドレスですから、L4機能の疎通確認はping(を含む...続きを読む

QSW、HUBのIPアドレスの調べ方

IPアドレスを割り当てられるSW、HUBが、
自PCと同じネットワークに存在する場合の
そのSW、HUBのIPアドレスの調べ方を教えてください。

たとえば、pingをブロードキャストで飛ばして、
arpテーブルを確認するとIPアドレスが載ってくるのでしょうか?

または、
Internet-----ルータ-------SW,HUB---------PC
という構成であるときに
Internetにtracerouteを打つとSW,HUBのIPアドレスは確認できますか?

Aベストアンサー

> たとえば、pingをブロードキャストで飛ばして、
> arpテーブルを確認するとIPアドレスが載ってくるのでしょうか?

PCと同じネットワークのIPアドレスが振られているのであれば可能性はあります
ただ、最近はブロードキャストアドレスにpingを打っても答えない機器も多いです

> Internetにtracerouteを打つとSW,HUBのIPアドレスは確認できますか?

普通のSW-HUBではTTLの減算を行わないので無理です

QVLANを構成するときは、一つのVLANに一つのネットワークアドレス?

VLANについて、勉強しています。

VLANは、一つのネットワーク(アドレス)の中でスイッチによって複数のVLANに分ける、するものだと思っていたのですが、下記のページの図1-4を見ると、一つのVLANに一つのネットワークを割り当てているのですが、実際はこういう使い方をするのでしょうか?

よろしくお願いします。

http://itpro.nikkeibp.co.jp/article/COLUMN/20060919/248444/?ST=nettech&P=2

Aベストアンサー

>一つのルータで、複数のネットワークアドレスを割り当てることが可能なのですね…。

 VLANから始まった質問なのですが、話が複雑になるのでここでは別にしておいてください。 またルータのことを理解する上では、家庭などで使われるブロードバンドルータを意識すると理解しずらくなります。
ルータは一般的にはLAN(ネットワーク)間を接続することに使われ、その中の一つにLANではなくWANがあると理解されたほうが分かりやすいです。

 1台または複数のスイッチで構成されるネットワークは、1つのネットワークアドレスを持ちます。このようなネットワークが別にもあったとすると、このネットワークをお互いに接続するにはルータを用います。(スイッチ同士を繋いでしまったら、これは大きな一つのネットワークに拡大したにすぎません) ルータはこのネトワーク間の橋渡しをする装置で、例えばルータにポートが10個備わっていれば、10個のネットワークを相互接続することができます。

 ルータの機能は、このネットワーク間の接続(ルーティング:宛先IPアドレスによって送り出す先のポートを選択する機能)を行うものです。
 ネットワーク内の通信ではスイッチだけで可能ですが、ネットワーク外への通信はルータに任せます。 PCにはデフォルトゲートウェイを指定しますが、これは異なるネットワークへの通信の場合に送出するルータのアドレスを指定するものなのです。

 インターネットは、これが極めて大きくなったものと言ってもいいでしょう。 何万ポートもある大きなルータが存在するわけではなく、ルータの先に更にルータが接続され、更にその先にもルータが・・といった風です。
 試しに、PCのコマンドプロンプトからtrcertコマンド(例えばtracert www.xxx.co.jpのように)を入力してみてください。通過したルータのアドレスが分かります。

 上記はシンプルに説明したものですが、これにVLANが絡んだり、WANがあったり、ルータにも他にいろいろな機能があったりして理解しずらくなっていますね。

>一つのルータで、複数のネットワークアドレスを割り当てることが可能なのですね…。

 VLANから始まった質問なのですが、話が複雑になるのでここでは別にしておいてください。 またルータのことを理解する上では、家庭などで使われるブロードバンドルータを意識すると理解しずらくなります。
ルータは一般的にはLAN(ネットワーク)間を接続することに使われ、その中の一つにLANではなくWANがあると理解されたほうが分かりやすいです。

 1台または複数のスイッチで構成されるネットワーク...続きを読む

Qポートの80と443

こちらのサービス(https://secure.logmein.com/)を利用すると、インターネットを見られるサーバーのポートの80と443が空いていればルータやファイアウォールに特段の設定なく外部からサーバーを操作できるそうですが、逆にサーバーのポートの80や443を空けることには何か危険性があるのでしょうか。

Aベストアンサー

ポート80は一般的なHTTP、ポート443はHTTPSです。
この2つのポートがあいていなければインターネット接続(WEBブラウジング)は出来ません。
ですから、ほとんどのファイアウォールでこのポートは開いています。(インターネット接続を制限している社内LANでは当然閉じていますが)

ちなみに、よく使うポートとしてはFTPで20、21、SMTP(送信メール)で25、受信メールPOP3で110あたりです。セキュリティポリシー上、この辺は制限される事も多いですが、HTTP 80、HTTPS(暗号化用)443は通常閉じません。


危険性?
WEBプロトコルを使ってFTP的なファイル転送(WebDAV)やVPN等も出来るようになっています。当然そこにはある種の危険はつきものですが、WEBブラウジングに伴う危険と大きく変わりません。ウィルス等に感染していればこの2つのポートだけでも相当危険でしょうね。

参考まで。

QCISCOルータのIPアドレスの確認方法。

CISCOルータ自身のIPアドレスの取得方法が知りたいです。ブラウザから設定をしたいので、IPアドレスを知りたいのですが、そういったコマンドはあるでしょうか?(初心者すぎで、トンチンカンなことを言っているかもしれません)

ターミナルソフト?で特権モードに入るまではできたのですが…。

Aベストアンサー

> すみません、常識以前の質問なのでしょうが、IPアドレス等は、CISCOルータに直接設定しなくてはならないのでしょうか?

以前の回答のように、BBルータであればWAN側をDHCPで運用みたいなことはあるでしょうけど.......
(CiscoでもCisco1812Jみたいな機種はそのような運用はありかもしれません)

基本的には各interfaceに固定でIPアドレスを振って使うのが普通です
あと、interfaceに振られたIPアドレスを確認する方法として、
show interface
(省略形はsh int)
を実行すればinterfaceに割り振られたIPアドレスも含めてinterfaceの状態も確認することができます

QCiscoのルータやスイッチにConfigを投入?

スイッチやルータにConfigを投入する作業をするというようなことを
聞きました。これはどういうことをするのでしょうか。
テキストファイルにスイッチなどの全設定をかいてこれを何かのコマンド
でロードするということでしょうか?

またNetscreenなどのCisco以外の製品にも同様のことが可能で、
そのようにして設定業務を行うことが一般的なんでしょうか?

Aベストアンサー

CiscoルータのIOSには、通常「startup-config」と「running-config」の2つの設定ファイルがあります。(実際には、vlan.datなど他にも色々とありますが、ここでは割愛。)

@network Cisco・アライド実機で学ぶ > Cisco実機で学ぶ(CCNA) > copyコマンド(設定の保存)
http://atnetwork.info/ccna/copy_command.html

まずは、ルータ起動時にどちらが最初に呼ばれて、起動後はどちらが主に利用されているのかとか、電源を落とした場合にデータが消えてしまうのと残っているのはそれぞれどちらなのかなどを確認してみてください。

参考URL:http://itpro.nikkeibp.co.jp/article/COLUMN/20080421/299651/?ST=nettech

Q1つのポートに複数のVLANを設定 cisco

シスコのSW-HUBについてお伺いします。
初心者のため、お手柔らかにお願いします。

質問内容は、1つのポートに対し、複数のVLANを設定可能か?です。
背景として、ポートに接続されるPC側で1枚のNICに対し複数のネットワークアドレスが割り振られているからです。
複数のネットワークアドレスが割り振られている理由は、アプリケーションで仮想的に2つの某管理システムを模擬しているからです。

下記2機種のうち、どちらかで設定可能か?
もしくは別の機種なら設定可能か?
その設定手順例などご教授頂ければ幸いです。

【SW-HUB】
 ・WS-C2960G-24TC-L
 ・WS-C3560V2-24TS-E


PCのOS情報とNIC枚数は下記のとおりです。

【PC】
 OS:Windows XP or 7
 NIC:1枚

以上、宜しくお願いします。

Aベストアンサー

残念ながらお使いのSWではそれはできません。
複数のVlanのパケットが流れるのは「トランクポート」という
スイッチとスイッチをつなぐポート間だけです。
PCを接続するポートは「アクセスポート」と言い、トランクポート
とは種別(用途)が異なるので、無理やりトランクポートに
PCを差しても使えません。

Ciscoだと「Catalyst 2900XL/3500XL シリーズ」がマルチVlan
に対応しています。

参考:http://www.cisco.com/cisco/web/support/JP/100/1008/1008382_3-j.html#xl


人気Q&Aランキング