最近Firefoxのメモリ使用率がおかしいです。何倍にも膨れ上がっていきます。
起動しているとどんどん上昇していき、動画サイトで動画視聴中に放置しているとプレーヤーがクラッシュしていることが多々あります。
その度にFirefoxを終了してメモリ使用率とCPU使用率を下げている状態です。(この現象時にはCPU使用率は100%になります)
設定も変更した覚えはないですし、最近入れたソフトも思い当たりません。
急にこうなりました。
こういう現象が起きる直前ではないですが、何ヶ月か前にOrbitというソフトを入れました。
そちらの設定も数ヶ月前からいじってません。(アップデートもしてません)
何か原因や解決法を知っておられる方は居ませんでしょうか。(メモリを増やす以外)

ちなみにhttp://gigazine.net/news/20060415_firefoxthunder …の方法は以前から実行してあります。

このQ&Aに関連する最新のQ&A

A 回答 (4件)

#3です。



>今日になってまたクラッシュし始めました・・・。

プロファイルを新規にされて、アドオンを入れない状態でも再発ですか・・?
XP Sp3の1GB RAMの搭載メモリーで問題ないのですが、その辺のスペックとかの環境ですかね。

ちょっと原因は分かりませんね。
    • good
    • 0
この回答へのお礼

やっぱりスペックがギリギリだからでしょうか・・・。
ご回答ありがとうございました。

お礼日時:2011/05/10 11:15

#2です。



Ver4.0で、結構な数の拡張機能を入れてますが、にこにこ(原宿)の一般会員として、動画のページに行って、個々の動画を再生をしても、クラッシュはないですね。

Flashの動画再生のプロセスとして、本体のfirefox.exeと分離されたplugin-container.exeが出現しますが、再生中はこのプロセスの占める利用率は50~60パーセントで、全体で他のものを併せて、70~90の間を上下しますが、特に、動画がかくかくしたり、フリーズやクラッシュには至りません。

拡張機能との衝突が関係ないとしたら、一度、プロファイルを新しいものを作成して、こちらを使用してテストみたらと思います。
今のプロファイルを削除することなく、切り替え起動ができますから、ブックマークも新しい方に移行することができます。
https://support.mozilla.com/ja/kb/Managing%20pro …

この回答への補足

プロファイルを新規に作成し、今までの設定やブックマークをコピーして数日はクラッシュすることは無くなったのですが、
今日になってまたクラッシュし始めました・・・。
この方法で今度こそ行けると思ったのですが・・・。

補足日時:2011/04/27 00:48
    • good
    • 0

Ver4.0ですか?


動画再生だとFlash Playerが関係していそうですが、他の拡張機能との衝突なども考えられるようです。

一度、Flashを削除して、入れなおしてみるのもよいかも知れません。
(Youtube 動画を見るときに Firefox がクラッシュする)
https://support.mozilla.com/ja/kb/Firefox%20cras …

この回答への補足

firefoxは最新版です。
その方法を試して、動画プレーヤーのサイトをタスクバーにしまって放置してみたらやはりクラッシュしてました。
因みにクラッシュしているのはニコニコ動画です。

補足日時:2011/04/20 17:43
    • good
    • 0

とりあえず、全てのアドオンを「無効化」して様子を見る。



改善したら、一つずつ「有効化」して様子を見る。
アドオンが原因ならこの方法で原因を特定できます。
原因を特定できたらそのアドオンを「無効化」しておきましょう。
バージョンアップで問題が改善されるかもしれません。

ちなみに自分の環境では350Mバイト以上掴んで離さない時があります。
(今は170Mバイトほど)

この回答への補足

ご回答ありがとうございます。
早速その方法を試してみます。

補足日時:2011/04/20 01:39
    • good
    • 0
この回答へのお礼

様子を見てみたのですが変わりませんでした。

お礼日時:2011/04/20 17:40

このQ&Aに関連する人気のQ&A

お探しのQ&Aが見つからない時は、教えて!gooで質問しましょう!

このQ&Aを見た人が検索しているワード

このQ&Aと関連する良く見られている質問

Qメモリ増設をしました。メモリ容量を確認したのですが確認方法が分りませんでした。ご存知の方教えてください。

メモリ増設をしました。メモリ容量を確認したのですが確認方法が分りませんでした。

パソコンは富士通のWINDOWSXP(FMV-BIBILO-NB50M)です。

メモリ増設をしたのは初めてです。

初めに512MBが増設されていました。

メモリを取り付けたのは1GBです。

メモリ確認画面で確認したところ次のように表示されていました。

サポート情報の文字上に物理アドレス拡張、この文字の上に1.40GHz,
1.43GB RAMと記載されていました。

私はメモリ取り付けに成功したと言えますか?

ご存知の方、ご教授おねがいします。



ご存知の方教えてください。

Aベストアンサー

スタート、マイコンピューターの順にクリックします
マイコンピューターが開きます
左側にシステムのタスクというのがあります
その中の「システム情報を表示する」をクリックします
システムのプロパティーが表示されます
その中のコンピューターという欄にCPUとメモリーが表示されます

システム情報を表示する、がないときはシステムのタスクの右にある矢印をクリックしてください
システムの情報が表示されていないときは「全般」をクリックしてください

Q最近FireFoxの文字の大きさがおかしい

環境
Windows XP SP3
FireFox3.010 

昔からFireFoxを使っているのですが
最近、文字表示がおかしいんです。

すべてのページでということではないんですが
たまに

あるページを訪問
   ↓
HPページが表示される
   ↓0.5秒ぐらい後に・・
一回り文字がデカく表示される(12px → 13、14pxぐらいに)


という具合がおきるんです。
結構おきます。

相手サイトのCSS設定(スタイルシート)の問題とは思えないんです。


で、それとは別に

Headline-Reader LiteというRSSブラウザを見るときにも
文字が異常に小さく表示されたりし始めました。

無料のRSSリーダー Headline-Reader Lite
http://www.infomaker.jp/readerlite/


教えてgoo!をHeadline-Reader Liteで見ると
むちゃくちゃ小さい文字で表示されて見えないです(汗

前はちゃんと見れたような・・気がしますが。


何かPCレベルで?文字関連の設定がおかしくしちゃったのかなぁと
思ってます。

何が原因なのか分かりません。
何か分かる方で構いませんのでアドバイスいただきたいです。

環境
Windows XP SP3
FireFox3.010 

昔からFireFoxを使っているのですが
最近、文字表示がおかしいんです。

すべてのページでということではないんですが
たまに

あるページを訪問
   ↓
HPページが表示される
   ↓0.5秒ぐらい後に・・
一回り文字がデカく表示される(12px → 13、14pxぐらいに)


という具合がおきるんです。
結構おきます。

相手サイトのCSS設定(スタイルシート)の問題とは思えないんです。


で、それとは別に

Headline-Reader LiteというRSSブラ...続きを読む

Aベストアンサー

#3です。

>FireFox2.0 → 3.0にバージョンアップされてから色んな不具合ができています

もし、バージョンアップの方法が、通常のアップデート更新でしたら、一度、プロファイルを新しい方を使用した方が良いと思います。

プロファイル内にアドオンを含め設定データなどが保存されているのですが、Ver3.0では一部の保存形式が変更になっていたりします。
http://firefox.geckodev.org/index.php?%E3%83%97%E3%83%AD%E3%83%95%E3%82%A1%E3%82%A4%E3%83%AB

アドオンの数が多いのかも知れませんが、競合するようなものはないですか?
また、テーマもデフォルトでしばらく使用した方がよいと思います。新しくPersonas For Forefoxという拡張機能で、テーマも変更できるようになっています。

アドオンはプロファイルフォルダ内にあるextensionsフォルダの中に入っていますが、それらに不具合が無ければ、新しいプロファイルないにコピーを入れたら復元します。
(参考:不具合診断チャート)
http://wiki.mozilla.gr.jp/wiki.cgi?page=chart

#3です。

>FireFox2.0 → 3.0にバージョンアップされてから色んな不具合ができています

もし、バージョンアップの方法が、通常のアップデート更新でしたら、一度、プロファイルを新しい方を使用した方が良いと思います。

プロファイル内にアドオンを含め設定データなどが保存されているのですが、Ver3.0では一部の保存形式が変更になっていたりします。
http://firefox.geckodev.org/index.php?%E3%83%97%E3%83%AD%E3%83%95%E3%82%A1%E3%82%A4%E3%83%AB

アドオンの数が多いのかも知れませんが、競...続きを読む

Qメモリの増設数値確認について

マイコンピューターのプロバティでメモリ確認をいたしますが、メーカー純正以外の他のメーカーのメモリで増設した場合に、プロバティでメモリを確認しても
増設されたメモリ数が表示されない事があるのでしょうか?教えてください。

Aベストアンサー

RZ350RRさんの回答通り、純正であろうとサードパーティ製であろうと、
メモリ容量は問題なく表示されます。
 
ノートPCの場合、スロットが細いので、目視で問題なく挿さっている
ように見えても、実際は接触が甘いケースがあります。
一般的なS.O.DIMMの場合、
1)まず斜めに挿し込み、その時点で確実に押し込む
2)メモリを寝かし、爪で固定する
特に1)が重要なのでした。

あと、メモリが対応しているかどうか(仕様、容量)もしっかり
確認してください。同じように見えて違う仕様の製品もあります。
メモリメーカーの対応情報を確認すると確実です。
http://buffalo.melcoinc.co.jp/search/pc/
http://ss.iodata.jp/Matching
 
あとは・・・メモリモジュールが不良の可能性もあります。
大半の場合正常に起動しませんが、PCが正常に起動しても
メモリとして動作していない場合、容量が増えないということは
起こりえます。

参考URL:http://buffalo.melcoinc.co.jp/search/pc/

RZ350RRさんの回答通り、純正であろうとサードパーティ製であろうと、
メモリ容量は問題なく表示されます。
 
ノートPCの場合、スロットが細いので、目視で問題なく挿さっている
ように見えても、実際は接触が甘いケースがあります。
一般的なS.O.DIMMの場合、
1)まず斜めに挿し込み、その時点で確実に押し込む
2)メモリを寝かし、爪で固定する
特に1)が重要なのでした。

あと、メモリが対応しているかどうか(仕様、容量)もしっかり
確認してください。同じように見えて違う仕様の製品もあります。...続きを読む

QFirefox3のCPU使用率

Firefox3について質問です。
先日、「さっきからやけにファンがうなってるな」とタスクマネージャのパフォーマンスを確認すると、CPU使用率が100%でした。

何がそんなに使ってるかとプロセスを見ると、Firefoxが60~80くらいでした。これでは他が少しCPUを使えば100%になるわけです。タブは20個ほどあいてる状態でした。少ないとは言いませんが、ネットを見てると50以上あけた状態でと言う記述もざらに見ますし、「特別に」多いとも思いません。また特別Youtubeなどで動画を開いているわけでもありません。


そこでタスクマネージャを常に手前に表示し、OKWaveの「今日の質問ダイジェスト版」メールから一つずつ質問ページを開いて、何個でどれくらいか実験してみました。タブが数個のうちは気にならないレベルですが、20個以上開くと常時60~80%ほど使っています。

15個 平均して30~40% たまに5・60
16個 平均40~50% たまに6・70
17個 平均60%前後 たまに7・80
20個 平均60~70% たまに8・90
「たまに」と言うのは、ウィンドウがアクティブな状態でスクロールしたりいじってると、と言う感じです。
新しくページを開く時には90%~100近くいきます。
これはファンがうなりっぱなしになるわけです。

環境は
FMV-C600 Celeron1.7GHz
メモリ 1GB
HDD 160GB
OS:Win2ksp4
です。

同じ事をOpera9.51でやると、ページを新しく開く時こそ4・50%いきますが、開いてしまえば20個以上タブを開いていても00とか02、05%、と言う感じでした。

いくらなんでもブラウザで常時60以上CPUを使われては多すぎだと思うのですが他の環境でもなるのでしょうか。
またこれはどこかを設定すれば軽減されるのでしょうか?

Firefox3について質問です。
先日、「さっきからやけにファンがうなってるな」とタスクマネージャのパフォーマンスを確認すると、CPU使用率が100%でした。

何がそんなに使ってるかとプロセスを見ると、Firefoxが60~80くらいでした。これでは他が少しCPUを使えば100%になるわけです。タブは20個ほどあいてる状態でした。少ないとは言いませんが、ネットを見てると50以上あけた状態でと言う記述もざらに見ますし、「特別に」多いとも思いません。また特別Youtubeなどで動画を開いているわけでもありません。

...続きを読む

Aベストアンサー

#2です。

じつは、私もこのfirefox3のCPU使用率が異常上昇する件をずっと調査しています。個人的には、特定の環境下で発生するfirefox3のバグではないのか?と推察しています。とくにシングルコアのCPUで発生しやすい不具合ではないかと。

例えば、質問者様のPC環境ですと、下のページを開くとCPU100%のまま下がらないのではないですか?おそらく下がらないでしょ?
(この症状が出ないPC環境もあります)
http://firefox.geckodev.org/?ChromEdit

でしたら、私はFirefox3のバグの可能性を疑ってます。

Qメモリ増設の確認が・・・

以前こちらで教えて頂いて、コミットチャージが物理メモリより多い事が判明しました。
先程、増設メモリ(1GB)が届いたのでPCにセットしました。
使用PCはSONYのVAIO、512MBのメモリです。

現在・・・
 コミットチャージ(KB)最大値 595680
 物理メモリ(KB)   合計 1562736
 カーネルメモリ(KB) 合計  117636

セットした後に気付いたのですが、以前の値をメモするのを忘れました・・・

ここで質問なのですが
 ・以前の値を確認したい場合は、今回増設したメモリを取って確認するしかないでしょうか?
 ・上記の値からして、以前のメモリを確認しなくても問題ないでしょうか?

どうぞ、よろしくお願い致します。

Aベストアンサー

面倒な計算はしたくないので・・・・・・

ちゃんとメモリの合計は1.5GBの値を示しています。

>今回増設したメモリを取って確認するしかないでしょうか?

特に不具合もないのにはずす必要はありません。
それより壊してしまう可能性のが高いです。

http://www.altech-ads.com/product/10000755.htm

瞬時にハードウェアを調べてくれるものです。

メーカーまでわかりますから、調べるならこちらでいいと思います。

QFirefoxを使っていることによってCPU使用率が100%になる

現在Firefox2を使っています。

起動するにしても再読み込みをするにしても特に異常はないのですが、
・画像等の小さいファイルをダウンロードしようとすると(ダウンロードマネージャを開くと?)やたらCPU使用率があがりカクカクになる

・ブックマークの管理を開いて、ブックマークや(ブックマーク内での)フォルダを上へ下へとドラッグするとCPU使用率があがりカクカクになる(カクカクになりながらもホイールを回したりするとPC内からプープーと音(警告音?)をならされるほど)

ダウンロードマネージャが悪いのかな・・とも思ったのですが、後付のアドオンではありませんし、ブックマークも原因がさっぱりわかりません。
特にブックマークの管理はカクカクすぎて不便極まりないです。。。。

何か解決方法アドバイスをよろしくお願いします。
WindowsXP SP2 Athlon3500+ 1024MBRAM

Aベストアンサー

こういうページを見つけました。

http://level.s69.xrea.com/mozilla/index.cgi?id=20060207_MemFAQ

一種のメモリリークではないかと思われます。対応策がいろいろ書かれているので参考にしてみてはいかがでしょう。拡張が原因、とは限りません。メモリキャッシュの制限や高速Back/Forwardの無効化など。

万策尽きたら、既存のプロファイルを一旦破棄し(ブックマークはバックアップしておきましょう)再構築し直す、という手もあります。

Qメモリ増設での確認方法

メモリーを増設したのですが、XPの起動時間等が
増設前と余り変わりません。増設した効果?が判りやすいのは
どのような事をしてみれば良いでしょうか?

他のソフトの起動とかも試したのですが余り時間が変わらない。
メモリが駄目なのか?memtest86?とかメモリの検査をした方が
いいでしょうか?ちなみに新品を購入しています

Aベストアンサー

XPの場合、512から増設しても起動時間はそれほど体感できないかと思います。
256→512にしたときはかなり体感できると思います。

体感できるとすれば重めのソフト(CAD等)の起動のときなどでしょうか。
あとはタブブラウザでたくさんタブを開いたりとか。


足りない128Mはビデオメモリで使われていると思います。

QFireFox2からFireFox3にバージョンアップ後、ツールバー表示がおかしく・・

いつものようにFireFox2を起動したら、いきなりFireFox2からFireFox3に強制バージョンアップされました。

動作がかなり早くなってて感動したんですが、なぜかツールバー(自体)の表示順番がおかしくなっていつもと違っていてやりにくいです。

今までの順番

(1)「戻る」とかのツールバー
(2)ブックマークツールバー
(3)webdeveloperツールバー
(4)googleツールバー

バージョンアップ後の順番

(1)「戻る」とかのツールバー
(2)ブックマークツールバー
(3)googleツールバー
(4)webdeveloperツールバー

どうすれば(4)を(3)に、(3)を(4)に入れ替えさせることができるのでしょうか?

気になることといえば、webdeveloperを最新版にバージョンアップしたんですが、設定でショートカットキーを設定しても呼び出せないです。またwebdeveloperツールバーの中に、他のアイコンを混ぜていました。webdeveloper自体の問題かなぁ。

Aベストアンサー

>どうすれば(4)を(3)に、(3)を(4)に入れ替えさせることができるのでしょうか?

どうしても順番が気になるなら、
ツールバーの位置を変更するアドオンもあります。

「DragNDrop Toolbars」
https://addons.mozilla.org/ja/firefox/addon/3571
使い方↓
http://wikiwiki.jp/firefox/?Ext%2Fbars%2FDragNDrop%20Toolbars

ただし、順番が入れ替わるかはこちらでは未検証。

Qメモリ増設後のスペックの確認

今日無事にメモリ増設を完了しました。(64+128=192MB)
計算上は192MBになっているはずなのですが、「パフォーマンス」等で確認すると、190MBになっています。
たった2MBなのかもしれませんが、ちょっと気になります。
これで正常なのでしょうか?
ちなみにVAIO-FX55にアイオーのメモリーを取り付けました。

Aベストアンサー

私のも1MB少ないだけです。
で、サポートで調べたらモデル違いのですがよく似たのが載ってました。
VAIO-FX55にも[VAIO]-[VAIOシステム情報]があるならそれで確認してみては?

参考URL:http://search.vaio.sony.co.jp/solution/S0008070003669/index.html

Qfirefox3を再起動するとfirefoxのオプション設定が消えてしまう

firefox3を再起動するとfirefoxのオプション設定が消えてしまい困っています。

IDやパスワード、ブックマークは残っているのですが、
ツール⇒オプションでの設定が毎回消えてしまい、
タブを閉じるかなどと毎回同じアラートがでたりします。

firefox3をインストールした直後は普通に動いていましたが、
一月ぐらいして、上記の状態になってしまいました。



環境
============
firefox3
winXP SP2

Aベストアンサー

不具合診断をされても良いですが、どうもクリーンインストールで直した方が良さそうです。
http://wiki.mozilla.gr.jp/wiki.cgi?page=chart

その際は、原因がプログラム本体の問題か、プロファイル内の関係ファイルの不調なのか不明なので、プロファイルにある「ブックマークや、サイトのIDとパスワード」のみをバックアップして、他のものはすべて削除した方が良いと思います。

ブックマークは、ブックマークの管理にある「インポートとバックアップ」→バックアップのメニューで、Jsonファイルで出力しておきます。

IDとパスワードは、プロファイルにあるkey3.dbとsignons.sqliteという二つのファイルをバックアップコピーして、再インストール後に、どれかのサイトを登録したら同名のファイルが生成しますから上書きですべてが復元します。
Password Exporterという拡張機能でも、バックアップとインポートが可能です。
https://addons.mozilla.org/ja/firefox/addon/2848

手順は、プログラムの追加と削除からアンインストールし、
C\Program Files\Mozilla Firefoxを削除、
その後に、次の二つのMozillaフォルダを削除後に、再インストールです。
○C:\Documents and Settings\ユーザー名\Application Data(隠しフォルダ)\Mozilla
○C:\Documents and Settings\ユーザー名\Local Settings(隠しフォルダ)\Application Data(隠しフォルダ)\Mozilla
※#2さんが貼られたMozilla JapanのXP/2000のプロファイルのパスでは、ApplicationDataが抜けているようです。

なお、プロファイルフォルダにあるExtenionsフォルダをバックアップコピーしていたら、導入されている拡張機能を復元する方法もあります。
症状からしたら、拡張機能の影響ではないような気もしますが、初期化後に、再度、入れた方が確実です。

不具合診断をされても良いですが、どうもクリーンインストールで直した方が良さそうです。
http://wiki.mozilla.gr.jp/wiki.cgi?page=chart

その際は、原因がプログラム本体の問題か、プロファイル内の関係ファイルの不調なのか不明なので、プロファイルにある「ブックマークや、サイトのIDとパスワード」のみをバックアップして、他のものはすべて削除した方が良いと思います。

ブックマークは、ブックマークの管理にある「インポートとバックアップ」→バックアップのメニューで、Jsonファイルで出力して...続きを読む


人気Q&Aランキング

おすすめ情報