図のように、スイッチでPCを2つつないで(それぞれのPCには、手動でIPアドレスを設定、サブネットマスクは255.255.255.0)、pingは通じるのでしょうか?

単なるスイッチだと(レイヤ2だから?)つながらないのでしょうか?

もし、つながらないとすると、どのようにすればpingできるようになるのでしょうか?(ルータをはさむなど?)

「スイッチで挟んでもpingは通らない?」の質問画像

このQ&Aに関連する最新のQ&A

A 回答 (2件)

ネットワークアドレスを同じ設定にしているPC同士なら


スイッチを挟んでpingは通るでしょ?
    • good
    • 0
この回答へのお礼

回答ありがとうございます。
うーん、、ちょっと通らなかったのですが…。というか、実はスイッチにVLANを設定していまして(もちろんPCたちは同じVLAN内です)、それが原因なのでしょうか?

お礼日時:2009/05/19 23:52

図?



どこ?
    • good
    • 0
この回答へのお礼

すみませんでした。

お礼日時:2009/05/19 23:22

このQ&Aに関連する人気のQ&A

お探しのQ&Aが見つからない時は、教えて!gooで質問しましょう!

このQ&Aを見た人はこんなQ&Aも見ています

このQ&Aを見た人が検索しているワード

このQ&Aと関連する良く見られている質問

QL2スイッチからpingを打つ時について。

L2スイッチからpingを打つ時について。

VLANが設定できるL2スイッチであれば、ポートによって所属しているネットワークが異なる場合があると思うのですが、pingを打つ際、ping元のIPアドレスおよび送出されるネットワークは、管理IPアドレスと管理VLANから、になるのでしょうか?
(たとえば、↓はL2スイッチだと思いますが、このような場合、どのような動作をするのでしょう)

http://www.alaxala.com/jp/techinfo/archive/manual/AX2400S/HTML/11_4/COMMINDX/INDEX.HTM

Aベストアンサー

通常、L2SWに付与できるIPアドレスは1つ、そのIPアドレスをくくりつけられるVLANは1つです
ですので、

> pingを打つ際、ping元のIPアドレスおよび送出されるネットワークは、管理IPアドレスと管理VLANから、になるのでしょうか?

ということになります

QL2スイッチ、L3スイッチ間pingについて

初歩的な質問ですいません。
L2スイッチとL3スイッチに同じセグメントのIPアドレスを付与した場合について教えてください。
(L2スイッチスイッチには管理用VLAN1にIPアドレスを振っています)

上記の場合、L2スイッチからL3スイッチへのpingは飛ぶのでしょうか。また、L3スイッチからL2スイッチへのpingは飛ぶのでしょうか。

Aベストアンサー

フィルタをかけてたりしなければ飛びますね。
正しく設定されていれば問題ありません。

Qping で 一般エラー。

コマンドプロンプトを「管理者として実行」で起動した後、
ping 128.0.0.1
を行なうと、「一般エラー。」が出力されます。
他のIPv4のアドレスを入力しても同じ結果です。
クロスケーブルでXpと接続しているのですが、通信できません。
Xp側からpingすると unreachになります。
どのようなことが考えられますでしょうか?

Aベストアンサー

いままでxp同士の接続と勘違いしてました。示したURLはvista側は参考になりませんね。すいません。
(ワイヤレスの事も見落としてました。imola51様ありがとうございます)
vistaの共有設定はこちら。
http://www.microsoft.com/japan/technet/network/evaluate/vista_fp.mspx

なぜそれにこだわるのか理解できませんが、pingのunreadchable問題を先に解決したいのであれば、imola51さんが指摘したように、ファイアーウォールを止めてみて、再チャレンジ。

・ウィルス対策ソフトをインストールしてある場合はそのマニュアルに従う
・Windows標準のファイアーウォールの設定は
スタート>コントロールパネル>セキュリティー>Windowsファイアーウォールの有効化または無効化
で「無効」を選択し「OK」です。

でも、pingのunreadchableに拘るのは、あまり得策ではないと思いますけど。

QCiscoルータコマンド(どのくらいの帯域を使ってるか確認する為)

Ciscoルータのコマンドについて教えてください。

128Kの専用線を使って、あるサーバにアクセスしていますが、この専用線の帯域がどれくらい使用されているのかを確認する為には、どんなコマンドを打てばいいのか分かりません。

sh int bri 0/1と打って、出力された
Available Bandwidthで確認できると聞いたのですが
これは、あくまで設定値みたいで、ある時点でどれくらい使用されているのかを確認したいと思っています。

IOSは、12.です。ルータはCisco1700です。

ご存知の方がいらしたら教えてください。

Aベストアンサー

トラフィック測定ということでしょうか?
Ciscoルータはあまり詳しくないので、ずばりといったコマンドはわかりませんが...、

sh int で5分平均の送受信量(bps と pps)が出ますが、どうでしょうか?

秒単位のトラフィックとなると、snmpのmibで"ifInOctets""ifOutOctets"を定期的に採取して
そこから求めるといった事になると思います。
例えばMRTGを使うとか。
http://www.iin.gr.jp/~taka/server/mrtg.html

QVLANを構成するときは、一つのVLANに一つのネットワークアドレス?

VLANについて、勉強しています。

VLANは、一つのネットワーク(アドレス)の中でスイッチによって複数のVLANに分ける、するものだと思っていたのですが、下記のページの図1-4を見ると、一つのVLANに一つのネットワークを割り当てているのですが、実際はこういう使い方をするのでしょうか?

よろしくお願いします。

http://itpro.nikkeibp.co.jp/article/COLUMN/20060919/248444/?ST=nettech&P=2

Aベストアンサー

>一つのルータで、複数のネットワークアドレスを割り当てることが可能なのですね…。

 VLANから始まった質問なのですが、話が複雑になるのでここでは別にしておいてください。 またルータのことを理解する上では、家庭などで使われるブロードバンドルータを意識すると理解しずらくなります。
ルータは一般的にはLAN(ネットワーク)間を接続することに使われ、その中の一つにLANではなくWANがあると理解されたほうが分かりやすいです。

 1台または複数のスイッチで構成されるネットワークは、1つのネットワークアドレスを持ちます。このようなネットワークが別にもあったとすると、このネットワークをお互いに接続するにはルータを用います。(スイッチ同士を繋いでしまったら、これは大きな一つのネットワークに拡大したにすぎません) ルータはこのネトワーク間の橋渡しをする装置で、例えばルータにポートが10個備わっていれば、10個のネットワークを相互接続することができます。

 ルータの機能は、このネットワーク間の接続(ルーティング:宛先IPアドレスによって送り出す先のポートを選択する機能)を行うものです。
 ネットワーク内の通信ではスイッチだけで可能ですが、ネットワーク外への通信はルータに任せます。 PCにはデフォルトゲートウェイを指定しますが、これは異なるネットワークへの通信の場合に送出するルータのアドレスを指定するものなのです。

 インターネットは、これが極めて大きくなったものと言ってもいいでしょう。 何万ポートもある大きなルータが存在するわけではなく、ルータの先に更にルータが接続され、更にその先にもルータが・・といった風です。
 試しに、PCのコマンドプロンプトからtrcertコマンド(例えばtracert www.xxx.co.jpのように)を入力してみてください。通過したルータのアドレスが分かります。

 上記はシンプルに説明したものですが、これにVLANが絡んだり、WANがあったり、ルータにも他にいろいろな機能があったりして理解しずらくなっていますね。

>一つのルータで、複数のネットワークアドレスを割り当てることが可能なのですね…。

 VLANから始まった質問なのですが、話が複雑になるのでここでは別にしておいてください。 またルータのことを理解する上では、家庭などで使われるブロードバンドルータを意識すると理解しずらくなります。
ルータは一般的にはLAN(ネットワーク)間を接続することに使われ、その中の一つにLANではなくWANがあると理解されたほうが分かりやすいです。

 1台または複数のスイッチで構成されるネットワーク...続きを読む

Qpingコマンドが成功しない。

ある本でネットワークの勉強をしているのですが、pingコマンドを実行しようとしても、下記のようにエラーが出てしまいます。

どんなことが原因に考えられるのでしょうか?OSはVISTAです。

C:\Users>ping 59.106.18.21

59.106.18.21 に ping を送信しています 32 バイトのデータ:
一般エラー。
一般エラー。
一般エラー。
一般エラー。

59.106.18.21 の ping 統計:
パケット数: 送信 = 4、受信 = 0、損失 = 4 (100% の損失)、

Aベストアンサー

ipconfigで表示される内容はすべてIPv4になったという事でしょうか?
自PCへのpingは動作するでしょうか? しない場合、一旦ウィルス対策ソフトを止めてから試して見てください。
またIPアドレスはDHCPによる自動取得ですか?

QCISCOルータのIPアドレスの確認方法。

CISCOルータ自身のIPアドレスの取得方法が知りたいです。ブラウザから設定をしたいので、IPアドレスを知りたいのですが、そういったコマンドはあるでしょうか?(初心者すぎで、トンチンカンなことを言っているかもしれません)

ターミナルソフト?で特権モードに入るまではできたのですが…。

Aベストアンサー

> すみません、常識以前の質問なのでしょうが、IPアドレス等は、CISCOルータに直接設定しなくてはならないのでしょうか?

以前の回答のように、BBルータであればWAN側をDHCPで運用みたいなことはあるでしょうけど.......
(CiscoでもCisco1812Jみたいな機種はそのような運用はありかもしれません)

基本的には各interfaceに固定でIPアドレスを振って使うのが普通です
あと、interfaceに振られたIPアドレスを確認する方法として、
show interface
(省略形はsh int)
を実行すればinterfaceに割り振られたIPアドレスも含めてinterfaceの状態も確認することができます

QL3スイッチとL2スイッチのVLANについて

以下、L3スイッチとL2スイッチのVLANについてご存知の方、教えてください。

少し長文ですが、困っているのでよろしくお願いします。

質問の部分は☆印のところです。

L3スイッチ(Catalyst3560)にVLANを3つ作成し、各VLAN間通信を許可する。
・VLAN1:192.168.10.0/24 (1port~8portを使用)
・VLAN2:192.168.20.0/24 (9port~16portを使用)
・VLAN3:192.168.30.0/24 (17port~24portを使用)

L2スイッチ(Catalyst2960)にVLANを3つ作成し、各VLANの1ポートは、L3のVLANに接続する。
・VLAN1:1port~8portを使用 →L3の1ポート目に接続
・VLAN2:9port~16portを使用 →L3の9ポート目に接続
・VLAN3:17port~24portを使用 →L3の17ポート目に接続

ネットワークアドレスが異なる各PC群を、L2に接続し、全PC間通信を可能とする。
→最終目標


質問の背景としては、もともとPCをL3に直接接続して、全PC間の通信を行う予定が、
PCが激増し、L2を介して通信することとなりました。
実際、L2スイッチは48ポートです。
L3スイッチに対する、VLANの設定、VLAN間通信の設定はできています。

質問事項
☆L3スイッチの設定
おそらく、現在のVLANの設定はポートVLANだと思われます。
L2スイッチとVLAN間同士で通信する場合、タグVLANという考え方が必要になるのでしょうか。

この構成におけるL3スイッチに必要な設定を教えてください。

現在行っている設定は、以下のサイトを参考に設定しました。
http://www.infraexpert.com/study/vlan1.1.htm

☆L2スイッチ
VLANを作成するにあたって、L3スイッチとVLAN-IDやVLAN-NAMEを合わせる必要があるのでしょうか。
また、L2スイッチにはIPアドレスを1つしか設定できないという認識で、且つL2スイッチにIPアドレスの
設定は不要という認識です。

この構成の場合、特にIPアドレスの設定は必要ないでしょうか。

以下、L3スイッチとL2スイッチのVLANについてご存知の方、教えてください。

少し長文ですが、困っているのでよろしくお願いします。

質問の部分は☆印のところです。

L3スイッチ(Catalyst3560)にVLANを3つ作成し、各VLAN間通信を許可する。
・VLAN1:192.168.10.0/24 (1port~8portを使用)
・VLAN2:192.168.20.0/24 (9port~16portを使用)
・VLAN3:192.168.30.0/24 (17port~24portを使用)

L2スイッチ(Catalyst2960)にVLANを3つ作成し、各VLANの1ポートは、L3のVLANに接続する。
・VLAN1:1port~8portを使用 →L3...続きを読む

Aベストアンサー

とりあえずコマンドだけ書くと

※L2とL3共通

interface range fa 0/1 - 8
switchport mode access
switchport access vlan 1

interface range fa 0/9 - 16
switchport mode access
switchport access vlan 2

interface range fa 0/17 - 23
switchport mode access
switchport access vlan 3

interface fa 0/24
switchport mode trunk
switchport trunk encapsulation dot1q

でお互いのfa0/24同士を接続すればタグ通信出来ます。

下の方が仰っているように、普通は冗長性を考えてchannelを使いますが、業務なのかどうかすら質問内容からは分かりかねるので、とりあえずトランク設定だけを載せておきます。

Q「宛先ホストに到達できません」とは

下記サイトのみ「宛先ホストに到達できません」となります。
その他のサイト(goo等)は接続できます。(ping応答あり)

「宛先ホストに到達できません」とはどういう時に出るのでしょうか?

自宅にある他PCも同現象です。

<ネット接続構成>
インターネット-無線LAN(WZR-G144N)-PC

<ping結果>
Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation. All rights reserved.

C:\Users\xxxxx>ping sfp.kyoraku.jp

sfp.kyoraku.jp [1.1.81.114]に ping を送信しています 32 バイトのデータ:
192.168.11.1 からの応答: 宛先ホストに到達できません。
192.168.11.1 からの応答: 宛先ホストに到達できません。
192.168.11.1 からの応答: 宛先ホストに到達できません。
192.168.11.1 からの応答: 宛先ホストに到達できません。

1.1.81.114 の ping 統計:
パケット数: 送信 = 4、受信 = 4、損失 = 0 (0% の損失)、

C:\Users\xxxxx>ping www.goo.ne.jp

www.goo.ne.jp [218.213.142.230]に ping を送信しています 32 バイトのデータ:
218.213.142.230 からの応答: バイト数 =32 時間 =67ms TTL=242
218.213.142.230 からの応答: バイト数 =32 時間 =66ms TTL=242
218.213.142.230 からの応答: バイト数 =32 時間 =66ms TTL=242
218.213.142.230 からの応答: バイト数 =32 時間 =56ms TTL=242

218.213.142.230 の ping 統計:
パケット数: 送信 = 4、受信 = 4、損失 = 0 (0% の損失)、
ラウンド トリップの概算時間 (ミリ秒):
最小 = 56ms、最大 = 67ms、平均 = 63ms

C:\Users\xxxxx>

下記サイトのみ「宛先ホストに到達できません」となります。
その他のサイト(goo等)は接続できます。(ping応答あり)

「宛先ホストに到達できません」とはどういう時に出るのでしょうか?

自宅にある他PCも同現象です。

<ネット接続構成>
インターネット-無線LAN(WZR-G144N)-PC

<ping結果>
Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation. All rights reserved.

C:\Users\xxxxx>ping sfp.kyoraku.jp

sfp.kyoraku.jp [1.1.81.114]に ping を送信しています 32 ...続きを読む

Aベストアンサー

状況からバッファローのルーターの問題であるような気がします。
ファームウェアのバージョンが低い場合は、アップデートで改善される「こと」もありますのでダメ元で試してみてはいかがでしょう?
あと、ルーターの経路情報や、ルーターにログインしてからpingテストをやってみて状況を確認してください。
ルーターからもpingが通らなければ(多分通らないと思いますが)、バッファローに問い合わせてみるのが解決への近道のような…。
他のルーターをお持ちでしたら、ルーターを変えてみるのもいいかもしれません。

Qpingが飛ばない原因が知りたい

いつもお世話になっております。

IPアドレスについての不具合です。

A端末にIPアドレスが設定されているのですが、
B端末、C端末からPINGをとばしたところ、LOSTしてしまいます。


A端末からはB,C端末へのPINGは返ってきています。
IP アドレスは 128.1.1.*(この部分が三台異なる)
サブネットマスク 三台同じ
デフォルトゲートウェイ 三台同じ

なにか考えられる原因はありますでしょうか。

Aベストアンサー

#3の方が言うように、128.1.1.*がグローバルアドレスなのが気になります。
自分では、グローバルアドレス=管理されているアドレス=自由に使ってはいけないという認識です。
昔、ケーブルテレビのインターネットで接続が2日程ダウンした事があり、復旧後に原因を聞いた所、「契約者の一人が使っていけないIPアドレスを設定した為」との事。
こちらとすれば2日接続が出来なかったので、「損害賠償モノだなぁ」と思ったり。

間違ってグローバルアドレスを使っているのであれば、プライベートアドレスの192.168.0.0~192.168.255.255(Cクラス)を使ってみてはどうでしょう?


このQ&Aを見た人がよく見るQ&A

人気Q&Aランキング

おすすめ情報