AKB48の推しメンをセンターにできちゃうかもしれない!? >>

P4M80-M4というマザーボードで組んだデスクトップに
Linux mint 13 をインストールしましたが、音が出ないので苦戦しています。

https://wiki.ubuntulinux.jp/UbuntuTips/Hardware/ …

を参考に情報を集めています。下記の情報から解決方法がわかる方、
お知恵をかしていただければ助かります。

1.サウンドデバイスがPCに認識されているかの確認

$ lspci | egrep -i multimedia\|audio を入力して以下の表示でした。

00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237 AC97 Audio Controller (rev 60)

2.lspci -v | less と入力し詳細表示は以下のとおりです。

00:00.2 Host bridge: VIA Technologies, Inc. CN700/VN800/P4M800CE/Pro Host Bri
dge
Flags: bus master, medium devsel, latency 0

00:00.3 Host bridge: VIA Technologies, Inc. PT890 Host Bridge
Flags: bus master, medium devsel, latency 0

00:00.4 Host bridge: VIA Technologies, Inc. CN700/VN800/P4M800CE/Pro Host Bri
dge
Flags: bus master, medium devsel, latency 0

00:00.7 Host bridge: VIA Technologies, Inc. CN700/VN800/P4M800CE/Pro Host Bridge
Flags: bus master, medium devsel, latency 0

00:01.0 PCI bridge: VIA Technologies, Inc. VT8237/VX700 PCI Bridge (prog-if 00 [Normal decode])
Flags: bus master, 66MHz, medium devsel, latency 0
Bus: primary=00, secondary=01, subordinate=01, sec-latency=0
Memory behind bridge: f4000000-f5ffffff
Prefetchable memory behind bridge: f0000000-f3ffffff
Capabilities: <access denied>
Kernel modules: shpchp

00:0f.0 IDE interface: VIA Technologies, Inc. VIA VT6420 SATA RAID Controller (rev 80) (prog-if 8f [Master SecP SecO PriP PriO])
Subsystem: Biostar Microtech Int'l Corp Device 3206
Flags: bus master, medium devsel, latency 32, IRQ 20
I/O ports at b000 [size=8]
I/O ports at b400 [size=4]
I/O ports at b800 [size=8]
I/O ports at bc00 [size=4]
I/O ports at c000 [size=16]
I/O ports at c400 [size=256]
Capabilities: <access denied>
Kernel driver in use: sata_via
:

3.ALSAレベルでサウンドデバイスが認識されているかの確認

$ cat /proc/asound/cards
0 [V8237 ]: VIA8237 - VIA 8237
VIA 8237 with ALC655 at 0xdc00, irq 22
$ cat /proc/asound/card0/codec* | grep -i codec
cat: /proc/asound/card0/codec97#0: Is a directory

$ cat /proc/asound/card0/codec97#0/* | head -n1
0-0/0: Realtek ALC655 rev 0


宜しくおねがいします。

このQ&Aに関連する最新のQ&A

A 回答 (4件)

No Sound with VIA 8237 (snd-via82xx) using pulseaudio


https://bugs.launchpad.net/ubuntu/+source/linux/ …
によれば:
(1)結論: 回答#86
 直さない(∵古いから@2011/7時点)

(2)動いた!との書き込み:
 回答#7) `modprobe -r snd-via82xx` and `modprobe snd-via82xx'
 回答#84) マザーボードのジャンパ設定が必要
 回答#85) サウンドの設定が必要だった
だそうです。

機種が違いますが、NECのVY10Aでは上記ページの回答#7が役に立ちました。

この回答への補足

ありがとうございます。

 回答#7) を読みました。etc/にはmodulesという名のファイルが既存していますが、modules.conf は別物でしょうか? 
検索結果には、なくてもいいファイルとありましたが、無ければ作る?
であってますか?

ファイルの記述の方法を教えていただけないでしょうか?

補足日時:2014/05/14 21:51
    • good
    • 0

古い音源では、external amplifierという項目があって


その設定を変える必要があるような話はあるんですけど、どうでしょう?

また、自作PCではフロントや拡張スロット用のオーディオ端子があっても
それをM/Bに繋いでなかったり
知らないうちに抜け落ちていることもあるので
バックパネルの端子で検証しないと、混乱することがあります。

状況的にMint特有の問題には見えませんが
念の為に、別のディストリビューションでのテストもしたほうがいいかもしれません。

この回答への補足

ありがとうございます。

Allsa mixer で external amplifier の設定項目を確認しましたが、オフになっていて矢印を上にしても 操作することができませんでした。

補足日時:2014/05/10 11:12
    • good
    • 0

PulseAudioであれば、設定タブでのプロファイルや


出力装置タブのポートの設定の組み合わせを変えたらどうでしょう?

サウンドカードのソフトウェアからの見え方は
必ずしも、サウンド回路における実際の配線と同じではありません。

ヘッドフォン端子に繋いであるのに
ヘッドフォン出力にすると音が出ないようなこともありえます。

この回答への補足

ありがとうございます。
出力装置タブのポートの設定 を変えてみましたが、無音状態です。

補足日時:2014/05/09 09:49
    • good
    • 1

alsamixerをいじって見ましたか。

この回答への補足

ありがとうございます。 該当するサウンドカードを選択して、各項目をいじっていますが無音です。

※設定中は、ブラウザーでYoutubeなどを再生しながら、PluseAudioで再生音が視覚的に見えるだけの状態です。

補足日時:2014/05/08 22:48
    • good
    • 0

このQ&Aに関連する人気のQ&A

お探しのQ&Aが見つからない時は、教えて!gooで質問しましょう!

このQ&Aを見た人が検索しているワード

このQ&Aと関連する良く見られている質問

QLinuxをインストールしてみたけど音が出ない・・・

音が出ない時ってサウンドカードに合ったドライバが無かったってことですよね。こういう時って、自分で何かプログラムとか書いてドライバを作らなきゃいけないんですか? もしかしてこういう場合、すごく難しいのでしょうか。 Linuxのプロフェッショナルさんはどうしてるか教えてください!!

Aベストアンサー

まず思い込みを排除して取り組むことを勧めます。
1.ドライバは対応するものを持っているのに、サウンド設定が行なわれていないだけ、という可能性。
対処: コンソールから alsaconf を起動し、サウンドを再設定してみる。

2.サウンド設定はされているのにボリュームがミュートされている可能性。
 (ALSAドライバは一般的にデフォルトでは音量はミュートされています。)
対処: コンソールから alsamixer を起動して各種音量を上げる。

注)Turbolinuxなら上記1,2を同時にやってくれる専用ツールがあるかも。
  turbosoundconfigとか turbosoundcfgとか。Turboは使わないので詳細は知りません。

他の方が言っているように、少なくとも最新カーネル(最新ALSAドライバ)なら
ES1978はES1968と同じドライバで動作するはずです。
必ずしも最新カーネルにしなくても動作する可能性はあるので、とりあえず
Turbolinuxの最新カーネルにアップデートしてみるのも手です。

まず思い込みを排除して取り組むことを勧めます。
1.ドライバは対応するものを持っているのに、サウンド設定が行なわれていないだけ、という可能性。
対処: コンソールから alsaconf を起動し、サウンドを再設定してみる。

2.サウンド設定はされているのにボリュームがミュートされている可能性。
 (ALSAドライバは一般的にデフォルトでは音量はミュートされています。)
対処: コンソールから alsamixer を起動して各種音量を上げる。

注)Turbolinuxなら上記1,2を同時にやってくれる専用ツールが...続きを読む

Qlinuxbean 音が出ない

いろんなんサイトを拝見しても自分の脳みそではどうも理解ができず困っています。
自分はlinuxbeanをpanasonicのCF-T2という機種で使用しています。
wifiもつながらないけど、そっちは自分で何とかしようと思っていますが、どうも音の出し方だけはわかりません。
複数の手段をわかりやすく解説してくれませんか。
あと他にも情報が必要なのでしたら、追記します。
どうか助けてください!

Aベストアンサー

Pulse Audioを入れてみたら?
具体的には
「Pulse Audio Manager (paman)」と「PulseAudio Volume Control」の2本が必須。

Synapticパッケージマネージャ上で「Pulse Audio」で検索をかけると、この2つがヒットするはずだから、それぞれインストールする。
インストール後、「PulseAudio Volume Control」を立ち上げて、
http://i.stack.imgur.com/rGCaW.png
 ↑
これの、「Port: AnalogueOutput(LFE)/Amplifier」とあるところで、
「Amplifier」(アンプリファイア)ではなく「NoAmplifier」(ノー・アンプリファイア)という選択肢があるはずなので、
「AnalogueOutput/NoAmplifier」(ノー・アンプリファイア)に変えてみる。
自分はそれで音がでるようになった。

それでもダメなら他のPulse Audio関係のソフト、たとえば「PulseAudio Preferences」(paprefs)や「PulseAudio Device Chooser 」(padevchooser)を入れてみていじってみるとか。


回答者No.1さんが言われているPAE非対応だのなんだのという問題は、OSインストール前の問題。
OSがインストールできて実際に使えているなら、問題はクリアできているため、この際無視しても構わない。

Pulse Audioを入れてみたら?
具体的には
「Pulse Audio Manager (paman)」と「PulseAudio Volume Control」の2本が必須。

Synapticパッケージマネージャ上で「Pulse Audio」で検索をかけると、この2つがヒットするはずだから、それぞれインストールする。
インストール後、「PulseAudio Volume Control」を立ち上げて、
http://i.stack.imgur.com/rGCaW.png
 ↑
これの、「Port: AnalogueOutput(LFE)/Amplifier」とあるところで、
「Amplifier」(アンプリファイア)ではなく「NoAmplifier」(ノー・アンプリ...続きを読む

Qサウンドのチップ?がESS ES1978S (MAESTRO-2E)だけど・・・

自分の中古パソコンのサウンドのチップがESS ES1978S (MAESTRO-2E)であることがサイトhttp://support.sharp.co.jp/mebius/myspec/spec_search.asp
で分かったけど、Turbo Linuxのサイトhttp://www.turbolinux.co.jp/products/compatibility/driver/sn10d/sound.html
で調べても意味が分かりません。
だって、
snd-es1968
ESS Maestro 2e
って書いているけど、これがESS ES1978S (MAESTRO-2E)のことを指しているのかがよく分からなくって。
これのことですか? 誰かご存知の方教えてください・・・。
結局サウンドカード?の読み方が分からないんですよね。ESSってメーカー? 1978って年代なのだろうか。カッコの中はな~に??? 意味不明です。

Aベストアンサー

こんにちは。

>じゃあ、アップデートすればいいんですね。

いえ、かならずカーネルのアップデートで解決するとは保障できません。
音が出ない原因が特定できてませんから。
よい機会ですから、カーネル再構築に挑戦してみてはいかがでしょう、という意味です。

>LAN内臓ではないのでLANカードを使わなければならないのですが、
>設定できなさそう。もうダメそうです。
>Linuxは挫折何度目だろう・・・。

どうしても、古そうなTurboLinux Personalを使う必要があるのですか?
最新の、FedoraCore, CentOS, VineLinuxなどもフリーで入手できるのですから
試してみてはいかがですか?

よほど、マイナーや最新すぎるチップでないかぎり、サウンドデバイスもLANデバイスも
自動認識してくれると思いますが。

以上、参考にしてください。

Qなぜubuntuは32bit版が推薦?

なぜUbuntu Linuxでは32ビット版が推薦されるんですか?もう64ビットのパソコンが普及しているこの時代なのに。

せっかく64ビットのパソコンあるのだから64ビット版を使いたいですよね。確かに動作はあまり変わらないですが。

理由がわかりません。

Aベストアンサー

64bitの環境が整備の途上なので、壁に当たる事が多く、初心者は直ぐ行き詰まる
可能性が大きいのです。

PAE(メモリ拡張機能)で32bitでも4GB以上のメモリが使用出来ますので、
64bitを使用する優位性が薄れます。

Qubuntuで動画が見られない

XPとubuntu12.04.2をデュアルブートしているものですが、動画を見ようとしても音声は聞こえますが、動画が見られません。TotemでもVLCプレイヤーでもダメです。理由がわかりません。
参考になるかどうかわかりませんが、最初に13.10をライブ起動しようとしましたが出来ず、12.04.2から12.10にアップグレードしようとしてもダメでした。

使用PC シャープPC-AE50L cpu AMD sempron 3000+ メモリ1.2G(増設済) ハードディスク60G(デフォルト) グラフィック VIA/S3G UniChrome Pro
2005年12月発売(2006年6月購入 )です。よろしくお願いいたします。

Aベストアンサー

Linux系OSは、消費者側で開発していると言っても良い体制なので
古いCPUの切り捨ては、あまり厳しく行われません。
逃げ道があるというか、救済策があったりします。

Sempronのスペックは把握していないので、制限がどう生じるかはわかりません。

たとえば、PAE非対応のCPUではUbuntu12.04LTSが導入できないという問題がありますが
これは、もとも性能の低いCPU向けのXubuntu12.04LTSやLubuntu12.04LTSを選べば
PAE非対応のCPUでもインストールができたりします。

こういったXubuntuやLubuntuのような軽量な派生版があること自体が
古いCPUや古いPCにとって有用な選択肢で
Ubuntu標準のUnityによるGUIよりも
Xubuntuが採用しているXfceによるGUIのほうが軽快に扱える可能性があります。

ただ、安定版でもある長期サポート版のLTSに比べれば
12.10から13.10では実験的な性質もあるので、S3のグラフィックチップに対して
うまく認識して動いてくれない可能性はあります。

S3やTridentやLynxは、少数派になりきった感があり
どうやら冷遇されているようです。

起動ディスクが、途中で画面真っ暗で頓挫するような症状なら、そういう問題です。
(対処方法自体はありますが、ここは割愛します)


そういうこともあるので、動画が再生できないのではなく、表示が出ないのであれば
単純に、現在動いているグラフィックのデバイスドライバーが
画面描画において、サポートしていない方法を、再生ソフトが用いている可能性があります。

VLCの場合は[ツール]-[設定]-[ビデオ]-[出力]まで辿って行くと
[デフォルト]になっているではないかと思います。

一般的には、出力にはXVideoが基本という感じなのですが
デバイスドライバーが対応していない場合は、X11ビデオ出力(XCB)を試します。
これでも表示されないとしたら、特殊な問題と考えられます。

なお、X11は普通のGUI描画と同様の描画になっていると理解していますが…
動画再生としては、再生性能が低くなります。
全画面表示が無理になるような場合は
画面解像度自体を落として対処するしかなくなるかもしれません。

Windows用ゲームにはそういう解像度を落として実行する機能があったりしますが
Linuxでの動画再生の場合は、手動で画面モードを切り替える必要があります。
GUIフロントエンドでの変更よりも、xrandrコマンドを使ったり
xrandrコマンドを使ったシェルスクリプトを、アイコンとして置いておくほうが便利です。


この時代のノートPCだと、USB接続のグラフィックアダプターを使うにも無理があるので
X11ビデオ出力で、充分な再生性能が得られないとなると、厳しいことになります。

DVDとか動画に特化した、GeeXboXみたいなアプローチもあったんですけどね。
日本では、さっぱり定着しなかったみたいです。


なお、GeeXboXに比べれば、XubuntuやLubuntuでも複雑で規模の大きいものですが
Xubuntuの場合で、起動直後のメモリー消費は300MBを下回る程度です。
GUIの処理自体も簡素になっているので
xubuntu-desktopという特殊パッケージを追加し
ログアウト後、Xubuntuを選択して再ログインするだけで、GUIをUnityからXfceに切り替えできます。

KafeeineはKDEを標準採用していた頃のTurboLinuxなんかでは標準の動画再生ソフトでしたね。
Ubuntuには、KDEを採用したKubuntuもあり、うちのメインマシンはそれになっています。
まぁKafeeineはTurboLinux以外で使ったことありませんけどね。
Kubuntuは、軽量というわけでも無いので、趣味が合う人以外は、特に選ぶメリットは無いかもしれません。

それぞれ、kubuntu-desktopやlubuntu-desktopというパッケージがあり
これらを追加することで、KubuntuやLubuntuに準ずる構成が得られます。
正確には、よけいなモノが残るので、省メモリーを追求する必然性がある場合だけは
XubuntuやLubuntuでインストールしなおすほうがいいでしょう。

Linux系OSは、消費者側で開発していると言っても良い体制なので
古いCPUの切り捨ては、あまり厳しく行われません。
逃げ道があるというか、救済策があったりします。

Sempronのスペックは把握していないので、制限がどう生じるかはわかりません。

たとえば、PAE非対応のCPUではUbuntu12.04LTSが導入できないという問題がありますが
これは、もとも性能の低いCPU向けのXubuntu12.04LTSやLubuntu12.04LTSを選べば
PAE非対応のCPUでもインストールができたりします。

こういったXubuntuやLubuntuのような軽量な派...続きを読む

Qapt-get install ****** でinstallしたものをuninstallするには?

御世話になります。
vncserverだけをinstallするつもりが
誤って
apt-get install vncとうってしまいました。
これをuninstallしたいのですが
どのようにすればよろしいでしょうか?

教えて下さい。

Aベストアンサー

# apt-get remove パッケージ名
では、設定ファイルは削除されずに残ります。

完全に削除するときは、
# apt-get --purge remove パッケージ名
です。


人気Q&Aランキング