人に聞けない痔の悩み、これでスッキリ >>

『Windows10Prox64』/『Apache24:httpd-2.4.16-win64-VC11』サーバーに『xmail-1.27』/『XMailCFG240b[1]』を導入、以下のスクリプトをコピーした『.htaccess』ファイルを『C:\Program Files\Apache\htdocs\xmailcfg\』フォルダーに配置しました。

AuthType Basic
AuthName "このページは、管理者専用です。"
AuthUserFile "C:\Program Files\Apache\htdocs\xmailcfg\.htpasswd"
<Limit GET POST>
require valid-user
</Limit>

管理者用コマンドプロンプトで以下のコマンドを実行し、パスワードを設定、『.htpasswd』ファイルが生成されたことも確認しました。

c:\> "C:\Program Files\Apache\bin\htpasswd.exe" -mc "C:\Program Files\Apache\htdocs\xmailcfg\.htpasswd" xxxxx

しかし、サーバー本機のブラウザーで『http://localhost/xmailcfg』にアクセスしようとすると、『500インターナル・サーバー・エラー』と表示され、ログイン画面が表示されません。

 ちなみに『Win10Prox32』/『Apache2.2:httpd-2.2.17-win32-x86-openssl-0.9.8o.msi』では、上記のエラーは発生しませんでした。

 Apache のバージョンが 2.4 以上の場合、初期設定でこの種のエラーが出る場合があるとのことですが、このエラーを出さないようにする方法を教えて下さい。

質問者からの補足コメント

  • 『Apache』の『httpd.conf』の以下の記述中の『Order allow,deny』を『Require all denied』に書き換え、『Apache』をリスタートしましたが、状況は変わらず、末尾の『Allow from all』を削除して『Apache』をリスタートしても、同じエラーが表示されました。
    <Directory "c:\Program Files\Apache\htdocs\xmailcfg">
    #Options +ExecCGI
    Options Indexes FollowSymLinks MultiViews ExecCGI Includes
    AllowOverride AuthConfig
    Order allow,deny
    Allow from all

    No.1の回答に寄せられた補足コメントです。 補足日時:2018/08/03 19:13

A 回答 (1件)

>Apache のバージョンが 2.4 以上の場合、初期設定でこの種のエラーが出る場合があるとのことですが、このエラーを出さないようにする方法



.htaccess ファイル→初期設定で内容を書き換える。
https://support.sugutsukaeru.jp/ja/troubleshooti …
この回答への補足あり
    • good
    • 0

お探しのQ&Aが見つからない時は、教えて!gooで質問しましょう!


人気Q&Aランキング