今晩は。kennkennと言うものです。Sambaについて困っています。ただいまVine Linux2.1.5を使っています。パソコンはNECのValueStar NXです。よろしくお願いします。問題はSambaがインストールできません。一旦、もともとインストールされていたSamba(多分samba-commmonとsamba-clientだけでした。)をアンインストールしました。そして

rpm -qa | grep samba

として、Sambaがインストールされていないことを確かめました。そのあと、インターネットで最新のSambaをダウンロードした後、Sambaをsamba-common,samba-client,sambaの順でインストールしようとしたところ、samba-commonとsamba-clientは無事エラーは出ずにインストールできたのですが、sambaは次のような指示が出てインストールできませんでした。

#################################アーカイブの展開に失敗:cpio:不正なマジック

意味がわかりません。cpioはファイルの展開、圧縮に関するコマンドだと言うのは調べましたが、これでもよくわかりません。。解決法をご存知の方、どうか教えていただけないでしょうか。よろしくお願いします。

このQ&Aに関連する最新のQ&A

A 回答 (1件)

ダウンロードが途中で途切れたりしたため、ファイルのデータが最後まで揃っていないのではないかと思います。


特に、プロキシサーバを通した場合など、プロキシのキャッシュの状態がおかしいと、この類の現象はよく出ることがあります。

そのサイトから何度ダウンロードしてもうまくいかない場合は、違うところからダウンロードし直してみてはいかがでしょうか?

この回答への補足

 ご返答ありがとうございました。返事が遅くなってすみません。ダウンロードしなおしましたが、それでも同じ結果でした。そこでじゃあこのバージョンがこのLinuxのバージョンにはインストールできないのではないかと思って、ちょっと古いバージョンのものを試してみましたがこれもだめでした。そこでここではなくて、ほかの掲示板で質問したところ、違うSambaを紹介してもらった(samba-2.0.10-ja_1.1_g2.i386.rpm)ので、こちらをインストールしてみたらインストールはできたのですけど、インターネットで見つけたSambaのホームページでは、インストールしたあとファイルの確認をするように、いろいろ書いてあったのですが、それを参照してみると、2.3個足りないファイルがあったのでいいのかなと思いました。それでもし、ファイルがちゃんとダウンロードできていないのが原因ならば、本についているSambaをインストールすればいいと思いましたが、インストールしようとすると、必要なファイルを別にインストールしなければ、システムが不安定になる可能性があると表示されました。どうすればいいのでしょう。ご助言お願いします。

補足日時:2001/10/16 19:28
    • good
    • 0
この回答へのお礼

 レスありがとうございました。ディストリビューションを変えてみました。また新たに挑戦してみます。

お礼日時:2001/11/16 13:54

お探しのQ&Aが見つからない時は、教えて!gooで質問しましょう!


人気Q&Aランキング

おすすめ情報