よろしくお願いいたします。
「フレーム」についてですが、
"フレームリレー" "メインフレーム" "OSIのフレーム"
など、ネットワーク関係では、フレームと言う言葉がよく出てきますが、
これらのフレームは同じ物なのですか?
コンピューター同士のやり取りのための通信信号(TCPみたいに、コネクション型通信信号)をフレームと思っておりますが、それぞれ別物でしょうか?

このQ&Aに関連する最新のQ&A

A 回答 (1件)

通信の世界では、フレームというのは「パケット」とオーバーラッ


プして使われることが多いですが、データ転送の単位のことです。
OSI的には、パケットは第3層以上で使うことになっているみたいで、
IPとかTCPとかはパケットといいますが、イーサネットのレイヤで
はフレームというのが一般的です。
コネクション型とかそうことに限定されるものではありません。

フレームリレーというのは、あんまり詳しくないですが、X.25 を
ベースにしたパケット交換網のことです。通信関係の多くの会社が
サービスしていると思います。

メインフレームは、これとは全然別で、大型コンピュータのことです。
    • good
    • 0
この回答へのお礼

回答ありがとうございます。
なるほど、単位なんですか。
いい勉強になりました。

お礼日時:2001/04/17 06:38

お探しのQ&Aが見つからない時は、教えて!gooで質問しましょう!

このQ&Aと関連する良く見られている質問

QTCP/IPとOSI(初心者の質問です)

初歩的な質問で申し訳ないのですが・・・
先日、LANに関する古い小冊子を読んでいたところ、
TCP/IPの使用を義務付けている状態(現在)

TCP/IPとOSIの両方を使用してよい状態

OSIの使用を義務付けている状態

という風に移行していくと記してありました。
今まで、私はTCP/IPとはOSI参照モデルに組み込まれているものとずっと思っていました。
これってどういうことなのでしょうか??
全くわかりません・・・。

Aベストアンサー

昔の話ですね。

UNIXというOSでTCP/IPが使われ、インターネットが世界的に爆発的に普及する以前のことです。
ISOでOSI標準としてTCP/IPなどとは別のプロトコルを開発していました。

当時の業界では、なんと言ってもISOのすることだから最終的にはOSIのプロトコルが使われることになるのだろうと、思っていました。IPアドレスなんてすぐ枯渇してしまうだろうし。

ところが、インターネットが世界的に普及してしまい、TCP/IPが唯一のプロトコルになってしまいました。
業界用語で「デファクトスタンダード」といいます。

今後、OSIプロトコルに移行することはありえません。
移行しても何のメリットもありません。
IPv6への移行はありえます。

そんなOSIプロトコルは、現在では7層モデルの説明にだけ登場します。
といってもネットワーク層の仕事が他の層よりも多く、合理的なモデルとは言い切れません。

参考URL:http://www.atmarkit.co.jp/fwin2k/network/tcpip003/tcpip01.html

昔の話ですね。

UNIXというOSでTCP/IPが使われ、インターネットが世界的に爆発的に普及する以前のことです。
ISOでOSI標準としてTCP/IPなどとは別のプロトコルを開発していました。

当時の業界では、なんと言ってもISOのすることだから最終的にはOSIのプロトコルが使われることになるのだろうと、思っていました。IPアドレスなんてすぐ枯渇してしまうだろうし。

ところが、インターネットが世界的に普及してしまい、TCP/IPが唯一のプロトコルになってしまいました。
業界用語で「デファクトスタンダー...続きを読む

QTCPのコネクションについて。

TCPのコネクションがよくわかりません。

3ウェイハンドシェークでお互いに通信するのを了承しあう、という説明がよくあると思うのですが、それをしたのがなぜコネクションになるのでしょうか?それをしないでデータを送っても破棄されるということでしょうか?

よろしくお願いします。

Aベストアンサー

なかなかわかりずらいですよね。

> スリーウェイハンドシェイクにより双方向に通信路を確保することができるようになるというわけです。
> の部分ですね…。
> なぜこれをやったら「通信路を確保」できたのでしょう?
ここで言う「通信路」というのは「通信回線」よりもはるかに高度の概念です。
コンピューター内のソフトやファイルまで含みます。

例えとして航空管制を使いましょう。
航空機が管制空域に入ると管制官と連絡を取りスリーウエイハンドシェイクで相互確認を取ります。(通信路の開設)
このあとは適宜情報をやり取りし、管制空域を離脱するときに通信路を切断します。

> やる前とやった後で何が変わったのでしょうか?
お互いに通信台帳を準備しこれと突き合わせながら通信していきます。
> これをやらずにTCPヘッダつきのパケットを送ってもだめだよ、ってことでしょうか?
はい、通信路を開設せずにTCP/IPでの通信はできません。
UDPなら可能ですが通信の信頼性はがた落ちです。

QCiscoルータ811のフレームリレー? について

現在の設定が専用線128Kで接続、以下になっております。

hostname AAAAAAA
!

enable password AAAAAAAA
!
username BBBBBB password 0 BBBBB
no ip subnet-zero
!
no ip finger
no ip dhcp-client network-discovery
isdn switch-type ntt
isdn leased-line BRI0 128
!
interface Ethernet0
ip address 192.168.BBB.B 255.255.255.0
!
interface BRI0
ip address 172.20.AAA.A 255.255.255.0
!
no ip http server
ip classless
ip route 0.0.0.0 0.0.0.0 172.20.CCC.C
!
line con 0
transport input none
stopbits 1
line vty 0 4
password XXXXXXXXXX
login
!
end

interface BRI0 を 仮想インターフェイスBRI0:1 BRI0:2 と分けて設定をしたいのですが、お教えください。 また、分けなくても通信できるのですか?(分ける事によってどのような効果があるのでしょうか) 稚拙な質問で、すみませんがよろしくお願いします。

現在の設定が専用線128Kで接続、以下になっております。

hostname AAAAAAA
!

enable password AAAAAAAA
!
username BBBBBB password 0 BBBBB
no ip subnet-zero
!
no ip finger
no ip dhcp-client network-discovery
isdn switch-type ntt
isdn leased-line BRI0 128
!
interface Ethernet0
ip address 192.168.BBB.B 255.255.255.0
!
interface BRI0
ip address 172.20.AAA.A 255.255.255.0
!
no ip http server
ip classless
ip route 0.0.0.0 0.0.0.0 172.20.CCC.C
!
line con...続きを読む

Aベストアンサー

自信の無い返事ですみませんが
この設定は、フレームリレー?では無いと思います。
DAの128kとかの設定だと思います。

NTTとの契約が専用線の128kで
設定が isdn leased-line BRI0 128 となっています。
この設定ですと、BRI0は128kで動作するので、BRI0:1 BRI0:2の仮想インターフェイスに分けることは不可能だと思います。

回線種別にもよると思いますが isdn leased-line BRI0 とした場合、それぞれ64kで動作する BRI0:1 BRI0:2の仮想インターフェイスに分けることは可能かも知れません。

使い道は、あまり意味がないと思われますが、128kを64k x 2 として使いたい場合に使用します。

自信のない返事でした。

QCiscoルータ811のフレームリレー設定について

Ciscoルータ811を使ってフレームリレー接続を実現しようとしていますが、うまくいきません。
現在は擬似環境で ルータ-FRシミュレータ-ルータという構成になっています。
状況としては、自分のWAN側ポートにさえpingがとおりません。
show intコマンドで見ると以下のとおりline protocolがdownになっていますが、
これはなぜでしょうか。

BRI0:1 is up, line protocol is down
Hardware is BRI with S/T interface
Internet address is 192.168.1.2/24
MTU 1500 bytes, BW 64 Kbit, DLY 20000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation FRAME-RELAY, loopback not set
Keepalive set (10 sec)
LMI enq sent 44, LMI stat recvd 16, LMI upd recvd 0, DTE LMI down
LMI enq recvd 0, LMI stat sent 0, LMI upd sent 0
LMI DLCI 1023 LMI type is CISCO frame relay DTE


↓show confの抜粋です。設定としておかしいところなどありますでしょうか。

interface BRI0
no ip address
encapsulation frame-relay
no arp frame-relay
frame-relay lmi-type cisco
!
interface BRI0:1
bandwidth 64
ip address 192.168.1.2 255.255.255.0
encapsulation frame-relay
no fair-queue
no arp frame-relay
frame-relay interface-dlci 21
frame-relay lmi-type cisco

よろしくお願いします。

Ciscoルータ811を使ってフレームリレー接続を実現しようとしていますが、うまくいきません。
現在は擬似環境で ルータ-FRシミュレータ-ルータという構成になっています。
状況としては、自分のWAN側ポートにさえpingがとおりません。
show intコマンドで見ると以下のとおりline protocolがdownになっていますが、
これはなぜでしょうか。

BRI0:1 is up, line protocol is down
Hardware is BRI with S/T interface
Internet address is 192.168.1.2/24
MTU 1500 bytes, BW 64 Kbit, DLY 20000 ...続きを読む

Aベストアンサー

通常FR回線のアクセスラインはデジタル専用線を利用しますので、BRIインターフェースを利用する場合にはデジタル専用線の設定が必要となります。
下記は日本でFR64kを利用する際の設定例です。

-----
isdn switch-type ntt
isdn leased-line BRI0

interface Ethernet0
ip address 192.168.2.1 255.255.255.0

interface BRI0
no ip address
shutdown

interface BRI0:1
no ip address
encapsulation frame-relay
frame-relay lmi-type q933a

interface BRI0:1.1 point-to-point
ip address 192.168.253.2 255.255.255.0
frame-relay interface-dlci 21
-----
BRI0:1でFRの設定をしますので、BRI0は特に何も設定する必要はありません。
そしてPVC(パス)毎の設定は仮想インターフェース(BRI0:1.1)に記述します。
PVC複数ある場合はBRI0:1.2、BRI0:1.3・・・というように仮想インターフェースを増やしてください。

また通常日本国内ではlmi-typeをq933aにすることが多いですよ。(接続するFR交換機によって違います。今回はシミュレーターですので、そのシミュレーターが対応しているlmi-typeを利用してください)

通常FR回線のアクセスラインはデジタル専用線を利用しますので、BRIインターフェースを利用する場合にはデジタル専用線の設定が必要となります。
下記は日本でFR64kを利用する際の設定例です。

-----
isdn switch-type ntt
isdn leased-line BRI0

interface Ethernet0
ip address 192.168.2.1 255.255.255.0

interface BRI0
no ip address
shutdown

interface BRI0:1
no ip address
encapsulation frame-relay
frame-relay lmi-type q933a

interface BRI0:1.1 point-to-point
ip ...続きを読む

QATM交換機やフレームリレーサービスって具体的に使っていますか?

ATM交換機やフレームリレーサービスという単語を情報処理の教科書で読んだのですが、いまいちイメージが沸きませんでした。

そこで質問なのですが、ATM交換機やフレームリレーサービスというのはわれわれが実際に使っている装置やサービスのひとつなのでしょうか。
もし無意識の間にでも使っているのであれば具体的にどういうときに使っているのか教えてください。

Aベストアンサー

使い方としてはイーサネットを置き換えるようなものです。
昔はWANでよく使っていたのですが、高価であることもあり最近では新規構築することは少ないですね。
ただし、帯域保障が必要な網までのアクセス回線としては今でもATMをそこそこ使っています。

そんな訳で古くからあるコンピュータシステムを使った場合は結構利用しているかもしれません。


このカテゴリの人気Q&Aランキング

おすすめ情報