人に聞けない痔の悩み、これでスッキリ >>

numpyの動作確認を行ったのですがエラーが出力されましたので、
対応策を教えて下さい。
>>> import numpy
>>> numpy.test()
Running unit tests for numpy
Traceback (most recent call last):
File "<stdin>", line 1, in <module>
File "/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/numpy/testing/nosetester.py", line 340, in test
self._show_system_info()
File "/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/numpy/testing/nosetester.py", line 193, in _show_system_info
nose = import_nose()
File "/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/numpy/testing/nosetester.py", line 71, in import_nose
raise ImportError(msg)
ImportError: Need nose >= 0.10.0 for tests - see http://somethingaboutorange.com/mrl/projects/nose

よろしくお願い致します。

A 回答 (1件)

・原因:メッセージに書いてある通り


nose = import_nose()     # noseをインポートした
mportError: Need nose >= 0.10.0 for tests # noseは0.10以上が必要

noseはここ!
http://somethingaboutorange.com/mrl/projects/nose


・対策:
noseを新しいのに入れ替える.現行バージョンはVer1.3.4だそうです。
    • good
    • 1

お探しのQ&Aが見つからない時は、教えて!gooで質問しましょう!

このQ&Aを見た人が検索しているワード


人気Q&Aランキング