忙しい現代人の腰&肩のお悩み対策!

初心者でさっぱり分かりません。
ActivePerl 5.6のPPMを利用してJcodeをインストールしたいのですが、どのようにしたら良いのか分かりません。
http://openlab.ring.gr.jp/Jcode/index-j.html
上述のホームページも参照してみたのですが、さっぱり分かりません。

初心者にも分かるように教えていただきたいのですが、よろしくお願いします。

このQ&Aに関連する最新のQ&A

A 回答 (3件)

#1>解決策はありますでしょうか?


私は、実は、ActivePerl 5.8を使っているんです。
そのためか、同じような動作にならないものを書いてしまってすみませんです。

解決策になるかどうかはわからないんですが、
エラーメッセージは、
インストールしようとしたパッケージがあなたのシステム用ではないというような意味なので、
例えば、5番をインストールしてみたらどうでしょうか?
5. Jcode [0.88] Japanese Charset Handler
6. Jcode [2.00] Japanese Charset Handler
7. Jcode [2.03] Japanese Charset Handler
ppm> install 5

うまく行くかどうかは自信はないですが…
このさい5.8にしてみるというのも1つの方法ですが・
たよりないアドバイスですみませんデス
    • good
    • 0
この回答へのお礼

引き続き早急な回答をありがとうございます。
5番のインストールを試みましたが、結果は同じでした。

ActivePerlのバージョンを上げても問題は無かったので、アドバイスどおり、5.8にしてみたところ、無事インストールできました。

ActivePerl 5.6ですと、Jcodeのインストールはできないのでしょうか。

いずれにせよ大変助かりました。ありがとうございました。

お礼日時:2005/08/03 16:51

そもそも Perl 5.6 の多国語 (UNICODE) まわりは結構クセがあるみたいで, Perl 5.8 がリリースされた今と

なっては積極的に Perl 5.6 を使う意味もないようですが....
    • good
    • 0
この回答へのお礼

アドバイスありがとうございました。
なるべく環境を変えずにできたらと考えていましたもので。

お礼日時:2005/08/05 23:22

コマンドプロンプトを開いて


ネットワークが利用できる状態(接続されている時に)で

ppm

と入力します。
PPM - Programmer's Package Manager version 3.1.
Copyright (c) 2001 ActiveState Corp. All Rights Reserved.
ActiveState is a devision of Sophos.

Entering interactive shell. Using Term::ReadLine::Stub as readline library.

Type 'help' to get started.
ppm>
とか表示されて入力待ちになるので、

ppm> s Jcode

と入力すると、現在利用できるパッケージの一覧が表示されます。
Searching in Active Repositories
1. Jcode [0.88] Japanese Charset Handler
2. Jcode [0.86] Japanese Charset Handler
3. Jcode [0.87] Japanese Charset Handler
4. Jcode [0.88] Japanese Charset Handler
[]の中の数字がバージョンで一番大きい数字のものを通常選びます。

ppm> install 1

とすると、1番のパッケージをインストールできます。

Successfully installed Jcode version 0.88 in ActivePerl (バージョン)
と表示されれば成功です。

ppm>quit

と入力してppmを終了します
    • good
    • 0
この回答へのお礼

早速、返答をいただきありがとうございます。

当方にてコマンドプロンプトから「ppm」を実行すると
「PPM interactive shell (2.2.0) - type 'help' for available commands.」
と表示されBLUEPIXYさんのバージョンより低いためか、コマンドを入力してもエラーになってしまいます。「ppm3」を実行するとコマンド自体はエラーにならないのですが、コマンドを入力すると

ppm> s Jcode
Searching in Active Repositories
1. HTML-Summary [0.017] module for generating a summary from a web page.
2. Jcode [0.82] Japanese Charset Handler
3. Jcode [0.86] Japanese Charset Handler
4. Jcode [0.87] Japanese Charset Handler
5. Jcode [0.88] Japanese Charset Handler
6. Jcode [2.00] Japanese Charset Handler
7. Jcode [2.03] Japanese Charset Handler
ppm> install 7
Package 7:
Error: no suitable installation target found for package Jcode.
ppm>
となってしまいます。

解決策はありますでしょうか?

お礼日時:2005/08/03 11:59

このQ&Aに関連する人気のQ&A

お探しのQ&Aが見つからない時は、教えて!gooで質問しましょう!

このQ&Aを見た人が検索しているワード


人気Q&Aランキング