自分のお店を開く時の心構えとは? >>

Ciscoルータ2台、スイッチ4台で研修用のネットワークを構築しております。

その中の1台のルータ(cisco2501)にtelnetをしようとすると以下のようなエラーが出てtelnetができません。
*ちなみにpingは問題なく通ります

% Connection refused by remote host


アクセス制限もかけていませんし、他にtelnetをしているユーザも存在しません。
このルータを介しての通信にも問題なく、telnetだけができない状態です。

このエラーが出る原因として何が考えられるのでしょうか?
教えていただけると幸いです。

このQ&Aに関連する最新のQ&A

A 回答 (4件)

もう、解決済みかもしれませんが、状況を教えてください。



AというルータとBというルータがあるとして、コンソール端末からAルータにコンソールポートでログインし、AルータからBルータにTelnetをおこなっているという状況ですか?
    • good
    • 1

line vty に exec-timeout 0 0 を設定しているために


セッションが残ったままとなってセッション数がオーバーしている
のでは?

参考URL:http://www.nishiya-it.net/cgi/xoops/modules/bxTi …
    • good
    • 0
この回答へのお礼

ルータの電源OFF→ONにて復旧しております;
(こんなことは研修用ネットワークゆえ気軽にできる事ですが…)

ご回答と参考URLを見るに、セッション数オーバーの可能性が高そうです。
以後同様の事象が起こった際にはsh line コマンドでセッションの確認をしてみます。

ご回答いただきありがとうございました。

お礼日時:2007/12/17 09:30

こちらの例にあるように、アクセスリストによって、telnet が制限されているような気がします。



http://xfreak.com/ccna/lab/scenario/nph-bbs_sys. …
    • good
    • 0
この回答へのお礼

ご回答ありがとうございます。

一応質問にもかかせていただきましたが、アクセスリストのような
アクセス制限はかけておりません。


↓ちなみにshow runにて表示されるコンフィグは以下となります↓
------------------------------------------------------
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router_A
!
enable password cisco
!
!
!
!
!
ip subnet-zero
!
!
!
!
interface Ethernet0
ip address 192.168.1.1 255.255.255.0
!
interface Serial0
ip address 192.168.0.1 255.255.255.0
clockrate 64000
!
interface Serial1
no ip address
shutdown
!
ip classless
ip route 192.168.2.0 255.255.255.0 192.168.0.2
ip http server
!
!
line con 0
exec-timeout 0 0
password cisco
login
line aux 0
line vty 0 4
exec-timeout 0 0
password cisco
login
!
end
------------------------------------------------------

お礼日時:2007/12/13 10:55

リモート側から接続しようとしていませんか



telnet接続を ローカル側に制限(ルータと同一サブネットからの接続のみ許可)している可能性があります
    • good
    • 0
この回答へのお礼

ご回答ありがとうございます。

リモート側からもローカル側からも接続できない状態です。
また接続に関しましては特に制限しておりません。

コンソール接続はもちろん可能ですが・・・

お礼日時:2007/12/13 10:50

このQ&Aに関連する人気のQ&A

お探しのQ&Aが見つからない時は、教えて!gooで質問しましょう!

このQ&Aを見た人はこんなQ&Aも見ています

このQ&Aを見た人が検索しているワード

このQ&Aと関連する良く見られている質問

Qtelnetやftpでの接続が拒否される;;

雑誌の付録のRedHatLinux7.3をインストールしました。
インストールが完了した後に、別端末からtelnet接続を試みたところ、
下記のように接続が拒否されてしまいました。
-------------------------------------------------------------------
C:\>telnet 192.168.0.3
接続中: 192.168.0.3...ホストへ接続できませんでした。 ポート番号 23.
対象のコンピュータによって拒否されたため、接続できませんでした。
-------------------------------------------------------------------

また、インストール時に匿名FTPもインストールするように選択
したのですが、こちらも接続しようとすると拒否されてしまいます。
-------------------------------------------------------------------
C:\>ftp 192.168.0.3
> ftp: connect :エラー番号が不明です

linuxのターミナルから接続しようとすると、
$ftp 192.168.0.3
ftp:connect:Connection refused
-------------------------------------------------------------------

何が原因でtelnetやftpが利用できないのでしょうか?
また、どのようにすれば利用できるようになるのかご教授していただきたいと思っております。

よろしくお願いいたします。

雑誌の付録のRedHatLinux7.3をインストールしました。
インストールが完了した後に、別端末からtelnet接続を試みたところ、
下記のように接続が拒否されてしまいました。
-------------------------------------------------------------------
C:\>telnet 192.168.0.3
接続中: 192.168.0.3...ホストへ接続できませんでした。 ポート番号 23.
対象のコンピュータによって拒否されたため、接続できませんでした。
-------------------------------------------------------------------

また、インストー...続きを読む

Aベストアンサー

RedHat Linuxのデスクトップ環境が使えるなら、Serviceconf で各種設定が行えます。
こちらで確認されてみては?

ftpとかtelnetくらいだと、xitend経由で利用する場合もありますので、そちらの方の知識が必要かもしれません。

参考URL:http://www.redhat.co.jp/manual/Doc73/RH-DOCS/rhl-cg-ja/s1-services-serviceconf.html

Qpingでポートの指定

pingでIPアドレスを指定して、通信できるかどうかというのは
よく使いますが、pingでポートを指定して応答するかどうかは調べられるのでしょうか?

よろしくお願いします

Aベストアンサー

pingを含むICMPというプロトコルは、OSIの7レイヤで言うところのL2(同一セグメント内通信)とL3(IPルーティングされた通信)の両方にまたがる、ちょっと珍しいプロトコルです。

IPアドレスは指定できますが、別サブネットに属するIPアドレスに到達できればL3通信、できなければゲートウェイと呼ばれる同一サブネットに属する中継装置からの回答を得るという点でL2(MAC通信ではなく、同一セグメント内通信という意味)通信です。

ポート番号はL4で使用されるアドレスですから、L4機能の疎通確認はping(を含むICMP)ではできません。

FTPの疎通確認であれば、クライアントからサーバに対するTCP/21通信(FTP-CMD)が可能であること(サーバからクライアントへのTCP/21からの応答を含む)+サーバからクライアントに対するTCP/20通信(FTP-DATA)が可能であること(クライアントからサーバへのTCP/21からの応答を含む)が必要でしょう。

監視ソフトによるものであれば、
・クライアントからサーバへのログイン(TCP/21)
・クライアントからサーバへのlsの結果(TCP/20)
で確認すればよいでしょう。

pingを含むICMPというプロトコルは、OSIの7レイヤで言うところのL2(同一セグメント内通信)とL3(IPルーティングされた通信)の両方にまたがる、ちょっと珍しいプロトコルです。

IPアドレスは指定できますが、別サブネットに属するIPアドレスに到達できればL3通信、できなければゲートウェイと呼ばれる同一サブネットに属する中継装置からの回答を得るという点でL2(MAC通信ではなく、同一セグメント内通信という意味)通信です。

ポート番号はL4で使用されるアドレスですから、L4機能の疎通確認はping(を含む...続きを読む

QwiresharkでパケットモニタするとRetransmissionが多発しているという意味は?

現在、自分で作成したパケット送信クライアントプログラムをテストしており、3秒に1回のタイミングでインターネット上にあるサーバのグローバルipアドレスに対し、TCPパケットを発信させて受信するというテストを行っています。
しかし、3秒に一回データを送っているはずなのに、その間隔10秒とか20秒とか間隔が開いてしまう時があります。

wiresharkというパケットモニタソフトで送信側、受信側共にパケットモニタを行ってみたところ、”Retransmission”が多発しているということがわかりました。(tcp.analysis.retransmissionというフィルタ設定で検索)この現象はある時とない時があります。テストして10日ぐらい経つのですが、このパケットが確認されるのはお昼の12時頃と夕方の6時頃が多いのですが、このことからどのようなことが起こっていると考えられますか?

わかる方いらっしゃいましたらご教授よろしくお願いいたします。

Aベストアンサー

簡単に言うと「トラフィック過多によるパケットの再送が多発している」です。

噛み砕いて言えば「回線が混雑していて、送信したパケットが、他の誰かが送信したパケットと衝突(コリジョンが発生)してパケットが消えた。なので、もう一度、送り直した」と言う事。

>このパケットが確認されるのはお昼の12時頃と夕方の6時頃が多いのですが、このことからどのようなことが起こっていると考えられますか?

「お昼休み、終業時間の6時になると、みんな、メールをチェックしたり、個人的にインターネットを閲覧し、トラフィック過多が起き、回線が異常に混雑する」と言う事が起きていると考えられます。

解消するには以下の方法があります。
・「休み時間も、終業時間後も、プライベートでネットを使うな!」と言う「通達」を全社に出す
・社内LANを、トラフィック過多によるコリジョンが起きないよう高速で帯域のあるネットワークカード、LANハブ、ルーターに変える
・受信側と送信側を、社内LANから(電気的、アドレス的に)独立した別のLANにする

要は「混んでる時間帯なので仕方が無い」って事です。

簡単に言うと「トラフィック過多によるパケットの再送が多発している」です。

噛み砕いて言えば「回線が混雑していて、送信したパケットが、他の誰かが送信したパケットと衝突(コリジョンが発生)してパケットが消えた。なので、もう一度、送り直した」と言う事。

>このパケットが確認されるのはお昼の12時頃と夕方の6時頃が多いのですが、このことからどのようなことが起こっていると考えられますか?

「お昼休み、終業時間の6時になると、みんな、メールをチェックしたり、個人的にインターネットを...続きを読む

Qポートの80と443

こちらのサービス(https://secure.logmein.com/)を利用すると、インターネットを見られるサーバーのポートの80と443が空いていればルータやファイアウォールに特段の設定なく外部からサーバーを操作できるそうですが、逆にサーバーのポートの80や443を空けることには何か危険性があるのでしょうか。

Aベストアンサー

ポート80は一般的なHTTP、ポート443はHTTPSです。
この2つのポートがあいていなければインターネット接続(WEBブラウジング)は出来ません。
ですから、ほとんどのファイアウォールでこのポートは開いています。(インターネット接続を制限している社内LANでは当然閉じていますが)

ちなみに、よく使うポートとしてはFTPで20、21、SMTP(送信メール)で25、受信メールPOP3で110あたりです。セキュリティポリシー上、この辺は制限される事も多いですが、HTTP 80、HTTPS(暗号化用)443は通常閉じません。


危険性?
WEBプロトコルを使ってFTP的なファイル転送(WebDAV)やVPN等も出来るようになっています。当然そこにはある種の危険はつきものですが、WEBブラウジングに伴う危険と大きく変わりません。ウィルス等に感染していればこの2つのポートだけでも相当危険でしょうね。

参考まで。

QCISCOルータのIPアドレスの確認方法。

CISCOルータ自身のIPアドレスの取得方法が知りたいです。ブラウザから設定をしたいので、IPアドレスを知りたいのですが、そういったコマンドはあるでしょうか?(初心者すぎで、トンチンカンなことを言っているかもしれません)

ターミナルソフト?で特権モードに入るまではできたのですが…。

Aベストアンサー

> すみません、常識以前の質問なのでしょうが、IPアドレス等は、CISCOルータに直接設定しなくてはならないのでしょうか?

以前の回答のように、BBルータであればWAN側をDHCPで運用みたいなことはあるでしょうけど.......
(CiscoでもCisco1812Jみたいな機種はそのような運用はありかもしれません)

基本的には各interfaceに固定でIPアドレスを振って使うのが普通です
あと、interfaceに振られたIPアドレスを確認する方法として、
show interface
(省略形はsh int)
を実行すればinterfaceに割り振られたIPアドレスも含めてinterfaceの状態も確認することができます

QCatalyst2950の設定について

誰か教えてください。
ntpサーバの設定を入れたいのですが、
ntp clock-period xxxxxxxx
ntp server xxx.xxx.xxx.xxx prefer

上記のntp clock-period xxxxxxxxの部分は何をあらわしているのでしょうか?同期のようなことを聞いたのですが、xxxxxxxxの部分はほかのルータやスイッチの設定と数字は重複しても大丈夫なのでしょうか?

Aベストアンサー

クロックの補正値です。
人間が設定する必要のない項目です。

一般に、NTPソフトウェアが計算した時刻と、
ハードウェアとして内蔵しているの時計の時刻はずれます(ハードウェアクロックには誤差があるため)が、
その値をルータ自身が記録しておくための項目です。

ルータが再起動した際、NTPで正確な時刻を計算するまでは時間がかかるので、それまでの間、この値を使用して、ハードウェア時刻を補正してソフトウェア時刻を計算するため、コンフィグレーションに記録してあります。

ルータを一週間程度稼動させ、十分正確な時刻をNTPが計算できた頃、補正値の精度も高くなっていると考えられるので、その時点でコンフィグをセーブするのが望ましい運用です。

ルータごとにハードウェア時計の誤差は異なるはずなので、ほかのルータと異なる値になるのが一般的ですが、
この値がほかのルータと重複したとしても(または正確でない値がセットされたとしても)再起動後NTPの精度が上がるまでのソフトウェア時計精度が下がるだけなので、
それを気にしない人or組織には大丈夫だといえます。

詳しくは参考URLを参照してください。

参考URL:http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/ffun_r/ffrprt3/frf012.htm#wp1043358

クロックの補正値です。
人間が設定する必要のない項目です。

一般に、NTPソフトウェアが計算した時刻と、
ハードウェアとして内蔵しているの時計の時刻はずれます(ハードウェアクロックには誤差があるため)が、
その値をルータ自身が記録しておくための項目です。

ルータが再起動した際、NTPで正確な時刻を計算するまでは時間がかかるので、それまでの間、この値を使用して、ハードウェア時刻を補正してソフトウェア時刻を計算するため、コンフィグレーションに記録してあります。

ルータを一週間程...続きを読む

QCatalystのL2スイッチのIPアドレス設定

CCNA取得勉強の為に教えてgoo!の過去の質問を見ていたときに疑問が発生しました。
分かる方がいらっしゃいましたら教えてください。

http://oshiete1.goo.ne.jp/kotaeru.php3?q=1199795

疑問が発生したのは↑の質問なのですが、

Catalyst2950に、インターフェースに対してIPアドレスを割り当てることができるのですか?

自分の認識だと、
・Catalyst2950はL2SWなので、データリンク層の機器であるため、インターフェースに対しIPアドレスは振れない
・但し、TELNETでアクセスしたり、snmpTRAPをあげるため、(管理的な意味で)管理VLAN(デフォルトでは1)に対し、IPアドレスを割り当てることが出来る。

なのですが。もしこの認識が間違っていた場合、インターフェースにIPアドレスを割り当てる方法をご教示いただきたいです。
よろしくお願いします。

Aベストアンサー

ネットワークエンジニアをしております。

>Catalyst2950に、インターフェースに対してIPアドレスを割り当てる
>ことができるのですか?

言葉の問題になってしまいますよね。インターフェースという言葉は、「その対象に出入りするための口」という意味なので、使い方やその人の認識に依存する話だと思います。。。

「インターフェースに割り当てることができるか」ということであれば
可能でしょう。要は「どういうインタフェースを意味しているのか」というのが問題です。

No.3さんが回答されている通り、Catalyst2950のスイッチポート(物理インタフェース)にはMACアドレスは振られますが、IPアドレスは振れません。

スイッチの「管理VLAN」は「論理インタフェース」です。これにはIPアドレスを振ることができます。
このVLANに振るIPアドレスは、スイッチ装置自身を特定するアドレスだと思ってよいと思います。(PCに振るIPアドレスと同様です)

理解されていると思いますが
紹介されているURLでは、telnetでCatalyst2950にアクセスする方法を聞かれているものだと思いますが、
telnet経由でCatalyst2950スイッチにアクセスするためには、スイッチポートを管理VLANと同じVLANに所属させておけば、スイッチポート経由でスイッチにアクセスできます。

スイッチポートで認識するPDU(プロトコルデータユニット)はフレームであり、そのアドレスはMACアドレスなど(メディアに依存)です。そのフレーム中にカプセル化されているパケットの(使うプロトコルがIPであれば)IPアドレスやそのほかのデータはフレーム中にカプセル化されていて、スイッチポートでは認識されません。
スイッチポートでフレームのMACアドレス(タグVLANを使用していればVLAN他)などが認識されて、スイッチポートからスイッチ内部に入ることを許可されればカプセル化がはずされ(フレームヘッダがはずされ)、パケット(IPアドレス等)が検査されることになります。

ネットワークエンジニアをしております。

>Catalyst2950に、インターフェースに対してIPアドレスを割り当てる
>ことができるのですか?

言葉の問題になってしまいますよね。インターフェースという言葉は、「その対象に出入りするための口」という意味なので、使い方やその人の認識に依存する話だと思います。。。

「インターフェースに割り当てることができるか」ということであれば
可能でしょう。要は「どういうインタフェースを意味しているのか」というのが問題です。

No.3さんが回答されてい...続きを読む

QVLANを構成するときは、一つのVLANに一つのネットワークアドレス?

VLANについて、勉強しています。

VLANは、一つのネットワーク(アドレス)の中でスイッチによって複数のVLANに分ける、するものだと思っていたのですが、下記のページの図1-4を見ると、一つのVLANに一つのネットワークを割り当てているのですが、実際はこういう使い方をするのでしょうか?

よろしくお願いします。

http://itpro.nikkeibp.co.jp/article/COLUMN/20060919/248444/?ST=nettech&P=2

Aベストアンサー

>一つのルータで、複数のネットワークアドレスを割り当てることが可能なのですね…。

 VLANから始まった質問なのですが、話が複雑になるのでここでは別にしておいてください。 またルータのことを理解する上では、家庭などで使われるブロードバンドルータを意識すると理解しずらくなります。
ルータは一般的にはLAN(ネットワーク)間を接続することに使われ、その中の一つにLANではなくWANがあると理解されたほうが分かりやすいです。

 1台または複数のスイッチで構成されるネットワークは、1つのネットワークアドレスを持ちます。このようなネットワークが別にもあったとすると、このネットワークをお互いに接続するにはルータを用います。(スイッチ同士を繋いでしまったら、これは大きな一つのネットワークに拡大したにすぎません) ルータはこのネトワーク間の橋渡しをする装置で、例えばルータにポートが10個備わっていれば、10個のネットワークを相互接続することができます。

 ルータの機能は、このネットワーク間の接続(ルーティング:宛先IPアドレスによって送り出す先のポートを選択する機能)を行うものです。
 ネットワーク内の通信ではスイッチだけで可能ですが、ネットワーク外への通信はルータに任せます。 PCにはデフォルトゲートウェイを指定しますが、これは異なるネットワークへの通信の場合に送出するルータのアドレスを指定するものなのです。

 インターネットは、これが極めて大きくなったものと言ってもいいでしょう。 何万ポートもある大きなルータが存在するわけではなく、ルータの先に更にルータが接続され、更にその先にもルータが・・といった風です。
 試しに、PCのコマンドプロンプトからtrcertコマンド(例えばtracert www.xxx.co.jpのように)を入力してみてください。通過したルータのアドレスが分かります。

 上記はシンプルに説明したものですが、これにVLANが絡んだり、WANがあったり、ルータにも他にいろいろな機能があったりして理解しずらくなっていますね。

>一つのルータで、複数のネットワークアドレスを割り当てることが可能なのですね…。

 VLANから始まった質問なのですが、話が複雑になるのでここでは別にしておいてください。 またルータのことを理解する上では、家庭などで使われるブロードバンドルータを意識すると理解しずらくなります。
ルータは一般的にはLAN(ネットワーク)間を接続することに使われ、その中の一つにLANではなくWANがあると理解されたほうが分かりやすいです。

 1台または複数のスイッチで構成されるネットワーク...続きを読む

QCiscoルータを初期設定(工場出荷)に戻すには

Ciscoルータを初期設定(工場出荷)に戻すにはどうすればいいのでしょうか?enableパスワードがわかる場合とわからない場合で教えていただければとおもいます。
よろしくお願いいたします。

Aベストアンサー

Ciscoルータは他のルータと違ってマニュアルなどもついてないので初心者には大変ですよね(^^;

enableパスワードがわかるなら特権モードに入った状態で「erace startup-config」と入力します。
※ただしIOSのバージョンが古い場合は上記のコマンドが使えないので「write erace」と入力してください。

上記コマンドを入力した後再起動「reload」すればOKです。


次にenableパスワードがわからない場合。これは厄介ですね。
ルータのレジスタをいじるので注意が必要です。
下記URLにCisco2500の初期化方法が紹介されているので参考にしてください。

参考URL:http://bird.dip.jp/computing/cisco.html

Q「ホストへアクセスできませんでした」と表示される接続エラーの原因を掘り下げて詳しく調べる方法

WindowsXPです。DOSVの画面で telnet ***.***.***.*** とIPアドレスを入れて接続しようとすると「ホストへ接続できませんでした。ポート番号23:接続に失敗しました。」と表示されます。
接続できなかった原因として、
・ローカルのパソコンの設定がおかしい
・ルータの設定がおかしい
・接続先のパソコンの設定がおかしい
などいろいろな原因が考えられると思いますが、どこが原因なのかをもっと掘り下げて調査するには、どのような方法があるのでしょうか?

Aベストアンサー

dosプロンプトから
tracert ***.***.***.***
と打ってネットワークがどこまで通じているかの確認をどうぞ


人気Q&Aランキング

おすすめ情報