IBMAptiva745をHDD1ギガ+2ギガ(こちらが起動ディスク)で使ってました。OSは98です。

IBMの10ギガHDD、DTTA-351010を2つ手に入れ、まず1ギガを外し、IBM Disk Manager DiskGo Version2.50で起動ドライブをそれまでの2ギガから10ギガに変更しました。ここで2ギガを外し、もうひとつの10ギガを2ギガの代わりに繋いだところ、BIOSでは2つのHDDを認識してるのですが、OSが立ち上がらないのです。BIOSの起動オプションをHDD1だけ、HDD2だけ、HDD1・HDD2の順、HDD2・HDD1の順と試してみましたが駄目です。2つのHDDはローカルバスIDEコネクター1に繋いで、起動ディスクをマスター、2つ目をスレーブにジャンパーピンも設定してます。
2つのHDDのケーブルを繋ぎ代えても駄目です。ここで、2つ目の10ギガHDDのケーブルを外して起動するとちゃんと立ち上がります。と言う事は起動ドライブはきちんと従来の2ギガから10ギガに変更されています。

再び2つの10ギガHDDを繋いだ状態で今度は起動FDDから立ち上げるとCドライブには2つ目のHDDが入って、もちろん、ファイルも何も無く空っぽです。1つ目の起動HDDはD、E、F、G・・・・どこにもありません。

ここで、元々の起動ディッスク2ギガ(中身はそのまま)を2つ目の10ギガHDDの代わりに繋いだところ、OSは立ち上がるのですが、それまでCドライブだった10ギガがDドライブになり、2ギガがCドライブになり、起動ドライブが入れ替わってしまってました。この状態で再度BIOSの起動オプションを上と同じ様にに変えて試してみましたがこの状態は変わりません。ここで、フロッピー立ち上げで2ギガをフォーマットしてしまい起動すると、またOSをインストールしろという指示が出てきました。2ギガHDDを外して立ち上げると、またきちんと立ち上がります。

今度は、ローカルバスIDEコネクター2に繋いであるCD-ROMのケーブルを外して2つ目のHDDをそこに繋ぐと普通に立ち上がり、起動ディスクがC、もうひとつがDときちんと認識されます。2つ目のHDDとして2ギガ、10ギガ両方試しましたがこの状態に変りはありません。しかし、ローカルバスIDEコネクター1に繋ぐとやっぱりアウトです。

どうしたわけかさっぱり解りませんが、ローカルバスIDEコネクター1に2つHDDが認識されると今の起動ドライブじゃない方のドライブを起動ドライブとして認識してしまってる様にどこかで設定されてるのかと思うのですが、そうだとするとどこでこの設定を変えられるのでしょうか?そうじゃないとすると何が原因でしょうか?助けていただけたら幸いです。

このQ&Aに関連する最新のQ&A

A 回答 (3件)

Durandalさんの補足です。



希望するディスク構成に変更し、
起動ディスクで起動後、

    A:¥>

と表示されたら

    fdisk /mbr 

と入力しEnterキーを押すことで、
MBR(マスターブートレコード)が初期化され、
Windowsが起動できる状態になるのではないかと思います。

ただし複数のOSを切り替えて使用しているなどの場合は、
Windowsしか起動できなくなるので注意が必要です。

MBRについては、参考URLにて検索してはどうでしょう。

参考URL:http://www.ascii.co.jp/ghelp/
    • good
    • 0

MBRを無くしてしまったためにディスク構成の整合性が取れなくなった為です。


これはハードウェアの問題ではなくOS側の問題なので起動ディスクの再構築をするのが問題解決の近道でしょう。

この回答への補足

アドバイスありがとうございます。
そこで、すいません、

1. MBRって何ですか?

2.起動ディスクの再構築というのはどうやったらいいんでしょうか?OSを再インストールする必要があるのでしょうか?

補足日時:2001/02/05 16:48
    • good
    • 0

マスター・スレブの切替は(ショゥトピン)してますよね (^_^;)


まれに 切り替えても、マスターかスレブにしか成らないHDドライブが世に存在するようですね。
特に8.5G以下のに多いようです。
私も以前悩んだことがあります、そこは割り切って、マスターかスレブでしか、このドライブは使えないんだと、印を付けて使ってました、数年前なので、しばらく忘れていましたが、そう言う場合も、有りますので参考に。
    • good
    • 0

お探しのQ&Aが見つからない時は、教えて!gooで質問しましょう!


人気Q&Aランキング

おすすめ情報