先ほど、gooで回答を投稿し、「投稿」ボタンを押したところで突然、画面が文字化けしました!!
画面の上の方に
Warning: 1 is not a MySQL result index in inc_setup.php3 on line 249
という文字が出て、右クリックで「エンコード」を見ると「Shift-JIS」になっていたので、これを「自動選択」にすると元に戻りました。
昨日、Nimda対策のためにIE5.5のSP2をインストールしたのですが、これと何か関係があるのでしょうか??
(ちなみに、回答の投稿は昨日から何回かしましたが、文字化けしたのは1回だけです。)
文字化けの原因&対策をご存知の方は、教えてください!!

A 回答 (6件)

同じ事で悩んでいました。


今日9月24日に直っていました。

サイトの問題だったのでしょう。夜中にメンテナンスの予告がありましたから。
安心しました。
    • good
    • 0
この回答へのお礼

ほんとだ!!確かに直っています!!
よかった・・・・
ありがとうございます!!
安心しました(^_^)

お礼日時:2001/09/24 23:20

「教えてgoo」から利用しておらず、「OKWeb」から利用しているので、気付かなかったのですが、gooは「日本語EUC」で作成されており、OKWebは日本語シフトJISで作成されています。


IE5.Xシリーズは、元々エンコードの切替えがへたくそなので、最後に指定したエンコードを優先してしまうようです。
ですから、教えてgooから回答をクリックすると
goo(EUC)>OKWebデータベースに接続(S-JIS)
と、エンコードが切り替わり、投稿を終ると
OKWeb(S-JIS)>goo(EUC)
と、また切り替わる為に、文字化けが起こるのでは?

参考URLにMicrosoftの見解ページを載せました。

参考URL:http://www.microsoft.com/japan/support/faq/KBArt …
    • good
    • 0
この回答へのお礼

OKWebでは文字化けしないんですね!!
たびたびご回答いただき、ありがとうございました!!
URLも、参考にさせていただきます。

お礼日時:2001/09/24 00:03

 私も文字化け現象が出始めています。


 私もなんかのウイルスの対策でサービスパック2をインストールしました。
 回答する・・ボタンを押して送信した後の画面が文字化けしますね。
 
 いろんな人に同時に起こっていると言う場合は下手に自分のPCをいじらずに,サイトが対応してくれるまで待ったほうが良いと思います。
 しばらく様子をみましょう。
    • good
    • 0
この回答へのお礼

ありがとうございます。
他でも同様のご質問がたくさん出ているので、私のPCが原因でないらしいと分かって安心しました。
おとなしくサイトの方で対応してくれるのを待ちます・・・(ーー;)

お礼日時:2001/09/24 00:01

回答ではありませんが私も同じです。


gooに限り投稿して回答するをクリックすると症状が出ます。
そのたびに日本語自動選択にしています。

今回は果たして?

mitchelさん相乗りでごめんなさい
    • good
    • 0
この回答へのお礼

そうですか。私だけではなかったんですね!!
ちょっと安心・・・
他の質問でも同じ症状の人がいるみたいだし・・・
でも、何故なんでしょう???

お礼日時:2001/09/23 13:41

[自動選択]ではなく[日本語自動選択]を選んでください。

この回答への補足

言葉が足りずにすみません。
[日本語自動選択]を選んでいるのですが・・・

補足日時:2001/09/23 13:31
    • good
    • 0

>Warning: 1 is not a MySQL result index in inc_setup.php3 on line 249



気にする必要ありません。
サイト上の問題です。
    • good
    • 0
この回答へのお礼

そうなんですか!!
メッセージについては気にしなくてよいのですね。
ありがとうございます!!

ただ、先ほど「1回だけ」と書きましたが、この後で「質問する」のボタンを押すなどして画面が切り替わるたびに文字化けするようになりました・・・(T_T)
原因は何なのでしょう・・・??

お礼日時:2001/09/22 19:59

このQ&Aに関連する人気のQ&A

お探しのQ&Aが見つからない時は、教えて!gooで質問しましょう!

このQ&Aを見た人が検索しているワード


おすすめ情報