RedhatLinux7.1Jを使用しています。

http://www.jp.redhat.com/support/errata/RHSA/RHS …

以上のサイトから、7.1用のApache最新版を入手し、
インストールしようとした所、以下のエラーが表示されて
インストールに失敗してしまいます。


apache本体を導入しようとすると、「mod_~.rpm」がないって怒られて、
「mod_~.rpm」を導入しようとすると、apacheと競合すると怒られ、
結局アップグレードできないんです・・・。


<その1>
 rpm -Fvh apache-1.3.22-1.7.1.i386.rpm
  ↓
 エラー: 依存性の欠如:
  mod_bandwidthは apache-1.3.22-1.7.1 に必要とされています
  mod_putは apache-1.3.22-1.7.1 に必要とされています
  mod_throttleは apache-1.3.22-1.7.1 に必要とされています

<その2>
 rpm -ivh mod_bandwidth-2.0.3-2.i386.rpm
 rpm -ivh mod_put-1.3-2.i386.rpm
 rpm -ivh mod_throttle-3.1.2-3.i386.rpm
  ↓
 エラー: 依存性の欠如:
  apache < 1.3.22-1 mod_bandwidth-2.0.3-2 と競合します

このQ&Aに関連する最新のQ&A

A 回答 (1件)

全部まとめて指定してください。


こんな感じです。

rpm -Uvh mod* apache*
    • good
    • 0
この回答へのお礼

まとめて実行するとは、考えもしませんでした。
ありがとうございました!

お礼日時:2001/12/18 11:09

お探しのQ&Aが見つからない時は、教えて!gooで質問しましょう!

このQ&Aと関連する良く見られている質問

Qjavaws-1_2_0_01-linux-i586-i.zip

/usr/java/j2re1.4.1_01のなかに
javaws-1_2_0_01-linux-i586-i.zip
というものがありますがこれはいったいなんなのでしょうか?
ひらいてみるといろいろなファイルがみえます。
そのなかにinstall.shというものがありますがこれを
インストールするとどうなるのでしょうか?
インストールしてみようかとおもったのですが
インストールの方法がわかりません。
よろしくおねがいします。

Aベストアンサー

Java Web Startという機能です。
詳しくは下記URLを参考にしてください。

javaws-1_2_0_01-linux-i586-i.zipについて一番下に載っています
http://java.sun.com/j2se/1.4.1/ja/install-linux.html

Java Web Startについて
http://java.sun.com/j2se/1.4/ja/docs/ja/guide/jws/index.html
http://java.sun.com/products/javawebstart/ja/index_ja.html
http://www.utj.co.jp/XML/dev/java/dxjava_3.html

QAPACHEとTOMCAT連携が上手く行きません。(mod_jserv.so)

Redhat7.1でapache(1.3.12)とtomcat(3.2.3)の連携を行っていますが、ファイルクラッシュ?エラーメッセージが出てしまいます。
モジュールはjakartaサイトからダウンロードしてきました。
詳細は---
/etc/rc.d/init.d/httpd start
Starting httpd: [日付] [warn]Loaded DSO libexec/mod_jserv.so uses plain Apache 1.3 API,
this module might crash under EAPI!
(please recompile it with -DEAPI)
    [OK]
------
と表示されます。
”再度DEAPIと一緒にコンパイルしろ”と云う事なのでしょうが、ディレクトリ内を幾ら探してもそれらしいファイルは見つかりません。
[OK]が出ていると云う事は、上記以外は通っている事なのでしょうか?[FAILED]なら解りますが・・・。
どの様に復旧させれば良いのか、皆目見当が付きません。
ご存知の方、是非ご指導の程宜しくお願い申し上げます。
因みに、TOMCAT単体では稼動します。

Redhat7.1でapache(1.3.12)とtomcat(3.2.3)の連携を行っていますが、ファイルクラッシュ?エラーメッセージが出てしまいます。
モジュールはjakartaサイトからダウンロードしてきました。
詳細は---
/etc/rc.d/init.d/httpd start
Starting httpd: [日付] [warn]Loaded DSO libexec/mod_jserv.so uses plain Apache 1.3 API,
this module might crash under EAPI!
(please recompile it with -DEAPI)
    [OK]
------
と表示されます。
”再度DEAPIと一緒にコ...続きを読む

Aベストアンサー

いつも、お節介で、回答を書いていますが、回答したあとで、とんちんかんなアドバイスではなかった、間違ったことを言ってしまったのではいか、後悔しています。世間には、「何を言っているの?馬鹿な、いいかげんなことを言って」と、冷ややかな見方をされる方もおいでですが、困っているときはお互いさまです。

お答えする前には、少なからずそれなりの実機でのテストで、ある程度の確認をしてお答えしていますが、最近のApacheの経験がないので、アドバイスにあまり期待しないでください。
コンパイル済みのApacheが、使用しているLinuxでは、ダウンロードどした状態では使用できないようです。

エラーメッセージの内容は、DSO(Dynamic Shared Object) libexec/mod_jseerv.so(ソース・オブジェクト)が、plain(通常の)Apache1.3 APIを使用しているので、EAPI(Extended Applicaction Interface)のところで、クラシュしていることを表示しています。そのために、DEAPI-多分EPAIをDisableして、再度コンパイルすることを指示しています。多分、makeする際の、Makefileの定義のところだとは思いますが、どこかは、特定できません。
もし、場所がわかりましたら、再度、アップしましょう。

Apacheが起動したら、php言語ですね!

それでは、ご健闘を祈ります。

hogehoge ojin

いつも、お節介で、回答を書いていますが、回答したあとで、とんちんかんなアドバイスではなかった、間違ったことを言ってしまったのではいか、後悔しています。世間には、「何を言っているの?馬鹿な、いいかげんなことを言って」と、冷ややかな見方をされる方もおいでですが、困っているときはお互いさまです。

お答えする前には、少なからずそれなりの実機でのテストで、ある程度の確認をしてお答えしていますが、最近のApacheの経験がないので、アドバイスにあまり期待しないでください。
コンパイル済み...続きを読む

Qmod_sslをインストールしたら、他のmodとのエラーが出てしまいました。

お世話になります。

mod_sslをインストールしたら、Apache起動の際に、下記のエラーが発生しました。

[warn] Loaded DSO libexec/libphp4.so uses plain Apache 1.3 API, this module might crash under EAPI! (please recompile it with -DEAPI)
(他のmod_* についても出ました。)

mod_ssl自体のインストールが間違っているのでしょうか?
再コンパイルが必要とならない、インストール方法があるのでしょうか?
また、再コンパイルが必要な場合は、どのように再コンパイルをやるのでしょうか?
ご教授のほどよろしくお願いいたします。

OS:RedHat7.2
Apacheのソース:apache_1.3.24.tar.gz
mod_sslのソース:mod_ssl-2.8.8-1.3.24.tar.gz
open_sslのソース:openssl-0.9.6c.tar.gz

インストールの際に参照させていただいたURL:http://www15.tok2.com/home/masato/

phpについて
env CFLAGS="-O3 -DEAPI" \
をconfigureに追加して、再コンパイルを行いましたが、
状況は変わりませんでした。

お世話になります。

mod_sslをインストールしたら、Apache起動の際に、下記のエラーが発生しました。

[warn] Loaded DSO libexec/libphp4.so uses plain Apache 1.3 API, this module might crash under EAPI! (please recompile it with -DEAPI)
(他のmod_* についても出ました。)

mod_ssl自体のインストールが間違っているのでしょうか?
再コンパイルが必要とならない、インストール方法があるのでしょうか?
また、再コンパイルが必要な場合は、どのように再コンパイルをやるのでしょうか?
...続きを読む

Aベストアンサー

phpを再コンパイルする際に
make distclean
は行いましたか?

上記を行わないとconfiguの内容がキャッシュされて更新されない場合が
ありますのでもしおこなっていないようであれば一度お試しください。

Q起動時DRIVER_IRQL_NOT_LESS_OREQUAL(Smb_driver_sys)

先日ウインドウズ7から10にアップデートした時から起動時ブルーバックでこのメッセージが出るようになりました
対処法がわからず困っています。メッセージをなくす方法教えてください、よろしくお願いします。

Aベストアンサー

OSは違うかもしれませんが、同様のエラーメッセージに対して先日回答しています。
かなり残念な内容ですが、ご参考になれば。
https://oshiete.goo.ne.jp/qa/9067332.html

Qrpmコマンドで-iや-Uが使えなくなった

お世話になります。
以前,システムファイルが壊れ,fsck -Aコマンドでどうにか普及しました。
それから少し経って異常に気づきました。
rpmパッケージをインストールしようと,rpm -ihv [file] と打ち込んでも何も起きません。
でも,rpm -q [file]コマンドを使うとちゃんとそのrpmパッケージのバージョンが分かります。
なぜでしょうか?
rpmだけ再インストールしなおさなければならないですか?
もし再インストールしなければならないのならば,そのやり方を教えてもらえないでしょうか。
なんせ,rpmコマンドが使えないので…
どうか,よろしくお願いします。

Aベストアンサー

> cp -r bin /bin
これだと、/bin/bin ができちゃいます。
cp -r bin /
ですね。

tar -c bin usr etc | tar -C / -x
なんてのも、良く使われる方法です。


人気Q&Aランキング

おすすめ情報