教えてください。

iPlanet Web Server Enterprise Edition 4.0
を使用しています。
JSPファイルを使用しようと思ったのですが、この
4.0に対応した、JSPは、JSP0.92みたいです。

これを、JSP1.1に対応させたいのですが、そんな事は
できるんでしょうか?もしかして、出来ない??

さっぱり、わからないので、よろしくお願いします。
補足要求などあれば、言ってください。

A 回答 (1件)

だいぶたってしまったようですが、分かる範囲でお答えしときます。

参考程度に見てください。
まずバージョンの変更は無理と思います。
コンテナは各ベンダでServlet2.0、2.1、2.2、2.3の何れかの仕様で実装されています。
更に各ベンダはServlet仕様で定められていない仕様をその上に盛り込んでいます。
よって、必要なJ2EEのjarをバージョンアップさせても正常に動作するか私には不明です。
このServletのバージョンに対するJSPのバージョンは0.92、1.0、1.1、1.2です。
JSP1.1を使用したいのなら、Servlet2.2で実装されたコンテナを使用するしかないと思います。最新のAPサーバは殆どこのバージョンです。
    • good
    • 0

お探しのQ&Aが見つからない時は、教えて!gooで質問しましょう!


人気Q&Aランキング

おすすめ情報