冬物クリーニング最大49%OFFはコチラ

コマンドプロンプトを「管理者として実行」で起動した後、
ping 128.0.0.1
を行なうと、「一般エラー。」が出力されます。
他のIPv4のアドレスを入力しても同じ結果です。
クロスケーブルでXpと接続しているのですが、通信できません。
Xp側からpingすると unreachになります。
どのようなことが考えられますでしょうか?

教えて!goo グレード

A 回答 (8件)

いままでxp同士の接続と勘違いしてました。

示したURLはvista側は参考になりませんね。すいません。
(ワイヤレスの事も見落としてました。imola51様ありがとうございます)
vistaの共有設定はこちら。
http://www.microsoft.com/japan/technet/network/e …

なぜそれにこだわるのか理解できませんが、pingのunreadchable問題を先に解決したいのであれば、imola51さんが指摘したように、ファイアーウォールを止めてみて、再チャレンジ。

・ウィルス対策ソフトをインストールしてある場合はそのマニュアルに従う
・Windows標準のファイアーウォールの設定は
スタート>コントロールパネル>セキュリティー>Windowsファイアーウォールの有効化または無効化
で「無効」を選択し「OK」です。

でも、pingのunreadchableに拘るのは、あまり得策ではないと思いますけど。
    • good
    • 5
この回答へのお礼

ありがとうございます。
ファイアーウォールを解除したら自分へのPINGはできました。

お礼日時:2007/04/12 21:14

そのハブとストレートケーブルを使って、インターネットに接続できているのですか?


いるのなら、単に共有設定の問題だと思います。
いないのなら、ハードの問題なのかどうかを、ストレートケーブルとハブの構成でチェックすればよいと思います。
クロスケーブルでの接続はトラブル場合が多いので、ストレートケーブルとハブでうまく動いていない物を、いきなりクロスケーブルで試すのは止めた方が良いと思います。
    • good
    • 0
この回答へのお礼

ハブで、もう一台つないで計3台でテストしたところ、問題だと思っていたVISTAには問題なくてXpだけがエラーになることが判明しました。
その後、Xpで使用していたネットワークカードを別のに変更したらすべて解決しました。なんどか差し替えたりしたのでこわれちゃったんでしょうかね。おかげで机のまわりがパソコンとケーブルだらけでサイバーオタクみたいな感じになってしまいました。
皆様ありがとうございました。

お礼日時:2007/04/14 20:51

ネットワーク・セットアップ・ウィザードで


「インターネットに接続していないネットワークに属している」
を選んで設定を更新した時点で、それまで使用していたネットワーク設定が上書きされると思いますので、ネットワーク・セットアップ・ウィザードを実行する前にpingがどうたら、と言っても、意味ないと思います。

この回答への補足

色々とウイザードを実行してみたのですが、
やはり繋がりません。Xpからもvistaからもtimeoutになってしまいます。両方のファイアーウォールを無効にしてからもクロスケーブルからハブ経由のストレートケーブルにしてみたりしてもやはりtimeoutです。うーん。

補足日時:2007/04/13 07:56
    • good
    • 2

とりあえず、状況からして問題があるのはVista側のようですね。



ネットワークの設定的には、特に問題があるようには見えませんが、念のため、デフォルトゲートウェイを空白にしてください。

デフォルトゲートウェイと言うのは、ルータ等のアドレスを指定するところです。別ネットワークへの接続への問い合わせ先となります。
今回の場合、同一ネットワーク上ですので何が入っていても動くような気がしますが、自分のIPが入っているのは誤っています。

yosaku_sp2さんの書き込みを参考に、ファイアウォールやセキュリティソフトの設定を見直してみてください。

この回答への補足

ありがとうございます。
ご指摘にしたがって、ファイアウォールの設定を変更したところ
自分のIPにはpingができるようになりました。
しかし、まだお互いに相手を認識することができてません。
もうすこしです。

補足日時:2007/04/12 20:52
    • good
    • 0

自分のIPアドレスに対してPINGはできますよ。


ファイアウォール等のセキュリティが有効になってないでしょうか?

と、今、気づきましたが、ん、ん、無線LANのアドレス?

ケーブルで繋いでるのなら、有線のネットワークアダプタにアドレスを設定しないと、そりゃ応答がないような気が^^;

間違って、無線LANアダプタにIPアドレスを設定しているのでは?

2台のPCのそれぞれの有線のネットワークアダプタの設定を教えてください。

この回答への補足

pingはどこにも通らなかったものですみません。

■Vista側はこんな感じです。

C:\Windows\system32>ipconfig
Windows IP 構成
Wireless LAN adapter ワイヤレス ネットワーク接続:
接続固有の DNS サフィックス . . . :
リンクローカル IPv6 アドレス. . . . : fe80::d18a:282e:1bcf:dc0e%13
IPv4 アドレス . . . . . . . . . . : 192.168.11.4
サブネット マスク . . . . . . . . : 255.255.255.0
デフォルト ゲートウェイ . . . . . : 192.168.11.1
イーサネット アダプタ ローカル エリア接続:
接続固有の DNS サフィックス . . . :
IPv4 アドレス . . . . . . . . . . : 192.168.111.1
サブネット マスク . . . . . . . . : 255.255.255.0
デフォルト ゲートウェイ . . . . . : 192.168.111.1
Tunnel adapter ローカル エリア接続* 6:
接続固有の DNS サフィックス . . . :
リンクローカル IPv6 アドレス. . . . : fe80::5efe:192.168.111.1%15
デフォルト ゲートウェイ . . . . . :
Tunnel adapter ローカル エリア接続* 7:
接続固有の DNS サフィックス . . . :
IPv6 アドレス . . . . . . . . . . . : 2001:0:4136:e378:2034:2968:3f57:f4fb
リンクローカル IPv6 アドレス. . . . : fe80::2034:2968:3f57:f4fb%9
デフォルト ゲートウェイ . . . . . : ::
Tunnel adapter ローカル エリア接続* 12:
接続固有の DNS サフィックス . . . :
リンクローカル IPv6 アドレス. . . . : fe80::5efe:192.168.11.4%16
デフォルト ゲートウェイ . . . . . :

C:\Windows\system32>ping 192.168.111.1
192.168.111.1 に ping を送信しています 32 バイトのデータ:
一般エラー。
一般エラー。
一般エラー。
一般エラー。
192.168.111.1 の ping 統計:
パケット数: 送信 = 4、受信 = 0、損失 = 4 (100% の損失)、

C:\Windows\system32>ping 192.168.111.5
192.168.111.5 に ping を送信しています 32 バイトのデータ:
一般エラー。
一般エラー。
一般エラー。
一般エラー。
192.168.111.5 の ping 統計:
パケット数: 送信 = 4、受信 = 0、損失 = 4 (100% の損失)、

■Xp側はこんな感じです。
H:\Documents and Settings\Naoyuki>ipconfig

Windows IP Configuration

Ethernet adapter ローカル エリア接続:

Connection-specific DNS Suffix . :
IP Address. . . . . . . . . . . . : 192.168.111.5
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . :

H:\Documents and Settings\Naoyuki>ping 192.168.111.5

Pinging 192.168.111.5 with 32 bytes of data:

Reply from 192.168.111.5: bytes=32 time<1ms TTL=128
Reply from 192.168.111.5: bytes=32 time<1ms TTL=128
Reply from 192.168.111.5: bytes=32 time<1ms TTL=128
Reply from 192.168.111.5: bytes=32 time<1ms TTL=128

Ping statistics for 192.168.111.5:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 0ms, Maximum = 0ms, Average = 0ms

H:\Documents and Settings\Naoyuki>ping 192.168.111.1

Pinging 192.168.111.1 with 32 bytes of data:

Request timed out.
Request timed out.
Request timed out.
Request timed out.

Ping statistics for 192.168.111.1:
Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),

補足日時:2007/04/11 21:23
    • good
    • 1

linux等のUNIX系OSでは一般に自分のIPにpingを打てば帰ってきますが、Windowsでは、試してみましたが、帰ってこないようです。



ところで、pingを打つこと自体は目的ではないのですから、その事はあまり気にせずに
> ご指摘の通りファイル共有やネットワーク通信がしたい
の問題に集中しましょう。
http://vcl.vaio.sony.co.jp/support/special/netwo …
のどの段階でうまくいかないのでしょうか?
    • good
    • 0

ひょっとして自分のIPにpingを打ってませんか?



クロスケーブルで接続して、何がしたいのですか?
ただ単にpingが打ちたい訳ではないですよね?

ファイル共有がしたいのならば…
という前提で、説明が載ってるページを探してみました。

2台のxp同士をクロスケーブルで接続する設定の説明の例のURLを書いておきます。

参考URL:http://vcl.vaio.sony.co.jp/support/special/netwo …

この回答への補足

回答ありがとうございます。
ご指摘の通りファイル共有やネットワーク通信がしたいのですが、
うまくいきません。
自分のIPアドレスに対してもpingできると思うのですが、
違いましたでしょうか?
相手側のIPアドレスに対しても「一般エラー。」が返ってきます。
ストレートケーブルとハブで接続してみても、同様にエラー
です。相手側からpingしても同様です。
2台は隣同士なんですが、近くて遠くは男女の仲状態です。

補足日時:2007/04/10 23:31
    • good
    • 0

ループバックアドレスは


127.0.0.1
ですよ。タイプミスですか?

この回答への補足

C:\Windows\system32>ipconfig
Windows IP 構成
Wireless LAN adapter ワイヤレス ネットワーク接続:
接続固有の DNS サフィックス . . . :
リンクローカル IPv6 アドレス. . . . : fe80::d18a:282e:1bcf:dc0e%13
IPv4 アドレス . . . . . . . . . . : 192.168.11.4
サブネット マスク . . . . . . . . : 255.255.255.0
デフォルト ゲートウェイ . . . . . : 192.168.11.1
- (省略) -

C:\Windows\system32>ping 192.168.11.4
192.168.11.4 に ping を送信しています 32 バイトのデータ:
一般エラー。
一般エラー。

となってしまいます。

補足日時:2007/04/10 21:38
    • good
    • 0
この回答へのお礼

ごめんなさい。間違っておりました。
ループバックは通りました。

お礼日時:2007/04/10 21:37

お探しのQ&Aが見つからない時は、教えて!gooで質問しましょう!

このQ&Aを見た人はこんなQ&Aも見ています

教えて!goo グレード

人気Q&Aランキング