Linuxの初心者です。
LinuxからADSLでインターネット接続を試していますが、失敗しました。

OS:RedHat7j
接続ツール:NTT東日本からのフレッツ接続ツール

インストール手順に従ってファイルをコピーしたり編集したりしました。
ところが!!
start-pppoeコマンドを実行したら何も反応しません。
status-pppoeコマンドを実行して見ると次のメッセージが出ます。

There are no active PPPoE sessions runing.
意味がわかりません。

ちなみにLinuxはWinMEと一台のマシンに共有されてます。
WinMeでは問題なく接続できます。
Linuxを始めて一週間しか経ちませんので詳しく教えてください  -,.-

このQ&Aに関連する最新のQ&A

A 回答 (3件)

Netscapeヶ使えないということなので、DNSサーバーの設定とdefault gateway


の設定を確認するべきです。
default gatewayは、DHCPなので、プロバイダーから貰ってきていると思います。
そのため確認だけしてください。
netstat -rn です。
DNSは、nslookupで確認してください。プロバイダーからDHCPで貰ってくるのか、自分で設定するのかは、ケースによって違うので確認してください。
設定ファイルは、/etc/resolv.confです。
その他のツールでも設定できると思います。
    • good
    • 0

う~ん...NTTで配布しているんですね...(-_-;


元のプログラムはなんなんだろう....

start-ppoeの内容がちょっときになります。


/var/log/messagesとかには接続の際のメッセージとかでていないでしょうか?

% su
# cd /var/log
# grep -i ppp *

とかするとエラーの出力されているファイルがわかるかもしれません。

ネットワークカードが認識されているかは

% /sbin/ifconfig -a

等として eth0があるかでわかるかとおもいます。

この回答への補足

ご返事ありがとうございます。
配布されたツールを使わなくても出来るんですね。
回答にしたがって次のように試してみました。

1./sbin/ifconfig -a を実行しました。カードは認識されてますでしょうか。
すると、次のようにメッセージが出ました。
eth0 Link encap:Ethrnet HWaddr 00:00:39:94:39:09
   UPBROADCAST RUNNING NOARP MULTICAST MTU:1500....
   RX (すべてが0)
   TX (すべてが0)
IO  ....(上のメッセージと似たようなもの)

2.rp-pppoe-3.0-1.i386.rpmとrp-pppoe-gui-3.0-1.i386.rpmはどこからインストールするのですか。(redhat7j CDの中身の覗いてみましたが見つかりませんでした)
それで、直接adsl-setupを起動して次のように設定しました。
USERNAME:guest@flets(アサヒネットも、、、)
INTERFACE:default(如何入れれば良いでしょう。)
Activate-on-demand:no
DNS:Do not adjust
Firewalling:STANDALONE
それで adsl-Stratを実行したがTIMEOUTで終りました。
モデム側のLINK(二つ)のLEDが電灯したまま何も反応はありませんでした。
3.Logは開いて見たんですが分かりません。-,.-

ちなみに、プロバイダはアサヒネットです。DNSはWinMEでは設定してません。
よろしくお願いします。

補足日時:2001/05/02 23:23
    • good
    • 0
この回答へのお礼

ハッハッハ!!(追加です。)

ただいま次のように設定を変更したところ接続に成功しました。(?)

USERNAME:My@アサヒネット
INTERFACE:eth0
Activate-on-demand:no
DNS:Do not adjust
Firewalling:NONE

adsl-statusコマンドでもちゃんとプロバイダからIPアドレスも割り当てられてました。
ところが!!!!
Netscapeからどこにもアクセスが出来ません。何も開けません。何かを設定しなければなりませんか。

お礼日時:2001/05/03 00:32

> インストール手順に従ってファイルをコピーしたり編集したりしました。



これを詳しく書いていただかないといかんともしがたいです。

自分だったら、
・rp-pppoe-3.0-1.i386.rpmをインストールする。
・rp-pppoe-gui-3.0-1.i386.rpmをインストールする。
・/usr/sbin/adsl-setupを実行しNTTからきた設定情報を設定します。
・/usr/sbin/adsl-startとする。
・/usr/sbin/adsl-statusで状態を確認する。

といったところかと思います。
NICが正しくインストールされているのは前提です。
    • good
    • 0
この回答へのお礼

ありがとうございました。

インストールは次のように行いました。

1.pap-secrets、chap-secretsの二つのファイルを作って /etc/pppの下におきました。ファイルの内容は次の一行で記述しました。(NTTのテストサーバーです)

guest@flets * guest *

2.CDROMに付属したファイルをそれぞれ次の場所に入れました。
cp /mnt/cdrom/linux/release/pppoed-2.2 /usr/local/bin/pppoed
cp /mnt/cdrom/linux/release/start-pppoe /usr/local/bin
cp /mnt/cdrom/linux/release/stop-pppoe /usr/local/bin
cp /mnt/cdrom/linux/release/status-pppoe /usr/local/bin
cp /mnt/cdrom/linux/release/options.pppoe /etc/ppp

3.start-pppoe ファイルの中のUSERIDに"guest@flets"を設定しました。
4.これが一番怪しいですけれども、、、
/etc/resolv.confのファイルは殻です。DNSは設定してません。
理由はWinMEでこの設定を行わなくても大丈夫だったからです。

以上の設定から次のコマンドを送ってみました。
/usr/local/bin/start-pppoe
すばやく次の行に移り、、モデムのLEDも反応ありません。
LANカードがLINUXで認識されないことはありますか。

またよろしくお願いします。

お礼日時:2001/05/02 00:28

このQ&Aに関連する人気のQ&A

お探しのQ&Aが見つからない時は、教えて!gooで質問しましょう!

このQ&Aを見た人が検索しているワード


このカテゴリの人気Q&Aランキング

おすすめ情報

カテゴリ