【無料配信♪】Renta !全タテコミ作品第1話

現在構築中のシステムでネットワークが不安定になっており、大変困っています。
解析方法や考え方等、ご存じの方いらっしゃいましたらお知恵を拝借できません
でしょうか?

WindowsServer2003 SP1のサーバにNICが2枚差し込んであります。
このサーバはWEBサーバ兼mailServerです。メールサーバは
SendMail AdvanceServer 1.3.2Jを使用しています。

NIC1:DMZのセグメントに接続(メトリック1)
NIC2:メンテ用のセグメントに接続(メトリック10)
現象としては、NIC1のゲートウエイの設定が失われてしまい外へ出られなくなって
しまうということです。現象の確認方法は以下の通りです。

■確認方法

1.他のプログラムからエラーで通知
2.該当サーバにログイン
3.ipconfigを実行
4.NIC1ののデフォルトゲートウェイが空欄となってしまう。

■解決法

1.NIC1をネットワークのプロパティで「修復」
2.ipconfigで確認
3.NIC1のデフォルトゲートウェイが空欄でなくなっている
4.ネットワーク設定が回復

NIC1,NIC2にはそれぞれ別のデフォルトゲートウェイが設定されています。
この現象は多いときには一日に複数回発生し、特に修復をしなくても自動で
元に戻っています。
ただ、外に出られないのは致命的なので解決したいと思っているのですが
皆目見当が付きません。以下のような点をアドバイス頂けるとありがたいです。

・この現象にたいする処方及び検証ポイント
・ハードか設定まわりかの切り分けの方法
・トラブルシューティングの考え方

他に必要な情報ありましたらすぐにアップさせていただきます。
何卒お力添えいただけまうようお願い致します。

このQ&Aに関連する最新のQ&A

A 回答 (4件)

Windows の世界では複数枚のNICを利用することを「マルチホーム」


と呼ぶそうです。
マルチホームの際に適切なルーティング設定は、Windows の各種設定
ダイアログボックスでは設定しきれません。
具体的にはコマンドラインから route add で(-p オプションを付与して)
設定する、ということですが、説明がとても長くなりそうなので
ポインタを示すことにします。

@ITのTIPS
http://www.atmarkit.co.jp/fwin2k/win2ktips/262ga …

Microsoft の文献
http://support.microsoft.com/default.aspx?scid=k …

混乱があるようなので基本的な部分を整理しておきます。
・default gateway はコンピュータ単位でひとつしかありえない。
・複数個設定できるがそれらは代替用であり、経路毎ではない。
・経路毎に異なる gateway を利用したいならば static route を
 設定する。
・static route を設定したところには代替を適用できない。

わからないところがありましたら、「どこのダイアログボックスで
どのような値をどこのフィールドに設定した」と route print の結果、
ネットワークの構成などとともに質問するようにしてください。

このレベルの質問は「メールサーバ構築サポート」などで、取引のある
SIerと契約を結んで、そちらに問いかけるものですョ。
こういった「質問コミュニティ」に解決を求めるのは無茶というものです。
--
    • good
    • 0
この回答へのお礼

みなさん、親切にご回答ありがとうございます。
この場を借りてmonda様、marimo_cx様、ooooooooooooo様にお礼を申し上げます。ありがとうございました。
なぜゲートウェイが二つあるかはネットワーク設計者に確認しますが、そもそもデフォエウトゲートウェイは2つあってはいけないというのが基本的なスタンスでそれでも使用する場合は独自でrouteを設定する必要があるということですね。
ここまで来るとネットワーク設計のポリシーにも関わるので一旦設計者と相談させて頂きます。
そもそも無謀な設定を無理矢理routeすることにちょっと怖さも覚えますので。


>このレベルの質問は「メールサーバ構築サポート」などで、取引のある
>SIerと契約を結んで、そちらに問いかけるものですョ。
>こういった「質問コミュニティ」に解決を求めるのは無茶というものです。

の件はごもっともです。いろいろご迷惑おかけしました。
とにかく皆様ありがとうございました。やっと糸口が見つかったのでこれから対処していきたいと思います。

お礼日時:2005/12/28 14:17

返事が遅れてしまってごめんなさい。


さて、先の回答です。

環境:
・当該ホストはDMZ上に配置。
・NICが2個。
・NIC1は外部ネットワーク(Internet)に向いており、DMZ上の
 ルータのアドレスが default gateway 。
・このルータのアドレスは XXX.XXX.XXX.XXX 。
・NIC2は内部ネットワークに接続しており、内部向けのルータ
 が同じセグメント内にある。
・この内部行きルータのアドレスは 172.16.1.1
・NIC2自身のアドレスは 172.16.1.10 、マスクビットは 24bit。
・内部ネットワークは 172.16.0.0 、クラスBのプライベート
 アドレス。
というふうに仮定してみます。

設定:
・NIC1のアドレスは「ローカルエリア接続1」のプロパティで
 設定する。
・ここでNIC1自身のIPアドレスとサブネットマスク値、および
 default gateway として XXX.XXX.XXX.XXX を設定する。
・NIC2のアドレスは「ローカルエリア接続2」のプロパティで
 設定する。
・ここでNIC2自身のIPアドレスとサブネットマスク値のみを
 設定し、default gateway の値は**空にしておく**。
・コマンドラインから、下記を実行する。

route -p add 172.16.0.0 mask 255.255.0.0 172.16.1.1

このように -p 付きで実行すればレジストリ(?)に格納され、
再起動しても消えません。
ほんとうはこのコマンドに if 2 のようにインターフェイスの
指定まで付ければ確実なのですが、Windows 自身がどのように
if の番号を振るのかイマイチ不明なので、なまじ付けない
ほうが良いようです。

-p オプションは add の時だけ指定できるオプションで、
これを付与しないと再起動毎に消えてしまいます。

設定結果は
  route print
で見えます。destination 毎に、期待した interface から
経路が設定されているか確認します。

残念なことに、こうやって設定した内容は確認するダイアログ
ボックスなどがありません。コマンドラインから
  route print
を実行して確認することしか出来ません。ひどいシロモノですね。
#だから Windows は…

もちろん質問者さんのネットワーク構成によって、設定する値は
異なります。例えば、destination をクラスBプライベートの
全ネットワークにしていますが、クラスBプライベートのうち
どこかだけを destination にするなら当然マスク値も異なります。
上記では例として値を埋めてみましたが、現実の状態にあわせて
値を適宜考えてみてください。
--
    • good
    • 0

>NIC1,NIC2にはそれぞれ別のデフォルトゲートウェイが設定されています。



>・トラブルシューティングの考え方

デフォルトゲートウエイが2つあるってどういう事でしょう?
デフォゲとはルーティングテーブルに該当が無い宛先のパケットをとりあえずブン投げれば後そっちのルーターが何とかしてくれるべぇというものです。
NIC2になんでデフォゲがあるのかわからないのですけど、何でですか?
    • good
    • 0

 デフォルフォゲートウェイは、1つです。


 複数枚のNICに設定出来ません。
 一つのNICで複数個設定出来るのは、使用出来ない(反応しない)IPだったら、次のを使うということで、どれか目的IPへ到達可能なゲートウェイを使うということではありません。
 従って、通常はInternet(不特定・大規模)側NICにデフォルトゲートウェイを設定し、他方は個別にルート設定します。
    • good
    • 0

このQ&Aに関連する人気のQ&A

お探しのQ&Aが見つからない時は、教えて!gooで質問しましょう!

このQ&Aを見た人が検索しているワード

このQ&Aと関連する良く見られている質問

Qデフォルトゲートウェイが表示されない

自作でPCを組み立て、Windows 7(32bit版)をインストールし、無事に起動したのですが、インターネットに接続できません。既存PC(Windows7 64bit版)でググって原因を調べてみたところ、デフォルトゲートウェイが表示されていない点が問題ではないかと思いました。
どうすればデフォルトゲートウェイが表示されるようになるでしょうか?また、デフォルトゲートウェイ以外にも何か原因として考えられることはあるでしょうか?

[状況]
・ipconfigで設定を確認すると、デフォルトゲートウェイに何も表示されない。
 (既存PCでは表示されている。)
・ルータに有線接続してアクセスしても、ルータの設定画面が表示されない。
・ネットワークと共有センターのトラブルシューティングを試みても改善されない。

[これまでに実施したこと]
・配線の確認 → 既存PCでLANケーブルに問題がないことを確認しました。
・DHCP等のプロファイル確認 → 既存PCと同じ設定であることを確認しました。
 (どちらもデフォルトの設定でした。)
・ドライバの更新 → ドライバの削除や、最新ドライバをインストールしても駄目でした。
・ルータのアクセス制限の解除 → 無線LANルータに既存PCを有線接続し、設定を確認した
 ところ、アクセス制限(MACフィルタ)の項目が設定されていたので解除しました。
 その影響かどうかわかりませんが、新PCと既存PCでデータのやり取りができるようになりました。
 制限解除後もルータの設定は既存PCからは可能ですが、新PCからはアクセスできません。
 無線LANのアクセス制限は有効のままです。

父の日プレゼント用に組み立てたPCなので、実際に使用する場所のネット環境は現在の環境とは異なります。ですので、できればIPを固定入力して解決するような方法は避けたいところですが、贅沢は言っていられません。
解決策をご教示頂きたく、よろしくお願いします。

自作でPCを組み立て、Windows 7(32bit版)をインストールし、無事に起動したのですが、インターネットに接続できません。既存PC(Windows7 64bit版)でググって原因を調べてみたところ、デフォルトゲートウェイが表示されていない点が問題ではないかと思いました。
どうすればデフォルトゲートウェイが表示されるようになるでしょうか?また、デフォルトゲートウェイ以外にも何か原因として考えられることはあるでしょうか?

[状況]
・ipconfigで設定を確認すると、デフォルトゲートウェイに何も表示されない...続きを読む

Aベストアンサー

ipアドレスが 169.254 で始まるAPIPAになっている、ということはありませんか?。
ネットワークアダプタのデバイスの状態は正常ですか?。
ping localhost の結果は正常ですか?(結果がipv6表示ならば ping 127.0.0.1 で確認)
ipconfigの結果が具体的でないので、何とも言えません。(結果を貼り付けて質問してください)

QWindows機で搭載CPU数がわかるコマンド

Windows機で搭載CPU数(物理的な数)がわかるコマンドを知っている方、教えてください。

Aベストアンサー

cmd
set
ナンバーオブプロセッサーズ=x

xがCPU数だと思う。
(いま目の前にデュアルCPU機ないので未確認だけど、だぶん合ってる)

QIP設定が突然消える?

こんばんは。ユーザアカウント兼PC管理を行っているものです。

何台かのクライアントPCで不可解な現象が発生しました。
固定IPを振っていたPCが突然接続できなくなり、
設定を見ると、午前中たしかに設定してあったIPが
DHCPに変わっているのです。
IP、サブネットマスク、デフォルトゲートウェイ、
DNS、DNSサフィックス(これなんでしょうか??)、WINS
が埋めて合ったのがきれいになくなっているのです。

OSが変になっていると思われますか??
見識ある方の情報いただければ幸いです。

環境:Windows XP SP1

Aベストアンサー

メーカーによっては、ネットワーク設定用のソフトが入っていて、それがOSの設定を上書きしてしまうことがあります。
無線LANの設定ソフトやネットワーク設定の切替ソフトなどは入っていませんか?

Qデフォルトゲートウェイの設定

デフォルトゲートウェイの設定について教えて頂きたい事があります。
IPアドレスを自動的に取得するに設定しているのですが、
コントロールパネルからネットワーク接続のローカルエリア接続より
状態のサポートタブを見てみると、デフォルトゲートウェイの欄が
空になっています。

WindowsXPで無線LANを使用しているのですが、
このデフォルトゲートウェイを設定しないと
外部機器(Wii)から見れないようです。。。

デフォルトゲートウェイの設定方法を教えて頂けないでしょうか。

宜しくお願いします。

Aベストアンサー

PCの起動時にIPアドレスを自動取得するプロトコルをDHCPといいます。
お使いになっている無線LAN親機なりBroadBandルータなりが DHCPサーバの役割を担っているはずですので,その設定画面でDefault GatewayのIPアドレスを設定しておけば,クライアントPCのIPアドレスとともにDefault GatewayのIPアドレスも自動取得します。
設定手順は,無線LAN親機/BroadBandルータのマニュアルに載っているでしょう。

QEXCEL の折り返し書式設定しても折り返し表示されない

エクセルで折り返し書式設定しても行の高さを変更しないと表示されない場合がありますが、理由をお教えください。手順に問題があるのであれば手順をお教えください。

Aベストアンサー

文字列を折り返して表示させる行には最低限の高さが必要なので、それより低く高さを設定しているのではないかと思います。
これを、自動的に行の高さを調整させて折り返して表示させたいなら、書式メニューの行をクリックして自動調整を押せばできます。
もし、レイアウトを崩したくないのであれば、ご注意ください。印刷結果なども変わると思います。

QStatic Route設定が消えてしまう

WindowsNTマシンに、ネットワーク経由でウィルスが入ってこないように、デフォルトゲートウェイを削除した後、通信の必要がある、3つの機器にだけroute add -p コマンドでStatic Routeの設定を行いました。

しかし、約1時間程、経過すると3つのうち、必要な2つのルーティング情報が消えてしまいます。(route printコマンドでも、消えている事を確認しました。3つ機器のうちの1つは緊急時のリモート接続用で、この設定だけは、何故か消えません)
ルータ、Bフレッツを経由して接続しています。

再起動すると、Static route設定は復活し、しばらくは接続できますが、1時間程放置しておくと、また接続出来なくなり、route printで確認すると2つの機器のルーティング情報が消えているのです。

何故このような現象が発生するのでしょうか?
しばらく使用しなくても、Static route設定が消えないようにするにはどうすればよいでしょうか?

Aベストアンサー

私も始めて知ったのですが、
WindowsNTで、ICMP DoNotFlagmentパケットを受信するとHOSTへのStaticルートが消えるようです。

http://support.microsoft.com/kb/244539/ja

解決策は、Windowsの最大MTUを下記リンク等を参照し、
Bフレッツ用(1454)に設定してください。
http://www.atmarkit.co.jp/fwin2k/win2ktips/800netmtu/netmtu.html

QタスクがSYSTEMアカウントで実行されません。

タスクがSYSTEMアカウントで実行されません。

タスクスケジュールでバッチファイルを実行しているのですが、
タスクの実行アカウントをAdministratorにすると問題ないのですが、
SYSTEMアカウントにすると実行されません。
正確には、バッチファイルの中で、
ローカルのファイルをLAN上のファイルサーバにコピーすることができません。
Administratorアカウントでは問題ありません。
また、バッチファイルの中のコピー以外については、
SYSTEMアカウントでも実行されています。
何が原因かわかりますでしょうか。
よろしくお願いします。

Aベストアンサー

http://support.microsoft.com/kb/417903/ja
タスクスケジューラで登録したタスクで行ったネットワーク ドライブへの接続は、「実行するアカウント名」に指定したユーザー アカウントの SMB セッションで行われます。タスクが実行された時に、システムに対話形式のログオンを行っていたユーザー アカウントが「実行するアカウント名」とは異なるユーザー アカウントであった場合、あるいは対話形式のログオンが行なわれていない状態(ログオフ状態)であった場合、このタスクが作成したドライブレターの削除や再割り当てを行うことができなくなります。
http://help.support.fcm.co.jp/__Help/FOV1-00012355/FOV1-00012358/S0004A3F5-0004A3FB?WasRead=1
「ローカルシステムアカウント」で実行されているサービスはネットワークドライブが見られないようにシステムによって制限されていることです。これは、Windowsの仕組みです。

Qネットワークのリストにコンピュータが表示されたりされなかったりします。

ネットワークのリストにコンピュータが表示されたりされなかったりします。

windows7proのパソコンから、スタートボタン→コンピュータ→ネットワークで
LANで接続しているコンピュータのリストが表示されますが、このリストにコンピュータが表示されたり、されなかったりします。 \\コンピュータ名で直接指定すると出てくるので接続が切れているわけではありません。表示されていないだけのようです。
また、表示されない場合はすべてのコンピュータが表示されないわけではなくて、1台か2台は表示されていて、後は表示されないという感じです。再起動すると直ります。
この症状が発生するのはwindows7のパソコンだけで、同じようにLANに接続されているXPのパソコンでは発生しません。
どうしてなのか分からず困っています。いつでも全てのコンピュータが表示されるようにしるにはどうしたら良いのでしょうか?

Aベストアンサー

反対にXPでは電源が入っていないコンピューターが表示されたという経験はありませんか? どうやらVista 以降は実際に稼働状態にあるパソコンを表示する様になった様です(想像ですので詳しい方はフォローを・・・)
USBメモリ等も実際にメディアが入っていないと表示されないのと同じで検索に時間がかかる?

さらに仕様としてデスクトップの表示のタイミングも変わったのも関係しているかもしれません(デスクトップに保存したはずのファイルが暫く表示されなかったり)。←ユーザーホルダーをCドライブ以外にしていると表示がさらに遅くなるかも?

さらにさらに7ではデフォルトでIPv6が有効になっており、IPv4より優先的に通信を行うようで、これがレスポンス悪化の原因になっているかもしれません。

IPv6が不要な場合、無効にすることで改善されるかもしれません。
コントロールパネル→ネットワークと共有センターよりネットワークアダプタのプロパティを表示しIPv6のチェックをOFFにします。

ダメもとで試してみてください。(IPv6は現時点では使用しているケースはまれです)
回答にはなっていませんが参考まで

追伸
 接続先のパソコンのショートカットを作っておくのも一つの方法かもしれません。

反対にXPでは電源が入っていないコンピューターが表示されたという経験はありませんか? どうやらVista 以降は実際に稼働状態にあるパソコンを表示する様になった様です(想像ですので詳しい方はフォローを・・・)
USBメモリ等も実際にメディアが入っていないと表示されないのと同じで検索に時間がかかる?

さらに仕様としてデスクトップの表示のタイミングも変わったのも関係しているかもしれません(デスクトップに保存したはずのファイルが暫く表示されなかったり)。←ユーザーホルダーをCドライブ以外に...続きを読む

Qデフォルトゲートウェイが使用できない

PCを起動させると最初はタスクバーのネットワークアイコンに黄色の三角がでてネット接続できません。がトラブルシューティングで自動かいけつをすると30秒ぐらいで「デフォルトゲートウェイは使用できません」との結果でネット接続できるようになります。以後再起動するまでネットは問題ありません。デフォルトゲートウェイが使用できないってどういうことなんでしょうか?ネットワークの知識がなくてよくわかりません。

Aベストアンサー

インターネット回線と家庭内や職場内のLANとの接続機器がデホルトゲートウェイに当たります、具体的にはブロードバンドルータがこれに該当します。

ルータからIPアドレスが正常に取得されていないものと思われます。
ちなみに、スタートからすべてのプログラム、アクセサリの中の、コマンドプロンプトをクリック。
コマンドプロンプト画面が表示されたら、ipconfigと入力し、EnterキーでIPアドレスの確認をされてみてください、接続時は192.168で始まる数値になっていると思います。
ネットワークアイコンに黄色の三角がでているときは、169.254とかの数値ではないでしょうか。

トラブルシューティングをされたとき、IPアドレスの再取得で接続可能になった物と推測します。

1、モデムやルータの電源を一度切り、数分してから電源投入してみてください。
2、ローカルエリア接続のアイコンを右クリックし、プロパティ、ハードウェア、デバイスマネージャとクリックし、ネットワークアダプタの項目に!印などが付いていたら、ドライバの更新なども効果があるかも知れません。

現段階での正格な原因箇所は特定できません、とりあえず2点確認してみてください。

余談ですが質問の際には、モデム、ルータ機種名、PC機種モデル名、OS名、このような現象に至った経過等も記述されたほうが的確な回答が得られますよ。

インターネット回線と家庭内や職場内のLANとの接続機器がデホルトゲートウェイに当たります、具体的にはブロードバンドルータがこれに該当します。

ルータからIPアドレスが正常に取得されていないものと思われます。
ちなみに、スタートからすべてのプログラム、アクセサリの中の、コマンドプロンプトをクリック。
コマンドプロンプト画面が表示されたら、ipconfigと入力し、EnterキーでIPアドレスの確認をされてみてください、接続時は192.168で始まる数値になっていると思います。
ネットワークアイコンに黄色...続きを読む

QVPN接続でVPNから先のサーバーに到達できない。

PC 特に、通信関係に関しては、素人同然のものです。

会社のサーバーに自宅からアクセスしようと、VPN 接続を試みています。
VPN そのものは接続を確認できたのですが、VPN から先、つまり、会社のサーバー (IBM System i) に到達できません。
( 当然ですが ping も通りません )
会社の他の同僚は、問題なく使用できているのですが、私のところだけつながりません。

念のためですが、VPN そのものは接続できています。
その先にあるサーバーにアクセスできないのです。
言わずもがなですが、自宅の PC で、通常のネット環境には問題はありません。
インターネットも、メールも問題なく動作しています。


この場合、System i に到達できない理由として、どのような事が考えられるのでしょうか?

ちなみに、会社側のルーターは、以前、別のルーターを使用していたのですが、その時は、問題なく使用できていた、という実績があります。
その時と、自宅環境は変わっていないはずです。( 少なくとも意識して変更した事はありません )

素人考えでは、なんらかの、アドレスの指定が重複しているのでは??
と考えているのですが、デフォルト・ゲートウェイとか、IP アドレスとか、自宅側のルーターのアドレスだとか、そのあたりではないかと思っているのですが
下手に変更すると、ネットそのものに繋がらなくなくなってしまいます。

変更するにしても、一箇所だけではなく、何箇所か整合性をとって変更する必要があるかと思いますが、詳しいところまでは知らないので、苦労しています。
御存知の方がおられたら、お教え頂けませんでしょうか?

冒頭述べましたように、当方、パソコン、特に、通信関係に関しては、ほぼ、素人同然です。
他に、似たような質問も見かけたのですが、少し、難しくて理解できませんでしたので、質問させて頂きました。

一応、環境の説明をしておきます。

●自宅のPC
(メーカー) ショップメイド
(OS) Windows XP Professional Version 2002 Service Pack 3
●自宅のルーター・通信回線
(通信回線) NTT Bフレッツ
(ルーター) NEC RV-230NE
(プロバイダー) BIGLOBE
●会社のルーター
(ルーター) Buffalo BHR-4GRV
●会社のサーバー
IBM System i ( AS/400 )

尚、現状、自宅のネット環境は、私が知りえる範囲で以下の通りです。

< VPN 接続前の ipconfig コマンドの結果 >
Ethernet adapter ローカル エリア接続:

Connection-specific DNS Suffix . :
IP Address. . . . . . . . . . . . : 192.168.1.3
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.1.1


< VPN 接続後の ipconfig コマンドの結果 >
Ethernet adapter ローカル エリア接続:

Connection-specific DNS Suffix . :
IP Address. . . . . . . . . . . . : 192.168.1.3
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.1.1

PPP adapter XXXXX:

Connection-specific DNS Suffix . :
IP Address. . . . . . . . . . . . : 192.168.1.8
Subnet Mask . . . . . . . . . . . : 255.255.255.255
Default Gateway . . . . . . . . . : 192.168.1.8

( PPP adapter XXXXX の部分は、VPN 接続先の会社側のものかと思います。XXXXX は会社名なので伏せさせて頂きました)

VPN 接続した状態で、サーバー IBM System i のアドレス 192.168.1.201 に対して ping コマンドを発行すると
C:\>ping 192.168.1.201

Pinging 192.168.1.201 with 32 bytes of data:

Request timed out.
Request timed out.
Request timed out.
Request timed out.

Ping statistics for 192.168.1.201:
Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),

以上のように、timed out となってしまいます。

また、補足情報ですが、会社側のルーターの設定で、ルーターのデフォルト・ゲートウェイが、私の自宅と同じ、192.168.1.1 であり、これが原因ではないかと思い、192.168.1.150 に変更しました。
しかし、結果は、何も変わりませんでした。
他の同僚については、問題なく繋がっています。

以上です。
長文になってしまいましたが、何卒、宜しくお願い致します。

PC 特に、通信関係に関しては、素人同然のものです。

会社のサーバーに自宅からアクセスしようと、VPN 接続を試みています。
VPN そのものは接続を確認できたのですが、VPN から先、つまり、会社のサーバー (IBM System i) に到達できません。
( 当然ですが ping も通りません )
会社の他の同僚は、問題なく使用できているのですが、私のところだけつながりません。

念のためですが、VPN そのものは接続できています。
その先にあるサーバーにアクセスできないのです。
言わずもがなですが、自宅の PC で、通常...続きを読む

Aベストアンサー

自宅とVPN接続先(会社)サブネットが同じ 192.168.1.0/24 なのでこのような結果になってしまいますね。

対応としては、
(1)自宅のネットワークを 192.168.1.0/24 以外にする
(2)VPN接続後にルーティング情報を追加する
になると思います。

(1)が可能であればこちらの方がいいですね。

(2)は 192.168.1.201 のサーバのみに接続出来ればいいのであれば以下のコマンドをVPN接続が確立した後に実行します。

route add 192.168.1.201 mask 255.255.255.255 192.168.1.8 metric 1 if xxx

xxxは route print コマンドで出てくるVPN接続のインターフェースIDです。
(if以降は無くてもいいかもです)
192.168.1.8の部分も接続時に可変となる可能性がありますのでその都度「PPP adapter XXXXX:」側のIPアドレスに合わせます。

これで 192.168.1.201 だけならば接続出来ると思います。
複数のサーバに接続が必要ならばその分このコマンドを実行する必要があります。

毎回毎回VPN接続時に入力が必要なので可能なら(1)ですね。

自宅とVPN接続先(会社)サブネットが同じ 192.168.1.0/24 なのでこのような結果になってしまいますね。

対応としては、
(1)自宅のネットワークを 192.168.1.0/24 以外にする
(2)VPN接続後にルーティング情報を追加する
になると思います。

(1)が可能であればこちらの方がいいですね。

(2)は 192.168.1.201 のサーバのみに接続出来ればいいのであれば以下のコマンドをVPN接続が確立した後に実行します。

route add 192.168.1.201 mask 255.255.255.255 192.168.1.8 metric 1 if xxx

xxxは route print コマン...続きを読む


人気Q&Aランキング