DELL の INSPIRON 4000 ( CPU : Mobile Intel Celeron 600MHz、
Video chip : ATI RAGE Mobility 128 ビデオグラフィックス)に、
FreeBSD PRESS No.2 の付録としてついていた、
FreeBSD 4.2-RELEASE をインストールしたのですが、

XF86Setup を実行すると、
「Press [Enter] to switch to graphics mode.
This may take a while ...」
と表示されたあと [Enter] を押すと、画面が真っ黒になって
その後うんともすんとも言わなくなってしまいます。
(Ctrl-Alt-Delete もききません。)
(/stand/sysinstall からとコンソールからの両方を試してみましたが
症状は同じです。)

 FreeBSD.ORG のページの検索等を使って、よく分からないなりに
自分で調べてみたのですが、解決方法がさっぱり分かりません。

 どのようにすれば XF86Setup が使えるようになるのか教えて
いただけませんでしょうか?

 関係あるかどうか分かりませんが…

1.インストール時の配布ファイルとして、 XFree86 のサーバでは
SVGA と VGA16 を選択しました。

2.XFree863.3.6 の README を読んでみると、
「3. Supported video-card chip-sets」の
ATI のところに Rage 128 とあります。
(一応 Rage 128 と Rage Mobility 128 との違いがあるのかもしれません。)

このQ&Aに関連する最新のQ&A

A 回答 (4件)

今 XFreeのページをみましたが、


Support for ATI Rage Mobility
となっているので、サポートされているでしょう。
 しかし、液晶のディスプレイを使用されているのでその辺で問題が起こっているのかもしれません。
 似たような環境のXF86Configを持ってくるか、テキスト版のXConfiguratorを使われてみてはいかがでしょうか?
    • good
    • 0

> Support for ATI Rage Mobility



"ATI Rage Mobility"と"ATI Rage Mobility 128"って
3DRageとRage128程度には違うのだと思ってたのですが
ATIのグラフィックカードは利用してないので勘違い
だったかもしれません。m(_ _)m
    • good
    • 0
この回答へのお礼

 結局私の技術では XFree86-3.3.6 を Inspiron 4000 で使うことはできなさそうです。
 他からの情報で、 XFree86-4.0.2 だと使えたとの報告があったので、試してみようと思います。
(ただ、 XFree86-4.0.2 をどうやって入れるかは別の問題として残っています。 Inspiron はネットにつないでないのです。)

お礼日時:2000/12/27 13:49

ATIのホームページをみるとWindows用のドライバーですら、「Rage128 Mobilityの場合液晶パネルや使用するハードウェアによりそれぞれのシステムに対して個別にカスタマイズが行われているのでGenericなドライバーはありません。

各ベンダーよりドライバーを入手して下さい」という主旨の説明があります。

それから推測するとおそらく Rage 128のドライバでは
xfree86は動作しないと思われます。

# xf86configでText画面から設定するという手段も
# ありますが、設定後うまく動作しない可能性が大です。
    • good
    • 0

XFree86Setupが使えない場合は、VGA16のサーバーが入っていないと使えないのですが、入っているということなので、堂なのでしょう。


確か、XFree86Setupを起動したときにデフォルトモードを使用するかどうかを聞いてきたと思うのですが、デフォルトを使用するようにすればよいかと思います。
真っ黒になってしまったときは、ビデオドライバーとカードがあっていないときになります。
そのときは、CTLR+Alt+BackSpaceで、Xサーバーをシャットダウンできると思います。
とりあえず、すべてのXサーバーを入れておいてはどうでしょうか。

参考URL:http://www.jp.freebsd.org/

この回答への補足

回答ありがとうございます。
デフォルトモードを使用するかどうか、聞かれませんでした。
また、すべてのXサーバを入れてみたのですが、症状は変わりませんでした。

 対応してないのかなぁ…?

 あと、Ctrl+ALt+Backspace でXサーバをシャットダウンすることができました。

 また新たな情報がありましたらよろしくお願いします。

補足日時:2000/12/24 22:12
    • good
    • 0

このQ&Aに関連する人気のQ&A

お探しのQ&Aが見つからない時は、教えて!gooで質問しましょう!

このQ&Aと関連する良く見られている質問

QXF86Setup が使えないです。助けて下さい。

RedHat7.2です。
テキストで、rootログイン後、
XF86Setup と、タイプしましたら、
bash: XF86Setup: command not found  と、返ってきたのですが、
XF86Setup を、使えるようにするには、どの様にするのでしょうか?

教えて下さいませ。m(_)m

Aベストアンサー

XF86Setup は無いので /usr/X11R6/bin/Xconfigurator を使用してください。

QFreeBSDでXfreeの設定

FreeBSD4.3-releaseでXfree86 4.1.0を設定しようとしているのですが、
インストール後、
#XFree86 -configure
で/root/XF86Config.newが作成されると本に載っているのですが、作成できません。
Fatal server error:
xf86EnableIO: Failed to open /dev/io for sxtended I/O
というメッセージが原因のようなのですが・・・

どうすれば良いのかわかりません。どなたか教えてください。。。

Aベストアンサー

ハードウェアの構成は?
4.1.0 ということは、標準のインストールじゃない気がするんですけど...。
4.1.0 以前のバージョンでは対応していないハードウェアってことでしょうか?

もう少し広い範囲のログを見せてもらわないと分からないと思います。
行の先頭に(EE) ってついてるのがエラーメッセージです。
その辺を教えていただけるともう少し様子がつかめるかも。

http://www.jp.freebsd.org/search.html
でエラーメッセージで検索したら、4.0.2 で同じメッセージがあったんですけど、
なんかよく分からないうちに出来てしまったみたいで、参考にならないですね。

参考URL:http://www.jp.freebsd.org/search.html

QXFree86 ver.4で文字化け

Vine Linux2.1(ftp版)を入れているデスクトップ機にXFree86 4.0.1を入れて
みました。
XFree86 3.3.6をアンインストールし、make WorldでXFree86 4をmake,インス
トールし、XF86Configを書き直し、.xinitrcを書き直し、ようやく
WindowManager( Window Maker ) を起動させることができました。

で、ネスケやEmacsを動かしてみたのですが、アプリケーション内では日本語
が表示される(潰れて見にくいですが)のですが、メニューの部分(ネスケ
の「編集」「表示」のところ)が文字化けしています。

Window Makerの設定でフォントをいろいろいじってみたのですが変わりませ
んでした。
デスクトップを右クリックした時に出るメニューは奇麗な日本語なのですが。

メニューの日本語を正しく表示し、ネスケの日本語表示も奇麗なものにする
にはどうすればいいのでしょうか。どなたか教えて下さい。

ちなみにビデオカードは3D BLASTER VoodooBanshee です。

Vine Linux2.1(ftp版)を入れているデスクトップ機にXFree86 4.0.1を入れて
みました。
XFree86 3.3.6をアンインストールし、make WorldでXFree86 4をmake,インス
トールし、XF86Configを書き直し、.xinitrcを書き直し、ようやく
WindowManager( Window Maker ) を起動させることができました。

で、ネスケやEmacsを動かしてみたのですが、アプリケーション内では日本語
が表示される(潰れて見にくいですが)のですが、メニューの部分(ネスケ
の「編集」「表示」のところ)が文字化けしています。

Wi...続きを読む

Aベストアンサー

/etc/X11/XF86Config中のSection "Module"という所で TrueTypeのフォントが
あるディレクトリは設定してあるでしょうか?

あと、Section "Files"という所でfreetypeのモジュールがロードされている
ようなら xttをロードしてみて下さい。

QXfree86がインストールできるCD

 FreeBSDのISOイメージを普通にインストールするとFree86がはいってこないようですがインストールのときにX-USERを選択してKDEでつかえるようにするために
Xfree86がはいったインストールCDをつくりたいのですがどうすればいいのでしょうか?WINCDR7をつかいます。よろしくおねがいします。

Aベストアンサー

FreeBSDのCDROMイメージファイルは以下から入手できます。

ftp://ftp.jp.FreeBSD.org/pub/FreeBSD/
ftp://ftp2.jp.FreeBSD.org/pub/FreeBSD/
ftp://ftp3.jp.FreeBSD.org/pub/FreeBSD/
ftp://ftp4.jp.FreeBSD.org/pub/FreeBSD/
ftp://ftp5.jp.FreeBSD.org/pub/FreeBSD/
ftp://ftp6.jp.FreeBSD.org/pub/FreeBSD/
ftp://ftp7.jp.FreeBSD.org/pub/FreeBSD/
ftp://ftp8.jp.FreeBSD.org/pub/FreeBSD/
ftp://ftp9.jp.FreeBSD.org/pub/FreeBSD/

ISO-IMAGES-i386/配下に各バージョンのISOファイルがありますので
ダウンロードしてCDRに焼いてください。

QXFree86 4.0.2 のインストールについて

以前 DELL Inspiron 4000 で XF86Setup がうまく動かないのでどうすればいいのか教えて欲しい旨の投稿をさせていただいた者です。

 結局 XFree86 の 3.3.6 が対応してないので 4.0.2 をインストールすればよいとのアドバイスをいただけました。
 そこで、 XFree86 を FTP でダウンロードしました。(ファイル名は X402src-1.tgz )

 そして、
1.「tar xzvf X402src-1.tgz」とすると、「xc」というディレクトリができてそこに解凍されたので、
2.「cd xc」と移動して、
3.「make World」とコンパイルし、
4.「make install」とインストールしました。
 手順とかについてよく分からなかったのですが、以上1~4をすることにより「/usr/X11R6」というディレクトリができたので、そんなに変なことはしてないと思ってました。

 しかしながら、「/usr/X11R6」には「XF86Setup」というコマンドがないのです。
 「XF86Config」を直接書くしかないのでしょうか?
(私の乏しい知識では自信がないので、できれば XF86Setup から使いたいのですが、どうすればよいかアドバイスをいただけないでしょうか?

 よろしくお願いします。

以前 DELL Inspiron 4000 で XF86Setup がうまく動かないのでどうすればいいのか教えて欲しい旨の投稿をさせていただいた者です。

 結局 XFree86 の 3.3.6 が対応してないので 4.0.2 をインストールすればよいとのアドバイスをいただけました。
 そこで、 XFree86 を FTP でダウンロードしました。(ファイル名は X402src-1.tgz )

 そして、
1.「tar xzvf X402src-1.tgz」とすると、「xc」というディレクトリができてそこに解凍されたので、
2.「cd xc」と移動して、
3.「make World」とコン...続きを読む

Aベストアンサー

XFree86 4.xにはXF86Setup は有りません。
理由は3.3.xと4.xのXF86Configの書き方が違うからです。

xf86cfgというのが代わりにあるのでそっちを使えばいいでと思います。XF86Setupとはまるで違った設定GUIなのでとまどうかもしれません。

もしうまくいかない場合は、たしかxf86configという昔からあるテキストベースのセットアップユティリティが有るのでそっちを使えばいいと思います。が、もしかしたら4.0になったとき削られたかも知れません。

詳しい設定をするにはやはり自分で書いたほうがいいかも知れません、LinuxMagazine 2001年1月号にXFree86のセットアップが徹底して意外と優しくのってるので買ってみるのもいいかも知れません。

参考URLに僕の設定のリンクをいれときましたので参考にしてもらってもかまいませんGeForce系の設定です。そのままだとFontPathがまずいかも知れません

参考URL:http://www.hasegawa.sccs.chukyo-u.ac.jp/~yoshi/XF86Config

XFree86 4.xにはXF86Setup は有りません。
理由は3.3.xと4.xのXF86Configの書き方が違うからです。

xf86cfgというのが代わりにあるのでそっちを使えばいいでと思います。XF86Setupとはまるで違った設定GUIなのでとまどうかもしれません。

もしうまくいかない場合は、たしかxf86configという昔からあるテキストベースのセットアップユティリティが有るのでそっちを使えばいいと思います。が、もしかしたら4.0になったとき削られたかも知れません。

詳しい設定をするにはやはり自分で書いたほうがいいかも...続きを読む


人気Q&Aランキング

おすすめ情報