tomcat4.0.1をいれていたのですが、
他のものとの互換性の問題があり、
tomcat3.2.3をいれました。
そうすると、以下のエラーで
tomcatが実行できません。

FATAL:java.net.BindException:
java.net.BindException
at java.net.PlainSocketImp1.socketBind(Native Method)
at java.net.PlainSocketImp1.bind(PlainSocketImp1.java:452)
at java.net.ServerSocket.<init>(Server\Socket.java:170)
at java.net.ServerSocket.<init>(ServerSocket.java:121)
at org.apache.tomcat.net. DefaultServerSocketFactory.createSocket(DefaultServerSocketFactory.java:97)
at org.apache.tomat.service.PoolTcpEndpoint.startEndpoint(PoolTcpEndpoint.java:239)
at org.apache.tomcat.service.PoolTcpConnector.start(PoolTcpConnector.java:188)
at org.apache.tomcat.core.ContextManager.start(Conte
at org.apache.tomcat.startup.Tomcat.execute(Tomcat.j
at org.apache.tomcat.startup.Tomcat.main(Tomcat.java

なにか、はずしていそうなことがありましたらおしえてください。

このQ&Aに関連する最新のQ&A

A 回答 (1件)

似たような感じのありますけど、違うかな??



http://oshiete1.goo.ne.jp/kotaeru.php3?q=211294

ここにある、参考URLの「その3」あたりが怪しいように思いますが。
全然、違ったらごめんなさいね^^;

参考URL:http://dennou.gihyo.co.jp/books/4-7741-1332-8/tr …
    • good
    • 0

お探しのQ&Aが見つからない時は、教えて!gooで質問しましょう!

このQ&Aと関連する良く見られている質問

QAPACHEとTOMCAT連携が上手く行きません。(mod_jserv.so)

Redhat7.1でapache(1.3.12)とtomcat(3.2.3)の連携を行っていますが、ファイルクラッシュ?エラーメッセージが出てしまいます。
モジュールはjakartaサイトからダウンロードしてきました。
詳細は---
/etc/rc.d/init.d/httpd start
Starting httpd: [日付] [warn]Loaded DSO libexec/mod_jserv.so uses plain Apache 1.3 API,
this module might crash under EAPI!
(please recompile it with -DEAPI)
    [OK]
------
と表示されます。
”再度DEAPIと一緒にコンパイルしろ”と云う事なのでしょうが、ディレクトリ内を幾ら探してもそれらしいファイルは見つかりません。
[OK]が出ていると云う事は、上記以外は通っている事なのでしょうか?[FAILED]なら解りますが・・・。
どの様に復旧させれば良いのか、皆目見当が付きません。
ご存知の方、是非ご指導の程宜しくお願い申し上げます。
因みに、TOMCAT単体では稼動します。

Redhat7.1でapache(1.3.12)とtomcat(3.2.3)の連携を行っていますが、ファイルクラッシュ?エラーメッセージが出てしまいます。
モジュールはjakartaサイトからダウンロードしてきました。
詳細は---
/etc/rc.d/init.d/httpd start
Starting httpd: [日付] [warn]Loaded DSO libexec/mod_jserv.so uses plain Apache 1.3 API,
this module might crash under EAPI!
(please recompile it with -DEAPI)
    [OK]
------
と表示されます。
”再度DEAPIと一緒にコ...続きを読む

Aベストアンサー

いつも、お節介で、回答を書いていますが、回答したあとで、とんちんかんなアドバイスではなかった、間違ったことを言ってしまったのではいか、後悔しています。世間には、「何を言っているの?馬鹿な、いいかげんなことを言って」と、冷ややかな見方をされる方もおいでですが、困っているときはお互いさまです。

お答えする前には、少なからずそれなりの実機でのテストで、ある程度の確認をしてお答えしていますが、最近のApacheの経験がないので、アドバイスにあまり期待しないでください。
コンパイル済みのApacheが、使用しているLinuxでは、ダウンロードどした状態では使用できないようです。

エラーメッセージの内容は、DSO(Dynamic Shared Object) libexec/mod_jseerv.so(ソース・オブジェクト)が、plain(通常の)Apache1.3 APIを使用しているので、EAPI(Extended Applicaction Interface)のところで、クラシュしていることを表示しています。そのために、DEAPI-多分EPAIをDisableして、再度コンパイルすることを指示しています。多分、makeする際の、Makefileの定義のところだとは思いますが、どこかは、特定できません。
もし、場所がわかりましたら、再度、アップしましょう。

Apacheが起動したら、php言語ですね!

それでは、ご健闘を祈ります。

hogehoge ojin

いつも、お節介で、回答を書いていますが、回答したあとで、とんちんかんなアドバイスではなかった、間違ったことを言ってしまったのではいか、後悔しています。世間には、「何を言っているの?馬鹿な、いいかげんなことを言って」と、冷ややかな見方をされる方もおいでですが、困っているときはお互いさまです。

お答えする前には、少なからずそれなりの実機でのテストで、ある程度の確認をしてお答えしていますが、最近のApacheの経験がないので、アドバイスにあまり期待しないでください。
コンパイル済み...続きを読む

QApacheとtomcatの削除

Redhat Linux,Apache1.3.24,tomcat4.0.3の環境です。

ApacheとTomcatをアンインストールしたいのですが、インストールしたディレクトリごと削除するだけで良いのでしょうか。
初歩的な質問かと思いますが、どうぞ宜しくお願いいたします。

Aベストアンサー

Redhat のソフトウェアは RPM という形式で管理されています。

root でコマンドラインから

rpm -qa | egrep -i 'apache|tomcat'

と実行して、表示されたパッケージ名に対して

rpm -e RPMパッケージ名(たとえば tomcat-3.3-3.noarch.rpm)

とすればアンインストールできます。

Tomcat が RPM パッケージでなかったなら、そのときはディレクトリごと削除すればいいと思います。

QDNSサーバを構築しています。/etc/rc.d/init.d/named reloadのところでエラーになってしまいます。

RedHat Linux 9 でサーバを構築しています。
DNSサーバを作成しているところでつまづいてしまいました。

vi /etc/named.conf のところで正引き、逆引きのゾーンを追記し、
vi /var/named/**.jp.db の正引きゾーンデータベースを作成し、
逆引きの方もゾーンデータベースを作成しました。

あとは、etc/rc.d/init.d/named start とやって起動させ、
namedが自動起動するように chkconfig named on と実行しました。

しかし、設定を反映しようと、
/etc/rc.d/init.d/named reload としたのですが、
何度やっても失敗と出てしまいます。
画面には、一部を書きに記述すると、

Reloading named: usage : killall [OPTION] [--] name ・・・
   killall -l, --list
killall -V --version

-l,--list list all know signal name
-V,--version display version infomation

となっていました。
とりあえず、shutdown -r now で再起動しましたが、
設定が反映されていないようで、次の
vi /etc/resolv.conf でIPアドレスを記述したあと、
nslookup コマンドを実行してDNSサーバのテストでやってもエラーになってしまいます。
何が原因でしょうか?
長々と書いてすみません。分かる方、どうかよろしくお願いします。

RedHat Linux 9 でサーバを構築しています。
DNSサーバを作成しているところでつまづいてしまいました。

vi /etc/named.conf のところで正引き、逆引きのゾーンを追記し、
vi /var/named/**.jp.db の正引きゾーンデータベースを作成し、
逆引きの方もゾーンデータベースを作成しました。

あとは、etc/rc.d/init.d/named start とやって起動させ、
namedが自動起動するように chkconfig named on と実行しました。

しかし、設定を反映しようと、
/etc/rc.d/init.d/named reload としたのですが、
...続きを読む

Aベストアンサー

/etc/rc.d/init.d/named 内のkillallコマンドでエラーが出ています。
reloadですから、killallで一旦namedを止めて再起動するわけですが、
止めるべきnamedがもともと動いていない、と言う事では?

QOpenOffice.orgのインストールが、できない

1.1.xにセキュリティホールが発見されました。と出ます。この解決する方法と、set up,exeが、出ません。
ダウンロードは、出来ました。Windows xpを、使用しています。

Aベストアンサー

参考URLを見ると解決しますよ。
OpenOffice.org1.1.4をインストールしてから、ダウンロードしたパッチをインストールする方法と、
OpenOffice.org1.9.m104(2.0のベータ版)をインストールする方法の2つの方法があります。
OpenOffice.org1.1.4は、
ftp://ftp.sfc.wide.ad.jp/pub/OpenOffice/localized/ja/1.1.4/
からダウンロードできます。

OpenOffice.org1.9.m104は、
http://download.openoffice.org/680/
からダウンロードできます。
このままインストールしても英語版ですので、
こちらから日本語環境にするためのランゲージパックをダウンロードしてインストールしましょう。
http://oootranslation.services.openoffice.org/pub/OpenOffice.org/680m104/

参考URL:http://ja.openoffice.org/1.1.4/security.html

参考URLを見ると解決しますよ。
OpenOffice.org1.1.4をインストールしてから、ダウンロードしたパッチをインストールする方法と、
OpenOffice.org1.9.m104(2.0のベータ版)をインストールする方法の2つの方法があります。
OpenOffice.org1.1.4は、
ftp://ftp.sfc.wide.ad.jp/pub/OpenOffice/localized/ja/1.1.4/
からダウンロードできます。

OpenOffice.org1.9.m104は、
http://download.openoffice.org/680/
からダウンロードできます。
このままインストールしても英語版ですので、
こちらから日本...続きを読む

Qapache1とapache2

最近apacheの本を購入したのですが、その本にapache1は
安定していると書かれていて、気になったので質問させて
頂きます。
※個人的にはapache2の新機能を読んでapache2にしたい
 と思っています。

1.apache2ってまだ安定してないんでしょうか?

2.apache2を使用してて何か問題が発生した事がありま
  すか?

3.将来的にapache1は無くなるのでしょうか?

4.apache2 + PHP + PostgreSqlの組み合わせで
  何か注意点ってありますか?

Aベストアンサー

1.apache2ってまだ安定してないんでしょうか?
2.0 から 2.0.45 のバージョンは脆弱性が発見されています。
最新の2.047にしてください。
1.3系は1.3.28が最新ですが1.3.23以降は特に
重大な問題はありません。

2.apache2を使用してて何か問題が発生した事がありま
  すか?
今後apache2はバージョンアップが頻繁にあるとおもうので
情報をチェックする必要があります。

3.将来的にapache1は無くなるのでしょうか?
最近1.3.28がリリースされました。当分は無くならないと
思います。というか無くなるというのはバージョンアップが
無くなるって事ですよね?

4.apache2 + PHP + PostgreSqlの組み合わせで
何か注意点ってありますか?
最新の情報をチェックしていれば特に重大な問題はないとおもいます。

ちなみに私はapache1.3.27+tomcat4.1.24+postgresql7.3.3です。
私の環境ではapache2新機能の恩恵が特にないですから。

1.apache2ってまだ安定してないんでしょうか?
2.0 から 2.0.45 のバージョンは脆弱性が発見されています。
最新の2.047にしてください。
1.3系は1.3.28が最新ですが1.3.23以降は特に
重大な問題はありません。

2.apache2を使用してて何か問題が発生した事がありま
  すか?
今後apache2はバージョンアップが頻繁にあるとおもうので
情報をチェックする必要があります。

3.将来的にapache1は無くなるのでしょうか?
最近1.3.28がリリースされました。当分は無くならないと
思います。...続きを読む


このカテゴリの人気Q&Aランキング

おすすめ情報