Miracle Linuxにソフトをインストールしようとしていますが、パッケージ
ソフト(.rpm)の場合、パッケージインストールすれば、make、make install
はしなくてもよいのでしょうか? 以下のような場合。

rpm -ivh nkf-1.71-2.src.rpm

よろしくお願いします。

このQ&Aに関連する最新のQ&A

A 回答 (3件)

はじめまして。



rpmというのは、バイナリパッケージと呼ばれる物で、通常はmakeやinstall等は使いません。
これらが必要になるのは、tgzや、tar.gzといったプログラムソース自体で配布されているものです。

さて、整理しておくと、rpmの直前のところが、
i386やppcとある場合は、honiyonさんが書かれているように、特定のアーキテクチャ用に作られています。
noarcは汎用です。
そのため、自分にあったパッケージを選んで、
rpm -ivh xxxx.i386.rpm
とすればインストールできます。

不安であれば、
rpm -qa
としてみてください。
インストール済みのrpmパッケージのリストが見れます。
また、
rpm -ql xxxx.i386.rpm
で、xxxx.i386.rpmの各ファイルのインストール先が確認できます。

ただし、honiyonさんが書かれているとおり、通常のrpmは、redhatやVineに合わせて作られています。
このためディレクトリ構成が違っていると、不具合が考えられます。
そこで、rpmでも、環境に合わせてコンパイルしてからインストールするタイプの物があり、それがsrc.rpmなのです。

つまり、nkf-1.71-2.src.rpmは
rpm -ivh nkf-1.71-2.src.rpm
では、通常のインストールはされません。
rpm --rebuild nkf-1.71-2.src.rpm
とすると、おそらく/usr/src/以下などに、自分の環境に合ったnkf-1.71-2.i386.rpmなどが作られると思うので、
それを
rpm -ivh nkf-1.71-2.i386.rpm
としてください。

もしどこにnkf-1.71-2.i386.rpmが作られたか分からない場合は、
find / -name nkf-*.i386.rpm
等で表示されるかと思います。
(Miracle Linux は使用していないのでm(_ _)m)

なお、rpm --rebuild nkf-1.71-2.src.rpmがうまくいかないときは、
rpm -ivh nkf-1.71-2.src.rpm
してから、コピーされたSEPCファイルを探して、
rpm -bb <SPECファイル>
とすると、同じようにnkf-1.71-2.i386.rpmが作れます。
(ちょっとわかりにくいので必要なければ無視してください)
    • good
    • 0
この回答へのお礼

こんにちは! yostyさん。

とても詳しく回答して頂きありがとうございます。
これを参考になんとかできそうです。

では、またなにかありましたら、よろしくお願いします。

お礼日時:2001/10/18 15:42

こんにちは、honiyonです。



 rpmには、「何をどこにインストールしたか」という情報を教えてくれるオプションがあります。 ちょっと今そのオプションの指定の仕方の情報が手元になく、頭にもない(^^; ので回答出来ないのですが...

 xxx.i386.rpm というのは多分 x86系向けのバイナリパッケージです。 それには実行ファイルが入っているので、rpmでインストールすれば makeする事なく使えます。
 但し、 rpmパッケージは RedHat Linuxを対象にしているのが多く、特に「○○向け」と書いていないバイナリパッケージは RedHatが対象と考えて良いかもしれません。
 お使いのディストリビュージョンは Miracleとの事で、ひょっとしたら動かない可能性があります。 Miracleについてよく知らないので何とも言えないのですが(^^;

 因みに、大抵の場合、ドキュメントは /usr/doc/ の下にインストールされます。 あとは、展開されたソースと共にというドキュメントファイルが出来ている可能性があります。 インストール(make)に関するドキュメントは、後者のケースで、 INSTALLというファイル名になっている可能性が高いかもしれません(?)
 ソースの標準的な置き場所は、 /usr/srcになります。

 UNIX系にはあまり詳しくないので曖昧な情報で申し訳ないですが、参考になれば幸いです(..
    • good
    • 0

こんにちは、honiyonです。



 そのパッケージは、ソースコードのパッケージです。
 インストールされるのは実行ファイルではなくソースコードなので、make & installをする必要があります。

 詳しい方法についてはドキュメントが同梱されていると思います。

 参考になれば幸いです(..

この回答への補足

honiyonさんこんにちは!

早々の回答ありがとうございます。
ドキュメントというのが、ない?ような。。。
すみません、LinuxというかUNIXが初めてなもので。

ちなみに xxxx.i386.rpm というファイルもあるのですが
これも同様なのでしょうか?

補足日時:2001/10/18 12:55
    • good
    • 0

このQ&Aに関連する人気のQ&A

お探しのQ&Aが見つからない時は、教えて!gooで質問しましょう!

このQ&Aを見た人が検索しているワード

このQ&Aと関連する良く見られている質問

QS-Jog Rpmパッケージ

いつもお世話になります

sjog-0.6-2.i586.rpmをインストール時に下記エラーとなりました。
Failed dependencies:
libgtk+1.2 >= is needed by sjog-0.6.2

gtk+-1.2が必要かなと思いgtk+-1.2.10-25.i386.rpmをインストールし
再度sjog-0.6-2.i586.rpmのインストールを試みるとまた同じエラーとなります。

これは何か別の設定やインストールしないといけないRPM等
あるのでしょうか?
超初心者ですがよろしくお願いします。

環境:
vaio Z505GR/K RedHatLinux9

Aベストアンサー

エラーメッセージは正確に

libgtk+1.2 >= 1.2 is needed by ....

ですね.

sjog のSPECには確かに上記パッケージへの依存関係が設定されていますが,RedHatのlibgtk+ は,単に gtk+ というパッケージ名なので,依存関係を壊さずにそのRPMをインストールすることはできません.

ソースから,おきまりの configure, make, make install の手順で簡単にインストールできると思いますが,それではダメなんでしょうか?

QLinux 6.2 でパッケージインストール RPM コマンドを使用した時にエラーがでる

OS Linux6.2 で rpm コマンドを使用した時にエラーになる

# rpm -Uvh bind-8.2.2_P7-1.i386.rpm をすると以下のエラーが出る

メジャー番号<=3のパッケージのみこのバージョンのRPMはサポートされています
エラー:bind-8.2.2_P7-1.i386.rpm cannot be installed

以上のメッセージが出てパッケージをインストールできないので
教えてください

Aベストアンサー

bind-8.2.2_P7←これが7なのが気になるのですが
RedHat7J用のRPMなんでしょうか?

redhat系だと 6.xと7以上でRPMのバージョンがかわり
6.x系のRPMでは新しいrpmがほどけなかった気がします。

先に、rpmのバージョンを最新の物に上げてみてください。

QMiracle Linuxインストール、グラフィカルログイン設定

Miracle Linux Standard Edition V1.0のインストールをしています。

一応インストールはできているようなんですが、現在テキストログイン設定です。

インストール後にグラフィカルログイン設定にしようと思っているのですが方法がわかりません。確かできますよね?

Aベストアンサー

># rpm -q hoge (hogeのところはパッケージ名)
hogeのところには
# rpm -qa kde
# rpm -qa gunome
# rpm -qa XFree86
等と入力してください。
WIN等が使えるならインストールCDを開いて
\ディストリビューション名\RPMS\の中身を見れば
パッケージ名はわかりますので・・・
(kde-base-2.2.1-11.i386.rpmとか名前がついています)

めんどくさいのであれば最初からインストールを選択して
再インストールしてみては?

それと、ふと思ったのですがMiracle Linux Standard Edition V1.0 
だとXの設定コマンドは
# miraclexcfg
じゃなかったかな?

QRPMパッケージのアップグレードについて

APACHEをRPMパッケージの最新版(apache-1.3.22-5.7.1)にアップグレードしたいのですが、
現在下記の様な状態で悩んでいます。

# rpm -Fvh apache*.rpm
でアップグレードしようとすると、

エラー:依存性の欠如
mod_bandwidthは apache-1.3.22-5.7.1 に必要とされています
mod_putは apache-1.3.22-5.7.1 に必要とされています
mod_throttleは apache-1.3.22-5.7.1 に必要とされています

というエラーが出ます。

次に、依存性の欠如で指摘されたファイルも一緒にアップグレードしようと、
以下のコマンドを入力しました。

# rpm -Fvh apache-*.rpm mod_bandwidth-2.0.3-2.i386.rpm mod_throttle-3.1.2-3
.i386.rpm mod_put-1.3-2.i386.rpm

そしたら、またしても

エラー: 依存性の欠如:
mod_bandwidthは apache-1.3.22-5.7.1 に必要とされています
mod_putは apache-1.3.22-5.7.1 に必要とされています
mod_throttleは apache-1.3.22-5.7.1 に必要とされています

と表示されてしまいました。

インストールされているか、rpm -q で確認すると、
インストールされていません と返ってきました。

じゃあ、インストールしよう、と思って

#rpm -ivh mod_bandwidth-2.0.3-2.i386.rpm mod_throttle-3.1.2-3.i386.rpm mod_put-1.3
-2.i386.rpm

と入力したら

エラー: 依存性の欠如:
apache < 1.3.22-1 mod_bandwidth-2.0.3-2 と競合します
apache < 1.3.22-1 mod_throttle-3.1.2-3 と競合します
apache < 1.3.22-1 mod_put-1.3-2 と競合します

と、返ってきました。


一体、どのようにしたら無事アップグレードできるのでしょうか?
それとも、現バージョンのAPACHEを削除してから新バージョンのインストールを
するしかないのでしょうか?


使用OS:Redhat Linux 7.1J

APACHEをRPMパッケージの最新版(apache-1.3.22-5.7.1)にアップグレードしたいのですが、
現在下記の様な状態で悩んでいます。

# rpm -Fvh apache*.rpm
でアップグレードしようとすると、

エラー:依存性の欠如
mod_bandwidthは apache-1.3.22-5.7.1 に必要とされています
mod_putは apache-1.3.22-5.7.1 に必要とされています
mod_throttleは apache-1.3.22-5.7.1 に必要とされています

というエラーが出ます。

次に、依存性の欠如で指摘されたファイルも一緒にアップグレードしようと、
以下の...続きを読む

Aベストアンサー

apacheのパッケージと、mod_bandwidthなどのモジュール類とを
一緒にインストールするのが(たぶん)正解だろうと思いますが、
エラーが出るってわけですね。
でも、それは、rpmのオプションがいけないんではないでしょうか?

rpm -Uvh

でリトライしてみてください。

rpm -Fvh は、「現在インストールされている」パッケージを
アップグレードしますが、mod_bandwidth等は、
現在インストールされていないわけですよね?
だからダメなんだろうと思いますよ。

Qnosrc.rpmのインストールができない・・・

nosrc.rpmのインストールの仕方が不明です・・・
ちなみにrpm -bというコマンドも使えません・・・
(マニュアルにはあるが引数として使えない・・・)
インストール方法わかりましたら教えてください!

Aベストアンサー

rpmのバージョンは4系でしょうか?
rpmは4系から--rebuild系のオプションが、rpmbuildへ移行しています。
(オプションはそのまま使えるようです)

詳しくは以下のURLを参照してください。
JM
http://www.linux.or.jp/JM/html/rpm/man8/rpmbuild.8.html
@IT
http://www.atmarkit.co.jp/flinux/rensai/linuxtips/413rebuilderr.html


人気Q&Aランキング

おすすめ情報